Visokio website     Downloads     Video tutorials     KnowledgeBase  
Connectors: Google Analytics - configuration via proxy? - Visokio Forums
Connectors: Google Analytics - configuration via proxy?
  • dominique November 10, 2010 10:43AM
    Could you help me configure the Connector in DataManager to access Google Analytics via a proxy?
    My settings are correct, i can update the licence via the web but it doesn't work with Google Analytics.
    OnmiscopeProxy01.png 19K
  •     chris November 10, 2010 11:41AM

    Thanks for your question.

    It may be possible that your system administrator has put restrictions on which applications can access certain web pages through your firewall. This means that Omniscope is allowed to connect to certain web pages (for example to allow licence activations), but not others. It would be worth speaking to your system administrator to see if this restriction is in place and if so ask them to provide access to Google Analytics and any other pages you want to allow Omniscope to retrieve data from.

    If you are still experiencing problems could you let me know what error message you get when you try to connect to Google Analytics.


  • dominique November 10, 2010 1:23PM
    There are no "application" restrictions to our firewall.
    And I can access google analytics.

    Are you sure that Omniscope use the proxy configuration when it tries to connect to google analytics ?
    Does Omnicsope use other port than 80 ?

    See screenshot attached
    OnmiscopeProxy02.png 15K
  •     chris November 10, 2010 1:40PM

    Could you provide me with the full error message that is shown in the Google Analytics when you try to connect. You can see this by clicking on the error label (the red text to the right of the connect button).


  •     chris November 10, 2010 1:41PM
    Can you also check whether you can connect to another online source in DataManager. A good one to try with is a Twitter or Yahoo search in the merging feeds section.
  • dominique November 10, 2010 2:26PM
    The error message for google analytics
    GoogleAnalytics03.png 33K
  • dominique November 10, 2010 2:26PM
    The error message for facebook
    Facebook01.png 18K
  •     chris November 10, 2010 2:32PM

    The error message you provided for Google Analytics is not the correct image.

    Could you try either twitter or Yahoo search instead of facebook and let me know if you manage to retrieve the data.


  • dominique November 10, 2010 2:37PM
    The error message for GoogleDocs
    spreadsheet01.png 31K
  • dominique November 10, 2010 2:40PM
    The error message for google analytics (correction)
    OnmiscopeProxy03.png 38K
  • dominique November 10, 2010 2:45PM
    It works for Yahoo
    Yahoo01.png 34K
  • dominique November 10, 2010 2:51PM
    It works for Twitter
    twitter01.png 34K
  •     chris November 10, 2010 2:58PM

    It looks like this might be a proxy issue.

    Could you try the steps suggested on the following web page:
  •     chris November 10, 2010 3:37PM

    Following on from my last post. The Google Analytics authentication server is on a HTTPS address. It is possible that this may be causing the problem (your proxy server/firewall may be rejecting these requests).

    One way to check whether Omniscope is able to retrieve data from the Google Analytics server is to set up a file with an image set containing links to images on the same domain.

    Attached is an a file with an image set referencing the first field in the data. I have set up one image link (on inside the file. I have also added a tile view in the DataExplorer tab. If you open the file and you can't see the image, it means there is a problem connecting to the Google server. You could then try adding more image links (eg http, other https sites) to get a better understanding of which requests are being rejected.
    ganalytics_test.iok 6K
  • dominique November 10, 2010 3:39PM
    I try the following :

    In ""
  • dominique November 10, 2010 3:52PM
    In "wrapper.conf"
  • dominique November 10, 2010 4:17PM
    Thats it !
    The problem comes from https, how to tell to Omniscope using proxy for https ?
    GoogleAnalytics04.png 89K
  •     mustafa November 11, 2010 11:09AM
    Dominique, the screen shot you have attached in your last post, is this after you have disabled proxy setting through
  • dominique November 15, 2010 8:22AM
    Yes, it's like nothing change with this configuration...
    It works with yahoo (rss) and not with google (https)
  •     mustafa November 22, 2010 12:13PM
    Domnique, can you try what is suggested here and see if that fixes the problem:

    Can you also verify for me whether or not you can access the following link directly from your Web Browser (Internet Explorer)
  • dominique November 22, 2010 1:59PM
    I can access the google https link with IE or Firefox.
    But it doesn't work more in omniscope with the configuration you suggest.
    GoogleSSL01.png 75K
  •     mustafa November 22, 2010 9:23PM
    Dominique, I will appreciate if you could do the following for me:

    1) Download the from
    2) Extract it to your Desktop or somewhere more convenient on your machine.
    3) Run the VisokioConnectionTester.exe
    4) Click on "Test connection" button.

    The purpose of the application is to check whether or not it is Omniscope related, the application will check whether or not it can access the link mentioned in my last post and some other URLs. Can you then post me a screenshot of the results it gives you in a dialog.
  • dominique November 23, 2010 8:44AM
    I run the test on my machine.
    The message of the test result is "no errors"
    See screenshot
  •     mustafa November 23, 2010 5:22PM
    Dominique, even though there are no errors there should have been more output then what you actually get.

    I have added some more information to the Visokio connection test which will provide more information as to what is happening.

    Can you re-download the zip from the same link mentioned in my last post and then post the results.

    By the way have you tried connecting to Google Analytics from a different machine and do you get the same problem?
  • dominique November 23, 2010 6:06PM
    Mustafa and Chris , thanks for your help.
    We SOLVE the problem via the java configuration, with the informations found in the page
    May be it will be usefull to add informations below in this page.
    I think this will work for every site with a proxy configuration.

    I change parameters :
    ( and port=8000 are NOT the real values)

    In ""
  •     mustafa November 23, 2010 7:53PM
    Glad to hear you are up and running now. We would like to thank you in return for all the help and information you have provided us in trying to get to the bottom of the issue which was very much appreciated.


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership