Visokio website     Downloads     Video tutorials     KnowledgeBase  
Issue with Ingres/Vector database blocks in omniscope server 2.9 b1835 - Visokio Forums
Issue with Ingres/Vector database blocks in omniscope server 2.9 b1835
  •     bernardpi September 28, 2016 12:34PM
    We use an ingres/vectorwise database which enforces lower case field names. When we refresh our database blocks using our own Omniscope desktop build, we ensure that the 'Auto-correct field name case' option is selected in the database block so that all field names come through in a proper case. This seems to work fine.

    However, when we use omniscope server to refresh our reports that contain these database blocks (using XML scheduler files), the reports are refreshed but the field names have lost their proper case even though the file has been saved with 'Auto-correct field name case' option selected.

    If the datamanager has other blocks below (merge joins, aggregates etc) this ends up affecting their ability to work as before (the merge joins will no longer work or work in an erroneous way).

    I have raised a bug against this and have included a cut down example in the report but I'm not sure what use it will be as you won't be able to refresh this database block externally.

    Please advise.
  •     bernardpi September 28, 2016 12:36PM
    Bug ref, 37196
  •     bernardpi September 28, 2016 12:46PM
    See attached image.
    omnicasingissue.png 94K
  •     steve September 28, 2016 1:27PM
    Bernard, I responded to your bug by email, as follows:

    The auto-case-fixing contentious behaviour we've had since very early days, and there have been a few users over time who disagree strongly with it. Typically databases have all-uppercase names where you want them to be fixed for readability, but acronyms often don't want fixing.

    As such we've had an app-wide setting allowing you to turn this off:
    Settings > Advanced > Data sources > Preserve field name case by default

    By default this is unticked, i.e. Omniscope auto-corrects case. It's possible your server has this option customised (ticked, i.e. disables auto-correction). Start the *desktop* app on the server in question and look at this menu. You should restart the server app if you change it.

    Let me know if this isn't the problem, and we'll look further.


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership