Visokio website     Downloads     Video tutorials     KnowledgeBase  
Scheduler: running as a service versus running as application? - Visokio Forums
Scheduler: running as a service versus running as application?
  •     WKeith June 8, 2012 10:53AM
    I am currently moving my scheduled tasks from an old Windows 2003 server to a Windows 7 box, both 64-bit.

    As part of the migration, I am replacing a routine which created a long XML file and then started the Scheduler with one where a series of XML files are dropped into the watch folder. This has been successful, but I have discovered that sometimes the Service appears to time out, while the application does not, when an Oracle query takes a long time to return data. Is there a way of adjusting the time out of the service?

    In addition there seems to a be a problem reading Excel files - I am about to try using the omniscope reader to fix this.
    log.rtf 34K
    wrapper.rtf 4M
  •     WKeith June 8, 2012 10:59AM
    using the omniscope reader has fixed it I think

    We are on 2.7 355 running 64 bit

  •     WKeith June 8, 2012 11:00AM
    Just saw the post about Excel in Scheduler
  • antonio     antonio June 8, 2012 11:05AM
    Yes, as posted here , the Excel reader type should be "Omniscope" , or you can also try the first workaround suggested.
  • antonio     antonio June 8, 2012 11:25AM
    To set the timeout, you can customise the "" property into the "wrapper.conf" file.

    The default setting is 30 seconds, so if you want to increase the timeout (for example to 2 minutes) , then add the following line:

    Also I noticed from your log that some hangs are caused by an out of memory issue.
    Please see here in the "Setting the memory for the Scheduler / Windows service" section how to set the service allocation memory.
  •     WKeith June 8, 2012 11:41AM
    I had set the memory to 10000, but the VM that it was running on only had 4096 Mb. I got that increased to the same as the prevoious one and will try again.

  •     WKeith June 8, 2012 12:00PM
    Increased machine memory has fixed it
    Where in log is out of memory?
  • antonio     antonio June 8, 2012 1:53PM
    In your wrapper.rtf file where it says INFO | jvm 1 | 2012/06/01 16:25:44 | java.lang.OutOfMemoryError: Java heap space
  •     WKeith June 13, 2012 11:14AM
    Bizarrely didn't see it!
This discussion has been closed.
← All Discussions


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership