Visokio website     Downloads     Video tutorials     KnowledgeBase  
Java Virtual Machine Launcher Error - Visokio Forums
Java Virtual Machine Launcher Error
  •     s_daffern May 5, 2011 8:07AM
    We currently have the free viewer installed on Citrix and all of a sudden we have started to get an error on start up of Omniscope. The error message says "Could not start the java virtual machine" followed by a further message stating that Omniscope has terminated abnormally and to run the debug.

    Has this error been seen before and do you have any suggestions on how to fix this?


  •     steve May 5, 2011 9:30AM
    This usually means there is a problem with the Java installation or the file.

    Copy your file to a backup location, in case there are changes you may want to keep in future. Delete this file. Install the Full installer of the latest Omniscope version. Does this fix the problem?
  •     walsh May 5, 2011 11:26AM
    I had the same problem running Omniscope under Citrix. Solution was to uncomment this line in


  •     steve May 5, 2011 4:27PM
    If this resolves it, you should go for as high as you can; 300 is too low for all but small data files. How much installed memory do you have? There are very rare cases where Omniscope automatically tries to allocate too much memory.
    You may find that you have already customised this line and put a value that is TOO high, which would have the same error. Increase and reduce it until it's roughly as high as it can go.
  • rinomasaya April 15, 2017 5:38AM
    Most of the time you can fix this problem by uninstalling the Java runtime and then reinstalling it all over again.

    To do this, go to the control panel and then Programs and Features. If you’re running Windows 8.1 Update 1, just right-click on the Start button and click on Programs and Features. Locate the Java runtime, uninstall it and reboot your PC.

    Next, download the latest Java Runtime from, taking care to install the correct version for your PC. You will likely want the 32-bit version as the 64-bit option is specifically for 64-bit browsers. Most browsers are 32-bit on Windows, even on 64-bit editions of the OS.

    Sometimes this error can be caused by not having enough system memory allocated to the Java Virtual Machine – or not enough system memory full stop.

    You can also try increasing the amount of system memory allocated to the Java virtual machine by setting an environment variable.

    To do this, go back to the Control Panel and click on System, then Advanced system settings. Now click the Environment Variables button to bring up a list of all those currently set.


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership