Visokio website     Downloads     Video tutorials     KnowledgeBase  
Source: Access data file update slow? - Visokio Forums
Source: Access data file update slow?
  •     filippobe January 7, 2011 5:01PM

    I have two Access tables (each one with 200,000 rows), linked as sources to an Omniscope file.
    Every time I open the file and I try to update the two blocks, Omniscope it's unable to connect with the database. It starts to work only after three or four attempts.Therefore, every time I want to update the blocks, all the process takes to me more than 5 minutes. I'm wasting a lot of time. Does anyone know why?
    Thank you

  •     chris January 7, 2011 5:42PM

    What version of Omniscope are you using?
    What error message is displayed when you try to update the database?


  •     filippobe January 7, 2011 5:47PM
    Hi Chris,

    The version is: DataManager 2.6 Okavango Build 2.6-alpha b477

    The error message is: Error with block "........."
    Unable to connect to the database: The server took too long to respond

    Thank you


  •     chris January 7, 2011 6:01PM

    In the following forum posting the user is experiencing a similar problem:

    Let me know if you are still experiencing problems.

  •     filippobe January 10, 2011 9:44AM
    I've changed the setting, but It's the same:
    It does connect to the database, but only after 2/3 attempts.
    Do you think it's something related to the network?
    Thank you for your help.

  •     filippobe January 20, 2011 10:14AM
    Hi Chris,

    I'm still experiencing the problem.
    I don't think it's something related with our local network and the linked database is not so big.
    Do you have some advices/ideas???

  •     steve January 25, 2011 2:54AM
    Please confirm you did the proxy settings changes outlined at the end of the linked post in full, and it didn't work.
  •     filippobe January 25, 2011 5:26AM
    I confirm.
    Please find attached configuration.

    configuration.txt 3K
  •     steve January 25, 2011 5:40AM
    So, to sum up:

    You have an access database, as an mdb or accdb file, on the same PC as Omniscope?

    You are using Omniscope 2.6 b477 DataManager to connect to the access database, using the "Access" option in the Database block?

    Please could you do the following:

    Tick "Settings > Advanced > Miscellaneous > Report database errors as bugs"

    Tick "Settings > Advanced > Miscellaneous > Report recognised errors as bugs"

    Reproduce the error

    If you see an error dialog, choose to report the error.
    If you see a red error message inside the block, click the message, and report the error when prompted.

    In your error reports, put "As requested for forum post 581".

    Untick the previous tickboxes, when you have finished.
  •     chris January 25, 2011 6:31AM

    I have sent you an email about this. Could you also follow the steps outlined by steve above.


  •     steve January 27, 2011 3:28PM

    I received both your error reports #14656 and #14659 - thank you.

    Both tell the same story. Omniscope is unable to connect to the ODBC database. It is taking longer than 30 seconds to connect (and not even retrieve data), and Omniscope is giving up.

    Is this an MDB or ACCDB file? Where does it reside - on your C: drive, or a network drive?

    Try opening the MDB/ACCDB file in Access itself, outside of Omniscope. Does it open quickly? Are there any messages displayed?

    Please could you send us your IOK file so we can look at its configuration. I think you have Chris' email address.
  •     filippobe January 28, 2011 4:46AM

    I've just sent the IOK file to Chris.

    The file is an .mbd,
    When I try to open the main table in Access it takes 2-3 seconds.
    The databse is on a shared driver. But this is not the problem...In fact when I tried to move everything on my hard disk I didn't notice significant changes.

    Let me know as soon as possible please.
    Thank you
    Kind Regards

  •     filippobe January 28, 2011 4:54AM
    I've just red this:
    Do you think it could be useful to push the limit up?
    My computer has 1.95 GB of RAM. At the moment the limit is setted at 75%, as default.

  •     steve January 28, 2011 5:48AM
    You could try it, but I don't think memory is the issue.


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership