Visokio website     Downloads     Video tutorials     KnowledgeBase  
Connection Error (SQL Server) - Visokio Forums
Connection Error (SQL Server)
  • dbzedler March 29, 2010 8:30PM
    When I try to connect to our SQL Server 2005 database, I get this error:

    Unable to connect to the database: The server took too long to respond.

    I'm running version 2.6 alpha build 216. Any ideas?

  •     steve March 30, 2010 7:39AM

    Please could you send us via email:
    - screenshots of the error dialogs and the preceding screens
    - details of your database server (physical location, type of PC, network configuration)
    - details of your client PC which is trying to connect
    - details of the network route in between

    Please also enable "Settings > Application-wide settings > Advanced > Miscellaneous > Report database errors as bugs" and disable the item about reporting recognised errors, then reproduce the error, submit an error report when prompted, then restore the menu settings to their previous settings.

    Please also try connecting to an SQL Server instance on another PC.

  • dbzedler March 30, 2010 4:32PM
    Data table configuration screen shot.
    Config.JPG 35K
  • dbzedler March 30, 2010 4:33PM
    Error dialog screen shot.
    Error.JPG 34K
  • dbzedler March 30, 2010 4:40PM
    Server runs Windows Server 2003. Please let me know what specific details you need about it. My PC runs Windows XP Professional sp 3. I submitted the error report as requested. I can try connecting from a different PC in a few minutes.

  •        mohamed March 30, 2010 5:20PM
    Can other software connect to the same database?
    You are using Windows Authentication, could you please check that there isn't an authentication pop-up showing and may be hidden behind some windows. If there isn't, use SQL Server Authentication which requires username and password?

    If the above does not work, in the Driver drop-down, select SQL Server 2005 driver and try connecting.
  • dbzedler March 30, 2010 8:25PM
    Yes, other software connects fine. I tried using SQL Server authentication, and I tried selecting the SQL Server 2005 driver. I get the same error.
  •     steve March 31, 2010 8:58AM
    This is almost certainly a proxy settings issue. Mohamed, please can you advise?
  •        mohamed March 31, 2010 9:13AM
    Please follow the below steps to fix this issue:

    1. Edit this file "C:\Program Files\Visokio Omniscope\".
    2. Replace this line
    with this one
    ADDITIONAL_JVM_ARGS=-Dvisokio.disableCustomProxySelector=true -DenableProxyDebug=true -Dvisokio.disableSystemProxies=true
    3. Save the file .
    4. Restart Omniscope.
    5. Connect to your database.
  • dbzedler April 5, 2010 10:08PM
    That did it. Thanks!


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership