Visokio website     Downloads     Video tutorials     KnowledgeBase  
Security: Server SSL Error-handshake alert:unrecognized_name - Visokio Forums
Security: Server SSL Error-handshake alert:unrecognized_name
  •     Veaceslav June 27, 2014 5:30AM

    Server SSL Error - handshake alert: unrecognized_name

    You may get this SSL error if the server you are trying to access has not been properly configured.

    For security reasons SNI extension has been enabled by default in Java 7. However, if you trust the server you are trying to connect you may want to disable SNI extension.

    jsse.enableSNIExtension is a java system property. Server Name Indication (SNI) is a TLS extension, defined in RFC 4366. It enables TLS connections to virtual servers, in which multiple servers for different network names are hosted at a single underlying network address.

    Some very old SSL/TLS vendors may not be able to handle SSL/TLS extensions. In this case, set this property to false to disable the SNI extension.

    To disable SNL extension you need to do the following:

    1. Open '' file located at {YOUR_OMNISCOPE_INSTALLATION_PATH}

    {YOUR_OMNISCOPE_INSTALLATION_PATH} - this is where Omniscope is installed on your machine (e.g. C:\Users\slavvi\AppData\Local\Visokio Omniscope app)

    2. Edit the file to add this line:

    3. Restart Omniscope

    Note: After setting this property, you may get the following error if the server you want to access does not have a certificate issued by a certified authority:
    The server you are connecting to does not have a valid certificate from an authorised authority
    To resolve this error please read the following post:
    However, you will be unable to execute step 2 outlined in that forum post unless you disable the SNI extension while executing that command. Here is how that command may look like:
    java -Djsse.enableSNIExtension=false InstallCert


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership