Visokio website     Downloads     Video tutorials     KnowledgeBase  
Sources: Excel Error - Communicating with Application? - Visokio Forums
Sources: Excel Error - Communicating with Application?
  • LukeWhiteley July 9, 2013 6:36AM
    We are trying to open local .xlsx files in a DataManager and are receiving the following errors:

    Invoke of: Open
    Source: Microsoft Excel
    Description: Unable to get the Open property of the Workbooks class

    Unable to get the open property of the workbook class.

    We only get this error when trying to read from a local file or Google Drive, files from our network drives open without any problems. We suspect this may be down to having concurrent installations of both 2.7 and 2.8 that look at the same 'Visokio' folder (see attached).

    visokio folders.jpg 22K
  •     chris July 9, 2013 6:51AM

    Are you able to report these to us as bugs? Would it also be possible to send us one of the Excel files. You can send it to: Thanks!
  • LukeWhiteley July 9, 2013 7:08AM
    Hi Chris,

    Thanks for the fast response. The Excel files that we've been using have just been created to test this error, we were originally trying to read from Google Drive. We suspect the Drive issue occurs at the point the file is downloaded so we caught a .xls file from /AppData/Local/Temp and moved it to Desktop. We then brought the file into a DataManager from Desktop where the same error occurred. After moving this .xls file to a network drive however, it opened absolutely fine. This is the same in both 2.7 and 2.8, unfortunately, the error does not allow us to submit a bug report.

  •     chris July 9, 2013 9:23AM
    Hi Luke,

    I've tried putting an Excel file on my desktop, dragged it into DataManager and it opened fine, so this is very strange. When you drag it into DataManager can you change the reader to "Omniscope". Are you able to open the file then? Can you send us an Excel file for us to test?
  • LukeWhiteley July 9, 2013 9:48AM

    I sent one of the test files to you and also tried using the 'Omniscope' reader in the file block but the error still appeared. The 2.7 and 2.8 installations both seem to be using the same 'Visokio' folder in /AppData/Local/ if that could be the issue?



It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership