Visokio website     Downloads     Video tutorials     KnowledgeBase  
User defined text in Record Details where value is null - Visokio Forums
User defined text in Record Details where value is null
  • VoteVote Up0Vote Down     WKeith January 15, 2010 11:32AM
    Currently when there is a null value, the record detail will display "no value". Could an option be introduced to allow the user to
    define the text to be displayed where there is no value.
  • %5BDeleted+User%5D [Deleted User] January 18, 2010 12:04PM
    Version 2.6 includes the option to suppress all empty/null fields from the Details pop-window altogether...given that you can suppress them in 2.6, would you still need to change the text from "no value" ?
  •     WKeith January 20, 2010 4:44PM
    I have spoke to my user, and they would prefer to be able to display the field name with a user defineable value for null, rather than suppressing it.


  •     tjbate January 26, 2010 7:07PM
    If you want to globally replace the "no value" text with another phrase, you can use the translations file to do this. First, export the translation file from Settings > Language > Edit translations. Open this separate IOK file, and set the text tools text search option to Exact and enter "no value" to find the cell where this value is specified. Replace the default text with your own text and save the translations file. You can then set Omniscope to use the edited translations file under Settings > Language > Use edited translations file. You will need to re-start Omniscope.

    The entire process for creating a new set of translations for any/all of Omniscope is explained here:
  •     WKeith January 27, 2010 12:11AM
    Will an iok file I create with the new language file in place be seen with the new text by someone who opens it, or will they also have to update their own language file?

  •     WKeith January 29, 2010 12:16PM
    I have edited the language file, but I think I made a mistake, changing the value in the en column, rather than putting my new one in en_GB, but now when I try to edit the file, even after deleting the languages iokj file and re-installing Visokio, I cant find the 'no values' field. Am I missing something?
  •     WKeith January 29, 2010 2:03PM
    Bizarrely, when I sorted the En column, I found the 'no value' record in the En column, despite the text search not finding it! I changed the En-GB value, and it now works as I want.

    Is there a way to get users who only have the viewer, not professional, to see the new value?
  •        mohamed February 3, 2010 2:58PM
    You need to send users your version of "editedLanguages.iok". They need to follow the below steps so Omniscope can use your copy of the languages file:

    1. They need to copy your version of "editedLanguages.iok" to their user home directory. Please do not change the name of this file.

    2. Enable this option Settings > Language > Use local translations file. (This option is not currently available in Omniscope Viewer in the latest build Omniscope 2.5 b297. But this option will be available in the new Omniscope 2.5 b298 build which you can get from our download page next Monday "8/02/2010").

    3. Please restart Omniscope for the new settings to take effect.

    Just out of interest, what is the new value you you are using instead of "no value".

    Regarding the search for "no value" issue, please use "En" filter device to do the searching. In order to make your search exact, please enable "Show text tools" from the configure drop-down in the device toolbar and change the search type to be "Exact".


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership