Visokio website     Downloads     Video tutorials     KnowledgeBase  
Scheduler: Setting failure email alert? - Visokio Forums
Scheduler: Setting failure email alert?
  •     mburgess December 6, 2011 9:31AM
    Hi - we are currently trialling server version of Omniscope 2.7 b123, it is installed on an Amazon Cloud machine image running Windows Server 2008

    I have a scheduled task and want to set a failure alert email notification. I have found the screen where i need to input the smtp, port, user & password & SSL & message info

    I have tried with a few email accounts - one my personal Hotmail, which i have the settings for on my IPhone.

    FYI - Although MS Office is installed, but there is no email set-up in a non POP3 or IMAP email client like Outlook Exchange on the server.

    All create an error message telling me that cannot connect to SSL and to check antivirus/firewall on the server. I have had infrastructure test the server and cannot find anything on the server that would be preventing this working? (screenshot attached in Word document)

    Is there anything i am doing incorrectly, some setting i need to change, is this a known bug in the alpha 2.7 version?

    Thanks - Matt Burgess
    visokio error.docx 886K
  •     tjbate December 9, 2011 12:02PM
    Matthew - We have run tests using personal accounts in web-based mail services like GMail, specifying SSL connections, and they work fine for us. Please give me a call and we can try to duplicate this using one of your GMail accounts....

    The fact that you are running on a cloud server from Amazon may mean there are more than a few barriers to using SSL in place.
  • timabraham September 25, 2012 9:43AM
    Hello - We have a similiar issue....did you ever find a solution to this at all?
    Thanks - Tim
  •     steve September 26, 2012 1:53AM
    Has the Windows Firewall been configured to permit traffic on the ports required for SSL email?
  •     steve September 27, 2012 6:21AM
    We've had a number of clients report issues with SSL email connectivity from Omniscope on an Amazon EC2 Windows instance.

    We're unable to reproduce the problem. The following test works perfectly for us:

    Amazon EC2 instance configuration
    • AMI: Windows_Server-2008-R2_SP1-English-64Bit-Base-2012.08.15 (ami-cbc87da2)
    • Zone: us-east-1b
    • Security group: default for a Windows box (3389 inbound, only - outbound is always unrestricted by Amazon)
    • Windows Firewall: no custom rules; outbound is always open by default

    Test sequence
    1. Connect using remote desktop.
    2. Download and install the latest 2.8 build.
    3. Register for a trial, or use a key of your own (remember to deactivate after testing).
    4. Open DataManager.
    5. Add an Email block.
    6. Configure a Google email connection or a Yahoo Business email connection (we tested both; both use SSL).
    7. Pick a folder (INBOX).
    8. Restrict the number of emails (for quick testing).
    9. "Load" the block.

    The email message data loaded correctly without any network/SSL errors.

    If you are experiencing issues, please follow this exact sequence of steps, provisioning a new instance, of the same type. If it doesn't work, let us know. Otherwise try to narrow down the difference in what you're doing that causes the problem.
  •     mburgess September 27, 2012 6:36AM
    i'm currently checking with our IT guys that figured it out, but i think it had something to do with the sender had to be verified in AWS console before it will allow send of notifications (i did not do myself so cannot provide exact details)
  •     mburgess September 27, 2012 6:42AM
    if above does not work, what i'm told we do now is we used our own automation to record the failure logs in a file which is then picket up by another process and sends from there (i.e. we worked round it rather than resolved it)
  • timabraham September 27, 2012 7:29AM
    Thanks so much both....we will try the changes proposed from Steve.

    Matt - seems like you never got the full functionality working without the workaround then?
  • timabraham September 27, 2012 10:25AM
    Steve - just noticed that your instructions i think refer to picking up emails in omniscope (this works ok) whereas the problem is with sending emails from omniscope?
  •     steve September 28, 2012 4:51AM
    Since we posted the above test, we connected to the same instance and tested using the Scheduler to send an email as a failure action for a Chain action.

    We did this from the Start menu, but not as a Windows Service. If you are having issues that are only present in the Windows Service, see here:

    We tested in fork and non-fork mode. We used the Google SMTP server settings which includes ticking SSL. Everything worked correctly and we received the emails.


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership