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Omniscope User Guide
Learning to Use Omniscope 

This User Guide is divided into sections, the contents of which are accessible using either the links below or the lower left-side User Guide
navigational menu that also displays the sub-sections.

Questions? Always consult our FAQs/Forums [1] page first. Try searching for specific commands, terms or phrases using the search box at
upper right to find all references in the Forums, on the site, this User Guide and the KnowledgeBase.

For a printed version of any section, or the entire User Guide, click on ‘printer friendly version’ at the bottom of the first page you wish to print,
then use your browser Print function. If available, choose PDF as the printer from your browser to obtain a PDF file version. Alternatively, you
can download the PDF file posted here, although it is not aways the very latest version.

 Printable version [2]       PDF version [3] (21 MB)
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1: Overview [5] - The introductory overview covers key Omniscope functionality and illustrates typical tasks in 10 steps; install Omniscope,
prepare data, load/import data from a spreadsheet, check the data types, explore/check the data, display the details, add/change views,
create report tabs, add links, and save the configured Omniscope files for distribution to others. The recommended 6-Phase approach with
checklist [37] sets out the sequence of steps in detail, and can be also be used as the basis for training sessions.

2: Install & Activate [6] - Describes the Omniscope installation process on Windows. Details regarding administered desktop and network
installation options, and installation on non-Windows operating systems, are covered in the KnowledgeBase [4].

3: Using IOK files [7] - Covers navigation of an example Omniscope file already prepared for you. It introduces the navigational
icons/buttons on the Main Toolbar, as well as the basics of selecting and filtering using the Side Bar. It also provides links to documentation of
the Main Toolbar command menus, which are primarily used for creating new Omniscope files, rather than exploring/navigating existing files
prepared by others.

4: Using Views [8] - Links to the pages detailing the commands and options available for each of the different views in Omniscope. Also
provides an introduction to using the commands common to most View Toolbars within views. If you wish to go directly to the section relating1/305



provides an introduction to using the commands common to most View Toolbars within views. If you wish to go directly to the section relating
to a specific view, click the links below (or visit the Views Reference [25] page).

Table [38]

Chart [39]

Pie [40]

Bar [41]

Graph [42]

Tile [43]

Pivot [44]

Tree [45]

Network [46]

(2.5+)
Portal [47]

Map [48]

Venn [49]

Web [50]

Content
[51](2.5+)
Dial [52] (2.5+)
Details [53]

[50]

DataPlayer [54]

Text*
Google Earth*

 

*To try these new v iews in development in version 2.5, go to Settings > Application-wide > Advanced > Show experimental features

5: View Details [9] - Explains the options for displaying some or all the values associated with individual records or selected groups of records
- the Details pop-window, the Side Bar details display options and the Details View. The highlighting function, which shows the position of
selected records in all open views, is explained and illustrated. Automatic record cycling and slide show image displays that provide file recipients
with automatic, unattended 'tours' of the data are also covered.

6: Queries & Subsets [10]- Introduces the related concepts of Named Queries and defined Data Subsets to generalise the concepts of data
universes and the basket used in earlier versions. The Main Toolbar Named Queries menu options are introduced, as is the Data Subsets
selector that appears on View Toolbars immediately to the right of the view name for all views.

7: Use Your Data [11] - Covers importing your own data into Omniscope to create and save IOK files for your own use and distribution to
others. Explains importing data from spreadsheets and other types of data files, maintaining links to source data, editing your data and
refreshing the data from or to linked sources. Also provides links to sections dealing with connecting directly to database tables/views.

8: Configure Data [12] - Outlines the four main steps to configuring a new Omniscope file; 1.) confirm data typing column order and
settings, 2.) configure Sidebar display(s), 3.) configure opening views and 4.) modify the appearance (optional). Explains the useful and
powerful Data > Manage fields dialog, together with Sidebar filter/query device configuration and use. Also covers the most common data
management issues (format, layout and orientation) with links to more detail. Introduces each of the 16 available views, with links to more
detailed documentation of the options available for each view (see also the Views Reference [25] section).

9: Main Toolbar [13]- This section documents the navigational functions located on the Main Toolbar, and introduces the command menus
available on drop-down menus on the left side of the Main Toolbar (see also the Commands Reference [27] section).

Version 2.5: | File [55] | Data [56] | Tab [57] | Layout [58]| Toolbars [59]| Settings [60]| Help [61] |
   (click links above to go directly to the Commands Reference page)

10: Controls & Side Bars [62] - Shows how to use the Controls drop-down menu on the Main Toolbar to reveal or hide the Side Bars and
the Cycling Toolbar. Provides detail on configuring the filter/query devices displayed on the Side Bars with the Devices and Tools Side Bar drop-
down menus, using the functions available on the filter/query devices, and the commands accessible by right-clicking on the devices. Also
provides detail on using the Cycling Toolbar to set Record, Value and/or Report cycling options to animate your files on opening.

11: Create Reports [15] - Introduces the process of creating and modifying Reports Pages, the Reports Navigator, the importance of
committing or reverting changes to Report Pages, how to exit Reports Mode and using various menus for managing all the Report Pages
already configured in a given file.

12: Formula Fields [16] [16]- You can define the values in a new Formula column to be evaluated according to mathematical functions and
logical expressions using the values in other columns. In addition to the same functions used in most spreadsheets, Omniscope also features
powerful SUBSET functions that operate on entire data sets. This section introduces the use of Formula fields (columns) and provides links to
more detailed sections on defining your own formulae and using Variables (assumed values used for sensitivity analysis) and the Functions
Guide [29], which provides more detail on using the specialised SUBSET functions.

13: File Appearance [17] - Highlights a few of the more commonly used options for branding the overall appearance of a given file using
Cover and Back information pages together with your own corner logos, etc. Options for adding your corporate identity to installations of
Omniscope itself, simplifying display menus, and adding banner advertising displays to Omniscope files are also referenced.

14: Refreshing Data [18] - Explains options for refreshing data from linked sources, introduces the Automatic refresh option

, and provides some guidelines for editing data in Omniscope then exporting the changed data. This section also introduces options for linking
Omniscope files to other Omniscope files (or even itself) as a linked data source, permitting many differently-configured distributed copies to be
refreshed from the same Omniscope file, itself being refreshed directly on the server from the data warehouse. Also explains how to unlink and
re-link Omniscope files from source data files.

15: Useful Tools [19] - Introduces some of the most commonly-used commands available on the Main Toolbar Toolbars
and Settings menus; such as specifying the display mode for individual record-level details, and selecting Tooltips to display key values or
images whenever individual or small groups of records are selected. Options for switching and editing languages are also explained.

16: Adding Links [20] - Explains the process for adding local links, using pre-configured links to free web services and creating custom web
links launched by clicking on specific cells/values in your files.

17: Adding Images [21] - Explains the process for associating folders of images (image sets) with your files and referencing them for display
in various views. Omniscope can associate more than one image with each record (row), and can associate more than one image set with a
file, either embedded or for delivery via the web. If multiple images are available for some records, slide show mode can display a sequence of
these images for each record selected. 2/305



these images for each record selected.

18: Using Maps [22] - Introduces the Map View and various ways of adding maps and geographic coordinates to your data sets.

19: Creating DataPlayers [23] - DataPlayers are exportable, data-bearing, interactive Flash 'dashboard' .SWF files which can be created,
refreshed and exported from Omniscope to web pages and documents such as PowerPoint, Excel, PDF ...with full interactivity. This section
explains how to create, combine and export many different, highly-configurable DataPlayer view types using the DataPlayer View of
Omniscope.

20: File Security Options [24] - Omniscope files can be saved with extensive file security options controlling who can open Omniscope files, for
how long and under what circumstances. 'Layered' security options are available for securing data against unauthorised copying (not even
cut-and-paste) and for implementing highly-secure deployment options such as domain locking and/or 'walled gardens'.

21: Views Reference [25] - Summarises the available and experimental views still under development and provides links to the detailed
section(s) documenting each view.

22: Commands Reference [27] - Summarises the Main Toolbar command menus and provides links to the section(s) for both version 2.5 and
version 2.4.

23: Functions Guide [63] - Link to KnowledgeBase section documenting standard Omniscope functions, the specialised SUBSET functions,
and examples of expressions for performing common tasks with Formula fields.

24: Connector Overview [30] - Connectors are used to provide high-performance data import, refresh and synchronise features for
data hosted on remote 'cloud computing' SaaS platforms, data base feeds or client-premise installed applications using Omniscope as the local
reporting/presentational interface. This section provides an overview of the web and direct connectors currently available (and some
still classed as experimental features) for use with activated editions of Omniscope. 

 Using Connectors:

25: Bloomberg Connector [26] - If Omniscope is running on a computer with access to Bloomberg [64], Bloomberg fields added can be added
and refreshed directly into the Omniscope file, either on opening of on-demand using Refresh from Source (Ctrl+F5). This section documents
the options for using the Bloomberg connector wizard to import and refresh Bloomberg data within Omniscope files (not available in free
Viewer).

26: Email Connector [32] - Connect and download e-mails using either POP3 or IMAP protocols.

27: Google Spreadsheets [33]- Connect to any Google spreadsheet and edit it online in the browser or off-line in Omniscope. Changes will
be synchronised bewtween Omniscope and Google Spreadsheets in real time. Permits collaborative compilation and maintenance of data sets
delivered in branded, highly-visual Omniscope files with the possiblity of live refresh and banner ads inside the file.

28: Facebook [34] - Import your friends network from Facebook.

29: Google Analytics [35] - Import data directly from Google Analytics.

30: Website Mapper [36] - Crawl a website and visualise its structure, adding data from Google Analytics and other sources.

31: Salesforce Connectors  [28]- Omniscope is integrated with Salesforce [65] and the Force.com [66] cloud computing platform. If you have a
Salesforce account and security token, you can go to File > Open online source andchoose to open either a Report (read-only) or Data
Object/Table directly from Salesforce. Using the direct connector, you can you can visualise, analyse, save offline, add/edit data and
synchronise yourchanges with Salesforce. There is also a free web connector for Salesforce listed on the AppExchange [67].Your Administrator
can install a 'Visokio Reports' tab into your Salesforce accounts to enable pre-configured downloads of Reports and Data Objects/Tables that
open in the free Viewer. Using an activated Omniscope, you can also modify the default templates provided for each Report and Data
Object/Table, and upload your customised files to the'Visokio Reports' tab in Salesforce to modify the online DataPlayer displayed or
provide alternative templates for future downloads. The free web connector can be installed in Group accounts, but the direct connector
involves API access which Salesforce permits only to subscribers with Professional, Enterprise and Unlimited Editions.

 

Omniscope Top [68]

Overview

Getting started with Omniscope
A very brief introduction to Omniscope

Omniscope free Viewer will open any Omniscope .IOK file of any size, up to the limits of your PC [69]. Each new Viewer installation also includes a
free 30-day trial of Omniscope Professional. During the 30-day trial period, you can import your own data from spreadsheets and databases,
and you can export data from any of the embedded or online demos as spreadsheet files to see how these files were configured from the raw
data. You can also use the DataPlayer View to create exportable, interactive Flash DataPlayers for embedding in web-based 'dashboards' and
common documents like PowerPoint, Excel and Adobe Acrobat .PDF.  After the 30 day free trail expires, the installatation reverts to being a
free Viewer, so there is never a need to un-install.

To see your data in Omniscope:
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To see your data in Omniscope:

Installation

If you don't yet have Omniscope installed, install the free Viewer [70]. The install sequence (for Windows) is shown here [71].

Select a data file

You can open tabular data sets such as spreadsheet files directly in Omniscope. A sample 6-column .CSV file for use with this Quick Start page
is attached here [72]. Download the sample data file, or choose a different one containing your own data. Try to avoid any blank rows and
merged cells. Check that your spreadsheet looks like this. [73]

 

 

If you want to try duplicating on of the embedded or online demo files, and you are within your 30-day trial period, or already running an
activated Edition, you can open any of the demo files and use File > Export > Export files and select the Data tab to save the data as a
.CSV or other supported file type. You can then re-import the data using File > Open file, and compare with the embedded demo to see how
the demo file looked before it was configured.

Start Omniscope, select & open any data file

Click File > Open File and point at the .CSV or other data file you wish to open.

 

 

Omniscope will open the file displaying three default views; a Table View, a Chart View and a Pie View.

 

4/305



 

The Table View is most familiar, but the Chart View is very useful for gaining insight into the data at a glance.

For more detail, see Using Your Own Data. [74]

Check Data Types

Omniscope examines the data in each column and makes some assumptions about the column's data type, which are not always optimal.
When importing data for the first time, always check and (if required) modify the data typing (i.e. whether a column's data is typed Numbers,
Dates and Times or Text). If there are only a limited number of different Text values, Omniscope will usually type the data as Category. To
review and edit data typing, click on Data > Manage Fields.

 

 

Frequently, Omniscope assumes that identifying numbers should be treated as integer numbers. You should change the data type of all-
numeric reference identifiers to 'Text'. Remove the separators in the number before converting to text using Options > Formatting
options: {untick} Show thousands separator. Also, for some date and time fields you may be asked to clarify the date/time format used
in your data before Omniscope can recognise it accurately as dates and times. For more detail on data typing options see Data > Manage
Fields [75].

Explore & Check Data:

Each view has a View Toolbar that enables you to perform many operations on the display in that view. For example, in the Table View you
can click on the column headers to sort each column in different directions. You can also check your data by using the Aggregation selector to
aggregate the records by main categories, then right-clicking on each column header and selecting various aggregation functions, allowing
you to see averages, minima, maxima, empty cells etc. for various categories, often detecting incorrect values.
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 [76]

 

Using the hurricane example file, close the Pie and Chart Views, and open a Table View. Click on the Aggregation command to aggregate all the
observations over time by Hurricane Name. By default, all of the columns will show the sum of the observations, nonsensical in this case. Right-
click on each column header, choose Aggregation function and display the median for the Longitude and Latitude columns, the mean
(average) Pressure and the maximum Wind Speed. The example above shows two Table Views, the lower with the aggregation functions
defaulting to Sum, and the upper showing the same data with the view configured to show meaningful results that can be used to spot errors
in the data. From version 2.4, the Aggregation drop down menu on the View Tolbar can be used to set both the fields to aggregate on and the
aggregation functions to apply to visible columns in the aggregated view.

For more detail, see Using the Table View [38]

Visual scrubbing with Chart View

Next open only the Chart View, which provides a horiziontal overview of all the columns in the data set. In the Chart View, under View Tools
> All charts, for each field (column) name you can decide how to graph the values in each column, e.g. histogram bars, pie charts, statistical
summaries, etc. Use this analytical view to further scrub your data.

 

 

The right-click menu provides links to many other settings related to the selected field (column). You can re-order or hide fields that are not
required by dragging or unticking them in the Fields drop-down pick list.

For more detail see Using the Chart View [39]
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Display Details

To see the values of all the fields for a given record (row), in the Table View, double-click on the record (row) header (farthest left). A
configurable Details pop-up window appears, showing the values for the selected record. You can configure the Details pop-up window
extensively using the Configure menu.

 

Add Views

Omniscope has 12 different views that can be used to visualise and explore your data. Click on  Add View in the Main Toolbar and try each
of the views not already showing. Each view has its own Toolbar and pick lists for selecting which fields (columns) to display. The powerful Bar
View has a tab that you pull from the left side to reveal all the options. When you have finished with a view window, click on the [X] in the
upper right hand corner to close it.

 

Create tabs

All users of your Omniscope file are not expected to know how to open views, set multiple filters etc. Instead, you decide the most important
combinations of views, filter settings and messages to other users, and save them as persistent tabs, which can be considered report pages or
simply separate workspaces. Tabs are preconfigured combinations of views, filter settings, formula variables and annotations. If you save an
.IOK file in Reports Mode with a Report Page selected, it will open and navigate just like a slide show presentation.

To create a tab in your file, click on Tab > New > From current layout from the Main Toolbar.
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You can also add page titles and annotations, insert logos and background images, etc. using the Layout menu.  Once the page looks exactly
like you want, click Tab > Commit changes. You can choose to hide your tab bar and show the "pages" in the side bar.

 

If you make further changes to a tab, always remember to click Commit to make them lasting. If you do not wish to change a tab after
performing some operations on it, click Revert to return the Report Page to its configuration when you last committed or created it. This is
useful when giving live presentations.  There is also an optional floating tab navigator in the lower left-hand corner, which reveals itself when
you hover your mouse (Toolbars > Floating tab navigator). For more detail, see Creating and Managing Report Pages [15].

Add links to related web pages and documents

Omniscope integrates with the Web by incorporating defined links based on your data. Values in your data are automatically transformed into
links when users of your files click to display related web pages. The web pages can display either in the Web View of Omniscope, or the users'
default web browser. To configure your own web links or add links to local documents on your network, use the Add links wizard available
from Settings > Links > Add web or Add local link.

 

8/305



 

Omniscope also includes pre-configured links to popular, free web services that accept a single string of text as an input, such a Google, EBay
or Wikipedia searches, or financial data on specific securities from Bloomberg, Reuters, Yahoo etc. Select Settings > Links > Preconfigured
links to see the menu of currently available free web services.

Save for Distribution

Once configured, save your Omniscope file using various options for distribution. Go to File > Save As and you will be presented with the
Data Export wizard set to save your file as IOK files. This wizard offers many options to save all or only selected subsets of your fields and/or
records, plus the option to set file update/refresh options, and to protect your data from unauthorised access and copying.

 

 

Next Section: Install & Activate [6]

User Guide Top [68]

Task Checklist

Task Check List & Training Outline
A step-by-step approach to configuring Omniscope files

 

Anyone can systematically configure Omniscope files following the 6-phase checklist outlined below. Most issues arise because essential steps
like checking and changing default data typing assigned by Omniscope on import are not addressed before moving on to other tasks.
Following the checklist below will enable you to achieve rapid results and make best use of Omniscope. This outline also serves as a useful guide
for structuring training sessions. 9/305



for structuring training sessions.

Import > Data Check > Analysis > Visualisation > Presentation > Publication  

Phase 1. Import Data

Options for importing data into Omniscope include importing from data files, relational tables/reporting views created using SQL, some multi-
dimensional 'cube' data structures (2.6+), and various remote-hosted or 'cloud' based data sources via connectors. These steps are
documented in the sections of this User Guide on importing data files [77], using database connections [78], and using connectors [30]. More
technical detail is available in the KnowledgeBase sections on supported data file formats [79] and examples of database connections [80] using
ODBC and JDBC.

Phase 2. Data Check 

The Data Check Phase emphasies data completeness and correctness. In this phase, data typing assumptions made by Omniscope on import
should be checked, columns expanded, collapsed or tokenized to facilitate end-user interaction with your file. Use Table View column sorting
and the Chart View to examine extreme values in each column, address null (blank) and missing values, then add other information to the
Omniscope file, such as image sets, maps and links to related web pages and web services.

In this phase, scrubbing view configurations (rather than presentational view settings and layouts) are used, normally working on a single tab
entitled 'Data Set' or similar. This tab should reveal all data and filters (use both sidebars if necessary to see a the filter devices) in the
Table/Chart View(s) without aggregations or groupings. 

Note: it is good practise to always leave this 'Data Set' tab accessible as the final tab on the far right of the file tab set, providing an instant,
credibility-enhancing view of the data at maximum granularity to any user who clicks on the tab. 

Phase 3. Analysis

The Analysis (and formula definition) Phase focuses on optimising the working data set for its intended audience. Column re-naming should be
used to shorten names and make them instantly meaningful to the end-user audience. Un-needed columns (especially empty or uniform-value
columns) can be hidden or deleted, and the number of unique category values can be reduced, either via re-naming/consolidating values with
data edits, or by adding formula columns that re-categorise records into fewer categories. Formulae can also be defined to transform imported
data fields into more useful values and to detect alert conditions to be highlighted. If you use formulae to convert/reduce total category
values, or to extract useful data fields from within text strings, your changes will be re-evaluated on every refresh. 

You may need to duplicate certain columns so that they can be typed differently, providing different filtering options for users. At the end of
this phase, all the values required to address the end-users' requirements should be in the file, and the single 'Data Set' tab should show all the
columns, both data and formula, which have not been globally hidden. Finally, on a separate 'Analysis' tab, useful data subsets will be made
referenceable as Named Queries, and Aggregation settings and formulae tested.

Phase 4. Visualisation

Omniscope provides a large and growing number of views, each of which is highly configurable. In the Visualisation Phase, you test each View
on its own tab, seeking the best configuration(s) of each view for the points you want to make to your intended audience. You may create
more than one variant of each view. Presentational use of Table View Grouping/Summary Row options are tested in this phase. Any views
determined to be of limited value to the audience for a given data set can be hidden. The default opening settings for each view will be defined,
and the paning and field selection drop-down menus edited so that only useful options are presented to the end user in each view.

At the end of this phase, you should have a tab for each view type you plan to use, with one or more variations of the view on each tab,
perhaps some with Aggregation menu settings and specified display functions for aggregated values, including a second, more presentational
version of the Table View with Aggregation, Grouping, and perhaps both.

Phase 5. Presentation

Unlike the first three Phases, where the mind-set was to reveal the data, the Presentation Phase takes a zero-based approach to file
configuration, i.e. everything should be hidden unless it is needed on a specific tab to make a specific point or enable a particular end-user
interaction. From this phase onward, the mind-set is simplification of the audience experience i.e. "less is more".  Based on the most useful view
configurations created in the previous Visualisation Phase, the objective in the Presentation Phase is to construct a multi-tabbed presentation
where each tab is addressed to a specific audience and specific point on each tab.  More tabs, each focused on one group or point to be
made, is better than trying to put too much on one tab. The objective is to create a file that opens and navigates just like a slide presentation.
View-specific visualisation tabs created in the previous Visualisation phase can now be deleted.

Phase 6. Publishing

In the final phase, we focus on options relating to how others will use the file. Refresh options, file security options, help screen authoring,
branding options (opening screen, closing screen, banner ads, corner logos, etc.) and use of other options are addressed in the Publishing
Phase.

Checklist: Data Check
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Close all the default opening Views on the opening Tab, except for a Table View.

2-A Check data typing -

2-B Address null (blank) values -

2-C Expand, collapse or tokenize columns -

Note: Expanding and collapsing columns are data edits that will not survive a data refresh. If the changes are to be made persistent, they
should be made in the source data.

2-D Look for aberrant values -

Note: Data deletions and corrections will not survive a data refresh. If the changes are to be made persistent across refreshes, the changes
should also be made in the source data.

2-E Import image sets -

2-F Download/import maps -

2-G Define links -

Commit all changes Tab > Commit changes for all  and Save (Ctrl+S) the file, preserving the link to the source data file if required.

Checklist: Analysis

Hide the Chart View (if open) and continue working in a single Table View in a single 'Data set' tab

3-A Perform merges - Use the Merge Wizard if additional data from other sources needs to be joined or concatenated.  Before performing a
join, test the uniqueness of join criteria columns using the Table View: View Tools > Tools > Select duplicate records command.

3-B Rename fields (columns) -

Use "\" in field names to introduce custom line breaks, which will appear in Table View column headers (assuming multi-line headers are enabled)
and also in filter devices showning on the sidebar.

3-C Hide or delete fields (columns) - empty, uniform value and fields not needed by end users for filtering can be hidden or deleted. These
actions will be re-performed on every file refresh. Values in hidden columns can be displayed in details and used in links.

3-D Define formula fields (columns) -

3-E Duplicate/re-format fields (columns) -  sometimes it is useful to duplicate a data/formula column so that the columns can be typed
two different ways to facilitate use of different filter types, often while allowing one of the columns to also be used as a splitting category.
Sometimes, the format of Dates & Times needs to be changed so that the values in duplicate columns sort better as categories or otherwise
better facilitate user interactions.

3-F Reveal both sidebars and order filter device display -

3-G Table View: Define Queries/subsets - In addition to the 'Data Set' tab already configured, create a new tab from the current layout
and name it 'Analysis' or similar. Open a Table View within the new tab (both sidebars should still be revealed with all the relevant filters as they
are in the Data Set tab. Move filter devices from the right to left sidebar by adding them to the left sidebar, they will be removed from the right
sidebar automatatically. On this new tab, use the sidebar filters to define some persistent Data Subsets by using Main Toolbar: Queries >
Create queries from filters, then Reset, then choose another combination of filters and create another Named Query subset. If you have
multiple unrelated data blocks in a single file, use this process to isolate eacg data block in a re-usable query setting.

3-H Table View: Define aggregations - use the Aggregate drop-down menu to define & check aggregations, specifying the aggregation
functions to be applied in each column. For formula fields, consider whether it is appropriate to apply the formual to the aggregated values.

Commit all changes Tab > Commit changes for all  and File > Save (Ctrl+S) the file, preserving the link to the source data file if required.

Checklist: Visualisation

In this phase, the focus is on making best use of the various views for visualisation and navigation. 

4-B Table View: Create a new tab called 'Table View' which will be used to experiment with the presentational aspects of the Table View using
Grouping and the various settings for the overall Summary Row.

Commit changes to the tab Tab > Commit changes

4-C Pie View: Define multiple pies with different combinations of Value and Split-by settings...experiment with horizontal and vertical paning,
save best/most useful  visualisations on tab called Pie Views or similar. Commit changes to the tab Tab > Commit changes

4-D

Commit all changes Tab > Commit changes for all  and File > Save (Ctrl+S) the file, preserving the link to the source data if required.

Checklist: Presentation
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Make sure that the opening tab is open, then commit all changes Tab > Commit changes for all  and File > Save (Ctrl+S) the file,
preserving the link to the source data if required.

Checklist: Publishing

 

Make sure that the opening tab is open, then commit all changes Tab > Commit changes for all  and File > Save (Ctrl+S) the file,
preserving the link to the source data if required.

 

 

Back to Overview [5]

User Guide Top [68]

Installation/Activation

Installation & Activation for Windows
Step-by-step installation of Omniscope on Windows machines 

Omniscope is a Java application, and the full installer provided on our download page [81] comes with a private version of Java included. There is
only one installer file to download for all Editions of Omniscope. The installer includes a 30-day free trial of Omniscope Professional. On expiry of
the initial 30-day trial, the installation will revert to a free Viewer, which never expires. No need to un-install ever.

Note: If you intend to install an Enterprise Edition with automated Scheduler and Generator capabilities, make sure to install on a machine that
will not be turned off, and activate the installation from an account that will not log-off.  See the Automation section of the KnowledgeBase for
more information on installing an Enterprise Edition as a Windows Service [82] to provide always-on data refresh and other automation services.

Omniscope Installation (for Windows)

To install on Windows, visit our download page [81]and download the free Omniscope Viewer installer for Windows.  

1. Click "Open" or "Save" when prompted. 
2. If you choose "Save", the installer file OmniscopeInstaller.exe will be saved. 
3. If you choose "Open", the installer wizard will launch automatically.
4. If you clicked "Save", find your OmniscopeInstaller.exe file on your computer
5. Double click on this installer file to run it

 

When the Installer launches, you will see the following security warning...just click Run...
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The next screen is the set-up wizard, click Next>

 

 

The next screen asks you to accept our licensing agreement.  More information on the terms of our licensing is available here [83]. Tick the "I
accept" box and the Install >  button to continue.
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You will see an installation  progress bar, a list of files being installed and then this screen: Click Finish with the Run Visokio Omniscope box
ticked.

 

Unless you have previously licensed Omniscope, your installation will open as a free Viewer, allowing you to open and navigate any Omniscope
.IOK file, such as the many embedded and online demos. [84]  In addition, all free Viewer installations come with a free 30-day trial of Omniscope
Professional, enabling you to make files with your own data. At the end of the trial period, unless activated the installation reverts to a general-
purpose free Viewer...no need to uninstall.
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Keeping Omniscope updated

By default, Omniscope installs with the option to automatically check for updates ticked.  Test that you have the latest version, and that your
automatic update function is working by clicking Help > Check for software updates now.

 

 

If you have a problem contacting our update server, it may be that your machine is accessing the Internet via another machine known as a
'proxy server'. Due to limitations in Java, Omniscope is sometimes not able to detect these settings automatically.  They useful not just for
updates, but also for Activation, bug reporting, etc.
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If your organisation is using a proxy server, you will probably have to ring your support person or network administrator to discover the
settings Omniscope needs.

 

 

More information on Proxy Settings [85].

Activating and Upgrading Omniscope

If you have a license key to upgrade from the free Viewer to Omniscope Professional or Enterprise, or you are upgrading from Professional to
Enterprise, you must click on Help > Product licensing and activation either activate (new install) or refresh (upgrades) your activation. 

 

 

The Activation wizard will prompt you to enter your license key, which is a string of numbers like this:

WSE5-544X-X8T5-FB6Q
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Contact us  [86]in order to obtain a license key.

Online Activation

Start your free Viewer from the Desktop or the Start menu. Click Help > Check for Software Updates Now to ensure you have the latest
version installed. Once you have installed the latest version, click on Help > Product Licensing and Activation. Enter your license key in the
space provided.

 

 

Enter the license key and click Submit. If your machine has connectivity with our server, you should see a dialog like this...

 

 

If you see an error message relating to connectivity with our server, check to see that you are online, and revisit the Proxy Server settings if
you are behind a Proxy Server.  If online activation fails, you will be invited to use browser-based activation [87], described in our Knowledge
Base. Otherwise, you should see an activation success confirmation like this:

 

 

At any time, you can see the licensing status of your installation by clicking on Help > Product licensing and activation.  Every time you
install a new version, you should refresh your activation to ensure you have access to all the latest features.
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The Help > About  (or press F3) information screen should also confirm your licensing status, and display your license key. The Edition you
are running should also be displayed on the opening screen every time Omniscope starts. 

 

 

The Help > About (or press F3) screen also reports the version of Java that Omniscope is using, which is usually a private version different
from other versions of Java on your machine. For more information on Java, see our KnowledgeBase [4].

This completes the User Guide coverage of typical Windows installation and activation. If you have questions or experience problems, please
visit the more detailed KnowledgeBase Installation [88] and Activation [89] sections.

 

Next section: Using .IOM/.IOK files [90]
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Using Side Bars

Using the Side Bars
Instant filtering query devices and tools

 

Side Bar Display

Whenever either Side Bar opens, there are three menus displayed at the top; the Devices drop-down menu, the Tools drop-down menu,
and the right corner [X] to close the Side Bar. The first time the Side Bar opens, three configurable display options (Reports, Search All, and
Exclusions) plus filter devices for all fields (columns) in the data set will be ticked and therefore visible on the Side Bar.

To configure or re-configure the Side Bar, click on the Devices drop-down menu on the upper left:

18/305



 

 

Except in a general Data Set page showing everything, you will probably not want filter devices for ALL the fields (columns) to be displayed on
most pages. Some field values may not be relevant to the message or useful for selecting/filtering the displays on a given page. Use the
Devices drop-down menu to Un-tick those fields to hide their filter devices. Use the drag hands at the right to move filter devices upwards
or downwards to achieve the desired display on the Side Bar. You can also move the filter devices themselves into a new order by dragging
and dropping them with the mouse upwards or downwards on the Side Bar.

The three configuration options at the top of the Devices list (Reports, Search All and Exclusions ) will be displayed on the Side Bar only if
you leave them ticked. Otherwise, untick these boxes and Report Page tabs will display across the top of the Main Toolbar (the default),
Exclusions (Move and Keep with history) will show on the Main Toolbar (without history), and Search All will be available in the Portal View [91],
when open.

Note: Side Bar settings are specific to each Reports Page, and must be changed page-by-page inside Reports Mode. Side Bar settings
established outside Reports Mode (always hit Escape to make sure you are not working in a specific Report tab) will apply outside Reports
Mode. If you create one or more Report Pages, you can either keep your existing Side Bar settings the same or change them to suit each
Report Page. . More on creating Reports Pages. [92]

Using Side Bar features

If you leave all three display configuration options ticked, the top of your Side Bar will look something like this:

 

 

Displaying Exclusions on the Side Bar has the advantage that you can expand the Exclusions device and monitor the history of your Moves
and Keeps (see image below). This is especially useful when you are recording a power query sequence of  Moves and  Keeps to send to
someone else as a query file for use with their copy of the file (see below for more on query files).

Displaying Reports on the Side Bar is useful when there are very few, or when there are many Reports Pages that need to be arranged in
groupings.

Like Search All above, any Side Bar text filter can be expanded to reveal a virtual keyboard for text search entry, with ANY and ALL multi-
term search options. Omniscope text search works like a search engine, on one, several or all fields (columns)simultaneously. In any text filter, if
you enter a single text string with no spaces, Omniscope will perform a prefix match, highlighting all records with text beginning with the
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you enter a single text string with no spaces, Omniscope will perform a prefix match, highlighting all records with text beginning with the
search string. If you enter two text strings separated by a space and do not enclose them in "double quotes", you can search a field (column)
of the data file for either one or both of the strings using the ANY or ALL search options. You can expand your search criteria to include
values in other columns by simultaneously entering text strings in more that one filter device. To the right of each device you will see the hits in
that column and at the top, in the barometer will show the combined record count.

Note: Omniscope does not yet support an EXACT match option, so searching for numbers and text can return records whose values are
supersets of the search term, i.e. a search for '22 ' will also display 222, 223, etc. leaving you to select the final records manually.

Closing the Side Bar

Notice that whenever a query device is actively filtering the data set, the device panel colour turns orange:

 

 

Closing the Side Bar with filters set will prompt a message either to reset all the filters, or to convert the query settings to Exclusions. If you
wish to keep the same record set in the IN Universe with the Side Bar closed, you must choose Convert to Exclusions, which means that
the filter settings will be translated to the equivalent   Moves and  Keeps that you can manage directly in the open views without the Side
Bar.

Side Bar Tools Menu

The Side Bar Tools drop down menu displays commands that affect the data and/or all other Side Bar query devices. The first three of these
are especially useful when managing the creation of Report Pages and using them in live presentations.

Reset variables- Variables are input values not
contained in a column of the data set that you
can include in formula fields to facilitate dynamic
modelling and sensitivity analysis. When you
specify a Variable, you define a minimum,
maximum and a default value in the range.
Each variable defined in a file can display a Side
Bar slider enabling users to change the
assumed value. Clicking on Reset variables
returns all variables to their default values. For
more on defining and using variables, see
Formulas & Variables [93].
Reset filters (query)- Clears all filter settings
and returns all records to the IN
universe...does the same as the  Reset on
the Main Toolbar.

Reset configuration (views & layout)- returns the current view to a 'pristine' state, with all views closed and the Side Bar reset to opening
default settings. Usually used to recover from confusing combinations of views and layout when constructing Report Pages.

Clear colour-by- each device has a small colour-by icon in the upper left. Clicking the device icon imposes the colouring scheme for that field
(column) on all the open views that use colouring, like the Table View, the Tree View, etc. This command removes all overriding colouring
schemes that have been set in the Side Bar (but not those already specified in the individual View Toolbars) 20/305



schemes that have been set in the Side Bar (but not those already specified in the individual View Toolbars)

Halo function: Also include records with the same value in: a powerful feature for managing groupings or clusters within a data set.
Setting the Halo function changes filtering behaviour to include/maintain all records sharing a common value in the specified field (column). For
more information, see Using the Halo function. [94]

[94]

Expand all- expands all visible Side Bar devices

Collapse all- returns all Side Bar devices to their collapsed state (default on opening)

Add new variable- brings up the Add Variable wizard...see Formulas & Variables [93]

Edit variables- brings up the Edit Variable wizard...see Formulas & Variables [93]

Convert all to exclusions- Converts the current settings of all query/filter devices into Exclusions (the results of Moves and Keeps), thereby
setting the green IN universe independently of Side Bar settings...allows Side Bar devices to be reset and/or hidden without changing the
current composition of the data universes.

Import XML query file- XML query files exported from Omniscope by one user, say a business user identifying data quality issues with
specific records (e.g. corrections or suspicious data) can be imported by another Omniscope user, say the Database Administrator, who wants
to view just the records at issue and decide whether to parse the XML file to import the corrections into the source database.

Export XML query file- Exports the current query settings as an XML text file which other Omniscope users can open to recreate the same
display, assuming they have the same .IOK file version open.

 

Right-click device menus

Right-clicking on any device displays a series of options for resetting/hiding the device, and changing the filter type. Changing the filter type is
sometimes necessary to facilitate user interaction. In the example shown below, the field 'Node' is an integer number field, displaying as a range
slider (the default) and with the 'Include empty (null) values' box ticked. If it was better to have users search for a specific number by typing it
in, we could change the filter type to Text search...without changing the data type to Text.

 

 

Below the Filter Type command are a series of commands for managing each field. These commands are the same as those accessible from
the Main Toolbar Data > Manage Fields menu, and are discussed here [95].

 

Next: Using the Halo Function [96]

User Guide Top [68]

Halo Function

Using the Halo Function
Advanced joint column filtering option

 

The Side Bar Tools menu includes an option to change filtering behaviour by activating the Halo function. This function changes filtering
behaviour from the default to a modified form which preserves all records which share a specific value in a specified field in the IN universe,
even if the value in the filters is not one of the selected values. 
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The Halo function is activated from the Side Bar Tools > Halo option, by changing the common value field (column) from (None) to one of
the fields in the data set. Once the Halo function is activated, a yellow caution triangle appears on top of the Side Bar telling you that filtering
behaviour is now in Halo mode.

The Omniscope Halo function is a powerful analytical tool already used extensively with retail point-of-sale (POS) data. The example below is
based on this file [97]. The file contains POS data on 223,484 items purchased at a number of convenience store Units/POS positions over a
month, in a wide range of categories. Items sharing the same UniqueTransaction number (first column text field) were bought at the same
time. 

On the top of the Side Bar, the Halo function has been set to include all records sharing the same value in the Unique Transaction field. This
means that filtering for a particular item will carry with it all the items that were bought at the same time. Notice the yellow caution triangle that
has appeared on top of the Side Bar.

 

 

In this example file, the Halo function is used to select all items which were bought together with a particular promotional item (i.e. they have
the same unique transaction number). In the example file, we filter the ProdName column to select the 'meal deal' promotion.  With the Halo
function on, filtering on ProdName 'meal deal' returns not only the 'meal deal' transactions, but also all other 'haloed' items that share the
same unique transaction numbers.  

Try downloading the example file [97] and repeating the analysis for specific days of the week, time slots or outlets.

 

Next: Cycling Options [98]

User Guide Top [68]

View/Filter files
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Using
Omniscope
.IOK/.IOM files
Exploring files created by
others

This section provides an introduction to 'navigating' or 'exploring' Omniscope .IOK/.IOM files that someone else has prepared and sent to you.
This section uses an Everton British football club file as an example, which you should download now [99].

Omniscope files always open as last configured and saved. In the case of the Everton file, it has many columns that could be used for filters, so
it has been configured to open with four views and both the right and left Side Bars open:

 

The following sections discuss the navigational features on the Omniscope Main Toolbar, and the use of Side Bar filters and other devices that
help you navigate any .IOK file and select the records (rows) that you wish to see in detail.

Main Tool Bar Commands:

 

The left side of the Main Toolbar contains top level command menus useful for preparing .IOK files. These are not needed to navigate .IOK files
already prepared by someone else with your needs in mind. More detail on these commands, which are not specific to using individual views,
can be found on these pages:

File Menu [100]- open, import, export, and save/print data files/images of files
Edit Menu [101]- modify data types/display of columns, changes to the data set
Tools Menu [102]- a wide range of settings/configuration options linked to the data
Reports Menu [103]- prepare report pages as slides combining views, queries, images, maps, etc.
Page Menu [104]- adding titles, annotations, logos and other formatting outside views
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Appearance Menu [105]- changing the look and feel of the file, outside pages and views
Help Menu- [106] version updates, documentation, demos, licensing, bug reporting links etc.

To the right of the command menus, the Main Toolbar displays a number of useful icons/buttons that are used to aid exploration/navigation of
the .IOK file:

 Add View- Used to add an additional View to the current display. In the demo, try adding a Details View to the display. To remove a View
from the display, click on the [X] in the upper right hand corner. To change one View to another, click on the View name and select the View
you want from the drop-down menu. In the demo, try changing the Map View to a Graph View.

 Reset- Omniscope files are flat tables of data, with records (rows) and fields (columns). One of the objectives of navigating an Omniscope
file is to select and focus on only a certain subset of records (rows), rather that the whole universe of records in the file. The Reset button
removes all of the filtering criteria you may have expressed, and returns the current display views to show all the records. It is very important
to always reset your data before filtering, so that all qualifying records will be considered in your subsequent query.

 Deselect- Omniscope navigation depends on 4 basic operations: Select (or Deselect), Move, Keep, and Reset. Every view provides ways of
selecting one or more records. In the demo, look at the Table View and under Player, click on the first picture (Richard Wright). His record is
now selected, indicated by blue animated shading, and his record is now highlighted in other views. In the Graph View, for example, we can see
from the blinking highlight that like most goalkeepers, he had no goals or assists. Now click the Deselect icon on the main Toolbar, and this
record is not longer selected. Try selecting, then de-selecting other players, or groups of players. For example, in the demo Pie View, click on
Republic of Ireland. This will select two goal-scoring players from Ireland. Be sure to click Deselect before moving on.

 Move- Selecting records is a precursor to deciding whether to Move these records OUT of further consideration. The Move Command
moves all selected records OUT of consideration, where they stay until the display is Reset.

 Keep- the opposite of Move, the Keep command keeps only the selected records IN consideration, and moves all the other unselected
records OUT of consideration.

 Back- like a browser, you can go back to the previous display at any time by pressing Back.

 Show Side Bar- clicking this icon gives you the option to show or hide the Side Bars on one or both sides of the current display. Uses
of the Side Bar are explained in the next section.

 FeatureFinder link- used to export data sets to Omniscope's companion applications FeatureFinder Desktop or Web. Use these separate
applications (or the Omniscope DataPlayer Studio plug-in available in version 2.4 and better) to convert your data (up to between 5-10,000
records, and possibly more, depending on content) into interactive Flash DataPlayers suitable for embedding in web pages and offline
documents like PowerPoint, Acrobat .PDF, or Excel. 

 Barometer- upon opening a file, it is useful to know how many records are in the data set. As you filter, it is useful to see how
many records have been kept IN consideration, and how many moved OUT. The barometer is a visual gauge that shows the total, as well as
the split between IN (green) and OUT (red). Click on the Republic of Ireland wedge of the Pie View in the demo. Notice how the barometer
tells you that you have selected two players. Now click  Move. Notice how the barometer tells you that you have excluded two players...just
because they were Irish? Since they were goal scorers, let's click  Reset and put them back on the team!

 Basket- the basket is a 'parking place' where you can put selected records, such that they will stay there even if you Reset the
display. At any time, you can open the Basket and see the records you have placed there. In the demo, go to the Table View and select the
Position 'Goalkeeper' instead of Richard or Wright. Notice that unlike a spreadsheet, the Barometer tells you that you have selected 3
Goalkeepers, not just Richard Wright. Now click the Basket, and choose 'Add selection to basket'. The record count in the Basket changes to
3. To view the contents of the Basket, click on the icon. We have just put all 3 of our Goalkeepers on the market! Let's re-consider...click on
the drop-down arrow to the right of the basket, then click Clear selection from basket, or Clear basket. More on Using the Basket [107].

 Help screen- click on the help icon to see what the publisher or re-publisher of the file may have to say that will help you understand more
about the file.

 Publisher logo link- if you are publishing or re-publishing a file, you can put your own logo here, and link it to your website.

Using Side Bars

Most Omniscope files contain pages with Side Bars showing on the right, the left or on both sides of the display. At any time, you can reveal
and configure Side Bars to help you and your readers navigate a file.  From Version 2.4, the display of Side Bars is controlled from the Main
Toolbar Controls drop down menu.  More infomation on configuring and using Side Bars [62] and using the Controls [14] drop-down.
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In the Side Bar text device labelled Surname, type a letter.
Notice how all views update to display only players whose
surnames begin with that letter. Back-space or click Reset at
the top to clear this and show all players again.

In the Side Bar category device labelled Position, click on the
green tick boxes for Defender (it turns into a red 'X'), then
Forward and then Midfielder. Now only Goalkeeper should
have a green tick mark, and only the 3 goalkeepers on the
team should be displayed. Click all the devices back to green
or click  Reset at the top to return to viewing all the
players.

In the Date of Birth date/time query device, click on the left-
most blue handle and drag the slider rightwards. Watch how
the players displayed disappear, oldest first, until only the
youngest player is visible. Return the slider to its original
position or click the  Reset button at the top to restore the
experienced players to your team.

Do the same with the Height and Weight numerical sliders to
determine who is the tallest and heaviest player...is it the same
man? Remember to return/reset the sliders.

Hovering the mouse on a Side Bar query device reveals basic
statistics on the values in this field/column...which may include
explanatory field notes from the data set and .IOK file
preparer about each field (column) of data.

Right-clicking on a Side Bar device reveals a wealth of options
to change things, such as resetting all the other filters or even
hiding the filter. To return all Side Bar filter settings to their
original state, click Reset on the Main Toolbar.

 

Next section: Using Views [8]

User Guide Top [108]

Using Views

Using Omniscope Views
Many different ways to display your data and related information on the web

 

Omniscope 2.4 currently offers 14 different views (version 2.5 has 17) to help you and recipients of your files analyse and illustrate the
messages in your data. Omniscope views offer much more than just data visualisation and portable/exportable charting and presentation.
Most views are complete data navigation environments enabling browsing, aggregation, analysis, filtering and drill-down to details. All views set
to show the same data subset/named query e.g. 'Filtered data (IN)'  update simultaneously to reflect filtering actions.

Some views are slightly different:

Web View [50], opens browser window(s) showing linked web pages and the results of web services associated with the data set.

Content View [51] (2.5+), displays free text comentary and links to web assets, including images and charts not referenced in the data set

Dial View [52] (2.5+), creates typical dashboard-style gauges to display filed (column) composition, progress and alert conditions, etc.

Details View [53], displays all (non-hidden) values for each single record, together with images and buttons/links connecting to related web
pages/services.

DataPlayer View [54], allows anyone to create interactive Flash DataPlayers encapsulating the data in exportable 'dashboards' for documents
and web pages.
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Adding Views

The vertical View Chooser drop-down menu appears whenever you click  on the Main Toolbar, or when you click on a view icon to
change an open window from one view to another.  Each View is represented by its own icon:

 

[38] [39] [40] [41] [42] [43] [44] [45] [46] [47] [48] [49] [50] [51] [52] [53] [54]

 

 

For more on using each of the views, and the options available on their respective View: View Toolbar > View tools menus, see the Views
Reference [109] page, or click on the view icons above or the names below to go directly to the discussion of each individual views:

 

Table [110]

Chart [111]

Pie [112]

Bar [113]

Graph [114]

Tile [115]

[113]

Pivot [116]

Tree [117]

Network [46]

(2.5)
Portal [91]

Map [118]

Venn [49]

Web [119]

Content [51]

(2.5)
Dial [52] (2.5)
Details [120]

DataPlayer [54]

Text*
Google Earth*

*To see these experimental v iews (you will need to re-start your Omniscope for full effect): 

Version 2.4: Tools > Advanced Tools > Application wide settings > Show experimental features;

Version 2.5: Settings > Advanced > Show experimental features.

Options for each view are generally available on the View Toolbar.  Many of the commands available from the View Toolbar > View Tools
drop-down menu are common to all views. Commands or options common to all (or most) views are documented here: View Tools
common commands [121].

View Toolbars

Each View has a View Toolbar, which presents the features and options applicable to that View, including a View Chooser, Data Sub-Set
selector, Aggregation options,  a View tools drop-down menu, Fields (columns) picker and oterh options specific to each view. View
Toolbars open and close at the top of each view window. All views and View Toolbars always open below the Main Toolbar, whose commands
apply to all open views.

View Toolbars vary in appearance, since each View features different controls on the toolbar, but they typically look like this:

 

View chooser - switching or closing views

In the left corner of each View Toolbar is the View icon which identifies the view currently selected. Clicking this icon also reveals the vertical
View Chooser drop-down from which you can change the view shown in that window.  On the right-most end of all View Toolbars is the
Close View icon, shown as a black [X]. Click this icon to close the view. You can always bring closed views (or new, additional views) back by
clicking this icon on the Main Toolbar:

Queries & Subsets selector - defining the data subset in each view

By default, new views will open with the Data Subset selector set to 'Filtered data (IN)' meaning you're looking at all the records that meet the
filtering criteria expressed on the Side Bar. You can change the Query/Subset of the data shown in the view using the drop-down selector.
More on Queries & Subsets [10]

Aggregation menu - defining the aggregation of records in the view  

Beginning with version 2.4, many Views include an Aggregation drop-down menu, used to define aggregated views of the data, together
with the function to be applied when aggregating each field (column). Aggregation differs from the presentational Grouping options available
only in the Table View.  Unlike Grouping, the end user is not meant to 'unroll' or 'drill down' the defined aggregation to the lower level of
granularity. User-interactive Grouping can be used in addition to Aggregation. For example, a file with each row defined as an observation for a
given day can be aggregated by week, then grouped by month and year. In the resulting Table View, an end user would be able to unroll the
groupings down to weeks, but to see the maximum granularity daily data, they would have to remove the Aggregation settings.
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View Tools

 

Fields

 

 

Next section: Viewing Details [122]

User Guide Top [68]

Displaying Details

Displaying Details
and Highlighting
with automatic cycling and image
slide shows...

With the exception of the Table View, Omniscope views do not show the all the values associated with individual records (rows) or small groups
of records. Once you have filtered down to a relatively small group of records of interest (using either Selection followed by Moves and Keeps,
or Side Bar filter devices) you have several highly-configurable options for viewing some or all of the details for one or a group of selected
records.

Details View and pop-up window for single records

If the Table View is open, and no Details View is open, selecting/double clicking on a row header (left-most part of a row) will display the details
for that record- either as a separate pop-up window (the Details window) or as an embedded panel in the left or right Side Bar (you set this
option from the Main Toolbar using the Settings > This tab > Details command).

 

Whenever the Details View is open, clicking on row headers or links set to display details will display inside the Details View. Only if the Details
View is closed will the Details pop-up window or embedded panel options display. Whenever the Details View is open, the settings for that view
(columns to show, etc.) will be used. When the Details View is closed, the settings for the pop-up Details Window or embedded Side Bar panel
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display will be used. Note that these settings are Report Page specific. If you wish to alter them in a given Report Page, you must open that
page, make the changes and commit your changes to make them persistent.

 

 

Viewing Details for multiple records

Every View Toolbar has a View Details icon next to the Add to Basket icon on the right hand side. This command opens a tabular view of
either the selected records in the view, or all data in the view, showing the fields set to be visible in the Table View, even if the Table View is not
visible. The View Details option is like opening a temporary Table View. Like the Table View, double clicking on the row header, or on any
underlined link set to open the Details Window/Side Bar panel, will display individual details for that record. You are always at most 2 clicks away
from full details on any record using the View Details option on any View Toolbar, followed by clicking on the row header or details link in
the View Details pop-up window.

 

 

Warning: The fields (columns) displayed in the View Details pop-up table window are the same (and in the same order) as the settings
governing the Table View. If you are in Reports Mode, you must configure a Table View (even if the Table View is not normally open on the
Reports Page), in order to control the order of the visible fields in the View Details pop-up for that Reports Page. If you do not do this, the
settings for the Table View at the time the Reports Page was created will be used. If you later change the settings for your working display Table
View, the changes will not automatically be made in the Reports Pages unless you select Apply these changes to all Table Views and then
explicitly elect to apply the same settings to all Reports Pages, or else you return to each Reports Page and change the Table View settings
individually.

Highlighting

If Settings > This tab > Brushing enabled (the fading of unselected records) is not enabled, whenever a single record is selected, the
position of that record is highlighted in aqua-blue in all open views., as shown above. Open Table Views will scroll to reveal the selected record.
Use highlighting to see the positioning of a record in plots, such as the Graph and Chart Views, and read off values for various fields of the
selected record in all open views. If you are using a colour-by setting on the Side Bar, highlighted rows will be partially highlighted, so that you
can still discern the colour assigned to the highlighted record (row). You can turn this feature off by clearing the Highlight button on the
view/pop-up toolbar.
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Record Cycling

Hovering on the Main Toolbar barometer reveals the control panel for record cycling. Record cycling automatically steps through the records
in the universe you select and displays the position of each record in all open views using highlighting. If you have a Details View open, or
details windows showing on the Side Bars, then the details for each record (including any related images) will be displayed as cycling steps
through. Cycling is turned on, paused, stopped, fast-forwarded and fast-reversed using the green control icons under the barometer.

 

 

Clicking on the Options button displays the record cycling configuration panel. Options available include Loop, which plays the cycle
continuously once started; Play on open, which starts cycling automatically when the file is opened; Universe: which selects the data
universe from which the records will be cycled for display; and Record order which sets the field used to order/sort the records to be
displayed.

 

 

Warning: If you have global record cycling enabled, and you turn off the Highlighting option, the record cycling will stop. To re-start record
cycling, hover your mouse on the barometer to expose the global automatic record cycling menu, and click on the green forward arrow to re-
start.

Note: Version 2.4 has improved control of cycling options, see using the Cycling Toolbar [98]

Slide Shows

Most View Toolbars feature a Slide show option. This option is used in files with associated or embedded image sets to display the image(s)
associated with each record in a special Slide show display window. This window can be any size and can be displayed on another monitor.
Unlike record cycling with the details view, slide shows can show multiple images associated with each record using tokenized file names in the
picture column. For more information, see Tokenized data [123]
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From the View Toolbar, click on the Slide show icon to reveal the configuration options panel. Options available on this panel include:

Jump to record: allows you to preview any record(s) by dragging the slider to the start point
Limit enlargement: prevents over-enlargement of images to be displayed (to the detriment of the clarity of the image based on
multiples of the size of the image available to the Omniscope file.
Sharpening: this setting can be used to compensate for poor image quality, which could be due to enlargement
Transition time: number of seconds between image displays (can be none)
Play Speed: number of seconds each image is displayed
Match/set image background: Controls the background displayed in the window together with the image.
Add to basket: adds the record being displayed in the Slide show to the Basket. For more detail, see Using the Basket [107].
Loop: repeats the slide show over and over again
Title Field name: Specifies which field in the data set will displayed together with the image(s)

For more information on configuring Details Windows and the Details View, see the Using the Details View [120] section of this User Guide.

 

Next: Queries & Subsets [10]  [10]

User Guide Top [68]

Queries & Subsets

Named Queries & Data Subsets
Creating Named Queries to define data subsets

Version 2.4:

By default, Omniscope works with 4 defined sets of data;  ALL data, filtered IN data, filtered OUT data and Selected data. Files open with
ALL data in the filtered IN set, but via Side Bar filtering, or selection, moves & keeps, some records are transfered to the filtered OUT data
subset as shown in the barometer. You can define aditional subsets of data which can be displayed alone or in conjunction with the defined
data sets/subsets using Named Queries.

The Named Queries drop-down menu is immediately right of the Barometer, and provides all the commands required to define and manage
Named Queries, combinations of filter settings or record selections which define selcted or filtered subsets of the file data expected to be used
frequently in configuring the views in the file. In the example below, 3 Named Queries have been defined; 'Basket One', 'Errors for Correction'
and 'Other Named Query'. At right, the example Venn View toolbar has been set to display the records contained in the Named Query 'Basket
One'.

 

Each View Toolbar includes a Data Subset drop down
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Each View Toolbar includes a Data Subset drop down
where you specify which of your defined Named
Queries (in brown) should be displayed in the view:

 

Named Queries can be defined using either Create empty query or Create query from filters.

 

Create empty query- give the query you plan to populate a unique name for this file. The new query will appear at the top of the Named
Queries drop-down list, and become a side menu option for commands such as such as Clear, Rename and Delete Query. The Show
button for option places a button with the name of the selected Named Query/data subset on the Main Toolbar to the right of the Named
Queries drop-down menu. These button(s) make it easier to manage adding or deleting selected/filtered IN records from multiple Named
Queries. Once an empty query has been created, e.g. 'Basket One' or 'Errors for Correction' you can add filtered IN or Selected records to
these queries at any time using Add or Remove selected/filtered data to query (if records are Selected, these records will be
added/removed, if not, then the current contents of the Filtered IN subset will be added/removed to/from the Named Query you select from
the sub-menu at right.

Create query from filters- this option lets you preserve the current pattern of filters set in the Side Bar as a Named Query. You can
subsequently refine the data set defined using Add or Remove selected/filtered data to query.

Import/export XML query file- the definition of any query in the file can be saved in XML file format and exchanged with others using the
same Omniscope file. This is useful for example, for highlighting anomalies and errors in the data requiring correction.

 

 

Version 2.3 and previous:

When Omniscope filters records, where do the excluded records go? Don't worry...they are not deleted!  Based on your input, Omniscope
classifies each record (row) in a given file as being in one or more Data Universes:

Green 'IN' Universe- records still under consideration
Red 'OUT' Universe- records moved out, excluded from further consideration
Black 'ALL' Universe- all records in the file/data set, regardless of queries/filters set
Gold 'BASKET' Universe- records saved to the basket during the session
Blue 'SELECTION' Universe- records selected at any given time

All of these Universes can be viewed at any time in any of the 12 available views in Omniscope. Click on  Add View on the Main Toolbar, then
select the Show other data universes option at lower right.
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Tick the box representing any combination of Views and Universes to see the records (rows) currently in each universe in each view.

If you save an Omniscope file, the contents of the IN and OUT Universes will be preserved, and the file will open with the barometer showing
the same IN/OUT split as when the file was last closed. However, the contents of the BASKET and SELECTION Universes will be re-set.
Always remember to do something with the contents of your  BASKET universe before you close the file, because this selection of records will
not be there when you open the file again. 

Let's explore the use of Data Universes in Omniscope, while re-visiting the filtering aspects of navigating .IOK files. Recall that there are 2
filtering approaches in Omniscope, which can be used interchangeably at any time, assuming at least one SideBar with instant filter/query
devices is showing.:

1. Side Bar filter/query devices (known as instant query mode)
2. Select/Move/Keep sequences (known as power query mode)

In the Tutorial below, we will see in more detail the difference between single-step, 'instant' filtering using Side Bar filters/query devices, and
multi-attribute, potentially multi-layered 'power' queries using Select/Move/Keep sequences. If you are viewing both the IN and the OUT
universe, it is also possible to do dual-directional, multi-layer power queries...which are difficult, and sometimes even impossible to do
programatically!

Using Data Universes

For this tutorial, please download another, especially-configured version of the Everton Football Universes [124] file. This version of the Everton
file has been configured to open with five Table Views, one for each Universe, and with only one Side Bar open:

 

The View icons on the far left of each View Toolbar are coloured to show which of the 5 Universes is being displayed in the view. In this demo,
the upper left-hand Table View is showing the green IN Universe, all 23 players. The upper right-hand Table View is showing the red OUT
Universe, currently empty because no players have been filtered out. The full-width black ALL Universe Table View in the middle will always
show all players, regardless of filtering. The gold BASKET Universe Table View is showing 'Basket Empty', since no players have yet been
placed in the Basket. Finally, the bottom blue SELECTION Table View is empty, indicating that no records are yet selected.

Using the Side Bar, type the letter 'B' into the top text query device labelled Surname. Notice how the right-hand green IN Table View changes
to display only the 3 players whose surnames begin with B, and the left-hand red OUT Table View now displays the records for the 20 players
whose surname does not begin with 'B'. A glance at the barometer confirms that the green IN Universe contains 3 players whose surnames
begin with B, and the red OUT Universe contains 20 players whose surnames all begin with other letters. In the Side Bar, back-space over the
letter 'B' to clear the Surname query device, which will Reset the file, since this was the only extant query/filter setting.

Notice that when using the Side Bar devices, the bottom Table View showing the SELECTION Universe did not show any records being
selected, and that moving 20 players to the OUT Universe was instant. 

Now let's try using Selection, which can be very useful for drilling-down and confirming details before deciding whether to execute a Move or
Keep operation. 

Go to the upper right green Table View showing the IN Universe, and click on the Position category Defender, which will display an animated
highlight in blue. This means you have selected all the players who are Defenders, and their records will now appear in the bottom blue
SELECTION Table View. A glance at the barometer will confirm that you have selected 9 Defenders out of the 23 on the team.

Let's say you want to take a closer look at the Defenders. On the main/top Omniscope Toolbar, click on the green check-marked icon labelled
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Let's say you want to take a closer look at the Defenders. On the main/top Omniscope Toolbar, click on the green check-marked icon labelled
Keep. This will keep only Defenders in the green IN Universe and move all others to the red OUT Table View to the right. Notice that the
SELECTION Table View has been cleared, pending you next selection.

Let's say you want to put all the English Defenders on the transfer market (don't ask...). In the Side Bar, using the 3rd device labelled Country,
click on the category name England. Notice that all other nationalities are X-ed out and all non-English Defenders are moved to the red OUT
universe, leaving only the 4 English Defenders remaining in the IN Universe. Now go to the green IN Table View Toolbar, and find the Add to
Basket icon right-most on the toolbar. Click the Add to Basket icon, and notice that the gold Table View showing the BASKET Universe now
shows the 4 English Defenders.

Click Reset on the Omniscope Main Toolbar. This will return all players to the IN Universe, and empty the OUT universe, but leaves the 4
English defenders in the Basket, as can be seen also on the top/main Omniscope Toolbar Basket icon to the right of the barometer.

Let's save the youngest English Defender for the future. In the gold Table View showing the 4 English Defenders currently in the BASKET
Universe, click on the column header Date of Birth. This will set a primary sort (see the orange downward arrow appear in the column header)
sorting the players in the basket from youngest to oldest. Double-click on the row header of the youngest player, Daniel Fox. This will display
the details window pop-up for Daniel Fox. Now click Remove from Basket to remove Daniel's record from the basket.

To clear the BASKET Universe completely, click on the right-most Clear basket icon in the gold Table View Toolbar, or use the Omniscope
Main Toolbar Basket > Clear basket command on the drop-down menu. More on Using the Basket... [107]

 

Next section: Use Your Data [74]

User Guide Top [108]

Using the Basket

Using the Basket Universe
Warning - legacy documentation. This page applies to Omniscope 2.3 and earlier.  From Omniscope 2.4, the basket universe
has been superceded by named queries [10] which are far more powerful.  The terminology "Data universes" has also been
dropped.  The Basket is no longer available in 2.4+.

Omniscope classifies every record in the data set as belonging to various 'data universes'. In addition to being in either the IN or OUT
Universe, all records are always in the ALL universe. At any given time, any selected records are in the SELECTION universe. Clicking 
Deselect, or executing a power query using  Move or  Keep removes all records from the SELECTION universe and shifts records
between the IN and OUT universes. Clicking  Reset moves all records from the OUT universe back to the IN universe.

Version 2.3 and previous: Every View Toolbar (except the Web View) allows you to put all (or just one or more selected) records into the
BASKET universe, building up a list of records in which you are particularly interested. The purpose of the BASKET universe is to allow you to
collect a session-persistent subset of records (rows) that does not Reset. The Basket allows you to use many different Side Bar filter criteria or
sequences of power queries to identify records of interest, placing each group of records in the BASKET for 'safekeeping' prior to executing a
Reset and applying other filtering sequences or power queries to your data.

Although records in the BASKET are unaffected by Resets, the contents of the BASKET not saved on Exit. If you wish to save, share or
reuse the contents of the BASKET, you must use the Export or Import basket references (or images) command options which appear
on the View Toolbar whenever you are viewing the BASKET target universe:

 

 

References are the values in a field (column) that are unique, that is, there is only one reference value for each record (row). (You should
always test for duplicate references using the Table View Tools Tools > Select duplicate values option )

Import basket references- if you or someone else using data with the same unique identifiers have previously saved a reference list as the
single column of values in a .TXT file, you can re-create the contents of the BASKET in your current Omniscope session using this command
to import the external .TXT reference file. Omniscope will move all matching records (rows) into the BASKET universe automatically, and tell33/305



to import the external .TXT reference file. Omniscope will move all matching records (rows) into the BASKET universe automatically, and tell
you if any references in the external file could not be matched.

Export basket references- typically, you use Side Bar filtering and power queries (together with geographic and image-based selection) to
identify a sub-set of records on interest, and accumulate them in the BASKET universe. Before you exit, if you want to save (to share or re-
use/re-create) the contents of the BASKET, you must use this command to export a .TXT file containing a list of the references currently in
the BASKET.

Export basket images- Omniscope can be used to manage and select images grouped in folders (image sets) for web-sites, DataPlayers,
and other uses. At any time, a selection of images in the BASKET can be exported as a new image folder using this command.

Export this view's data- used to export the entire contents of the BASKET universe in various file formats ( .IOK/.IOM, .XLS, .CSV, .TSV,
.XML, etc.) using the Export Data wizard [125].

Details View of the Basket

You can enable your users to browse the contents of the BASKET in any view(s), but given that they will have already selected these records
and placed them in the basket for closer review, a free-floating instance of the Details View with the records navigation slider revealed can be
the most effective.

To create a free-floating view, use Add View command on the Main Toolbar with the Open new window option ticked. From the Details
View Toolbar, choose Show navigation controls to display the arrows and slider navigation at the top, and untick the Sync option, since this
view is for user review of the BASKET universe only. Add a title, use the Links option to add buttons for the action links at the bottom, then
hide the View Toolbar and users will be able to interact with their baskets record-by-record using a floating window something like this:

 

 

Back to Queries and Subsets [10]

User Guide Top [68]

Use Your Data
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Using Your Data
Importing your data into Omniscope

Thus far, you have been learning how to navigate Omniscope .IOK/.IOM files prepared by others. Now you are ready to start opening your
own data in Omniscope, and configuring .IOK files for use by yourself and recipients of your files.

Omniscope imports tabular data (data in rows and columns) from spreadsheets and databases. The simplest way to get data into Omniscope is
to open/import the data from a spreadsheet, such as an Excel .XLS file. All popular spreadsheets and databases allow exporting or saving as
comma-separated values (.CSV) files. You can import .CSV files into Omniscope just like a spreadsheet, without the row limits imposed by
spreadsheets. Tab separated values (.TSV) and some other common delimited text data file formats are also supported, as is .XML. You can
also cut and paste tables of data directly into the Table View of Omniscope.

Opening/Importing Tabular Data

If you have both Excel and Omniscope installed, Omniscope can open data from native Excel .XLS files directly. Before opening a spreadsheet
file in Omniscope, first check that the spreadsheet has a suitable tabular structure (see example). [126]

A sample 6-column .CSV data file containing repeated observations of location, air pressure and wind speed for a series of hurricanes over time
is available here. [127]

To open your spreadsheet data file in Omniscope, simply choose File > Open file from the Omniscope main menu, and browse to your .XLS
or .CSV spreadsheet file. Omniscope will only import data from a single worksheet tab in a spreadsheet file. If you have a data set spread across
more than one tab, you will need to start by opening/importing the data from each tab and saving it as a separate Omniscope file, then using
the Merge Data wizard to combine them into a single Omniscope file. For more information, see Using the Merge Data wizard. [128]

Opening/ and importing a new table of data in Omniscope creates a new .IOK/.IOM file, which by default opens with 3 views of the data; a Table
View, a Chart View, and a Pie View (which will be displaying the record-count split of one of your columns of data):

 

 

For more detail on importing data files into Omniscope, see Opening Datasets [129]. Omniscope can be configured to open spreadsheets that
vary somewhat from the simple structure using the options available in the Open Data Set Wizard [129]. Common issues related to data format,
file layout and orientation are discussed in the Data Management [130]section. More detailed information on supported file formats and methods
of dealing with common issues is also available in our Knowledge Base section on Data File Import [131].

For more information on connecting directly to database tables/views instead of data files, see the section on Connecting to Databases [132].

Refreshing from Linked Sources

Maintaining links to data sources enables Omniscope files to be updated whenever the data in the original source file changes. This is especially
useful when working with reporting views automatically extracted from central databases, or when a specific tab on a specific spreadsheet is
being used to generate the source data. Every time a new view is generated and a new file produced, if it is saved to the same location with
the same name, Omniscope will automatically detect the change on next opening and import the newest values. More on Refreshing Data [133].

Unlinking from/Re-linking to Source file
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Every time a linked .IOK file is opened or closed, the user is given the option to unlink the file from its original source. It is also possible to re-
establish a link to a source file using the command Data > Edit source and pointing at the data file again as before, which will preserve any
field conversions and formulae applied to the previous source.

 

 

Editing and Saving back to Linked Sources

Upon opening an Excel spreadsheet or other supported tabular data file, you'll be working on a new, unsaved Omniscope .IOK file. When you
save the Omniscope .IOK file, all the imported data (and any edits you may have made), together with the view configurations and layout
settings will all be saved in the new .IOK file. In addition, by default, you will have established a 'pairing' or 'linked source' relationship between
the Omniscope file and the original data source file. As long as the linked data source file remains in the same relative location, Omniscope will be
aware of this 'linked source' file and its most recent version. If it changes, Omniscope will notice and offer to refresh the data from the linked
source file.

If you make changes to the data in Omniscope, on closing the .IOK file, you will be asked if you want the changed data Saved back to
source or whether you wish to Unlink the file from its source. If you chose to save your data edits back to source, the original spreadsheet
will be replaced. Please note the following warnings about writing Omniscope files back to linked source spreadsheets:

Warning- Edit only one file at a time: If you make changes to both the Omniscope file and the linked source file, you risk not being able to
preserve or "merge" both sets of edits

Warning- Multiple Worksheets: If your spreadsheet has more than one non-empty worksheet tabs, Omniscope will ask which of the tabbed
worksheets you want to import from. However, if you edit this data in Omniscope, choose to preserve the link, and choose to save back to
source, Omniscope will overwrite the entire multi-tabbed spreadsheet file with a single-worksheet spreadsheet.

Warning- Formulae and Formatting: All formulae, formatting and other non-tabular information in the source spreadsheet file are ignored on
import, only the formula result value is imported. If you choose to maintain the link, and you chose to write back to source, you will overwrite
your spreadsheet formulae with static data. Merged cells and other formatting, embedded graphs, etc. are ignored.

Warning: remember, saving back to source will overwrite the spreadsheet with a plain unformatted file of tabular data with
only one worksheet.

Suggestion: If you have worksheets with macros and other report formatting, but wish to visualise, filter, edit and otherwise manage the
source data in Omniscope, try using cut and paste to move the data from Omniscope onto the first tab of your spreadsheet, and move all the
macros and formatting onto subsequent tabs referencing the required values from the first tab in the spreadsheet pasted from Omniscope.

For more technical information on data file formats supported and how best to open them, consult our Knowledge Base [131].

 

Next Section: Configure Your Data [134]

User Guide Top [108]

Configure Data

Configuring
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Your Data
Make your data
interesting...

Once your data has been opened and imported into Omniscope, there are four general steps to configuring how Omniscope displays your
data for maximum impact, utility and ease of navigation.

1. Confirm data typing, default column order & settings
2. Configure Side Bars, show/hide filter devices
3. Configure opening views
4. Modify appearance (optional)

Suggestion: Remember to click File > Save as to start the process, and save your IOK file frequently as your configuration work
progresses.

Data Typing & Column Order

Omniscope uses four Data Types to help it display the most appropriate filter/query devices and in many other ways. When importing new a
new data set, Omniscope inspects all the values in each field (column), and sets an assumed Data Type for each field (column) to be one of five
types:

Text- character strings, and numbers used as codes, like identifying codes.
Category- limited numbers of unique text words/values, like country names, colours, true/false fields etc.
Integer numbers- whole numbers with no decimals.
Decimal numbers- numbers used in calculations and percentages.
Dates & Times- many different date and time formats occur in source data, most of which are recognised and converted
automatically.

The first step in configuring your own data file is to confirm that Omniscope has correctly typed all the fields (columns) in your data. To do this,
click on Data > Manage Fields to display the Manage Fields [75] dialog:

 

The Data > Manage Fields panel provides an overview of all the fields (columns) in a data set, their current Data Type settings, and allows
you to Change Data Types, Add, Rename or further Configure a field, Hide Fields from all views, and Remove fields (columns) from the
file. The drag handle 'hands' at the far right are used to grab and re-order the fields from the default import order, to a more useful 'master'
order. Once you have the fields (columns) in the order you want, click on Reset field orders and the new order will become the starting point
in each view you configure. You can make persistent changes to the field (column) order view by view, and in Report Pages, but whenever
you return to Data > Manage fields > Reset view field orders, the field (column) order in all views will be reset.

For more on adding, removing, hiding, renaming and converting field Data Types, see the section on Managing Data [130]

For a more detailed explanation of all the commands and options in the Data > Manage Fields dialog, see the Main Toolbar Commands
section Data > Manage Fields [75].

Data formatting, layout and transposition issues

Data formatting, layout and transposition issues can arise for various reasons. Date & time formats [135] can sometimes not be imported
automatically until you assist Omniscope by clarifying the format your date and time data is in. International differences [136]in data formatting
may need to be . You may also want to use the ability of Omniscope to manage more than one value in a cell (e.g. to capture one-to-many
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relationships) using tokenized data fields [123]. Omniscope time series [137] data needs to be oriented 'vertically' with all the dates and values of
repeated observations in columns (not rows). You can use the Omniscope De-pivot/Re-pivot functions [138] to transpose (change the
orientation) of some or all of your data.

For more detail on these and other data formatting, layout and orientation issues...see the Managing Data [130] section.

Configure Side Bars/Filter Devices

The default opening configuration includes an open right-hand Side Bar. If it is not visible, the  Show side bar icon on the Main Toolbar
can be used to reveal one or both Side Bars. 

The Side Bars display filters/query devices, which can be used for instant filtering of records based on the values in a given field (column). By
default, devices for all fields (columns) are visible. Many of these will not be useful for filtering, and should be hidden. Different combinations of
devices can be shown on different Report Pages, using one or both Side Bars. To configure, re-order or show or hide devices on the Side
Bar(s), click on the Devices drop-down at the upper left of the Side Bar:

The Devices drop-down menu begins with options to show or hide the Reports Panel (for more detail see Creating and Managing Report
Pages [92]), the global Search All text search device (works like a search engine across the whole data set), an Exclusions device (places the 

 Move and  Keep buttons on the Side Bar when ticked), folowed by all the fields (columns) in the data set. Unticking Reports and
Exclusions options (Move & Keep buttons) removes them from the Side Bar (Reports will be shown as the default tabs, and the  Move and 

 Keep buttons will re-appear on the Main Toolbar as usual.)

Filter/query devices for fields that are not useful for filtering should be hidden by unticking the boxes under Devices. The order of the filters can
be changed by dragging the 'hands' at the right up or down to re-order the devices. You can also drag and drop devices themselves up and
down to re-order them on the Side Bar. If you have a large number of fields (columns) in your data set, use the search box to find the field
you want to display devices for and drag them to the top...ticked and in the order you want the devices displayed from top to bottom on the
Side Bar.

Right-clicking on a displayed filter/query device displays sub-menus containing many of the same commands as are available in Data >
Manage Fields [75]. Devices displayed can also be expanded by clicking on the field (column) name. Text devices, for example, expand to
reveal a keyboard and a bulk list import function for matching. Category fields expand to show the full list of categories. Hovering on a device
shows information about the values in the field (column), including any Field Notes which you may have been entered to attribute sources or
describe important limitations and assumptions in the data.
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Although fields (columns) can be hidden in the various Omniscope views, hidden columns can still can be used for filter/query devices. If you
wish to use both the right and left Side Bars, please note that a device can only appear on one Side Bar at a time. Adding a field filter/query
device to one Side Bar will remove it from the other. For more detail, see Using Side Bars. [139]

Configuring Opening Views & Appearance

Omniscope has 12 different views, any or all of which can be used to bring your data to life. In Creating and Managing Report Pages [92], we will
see how combinations of open views, filter and variable settings, plus explanatory title and annotation text can be saved as Report Pages.
Report Pages you configure for your users will always be available on tabs above the Main Toolbar or on buttons in the Side Bar Reports Panel.

Regardless of which views you think are most appropriate, or which views you configure as persistent Report Pages, you should always loook
at you data and try to configure all the views. Any time the user exits Reports Mode, they can open or add any one of the 12 available views
you have not hidden, and the default configuration of each individual view will be displayed. To learn how to hide views, see Managing
Appearance [105].

You can discourage (but not prevent) users from exiting Reports Mode and opening and navigating views on their own. If you by close all
views outside of Reports Mode, then return to the opening Report Page and save the file, any user exiting Reports Mode will see only a blank
screen unless they start adding views. In general, however, you should assume that users of your file could eventually open any non-hidden
views (and some will soon learn to un-hide those views as well). It is important for you as creator/publisher of the file to open each of the 12
views in turn, decide the best way to configure each view (or decide to hide the view) and then close each view looking as it should if and
when it is ever opened.

Warning: Whenever you save your Omniscope file, all views will remember their last open configuration. File recipients will see these
configurations if they exit Reports Mode and open and navigate any views you have not hidden. See Creating and Managing Report Pages [92],
Managing Appearance [140] and Help > Create/Edit Help page [106] for discussion of the options most useful for authoring user help displays
and managing the branding, layout and overall usability of your file.

Below, we briefly introduce configuration considerations for each of the 12 views currently available to make the most of your data. Details on
configuring each view are covered in the Views Reference [109] section.

Table View:

The Table View shows the underlying data values by record (row) for selection, browsing and editing. It displays all non-hidden values with
instant sorting, aggregation, and zooming views of related images. Many powerful data management features are available under View Tools,
including tools for splitting/combining text strings across columns, checking for duplicates, specification of formulae to generate calculated
columns, etc. The Aggregation menu allows grouping of records by field values and calculation of sums, means and other statistics based on
the values in other columns.

 

 

Start by clicking Reset on the Main Toolbar to reset your data (all records return to the green IN universe) and confirm the reset by looking
at the (all green) barometer. Close all Views but the Table View. Decide which fields (columns), if any, you want hide from this view using View
Tools > Columns to show. Untick the names of any fields you wish to hide in this view only. Also, use the 'hands' at the right to drag field39/305



Tools > Columns to show. Untick the names of any fields you wish to hide in this view only. Also, use the 'hands' at the right to drag field
names up and down to set the field (column) order for this view only. Click and roght-click on the column headers to experiment with
aggregation and sorting options. You may also wish to try defining new Formula fields whose values are given by calculated formulae. For more
detail, see the User Guide section Using the Table View [110].

 

Chart View:

The Chart View gives the most comprehensive overview of the contents and structure of your dataset; proportions, ranges, missing values,
etc. are all revealed. The Chart View shows each of your columns of data using horizontal visualisation ‘devices’ for numbers/dates, categories,
and text fields. Each chart view device shows the spread of values within each field (column). Missing values are shown with a grey
background. Zero values will show with a white background. Clicking on a device will expand that device to show more detail. Right-clicking on
a field reveals a rich set of options for further analysis. You can select multiple segments or ranges across multiple devices and execute power
queries using the  Move or  Keep commands.

 

 

When preparing Omniscope IOK files for use by others, or when looking at an IOK file whose data has been imported for the first time or just
refreshed, some 'quality-control' filtering of a file is required to ensure the data is correct and complete. Some people call this phase of
preparing/evaluating a new/refreshed data set ‘scrubbing’. The Chart View is a powerful view for reviewing, understanding and correcting large
data sets.

Reset your data and close all but one view. Change the view to a Chart View, which is ideal for visual data scrubbing. Click on each of the
horizontal devices representing each field (column). The device will expand. Look for inconsistencies, such as Text fields (signified by the
alphabet motif on display) where the character count is too short or too long. Right-click on segmented multi-coloured Category devices to
plot them as bars or pies. Look for erroneous spellings, which appear as small categories with one record. Select and keep suspicious records
using the Add to basket option at the top right of the View Toolbar. Continuous values like numbers and dates are plotted...check the end
point values. If a numeric device looks very white, right-click and select logarithmic rather than linear scaling to reduce the effect of a wide
range of values. When you are ready, click on the Basket icon on the Main Toolbar to see your collection of suspicious records in detail. For
more detail, see Using the Chart View [111].

 

Pie View:

A familiar view, with single or multiple (paned) display modes and some new twists, including animated displays to aid legibility. Commonly used
in report pages to show the composition of aggregates.
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Click Reset to reset your data. Confirm the reset by looking at the barometer. Add a Pie View. Choose the field (column) that will be
represented as 100% of the pie, then choose another category field to split the pie into wedges. Choose the most useful display and close the
Pie View. For more detail, see Using the Pie View [112].

 

Bar View:

Displays bars stacked vertically or horizontally, in single or multiple (paned) configurations, mixing positive and negative values and with many
other powerful options. The Bar View is used in most reports for comparing magnitudes and showing the composition of aggregates.

 

 

Click Reset to reset your data. Confirm the reset by looking at the barometer. Close all views but one and change that view to a single Bar
View. At the top of the Bar View display window, use the drop-down field selector to select an amount to display (or number of records), and
directly to the right, use the Split-by drop-down to select a field to use to divide the amount into bars. Try selecting various combinations of
amount fields and Split by fields. Notice that the amount total/record count is shown to the right of the Split by drop down. Use the Pane by
selectors at the bottom right or upper left to create multiple bar displays.

Once you have an informative display of bars, try using the first two icons on the View Toolbar, labelled Flip (changes the base of the bars
between horizontal and vertical) and Cascade (plots the bars in ascending, staircase style). For more detail, see Using the Bar View [113].

 

Graph View:

Creates highly-customisable scatter plots with options for colouring and sizing of markers and using marker aggregation to display record
density. Automatically calculates correlations to find trends. Used to spot anomalies and for spatial selections of plotted data.

 

 

Click Reset to reset your data. Confirm the reset by looking at the barometer. Change the open view to a Graph View. Select which fields you
wish to see graphed using the X-axis selector at bottom right and the Y-axis selector at upper left. Try graphing various quantities against each
other, and using a time/date field (if you have one) as the X-axis. On the Graph View Toolbar, click on the Trends drop-down and tick 'show
line of best fit' to see statistics on the relationship (if any) between the values in the fields you are graphing. Use the other View Toolbar drop-
downs from left to right, starting with Mode (set to 'lasso select' and try encircling a group of points with the mouse), Zoom (move the X and
Y sliders to expand the plots), Colour, Size and Shape all select other fields to use to modify the colour, sizing and shape of the markers on
the plot. For more detail, see Using the Graph View [114].

 

Tile View:

Used as a simple image browser or as a complex 'tree map', a tile representing every record shows its characteristics using size, order, colour
and grouping. Used to display 'heat maps' and convey other image-based attributes of records. Enables selection of records based on related
images in the data set.
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Click Reset to reset your data. Confirm the reset by looking at the barometer. Change the open view to a Tile View. From the View Toolbar,
select which column values you wish to represent as tiles in various groupings, with sizing and colour used to display variations. Using the View
Toolbar drop-down field selectors, try changing the Group, 2nd Group, Size, Sort and Colour fields, the groupings and the sizing and
colouring options. For more detail, see Using the Tile View [115].

 

Pivot View:

Aggregates record data by two fields, applying various functions (record count, sum, mean, etc.) at the intersection of the visible fields. Tables
can be sorted both ways, and display hover plots showing breakdowns of values in specific cells. Widely used in both analysis and reporting.

 

 

Click Reset to reset your data. Confirm the reset by looking at the barometer. Change or open new views to reveal multiple Pivot Views. Using
the drop-down field selectors on the View Toolbar, choose different values for the X: (top) and Y: (side) displays. The cells show the number
of records (rows) that share each X and Y value. Use the Function drop down to the right of the Y: to show the Sums, Means (averages) etc.
Try the sorting by clicking on a given row and column. Clear the sorts by clicking the X in the upper left. Also try switching the axes using the
switch arrow to the right of the clear sorts X in the upper left corner. For more detail, see Using the Pivot View [116].

Tree View:

Presents a hierarchical view of your data. You can change the structure of your hierarchy at any time by re-ordering the fields with your
mouse. Useful for display and navigation of both pure hierarchies (like organisation charts and family trees), and comparative hierarchies
present in the structure of most data sets.
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Click Reset to reset your data. Confirm the reset by looking at the barometer. By default, the Tree View opens showing a few random
categories from your data. On the View Toolbar, to the left of View Tools is a Fields drop-down selector. Click the selector, then un-tick all
the field boxes to clear the display. Now select 2 related field boxes and the Tree View will display. Tick another box to add another field to the
display. Click one of the boxes to see that branch of the tree. Click on the All box at the top of the tree to Reset, or use the Reset command
on the Main Toolbar. You can change the order of the columns by dragging the column headers left or right. You can change the colouring
of the tree by clicking the column header you wish to colour by. For more detail, see Using the Tree View [117].

Map View:

Omniscope allows you to plot coordinates on both online map services, such as Google Maps, or embedded zooming maps with multiple layers
users can hide or reveal. Users can switch between mapping sources at any time. comes with a wide selection of maps which can be added
into any file. Decimal coordinate columns are automatically plotted on maps or scanned images, allowing easy zooming, selection and editing.

 

 

Opening the Map View for a given data file for the first time, you are offered the embedded world map as a backdrop and are asked to specify
whether your existing data set already has coordinates. If your data already has decimal longitude/latitude coordinates, select Use existing
columns and specify which ones they are. Your data should be plotted automatically. You can switch between Google Maps and the
embedded world map. Once you have verified that all coordinates are correct, you can add more detailed country or city maps to the file from
our Maps Library [141].

If you do not already have decimal coordinate columns, select "create new coordinate columns". There are many options for adding decimal
coordinate values; 1.) using merge files [142] to import them automatically, 2.) placing markers [143] on embedded vector maps or the online
Google Maps, and 3.) by using the Google Earth search engine to look up missing values, setting a place marker, then cutting-and-pasting the
decimal coordinates into Omniscope. For more detail, see Using the Map View [118], and the Knowledge Base section on Maps & Coordinates
[144].

 

Portal View:

A familiar web-style interface allowing easy searching and browsing of data with a coloured, text-based field breakdown. Global search box
combined with text-based selection enables rapid search. Can be configured to show record counts and re-group values dynamically us the
number of records under consideration (via  Moves and  Keeps) is reduced.

 

 

Click Reset to return all records to the IN universe. Confirm the reset by looking at the barometer. Switch the open view to a Portal View. Add
a Table View using Add View on the Main Toolbar. By default, the Portal View features a global Search Box (it can be hidden). Try typing terms in
your data set into the global search box as you would an Internet search engine. In the barometer on the main Omniscope Toolbar you will
see the number of 'hits', i.e. records that contain what you have entered, in whole or in part. Clicking on Keep will display only those records in
the Table View, and update the Portal View display to reflect the breakdowns of only the records you have kept in the IN universe. Try clicking
on several different items on the Portal View. The barometer shows the number of records that share all the values you have selected. If 'no
matches' shows in the barometer, click again on selected values to deselect them. For more detail, see Using the Portal View [120].
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Details View:

Whenever just one record is selected, the Details View (or a pop-up details window) displays data and images as configured. The Details view
can also provide buttons/links to related content and services, or as an editable form for data correction and input.

 

 

Open a Table View and a Details View. If no record is selected in the Table View, the Details View will show all the values for the first record at the
top of the Table View (depending on the Sorts which are applied in the Table View). Click on the row header of the second, or a subsequent
record in the Table View and the details of that record will appear in the Details View. The Details View is highly configurable, with a drag-and-
drop orientation bar and options to display related images. For more detail, see Using the Details View [145].

 

Web View:

Omniscope is totally web-aware, with built-in browser functionality. If you are online, any configured links to web pages related to the data file
can be displayed in one or more Omniscope Web Views.

 

 

By default, upon opening a data file which has no web links configured and associated with the Web View, the Web View will display the Google
home page. You can have multiple web views open at any time. Try creating a new, single record (row) Omniscope file containing the URLs of
three major websites, then open 3 Web Views and associate them each with a different field (column) in your data. Each view should point to a
different page.

Before you can use the Web View dynamically, you need to configure or add web links/services that relate to your data. Omniscope comes
with a menu of preconfigured links that use field (column) values as inputs to the web service request, for example a Google or Wikipedia
search on names in your file. By adding links to your data file, you can use the Web View to display web-based charts, detail, images, adverts,
etc. related to the values in specific records selected by the users of your file. To configure links and web services, go to Settings > Links on
the Main Toolbar (see Adding Links [146]).

For more detail, see Using the Web View [119].

Next section: Using the Side Bars [139]

User Guide Top [108]

Manage Data
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Managing Data
 

Omniscope easily imports tabular data, but making the most of the data in Omniscope sometimes requires modifying the names of the fields
(columns), the layout (how data is arranged or divided across columns) or orientation (which are columns and which are rows) of the data in
the Omniscope file. Omniscope offers many powerful data manipulation features to help you make these changes. These modifications are
internal to Omniscope and some changes (such as re-naming and hiding) can survive refreshing from the original linked source. Other data
modification operations must be repeated after each refresh if the source data layout or orientation cannot be changed.

Warning: Omniscope does not yet support partial refresh of only certain columns from linked data sources. If you add columns which are not
present in the original linked data source (such as map coordinates or image references) to your Omniscope file, these columns will be lost or
overwritten if you need to refresh from source. To preserve your added data, keep all columns not found in the source file in a separate merge
file, with a common column of references so you can join the files together after each refresh. For more information, see Refreshing Data
[133]and Merging Data. [128]

Managing Fields (columns)

Omniscope permits you to add, remove, hide and rename fields (columns) and to convert field data types using the Data > Manage fields
dialog. Database field names are often not self-explanatory, so renaming some fields is often a good idea, as is hiding columns you use, but not
displayed to users of your file. Removing columns neither you nor your users will need will make your file smaller, but refreshing from source will
restore the removed columns.

 

 

If you wish to replace a string of text in one or more columns with a different string, you can use the Replace within values option. If you
want to calculate (and re-calculate) results in a column, perhaps applying additional logic tests, you can convert the column into a Formula
field. For more information, see using Data > Manage fields. [95]

Managing Values within fields

Data is imported from source may have either too much or too little information in each cell. If there is too much (first name, middle name and
last name in the same cell), you may want to split the values from one column across several new columns. If there is too little (the first 4 digits
of a post code in one column and the rest in another), you may wish to collapse the values in multiple columns into a single column.
Sometimes, you may want to add a prefix or suffix to all the values in a column.

 

 

The Table View Tools sub-menu contains Collapse values (reduce to one column), two kinds of Expand values (spread across more than
one column), and Append/Prepend text to values options which allow you to change the layout of your data across columns, or add
defined prefixes or suffixes to values in selected columns. For more information, see Using the Table View. [110]

International issues

When importing data by opening a .CSV or Excel .XLS file, Omniscope analyses the data in the file to determine how the data is arranged and
which fields (columns) are most likely of data type Text, Numbers, or Dates & Times. The regional settings in your computer's operating
system (Windows, or Mac, etc.) have a strong influence on this. For some combinations of settings and data formats, Omniscope cannot
reliably detect the situation automatically. 45/305



reliably detect the situation automatically.

 

.

 

If you find your data opens incorrectly and your fields are not correctly structured, your numbers have the wrong decimal place, etc. consult
the File > Open file... > Open Data Set [129]wizard page, which contains options to help with some common issues. For more information,
see International issues [136].

Specifying custom date formats

Omniscope supports Date & Time data typing. Most common Date & Time formats are recognised automatically on import. If you create a
new date field (column), or Omniscope does not recognise the format in your imported data set, you may be asked to provide guidance on
interpreting the format, and to specify how the imported values should be displayed. The Date & Time formatting wizard will appear, or can
be accessed from the Data > Manage Fields dialog whenever changing a data type to Date & Time:

 

 

A date format is a sequence of case-sensitive characters describing the format of date/time values, not the dates themselves. For example, to
show a dates such as "16-Mar-2002" you would specify the date format "dd-MMM-yyyy" in Omniscope. You can specify a wide range of
formats, including days of week and time zones. For more detail and complete discussion of date and time formatting options, see Dates &
Times. [135]

Tokenized data- multiple values per cell

Sometimes, more than one value is associated with certain attributes of a record. For example, shoes can be available in more than one size, or
you may have more than one image associated with a house (or whatever). Items available in more than one size, or with more than one
associated image are examples of many-to-one relationships. Omniscope handles these kinds of relationships with a data subtype for Text and
Category data fields called 'Tokenized'. In the example below, each record (row) is a pair of shoes, each of which is available in more than one
size.
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By declaring the filed (column) 'Size' to be tokenized, we can enter more than one size in the cell, divided by commas (or any separator you
choose). Users of this file can specify their shoe size, and Omniscope will show only those records available in that size. For more detail, see
Using Tokenized data [123].

Adding map coordinates

There are currently three ways to add geographic decimal coordinate (longitude and latitude) columns to your data for map displays. One
option is to locate your records in Omniscope using the free Visokio world, country and city maps- just place the markers manually to
generate the coordinates automatically as shown below (see the tutorial on Using Maps [147]).

 

 

Alternatively, you can also look up missing coordinates using online sources such as Google Earth (and often Wikipedia), both of which can be
integrated into Omniscope work flow as web services links. Just look up the missing values, then type or cut-and-paste them into Omniscope,
copying the same values down for all the records in the same location.

If you have county or city names in your file, you can also merge geographic coordinate columns into your Omniscope data automatically
using a merge file. [142] To merge in coordinate columns for capital cities or geographic centres of countries, we supply a free 'By Countries'
[142] merge file containing these columns. We also supply a free 'By Cities' [148] file containing coordinates for about 60,000 of the world's
largest cities. Free merge files 'By Post codes [149]' are available for the UK and the U.S., and an increasing number of other countries. Other
free and licensed reference merge files may be available from other suppliers in future.

To learn more, see the User Guide section on Using the Map View [118], and the Knowledge Base sections on Maps & Coordinates [144].

 

Data Orientation- Time series [138]

Omniscope processes repeated observations of values over time in vertical columns, rather than horizontal rows often used in spreadsheets. In
the example of a time series data layout below, we have various bonds, each with a reference ISIN identifier in the first column. We also have
repeated observations of Dates and Values (Price/Yield) over time entered vertically down the Date and Values columns. Each record (row) in
the data is therefore a separate observation of the Values (Price/Yield) on a given Date repeated over time 'vertically' in separate rows:

 

 

Time series data layout in Omniscope requires at least one field (column) with a natural order, such as Date, and one or more values columns
'Price', 'Yield', etc. for repeated observations of values that make up the time series. In addition, to have multiple curves on one graph, there
should be a Category field (with less than about 200-250 unique values) which contains the names of each curve to be drawn. In this
example, we have many observations, but only 9 individual ISINs (bonds), so the curves can be plotted by the Category 'ISIN' reference field
as shown in the example above. Don't worry about the apparent repetition in the data values. Outside of the Table View, Omniscope will render
this invisible to the users of your files. For more information, see Displaying Time Series .

If your data is arranged differently from the example above, (e.g. 'horizontally' with the dates as columns and each cell in the row representing
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an observation over time) you may want to use the the tools available under Data > De-/Re-Pivot on the Main Toolbar to transform your
data set to the correct 'vertical' orientation in Omniscope (see below).

Changing Data orientation using De-Pivot/Re-Pivot

Omniscope provides powerful tools to change the orientation of the data from rows to columns, or from columns back to rows. This can be
useful when working with data in Omniscope, and also to change the orientation of data being exported from Omniscope to other applications.

 

 

For more information, see Using De/Re-Pivot [138]

 

Merging Columns and Rows from other files

Omniscope enables you to assemble data sets from multiple sources by merging, adding either more columns or more rows to your
Omniscope data sets. You can merge data from other .IOK files, or from .XLS, .CSV, .TSV data files, or from database views/tables using the
Merge Data [128]wizard accessed from Data > Merge :

 

 

Merges can be either a 'Join' where new columns are added to existing data using values from a common column (one to one, one to many
or many to one relationship), or a 'Concatenate' where new records are added to existing columns (column names must be the same). Joins
can use multiple criteria, and you can choose to import non-matching records, etc. For more information, see Using the Merge Data wizard
[128].

Back to Configuring your Data [134]

User Guide Top [108]

Tokenized Data

Tokenized Data
Sometimes, more than one value is associated with certain attributes of a record.  For example, shoes can be available in more than one size,
or you may have more than one image associated with with a house (or whatever). Shoe sizes and multiple images of a house are examples
of many-to-one relationships. Omniscope handles these kinds of relationships using a data subtype for Text and Category fields (columns)
called 'Tokenized'.
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When you declare a Text or Category data type to be 'Tokenized,' it means each cell in a field can contain more than one value, i.e. multiple
"tokens" separated by a character you decide. The default separator is a comma, but you can choose to use any thing: a space to separate
words, or an unusual character such as a  \ backslash if you need to use commas within your values.

The example below (you can download a copy of this example file here [150]) is a shoe store data set.  Each record (row) corresponds to a pair
of shoes, and a 'Size' field containing size numbers in stock (38, 39, 40, 41 etc.). The 'Size' field has been declared a Category field since it
contains only a few values, and since the size numbers awill be treated as text, not numbers used for calculations. 

 

 

Using Data > Manage fields > Configure > Field options, we have set the data sub-type of the 'Size' Category to be 'Tokenized
Category' with the default comma separator  dividing the values within the cells. We then check the data to ensure that each available shoe
size is entered in the 'Size' column with a comma separator as shown in the Table View above.

We can quickly check that all values have been entered correctly in the Side Bar query device for 'Size', each size should appear separately. In
the example below, the user has set filters to display only shoes available in sizes 39 and 40.

Notice that in the Chart View, the highlighting for a specific pair of shoes available in 39 or 40 (or both) still shows the full range of sizes
available. This also affects other views that display breakdowns of Tokenized Categories, such as the Pie and Tile Views.

 

 

If there were multiple images for each pair of shoes, we would have done the same thing in the 'Photos'  image references field (column), so
that we could relate more than one image to each pair of shoes, and display the multiple images in the Slideshow window.

Back to Configure your Data [134]

User Guide Top [108]

Time Series
49/305



Time Series Data Layout
Omniscope makes use of repeated observations over time in vertical rows, rather than horizontal layouts often used in spreadsheets. To create
a multi-line time series, in Omniscope, put your data in the following 'vertical' format:

 

In this example of a time series, we have 5 companies "A" to
"E" with historic share prices for each month. Each record in
the data file is a price/time point for a company.

The Company field contains Category values correlating to
different lines in the time series. Let's call this our Category
field.

The Month field contains Date and Time values representing
the time part of the time series, along the X axis. Let's call this
our Time field.

The Price field contains quantitative Decimal number values
for the Y axis. Let's call this our Value field.

Don't worry about the vertical repetition in the data...this will
be invisible in all views except the Table View and not evident
in the time series reports you configure.

 

Check your data types- After importing your data, make sure the Time (here Month) and Value (here Price) fields are the correct format.
They must be numeric (decimal or integer), or dates, shown by the red to green colour gradation. Also make sure the Category field is of
type Category, shown by the variety of different colours. You can convert data from one type to the other by right-clicking the column
header in the Table View and choosing Convert field data type.

My data goes the other way!

Sometimes source data is laid out horizontally when Omniscope would manage it better vertically (e.g. time series), and vice-versa. Sometimes
data needs to be exported from Omniscope transposed to an orientation different from that used in Omniscope reports. To avoid the time
consuming process of changing the orientation of data from horizontal to vertical (row becomes column) or vertical to horizontal (column
becomes row), Omniscope has both a De-pivot and Re-pivot function. Use of these functions is discussed in more detail here [138].

 

For a continuation on displaying line graphs like time series, see the the Graph View section displaying time series [151].

 

Back to Configure your data [134]

User Guide Top [108]

Dates & Times

Working with Dates & Times
Omniscope supports Date & Time data typing. Most common Date & Time formats are recognised automatically on import, although
Epoch/Unix format dates and times must be read in first as integers (see below) [152]. If you create a new field (column) typed Date & Time, or
if Omniscope does not recognise the format your imported data is in, you may be asked to provide guidance on interpreting the format
and to specify how the imported values should be displayed. The Date & Time formatting wizard will appear, or can be accessed from the
Data > Manage Fields dialog whenever changing a data type to Date & Time:

 

50/305



 

Use the Date & Time formatting wizard if Omniscope needs help detecting the format of existing data, or to change a column's Date & Time
display format to another. If you specify the time zone, it is important to specify the time zone and daylight-savings time settings of the
database server recording the data, which may be different from your own. It is possible for server clocks not respecting daylight savings time
to record data inconsistent with the time zone setting you have selected. You must also respect leap year dates, and not enter non-existent
dates. Invalid times or dates will NOT be coverted. (See below for further discussion of time zone and Daylight Savings Time-DST issues).

WARNING: When specifying date formats, make sure your data column is uniform. For example, if some cell values have
Hours:Minutes:Seconds after the date, and you want to preserve this format in Omniscope, make sure that ALL cell values in that field have
entries for Hours:Minutes:Seconds. If necessary, you can pad them out with all zero values like this: 00:00:00. Also, if you are using Date &
Time fields as criteria for Omniscope merge file joins, make sure the fields are set to exactly the same format. If you intend to use AM/PM
please make sure that your time is in 12 hour clock rather than in 24 hour clock format.

Help With Date Formatting
A date format is a sequence of case-sensitive characters describing the format of date/time values. For example, to show your dates as "16-
Mar-2002" you would use the date format "dd-MMM-yyyy". You can use any punctuation, but letters must be in one of the valid patterns of
characters listed below:

Symbol Meaning Examples Notes

yyyy Year
2002, 53,
1997, 500
BC

Literal year values, where "53" and "1066" will mean
the years 53 and 1066 AD, and "200 BC" means
the year 200 BC.

yy Year 02, 53, 97

Two-digit years, with Y2K fix, where "53" and "10"
will mean the years 1953 and 2010. Assumes any
two-digit years fall within the last 80 years or next
20 years.

w Week 1, 3, 52 Week in year 

MMMM Month
March,
December

Full month name

MMM Month Mar, Dec Abbreviated month name

MM Month 03, 12 Two-digit month number, padded with zero

M Month 3, 12 One- or two-digit month number, no padding

dd
Day of
month

03, 16 Two-digit day in month, padded with zero

d
Day of
month

3, 16 One- or two-digit day in month, no padding

EEEE Weekday Tuesday Full name of day in week

EEE Weekday Tue Abbreviated name of day in week

Symbol Meaning Examples Notes

aa AM/PM AM, PM Use aa for the AM/PM marker

HH Hour (24)
00, 07, 15,
23

Hour of day in 24-hour clock, from 0 to 23, padded
with zero

H Hour (24)
0, 7, 15,
23

Hour of day in 24-hour clock, from 0 to 23, not
padded
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hh Hour (12)
01, 07, 11,
12

Hour of day in 12-hour clock, from 1 to 12, padded
with zero

h Hour (12)
1, 7, 11,
12

Hour of day in 12-hour clock, from 1 to 12, not
padded

mm Minutes
00, 09, 23,
59

Minutes past the hour, padded with zero

m Minutes
0, 9, 23,
59

Minutes past the hour, not padded

ss Seconds
00, 09, 23,
59

Seconds, padded with zero

s Seconds
0, 9, 23,
59

Seconds, not padded

SSS Milliseconds
000, 009,
023, 595

Milliseconds, padded with zero

S Milliseconds
0, 9, 23,
595

Milliseconds, not padded

Example patterns:

dd-MM-yy for values like: 21-11-99 meaning 21-11-1999

yyyy.MM.dd for values like: 2001.07.04  

yyyy.MM.dd HH:mm for values like: 2001.07.04 23:55  

EEE h:mm a for values like: Sat 9:33 PM  

For a further information see the full Java documentation [153], including additional date pattern symbols such as "D" for "day of year".

Time Zone Issues

Databases record data using the time zone specified for that database. The database could be located anywhere in the world. In addition, the
database may or may not reflect daylight savings time adjustments, even locally. If the data in the data set does not reflect daylight savings
time, i.e. runs on GMT, and you select BST British summer time as a time zone for your data, Omniscope (and Java) will report invalid
dates/times for some records. This occurs when daylight savings time adjustments 'skip over' one hour after midnight on specific dates. To fix
this problem, you must isolate the offending times, and manually advance them by 1 hour.

Importing Epoch/UNIX/POSIX dates & times

Epoch (or UNIX or POSIX) time is a system for describing points in time, defined as the number of (milli) seconds elapsed since midnight
Coordinated Universal Time (UTC) of January 1, 1970, not counting leap seconds. Omniscope will import dates and times in this format if they
are first read in as integer numbers. Once your data is imported as integer, in Data > Manage fields change the data type to Date & Time
and select the option at the bottom Convert milliseconds since 1970 into dates. Omniscope uses milliseconds, so if your data is in
seconds, multiply the values by 1000 using a formula column, then specify the Date & Time display format you wish to use.

 

Back to Configure your Data [134]

User Guide Top [108]

Common Issues

Importing Data - Common Issues
Differences in formatting of data for presentation around the world can affect data import and display in Omniscope. Many international issues
affecting data import have been addressed in recent versions, all of which are free upgrades. If you are experiencing problems with dates,
thousands separators, etc., please ensure you are running version 2.2 or better.

Some common issues - e.g. importing international data formats

When importing data by opening a .CSV or Excel .XLS file, Omniscope analyses the data in the file to determine how the data is arranged and
which fields (columns) are most likely of data type Text, Numbers, or Dates & Times. The regional settings in your computer's operating
system (Windows, or Mac, etc.) have a strong influence on this operation. For some combinations of settings and data formats, Omniscope
cannot reliably detect the situation automatically. If your data opens incorrectly and your fields are not correctly structured, numbers have the
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Table View [38]

Chart View [39]

wrong decimal place, etc. please consult the File > Open file...Open Data Set [77]wizard page, which contains options to help with some
common issues further described below:

Data File delimiters -.CSV stands for "Comma Separated Values", which means the cells in each record (row) of the data table are separated
by the comma character. However, if you are in a region that also uses the comma in numbers instead of the decimal point (e.g. several
European countries, such as France), some versions of Excel create .CSV files that use a semicolon as the separator character. Sometimes
these multi-column tables files are saved with a .CSV or even a .TXT extension. Omniscope is unable to detect this situation automatically. If
you open such a file in Omniscope, your data will very clearly be wrong, with most columns appearing as text with semicolons. To avoid this
problem, use the Data Import wizard Customise data import dialog to change the Separator character to a semicolon " ; ".

Note: this also works with 'pipe'  "|" delimited files, but you must first change the file extension on the data file to .CSV, even though it is 'pipe'
and not comma delimited.

Dates & Numbers - If you are running on Windows, when importing data that is in a delimited text format such as Excel .XLS, .CSV or .TSV
(tab-separated values), Omniscope will use your Windows Regional Settings to try to automatically recognise data. For example, for a PC with
United States Regional Settings, Omniscope will recognise "5/13/2005" as a date and "1,500.5" as a number. For some international users,
however, this may not work as expected and the result will be an import of all columns as data type Text (shown in Omniscope either as multi-
coloured Category columns or white Text columns). If this occurs, you can usually manually convert fields (columns) containing numbers or
dates and times using the Data > Manage fields [75]dialog. For more information on formatting dates and times and managing time zones,
see the section on Dates & Times [154].

If you know your data has been formatted for a different region, change the Locale drop-down accordingly. For example, if you live in
Germany but have received a .CSV from an American customer, you should choose "English (US)". If you find Omniscope gets things wrong
and your data is incorrectly recognised, you can disable auto-detection of dates and numbers by deselecting the two Recognise... check
boxes on the Open Data Set [77]dialog. All fields will open as Category or Text data and their text values will be preserved. You can then use
Data > Manage fields [75] [95]to configure each field (column) as you would like it to display.

 

Back to Configure your Data [12]

User Guide Top [68]

Main Toolbar

Using the Main Toolbar
Navigation, filtering and command menus

Version 2.4:

The Omniscope Main Toolbar contains both a series of drop-down command menus on the left and  a selection of navigational command icons
and functions used to explore and refresh .IOK/.IOM files to the right of the command menus. The command menu options are generally not
needed to navigate Omniscope .IOK/.IOM files prepared by others.

 

 

 

Immediately to the right of the Help command is the Add View drop down menu, used to add an additional view to the current display. To
remove a view from the display, click on the [X] in the upper right hand corner of the view. To change a window from one view to another,
click on the view name and select the view you want from the drop-down menu. If you want to add a view showing another data subset, you
can select it using the Data Subset drop-down to the right of the view name in each View Toolbar.There is no upper limit on the number of
views you can open in Omniscope, but display screen size limitations encourage using multiple tabbed Report Pages to display different
combinations of views, rather than crowding the working display with too many open views. More on creating Report Pages [15].

 

| File [55]| Edit [155] | Tools [156] | Reports [157] | Page [158] |
Appearance [159]| Help [61] |

The left side of the Main Toolbar contains all the top-level
command menus. When no .IOK/.IOM data file is loaded, the Main
Toolbar displays only the command menus.
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Pie View [40]

Bar View [41]

Graph View [42]

Tile View [43]

Pivot View [44]

Tree View [45]

Portal View [47]

Map View [48]

Venn View [49]

Web View [50]

Details View [53]

DataPlayer View [54]

Tick first to open new
floating view window

File menu [55]: importing/refreshing, saving, exporting and
printing data, maps and image sets.

Edit menu: [155] managing data columns (fields) and values
within categories, adding new columns & rows and changing data
orientation (de-pivot and re-pivot).

Tools menu: [156] enable auto-refresh, change languages, set
details display options, define links, image sets and web services
related to the file.

Reports menu: [157] create, modify and navigate Report pages.

Page menu: [158] modify aspects of the workspace or current
Report page.

Appearance menu: [159] add branding and modify/simplify most
aspects of the colouring, look and feel of the file.

Help menu: [61] create file-specific help screen, access learning
resources, send bug reports/suggestions, check for updates and
licensing status (see Installation/Activation [6]).

 

Complete documentation of all the commands on these menus
can be accessed from the Commands Reference [27] page or by
following the links above.

Add View menu:

 

 

Whenever an .IOK/.IOM data file is loaded, to the right of the command menus, the Main Toolbar also displays a selection of navigational
command icons and functions used to explore and refresh .IOK/.IOM files:

 

Reset- Omniscope files contain flat tables of structured data organised into records (rows) and fields (columns). Navigating an
Omniscope file usually involves either setting Side Bar filters, or Selecting plus either Move or Keep operations to focus on only a

certain data subset. The Reset button removes all of the filtering criteria you may have expressed, and returns the current display views to
show all the records in the Filtered IN universe. It is very important to always Reset your data before filtering, so that all qualifying records will
be considered in your subsequent query. Unless you configure them otherwise, Report Pages remember their queries/data subsets, so if you
want a Report Page to open showing all the data, make sure to Reset all the filters and commit the changes before you save the file. Note: On
the Side Bar filter devices it is possible to reset each filter individually, and if a Side Bar filter device is set to Freeze, that filter's settings will
survive a global Reset.

 

Deselect- Removes all records from the Selected data subset and greys-out the option to do Move or Keep operations on selected
records. Omniscope power query filtering directly on views (as opposed to Side Bar filtering) involves 4 basic mouse operations: Select

(or Deselect), followed by Move or Keep, and then perhaps a Reset. Every view provides ways of selecting one or more records using just
the mouse. In most views, you can also Deselect by clicking again on one or more of the selected areas or groups of records. It is not
necessary to use this global Deselect on the Main Toolbar unless you wish to clear all selections made simultaneously.

 

Move- Selecting records is a precursor to deciding whether to Move the selected records, i.e. filtered OUT of further consideration.
If you are working from a view of the filtered IN data subset, the grey Move command moves all selected records OUT of

consideration, where they stay until they are returned or the display is Reset. The barometer will give you a preview of this on the left side,
where selected IN records to be moved will be highlighted. If you are working from the filtered OUT data  subset, the display will change the
colour of the Move icon to blue, since moving records from the filtered OUT subset will return them to the filtered IN subset. The barometer
will show you the selected OUT records highlighted on the right side. If you are working from a view set to display ALL Data, the barometer
will show you the effect of Moves and Keeps, but that specific view will not update as a result, since views showing ALL Data always display all
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will show you the effect of Moves and Keeps, but that specific view will not update as a result, since views showing ALL Data always display all
records regardless of whether they are filtered IN or OUT.

 

Keep- the opposite of Move, the Keep command keeps only the selected records in the filtered IN subset, and moves all other
unselected records to the filtered OUT subset. If you are working from a view displaying the filtered OUT subset, the Keep icon will

change colour to grey, since the effect will be to Keep the selected records in the filtered OUT subset. If you are working from a view set to
display ALL Data, the barometer will show you the effect of Moves and Keeps, but that specific view will not update as a result, since views
showing ALL Data always display all records regardless of whether they are filtered IN or OUT.

 

Back- similar to a browser, if you have performed a filtering operation, you can go back to the previous query state(s) at any time
by pressing the Back button.

 

Controls- this drop-down menu controls display of the two Side Bars, as well as the Cycling Toolbar. For more detail, see the Controls
[14] subsection.

 

Barometer- this very useful indicator depicts the top level query state (records IN and OUT, with currently
selected subsets counts) at any given time.  In this example, the data set contains 4,886 total records (rows),

of which 4,292 remain in the filtered IN subset, and 594 have been moved to the filtered OUT subset. In addition, 1,719 records have been
selected, and the currently highlighted single record is among those selected. Always keep an eye on the barometer before initiating new
filtering/queries to ensure that you have Reset (or gone Back) to the correct IN subset.

 

Queries- this drop-down menu is used to manage defined data subsets associated with Named Queries. Using this menu you can
name empty queries ( e.g "Basket" or "Errors") to collect records you add, or you can define complex queries as re-usable Named

Queries using patterns of Side Bar filter settings. Each Named Query defined is added to the data subsets that can be displayed in most views.
Detailled documentation of the use of the commands on this menu is here [10].

 

Auto-refresh settings- Omniscope files can have other Omniscope files as data sources. Activated Omniscopes can refresh the data
in an open .IOK/.IOM file from the data in another .IOK/.IOM file accessible over a network. The Auto-refresh drop down menu is

revealed by activating the Automatic refresh option from the Tools menu [156]. Once revealed, this menu allows all aspects of the refresh
process to be configured, as described here. [18] There is an option to display a Pause/Resume button (see below).

 

 Pause/Resume (auto-refresh)- Auto-refresh settings options include displaying a Pause/Resume auto-refresh button on the
Main Toolbar.

 

File-specific help screen- click on this help icon to see what the publisher or re-publisher of a given file may have written to help users
understand more about the file. If you are configuring a file for others, the content of this screen may be composed from Help > Edit

Help screen.

Corner logo- if you are publishing or re-publishing .IOK/.IOM files, you can replace this logo and link with your own. See
Appearance > Branding > Add Corner Logo and Set Publisher link  (for best results, use a logo 19 pixels high).

 

Close file- click here to close the .IOK/.IOM file currently open. Once the data file is closed, the screen will display the Omniscope opening
desktop, which includes links to previously opened files, as well as learning resources, embedded demos and other useful resources.

 

 

Version 2.3:

The left side of the Main Toolbar contains all the top-level command menus. When no .IOK or .IOM data file is loaded, the Main Toolbar displays
only the command menus. These commands are generally not needed to navigate an Omniscope .IOK/.IOM file prepared for you by someone
else. Documentation of all the commands on these menus can be accessed from the Commands Reference [160] page or by following the links
below:
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| File [100]| Edit [101] | Tools [102] | Reports [103] | Page [104] | Appearance [105]| Help [106] |

 

Main Toolbar navigational features

Whenever an .IOK/.IOM data file is loaded, to the right of the command menus, the Main Toolbar also displays a selection of navigational
command icons and functions used to explore .IOK files:

 

 

 Add View -Used to add an additional view to the current display. To remove a view from the display, click on the [X] in the upper right
hand corner of the view. To change a window from one view to another, click on the view name and select the view you want from the drop-
down menu. If you want to add a view showing another Universe, click on the Show other data universes option to display a grid of all
views and universes. There is no upper limit on the number of views you can open in Omniscope, but display screen size limitations encourage
using multiple Report Pages to display different combinations of views, rather than crowding the working display with too many open views.
More on creating Report Pages [92].

 

 

 Reset- Omniscope files are flat tables of data, with records (rows) and fields (columns). One of the objectives of navigating an Omniscope
file is to select and focus on only a certain subset of records (rows), rather than all the records in the file. The Reset button removes all of the
filtering criteria you may have expressed, and returns the current display views to show all the records in the IN universe. It is very important
to always reset your data before filtering, so that all qualifying records will be considered in your subsequent query. Unless you say otherwise,
Report Pages remember their queries, so if you want a Report Page to open showing all the data, make sure to Reset the views and commit
the changes before you save the file.

 Deselect- Removes all records from the blue SELECTION universe, and greys-out the option to do Move or Keep operations on
selected records. Omniscope filtering using power queries depends on 4 basic operations: Select (or Deselect), followed by Move or Keep,
and perhaps a Reset. Every view provides ways of selecting one or more records using just a mouse. In most views, you can also Deselect by
clicking again on one or more of the selected areas or groups of records. It is not necessary to use the global Deselect on the Main Toolbar
unless you wish to clear all selections.

 Move- Selecting/deselecting records is a precursor to deciding whether to Move the selected records OUT of further consideration. If you
are working in the IN universe, the Move command moves all selected records OUT of consideration, where they stay until the display is
Reset. If you are working from the OUT Universe, the display will change the colour of the Move icon to green, since moving records from the
OUT Universe will return them to the green IN Universe. If you are working from the black ALL universe, the display will change the Move
button, substituting OUT for Move, signifying that moving records from the ALL Universe places them in the OUT Universe, if they are not
already there. Remember that the black ALL Universe always contains all records and does not change.

 Keep- the opposite of Move, if you are working in the IN Universe, the Keep command keeps only the selected records IN consideration,
and moves all other unselected records OUT of consideration. If you are working from the OUT Universe, the display will change the colour of
the Keep icon to red, since it will keep selected records in the OUT Universe and will return all others to the green IN Universe. If you are
working from the black ALL Universe, the display will change the Keep button, substituting IN for Keep, signifying that keeping records from
the ALL Universe places them in the IN Universe, if they are not already there. Remember that the black ALL Universe always contains all
records and does not change.

 Back- like a browser, you can go back to the previous display at any time by pressing Back.

 Show Side Bar- clicking this icon gives you the option to show or hide the Side Bars on one or both sides of the current display. You
can choose to display a Side Bar on the right, the left or both sides of the display. If you display both Side Bars, adding a device to one Side
bar display will remove it from the other.
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  FeatureFinder link- used to export data sets to Omniscope's companion applications FeatureFinder Desktop or Web.  These separate
applications ( or the DataPlayer Studio plugin available in Omniscope 2.4) will convert your data into interactive Flash .SWF DataPlayers suitable
for embedding in web pages and offline documents such as PowerPoint, Adobe Acrobat .PDFs, Excel etc. DataPlayers do not scale to more
than about 5-10,000 typical records [161], so you may have to use Omniscope to divide your data set into smaller sets before exporting the
data to convert as DataPlayers.

 Barometer- upon opening a file, it is useful to know how many records are in the data set. As you filter, it is useful to see how
many records have been kept IN consideration, and how many moved OUT. The barometer is a visual gauge that shows the total, as well as
the split between IN and OUT Universes. More on Data Universes [162]

 Basket- the basket is a 'parking place' where you can put selected records, such that they will stay there even if you Reset the
display. At any time, you can open the Basket and see the records you have placed there.

 Help screen- click on the help icon to see what the publisher or re-publisher of the file may have to say that will help you understand more
about the file.

 Publisher logo/ link -if you are publishing or re-publishing an .IOK file, you can put your own logo here, and link it to your website.
See Appearance > Branding > Add Corner Logo and Set Publisher link (for best results, use a logo 19 pixels high).

 

Next section: Using the Side Bars [139]

User Guide Top [108]

Controls

Controls- Displaying Side Bars and Cycling Controls
Make your files easier to filter and automate the display

 

From version 2.4, the Controls drop-down menu is located on the Main Toolbar to the left of the barometer.

 

 

 

Show right/left Side Bar- displays one or both Side Bars. By default, all filter Devices are initially displayed on the right side bar. To move filter
Devices to the left Side Bar, open the left Side Bar and use the Devices drop down on the left Side Bar to tick which devices you want to move
from the right to left Side Bar. Using Side Bars [62]

 

Auto-hide main toolbar- ticking this option will cause the Main Toolbar to retract for all Report Tabs and the workspace, unless the mouse is
hovered above the Report tabs at the top of the screen. This is often useful when simplifying the page layout for live presentations. This option
can also be set on an individual Report Page basis by unticking the Show main toolbar option at the bottom of the Page menu [158], then
committing the change on each Report Page tab for which you do not want the Main Toolbar displayed.

 

Cycling toolbar- the Cycling Toolbar contains the setting for automatically cycling through Records, Values and Reports, introducing a
degree of automation in the display of the data and images in the file.  When set to Hide, the Cycling Toolbar will not display. The Auto-show
option will enable display of the Cycling toolbar when the mouse hovers at the bottom of the screen. The Show option will display the Cycling
Toolbar at all times. Using the Cycling Toolbar [98]

 

 

Next: Using Side Bars [62]
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User Guide Top [68]

Cycling Options

Setting Cycling Options
Using record, value and report cycling

 

In progress...

 

 

 

 

 

 

 

 

 

Next: Creating Report Tabs [15]

User Guide Top [68]

Automatic Refresh

Automatic Refresh Options
Using the auto-refresh menu

 

In progress...

Report Tabs

Creating and Managing Report Tabs
One-click access to the most important displays and messages 

Any combination of views, settings, filters, titles and annotations can be saved as a persistent Report Tabs across the top of the Main Toolbar.
Tab names can also be displayed as buttons from the Side Bar Reports panel. Any number of different Report Tabs can be configured, with
individual or groups of Report Tabs addressing the needs of different audiences among the users of your files.

58/305



If you close and save an Omniscope file displaying a configured Report Tab, this file will open next time displaying the same Tab. Users of the file
simply page through the interactive report page tabs just as they would a presentation slide show. If displayed, they can also use the forward
and back screen arrows in the lower left corner Reports Navigator, or the right and left keyboard arrow keys (e.g. for live presentations) to
page through their Report Tabs.

Below is a high-level introduction to report page tabs; how they are created, modified and navigated. More detailed documentation of the
commands related to creating and managing Report Tabs is available under the Main Toolbar Reports [103] and Page [104] menu commands.

Creating Report Tabs

To create a Reports Tabs, click on Reports on the Main Toolbar and choose one of the three options available under the Create Page
heading:

If you are currently displaying a combination of
views, queries, variable settings, etc. that you
would like to make persistent, choose From
current Omniscope configuration. You will
enter Reports Mode and all your current settings
will be copied to create a new Report Page. In
Reports Mode, any further changes you make will
apply only to the open Report Page, and all
subsequent changes must be Committed to
become persistent (see below).
If you choose Text only, you will presented with
a dialog to create a typical formatted text
presentation page, with up to 3 different images
embedded. Note: embedding a centre image will
move your text field to the bottom.
If you choose From image or PowerPoint, a
file browse dialog will open to select either a large
image file (for example a .JPG screenshot file
exported from another Omniscope file) or an
existing PowerPoint file, from which you can
select slides to import as Report Pages.

If you choose to create the new page from the current Omniscope configuration, the Create New Page wizard will display like this:

Page name: this name appears on a
report tab at the top of the display, or a
button on the Side Bar Reports Panel if
you provide access to Report Pages
there.
Query State- preserves all filter settings
and exclusions as persistent settings for
the page
View and layout configuration-
preserves the open views and layout
Variable states- if you have defined one
or more assumption variables as part of
formulae, this preserves the current
value(s) of those variables as the opening
value(s) for the page.
Title: the title text that will appear at the
top of the page...you can edit this at any
time 
Annotation: explanatory text you enter
that can be edited on the page at any
time.
Header or Background Image-
enables you to add logos and image
backgrounds

Apply default report layout: If you leave this box ticked, Omniscope will hide the View Toolbars and increase the margins around the views
for a cleaner display. If you wish to preserve the existing settings, untick this box.

Once configured and named, each pre-defined, persistent Report Page appears anytime the user clicks on the top report tab, or the button
next to the Report Page name in the Side Bar Reports Panel, or uses the Reports Navigator menu, which appears faintly in the bottom left
corner of the display in Reports Mode (see Using the Reports Navigator below).
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Configure Report Pages

The Main Toolbar Page menu commands provide many options useful for creating self-explanatory Report Pages. The commands on this
menu can be used to configure many aspects of the current display, whether that display will eventually be converted to a persistent Report
Page or not. If you make changes to the current view using Page menu commands, then close and save the file, it will next open with those
changes preserved in the current display.

Page menu commands can be used to:
Reset layout- returns the current page layout to the
default
Remove all views- closes all views on the current page
Page margin- sets the width of the space that is used to
display titles, header images, annotation text etc. around the
views on the page
Add Background, Header and Centre images- allows
you to add images, includeing faded background images to
provide more beranding and identity to your file
Add, style or remove a Title- creates and styles an
optional free text title at the top of the page in the margin
Add, style or remove an Annotation- creates and styles
an optional free text field that displays at the bottom of the
view, unusually conveying the main message of each Report
Page.

You can also tick/untick the options to display or hide the
Main Toolbar and the View Toolbars on open views of the
page. Toolbars are usually hidden if Report Page users are
not expected to access the options available on them. Even
when hidden, the Main Toolbar comes back into view
whenever the user hovers the mouse near the top of the
display.

Page menu commands apply to each Report Page individually, and any changes must be Committed to become a persistent change, or
Reverted to return the Report Page to its default configuration/layout. For options covering aspects of the look and feel of Report Pages that
apply to more then one page, see the introduction to the Appearance [140] command menu.

Using the Reports Navigator

The Reports Navigator menu appears in the lower left-hand corner of the display whenever Omniscope is in Reports Mode, meaning
displaying a persistent Report Page. The Reports Navigator is faint until you mouse over it, at which point it appears clearly, with forward
and back arrows pointing to either side of a reports document icon. Clicking on the forward or back arrows cycles through all the Report
Pages already configured in the file. The same list as can be seen in the Side Bar Reports (or some other name if you have renamed the
Reports heading) panel and under the Main Toolbar Reports Navigation section.

Clicking on the Reports Navigator document icon at lower left reveals a menu listing a number of report navigation, creation, layout and
reset options.

 

 

Start; Next; Previous; Go to
page...used to cycle through the
Reports Pages already configured in
the file.
Administer all pages sub-menu:
Commit all modified pages-
makes all changes which you have
made to your Report Pages
persistent
Revert all modified pages- returns
all Reports Pages to their last
persistent configuration
Delete all pages- deletes all Report
Pages currently configured

 

 

If the Commit and Revert modifications commands are solid, rather than greyed-out, it means that you have modified the current Report
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Page and must now either overwrite the previous settings with the new ones (Commit) or return the report to its original look, leaving the
original settings unchanged (Revert). If the name of the Report Page is showing in red on the top report tab, this also means that you should
either Commit or Revert your changes. If you have chosen to show the Side Bar Reports panel, these buttons also show in the Side Bar under
the current Report Page whenever changes have been made to the current page, and the report titles will show in red until changes are either
Committed or Reverted.

 

Tools sub-menu: Tick or un-tick to
Show or Hide various toolbars. Note
that these changes apply to the current
Report Page only, and only if the
modifications are Committed to make
them persistent.
Show/Hide main toolbar-same as
above
Show/Hide view toolbars-same as
above
Show/Hide unused options-used to
simplify the display of certain view
menus
Show/Hide right/left side bars-
same as above

Reset Layout- returns the layout of the current Report Page to the default, with all the optional Show/Hide settings set to Show

Save file as...opens the Export file wizard [163]with the tab set to .IOK/.IOM files.

Exit Report: Exits from Reports Mode and the Report Navigator menu disappears. Remember that it is usually better to Exit Reports Mode if
not modifying existing Reports Pages. You can also Exit Reports Mode from the Main Toolbar Reports menu (see below) or from the Side Bar
Reports Panel if you are displaying reports there.

Managing Report Pages

Commands required to manage all configured Report Pages are available from the Main Toolbar Reports menu. In addition to many of the
same commands as are available on the Reports Navigator menu, the Main Toolbar Reports menu includes commands such as Commit and
Revert all modified pages that operate on all Report Pages simultaneously. When the Reports menu is opened, the title of the current
Report Page is shown at the top in bold italics.

 

 

For more detail, see the sections documenting the Main Toolbar Report [103]s and Page [104] command menus
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Organising Report Pages

This refers to the functionality allowing Report Pages to be organised into named sections (or "groups"). To date, Report Page organisation has
been implemented only in the Side Bar Reports Panel. To show the Reports panel, the right-hand Side Bar must be showing. However, the Side
Bar Reports Panel is not displayed by default.

Use the  Side bar button on the Main Toolbar to change this. Then, ensure the Reports Panel is ticked for display using the Devices
drop-down on the Side Bar toolbar. When the Reports Panel is displayed, the Report Page tabs across the top of the display will disappear
unless they have been explicitly shown. You can explicitly hide/show the Report Page tabs using the Tab > Tab settings > Tab bar option
available from the Main Toolbar. For more information, see the Appearance menu [105]commands..

Adding and administering report sections

The Side Bar Reports Panel must be expanded to show the Create new button at the bottom of the panel. Expand/collapse each device by
clicking its title. Click Create new, choose Section and enter the section name when prompted. Drag the sections and Report Page titles
around to achieve the desired structure.

To manage existing section titles, click the black triangle on the right to show a drop-down menu, allowing you to rename or delete each
section grouping.

 

 

Next: Formula Fields [164]

User Guide Top [108]

[108]

Formula Fields

Adding Formula Fields and Variables

Defining calculated columns and modeling assumptions 

Omniscope can calculate values based on values in other columns, using a standard menu of functions (same syntax as Excel) plus some
additional Omniscope SUBSET functions. Omniscope formulae are expressed only in terms of columns, not using individual cells as
with spreadsheets. You cannot define an Omniscope formula that depends on the value in a cell belonging to another record (row). Instead,
you specify additional values called Variables, which are input assumptions, not values in the fileds (columns) of the data set. Variables can be a
single value, but usually are expressed as a range of values with a minimum, maximum and default value (see Add/Edit variables below).

You add defined Formula Fields to your data sets using the Formulas drop-down menu available on the Table View Toolbar:

 

62/305



 

Add formula field-  creates a new field (column) of values calculated as a function of the values found in other columns, together with any
Variables whose ranges have been defined  (see Add/Edit Variables below).  You use the Add formula field wizard to define the calculation
you want Omniscope to perform when populating the new column.

 

 

 

 

The Add/Edit formula field wizard displays a blank formula definition workspace (or the current formula definition, if any, for editing). You
specify formulae by selecting columns, typing in arithmetic operators, selecting functions from the the functions list library, and Variable you
have already defined (see below). If you make a mistake, backspace to remove it and try again. The functions list library contains all the
standard spreadsheet functions (same syntax as Excel), plus special Omniscope SUBSET functions documented in the
KnowledgeBase Functions Guide [63]. 

Add/Edit variables- Variables are values with ranges you define which are not contained in the data set, but are available to be used in
Formula field calculations. Variables can take on a range of values, and if you reveal the corresponding Side Bar device, you and users of your
files can 'use Side Bar sliders a check-boxes to 'flex' the model assumptions, performing real-time, multi-variate simulations and sensitivity
analysis, with all views and totals updating automatically.

Complex formulas can be made easier to read if you add line breaks and spaces to space it out.  In Omniscope 2.5, you can also add
comments, using /* to begin a comment and */ to end a comment, like this:   /* This is a comment */.   Comments, line breaks and spaces
have no effect on formulas.

For more detail on using the Add/Edit formula wizard to specify formula fields, and defining Variables for use in sensitivity analyses, see the
section on Formulas and Variables [93] under the section on the Table View [110].

 

Next: Managing Display Appearance [140]
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Manage Appearance

Managing Display Appearance
Present your data and links with pride... 

 

Deliver interactive, data-rich, visual reports in Omniscope rather than dull, complex spreadsheets or static, presentation slides. Omniscope
offers extensive options for branding your file, displaying advertising, focusing the end users' navigation options, and changing the layout,
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offers extensive options for branding your file, displaying advertising, focusing the end users' navigation options, and changing the layout,
styles and colouring to match your organisation's standards for internal and external documents.

Commands affecting the display of a given file are found in the Main Toolbar Settings and Layout menus. In this section, we will introduce
only two of the most commonly-used sets of options; Branding and View restrictions. 

Settings > This file > Branding

{Omniscope Professional & Enterprise only} The Branding sub-menu provides options to configure either of two informational pop-up pages
presented on opening and closing a given file. It also provides the option to change the corner logo display from 'Visokio' to a logo of
your own (with a link back to your own page), and to display banner advertising images and links in your downloadable Omniscope files.

 

 

There are two informational pages you can configure:

The Cover page opens (and closes) before any working displays or Report Pages.
The Back page displays when the file is closed, and is useful for reminders, acknowledgements and providing contact details relating to
the file.

The Add Corner logo, Add Web Services menu logo, and Set publisher link options enable data publishers to further brand their files.
The Banner advert sub-menu enables publishers to add advertising images and links to their files to fully integrate with the commercial
aspects of their business. For more information, see Appearance Menu [105] and Advertising Options. [165]

Note: The Help page and banner advertising displays are currently the same for the working display and all the Report Pages in the file, rather
than configurable for each Report Page. This may change in future versions. To edit the file specific Help Page, see Help > Create/Edit help
page.

Configuring Information Pages

Clicking on the option to configure a Cover and Back informational page launches a Set Page dialog that accepts 5 inputs from you. The
dialogs used to create the Cover and Back informational pages are both similar to the one shown below:
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Note:  Both information pages support some aspects of HTML text formatting, such as <b>, <i> etc.

Suggestion:  Use 'hard' returns to wrap your text for readability. Click 'Preview appearance' and then re-size the window by introducing hard
returns to define the size and shape of information page. Click 'Submit' and the size, shape and text-wrapping of the information page will be
preserved.

Note: Informational pages behave differently to the Help Page, which does not require hard returns and can be re-sized directly in preview
mode. 

Settings > This tab > Advanced tab settings > View restrictions

For any given data set, one or more of Omniscope's 14 different views may not be needed to best depict the data set and support user
interaction. It may be that the data does not contain any fields (columns) useful to plot against other fields in the Graph View. Some files could
have so many different unique Category values in different fields that the Tree View becomes slow to open and use. Whether for these or
other reasons relating to simplifying the file, it is possible to hide selected views from the users' View Chooser menus by unticking the view on
the list displayed under Settings > This tab > Advanced tab settings > View restrictions:

 

 

Styles

In addition to logos/background images and font selection, all the colours associated with an file can be managed using the options available
under Layout > Configure styles. There is a library of style presets you can test from Layout > Styles. You can also create your own
combination of corporate colours and save them as your own named style. More on managing styles [166].  You can also configure the colours
used for data values using Settings > This tab > Value colours.

Learn more...

For a more complete discussion of all the available menu commands, see Commands Reference [27], in particular the Layout Menu [58].

 

Next section: Refreshing data [133]
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Managing Styles

Creating & managing styles
Controlling colours and presentation across files
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Styles are combinations of display settings you can change under Layout > Configure styles.  These settings control most of the visible
aspects of each file, outside of the controls available within individual views. By default, a built-in style called Default is used for every file. A
menu of alternative pre-defined styles is available Layout > Styles. You can see the different colouring effects by changing the style applied to
the open file.

 

Ice Blue Bordeaux

 
Forest

 
Darth Vader

 

Create a corporate style corresponding to your corporate colours and general style of presentation, using a combination of official logos, font
settings, colours and effects, which you can define using Layout > Configure styles.  Once you are satisfied with all the settings, name and
save your official style preset and it will become a new option on your Layout > Styles  menu. You can also copy this customised style preset
to others in your organisation (see below), so that the official corporate preset is available in the same menu to everyone configuring files.

Customising, Saving, Exporting & Installing styles

If you change any settings relative to the current style preset, the Preset selection drop down will show that the new altered preset is not
saved. Click Save to give a name to the newly-modified style preset and save it to your installation, from which it will be available for future use,
and transferable in the form of an .XML file you can copy across machines.

The settings corresponding to the new style preset are saved in a local .XML file
named {YourPresetName}.XML. Anyone who creates a new file from an
existing file can use the same style preset, which is part of the file.  However,
anyone creating a new file will not have access to the custom corporate style
unless it is first copied to their machine.

 

Currently, to make a style preset you have defined available to others, you
need to find the file called {YourPresetName}.XML on your machine, send a
copy of this file to others needing to originate (not view) files with his preset,
and tell them the location on their machine to copy this file so that it will be
available to them whenever they create a new Omniscope file.

 

The location to find/copy the .XML style preset files varies by version of Omniscope and your version of Windows, as described below:  

Omniscope version 2.4

Vista:
C:\Users\UserName\AppData\Local\VirtualStore\Program Files\Visokio Omniscope\UserThemes

Windows XP:

C:\Program Files\Visokio Omniscope\UserThemes

66/305



Omniscope version 2.5

Windows Vista:
C:\Users\UserName\AppData\Local\Visokio\Omniscope\UserThemes

Windows XP:
C:\Documents and Settings\admin\Local Settings\Application Data\Visokio\Omniscope\UserThemes

Revealing Hidden System Files

If your system is set to hide system-related files and folders, you may not see the above locations until you change this setting:

1. Open the folder options in Windows:

Windows XP:
Open menu START > Settings > Control Panel > Folder options

Windows Vista:
Open menu START > Control Panel > Appearance and Personalisation > Folder options

2. Click on the View tab and enable the option 'Show hidden files and folders'. 

 

Back to Managing Appearance [17]
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Update/Refresh Data

Data Refresh Options
Keeping your data up-to-date

 

Omniscope IOK files include a highly-compressed snapshot of all the data already imported. Access to the linked data source is NOT needed for
you or others to view and explore data already in Omniscope. You can send an IOK file to a friend who does not have access to the original
data files, and they will still be able to explore the full copy of the data in the Omniscope file. However, unless the IOK file has been created with
a special Commercial Publishing license key, free Viewers cannot refresh the data in a file. A new IOK file needs to be created and distributed to
users of the free Viewer whenever the data changes. 

Activated versions of Omniscope, however, can refresh the data (and configuration) in distributed Omniscope files in various ways.

Refresh from linked data sources on file opening:

Omniscope files usually contain data imported from other data files or relational database reporting views being changed regularly. Omniscope
remembers the location and format of the external data imported, which could be one or more Excel .XLS or other spreadsheet .CSV files, a
database reporting view exported and saved as a .CSV or .TSV file, reporting views defined by any SQL statement that returns a table from
relational tables from one (via ODBC) or more (via JDBC) relational databases, or a folder of files or images on an Internet server or your PC.
Remembering its 'linked data source' enables Omniscope to refresh the data in IOK files on opening, whenever the source data has been
changed. Upon opening, IOK files automatically detect (from the time stamps) that their data source(s) contain changed data. Depending on
file refresh settings (see File > Save As dialog) the file either automatically refresh the data, or may ask the user if he/she want to refresh the
data from source before displaying the Omniscope file. Moving the linked data source file(s) location relative to the Omniscope file will break the
link. You can delete or restore any Omniscope file's link to external data sources at any time. When opened, the IOK file will automatically
detect that its data source has been changed and will ask you if you want to refresh from the new source before opening. This refresh affects
data only, not the overall configuration of the file.

Refresh direct from relational databases:

If Omniscope is unable to automatically detect changes to the external linked data source (for example, if the source is a database table being
accessed via ODBC or JDBC [167] protocols), you can configure the file (via File > Save As) to always refresh on opening, or just manually
refresh the file after opening by choosing Data > Refresh from source.  If you have added Connector-based fields such as Bloomberg fields
to your data set, and have access to Bloomberg on your PC, you can use Data > Refresh Bloomberg data to refresh these fields at any
time. This refresh affects data only, not the overall configuration of the file.

Warning: Omniscope does not currently support partial refresh of data tables. Any Omniscope data (not Formula) columns not contained in
the external linked source will be overwritten or lost if the Omniscope file is refreshed (Formula columns are re-calculated). If you have added
data columns from sources other than the linked source, i.e. maintain a lot of local data in your working Omniscope file such as columns of
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notes, or pasted copies of e-mail correspondence, or references to pictures or map coordinate references which are not in the linked data
source, you must divide your working IOK file into two separate Omniscope files prior to refreshing only the columns originating from the linked
source. This is easy to do. Once you have refreshed the Omniscope file containing only data columns from the external source, you can
join both parts of the working file back together again. For more information on separating and joining IOK files, see the  sections on the
Export Data Wizard [125] and the Import/Merge Data Wizard. [168]

Although any number of distributed Omniscope files can refresh directly from the same relational database reporting views, all users need
access rights for these views, and if the number of users becomes large relative to the load on the database, it may be better to link the
database to one central copy of the Omniscope file, and let distributed users refresh their copies remotely from that central IOK file, rather than
directly from the database.  In this configuration, the central Omniscope file is acting as a highly scalable, visual and configurable 'data mart',
but 'data mart' nonetheless.

Linking Omniscope files to other Omniscope files:

In addition to other types of data files, Omniscope IOK files can be configured with other IOK files (including a copy of itself) as linked data
sources. This option has the advantage that only the updated data set can be delivered to the distributed User Omniscopes, without changing
what may have become personalised Omniscope configuration(s) of Views, Filters, named Queries and Report Pages. A large-scale Source
Omniscope file running on an always-on server can serve as a 'data mart', providing the data source for a wide range of different end-user
Omniscope files refreshing from it. The central 'data mart' IOK file should in turn be refreshing itself via continuous, always-on access to
reporting views drawn from your relational data warehouse or analytical 'staging' database.

Automatic refresh from live data sources

From version 2.3, you can now configure any number of desktop Omniscope Professionals to automatically refresh their file data from
a Source IOK file running elsewhere, over your local network or across the web. If the Source IOK file is in turn refreshing itself directly from the
original source database view/table(s), this configuration provides a scalable, near real-time live data refresh solution. While distributed Users are
working on their files, auto-refresh awaits a pause in their activity. Each time Users re-open their copy of the auto-refresh linked file, it either
refreshes only the data, or returns to the file to the default opening configuration of the Source file, depending on settings. To allow Users to
maintain their own individualised configurations and import only the latest data when working, use the Refresh from linked data source.
Alternatively, auto-refresh can be configured to Refresh by reloading IOK file which returns the distributed copies to the default
configuration on refresh.

For more information, see the Knowledge Base sections on Integration [169]and Auto-Refresh [170].

I can't refresh from source!

If your linked data source has moved or is inaccessible, Omniscope will be unable to refresh from source. If you imported from a source file
such as a .CSV or Excel .XLS spreadsheet, the linked source file must always remain in the same relative location compared to the IOK file. If
you have moved either file independently, you can re-establish (re-locate) the source file by choosing Data > Edit source. If you imported
directly from a database, check that the database server is started, and is accessible across your network if it is running on a different PC or
server.

Making changes to source data

Exporting changes back to linked data files- be careful!

Omniscope allows you to edit cells in the Table View, right clicking on the cell to edit cell data, and right-clicking row headers to add/remove
records (rows). You can also add and remove fields (columns) using the Data > Manage Fields. When you have finished your edits, save
your work in the IOK file as usual by choosing File > Save. If you originally imported from a linked data file (such as a .CSV or .XLS file), you
may be asked if you also want to save back to source - i.e. to save your changes back to the linked source file. At any time, you can also
manually save your edits back to the source file by choosing File > Export > Export back to source. {Professional & Enterprise Editions
only}

Warning: Whenever you choose to save back to source the entire source data file will be completely overwritten with your latest edits from
the the Omniscope file. If you have deleted fields, these will also be deleted in the source file (therefore usually better to just hide them). If your
source file is an Excel XLS file, all formatting and formulae will be deleted as the export is only for cell data. If you have a multi-tab spreadsheet,
all the other tabs will be lost.

Exporting changes directly back to relational databases- not supported

Omniscope does not support saving changed data sets directly back into to database tables. If you need to save changes back to a database,
collect your changed records in a Named Query (such as 'Errors for correction') then export a .CSV or .XML file containing the changed
records, and perhaps a 'Comments' column explaining the changes. You or your database administrator can then use a database utility to
import your changes directly into the transactional database table(s). For more detail, see Queries & Subset. [10]

Unlinking/Re-linking to source data files

At any time, you can deliberately remove the persistent link between an IOK file and its linked data source by choosing Unlink from source
from the File > Export menu, or by un-ticking the Linked to source check box when saving the IOK file using the File > Save as dialog.

Also, any time you are prompted to refresh from source or save back to source, there is always the option to click Unlink or Skip to prevent
overwriting the source file. You can also reconfigure the linked source file at any time by choosing Data > Edit source which will preserve any68/305



overwriting the source file. You can also reconfigure the linked source file at any time by choosing Data > Edit source which will preserve any
field conversions and formulae applied to the previous source.

 

Next section: Useful tools [171]
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Useful Tools

Introducing the
Tools Menu
Useful tools for improving
your files...

The Main Toolbar Tools drop-down menu provides access to a wide range of useful commands. In this section we will look at three of the most
commonly-used sub-menu options accessed from the Tools drop-down menu:

Tools > Languages

Select your preferred language for all Omniscope menus and dialogues. This will not change the language of your data, only the Omniscope
commands. For detailled instructions on switching languages, see Tools > Languages [102].

 

 

If you would like to edit/modify the language translation files you use, see our Knowledge Base Translation Guide. [172]

Tools > Show details using...

In addition to the Details View [120], Omniscope can display configurable record-level details as pop-up windows and embedded Side Bar panels.
Open a Side Bars on your file and try each option for viewing details outside of the Details View.
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More on Viewing Details [122] and Adding Links [146]

Tools > Tooltips

Tooltips are extra pop-up displays that appear on top of views whenever users hover their mouse on specific records, such as a single row in
the Table View or single record dots plotted in a Graph View. You can select which fields are displayed in the pop-up Tooltips hover display. This
is an extremely useful way to help users understand the key attributes of any record just by pointing with the mouse.

 

 

 

You should be selective displaying Tooltips, however. Trying to display too many fields in the Tooltips pop-up results in large, cluttered displays
that obscure other important aspects of your reports.

The other commands located on the Tools menu are discussed in other sections:

Links- discussed in the Using Links [146] section
Web Services- discussed in the Web Services [173] section
Images- discussed in the Adding Images [174] section
Advanced Tools- discussed in the Tools-Advanced Tools [175]section

 

Next section: Adding Links [146]
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Adding Links

Adding and Using Links
Link to documents, other files and the web

Links extend your file users' experience to include content not contained within the Omniscope IOK file itself. By adding links, anyone can
integrate related external content (documents, files and web pages) into their IOK files, with one-click access via their local network, and
the open web.

Links in Omniscope allow you to link a single record to some online content, optionally passing field values to the web server, allowing you to
search for field values on external websites, for example.

If you need to post multiple records to a server, you need to use Settings > Web Services [176] instead. 

The Add links wizards

You specify links and make them available for use within your IOK file using the Add web link, Add local link and Preconfigured
links dialogs available from Settings > Links menu on the Main Toolbar.
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The Add local link, Add web link and Preconfigured links dialogs are simple to use and allow anyone to create dynamic local and web links
combining text strings typed in just once (like a network file server/folder locations or web site domain names) with the values of fields
contained in the .IOK file. The result is user-selected, dynamic, data-driven links that extend users' access to information dramatically.

Creating local links

File folders located on your machine (or on other machines accessible to you over your networks) can contain documents, images, audio and
video clips, practically any kind of digital content related to your data. For example, you may store a folder of documents on a remote file
server that users of your .IOK file may wish to consult. If you have a reference name for each document (or the enclosing folder for groups of
documents), including this information as a column in your .IOK file will permit users of your file to link to the folder or specific documents,
audio or video clips, etc. inside.

 

 

Using the Add local link wizard, you build up the link by:

1.) Browsing to the network location containing the files you are linking to,
2.) Building the file name by adding in any text that does not change (e.g. 'fileserver' in the example above) and specifying each of the fields in
your .IOK file containing values that will add specificity to the location/document/file the user will be linking to. To delete, backspace and try
again. Once have have fully specified the link to an existing file/document, 
3.) Try the link across a number of different records ( in the example above, there was no document found)
4.) Name the link once you are sure that the link is correctly specified and working across the full range of records

Once the link is fully configured, it will appear with the name you have given it on all menus relating to links in the file. If you then assign the link
to a field (column) in the data set,  Omniscope will create an underlined link from all the values in that field that launches the link whenever the
user clicks on a value in that field (column). You can associate local links with any field (column) and they can appear as action buttons/links in
the Details View and pop-up displays.

For more information on how Omniscope builds links, please see Absolute and relative links [177]. 

Preconfigured links

There are many free reference and look-up services available on the web. Omniscope includes a library of preconfigured links you can use to
extend the reach of the users of your file, eliminating the need for them to re-type what could be long and complex codes or foreign
languages in order to access a service.
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Free pages tend to expect a single string of text, i.e. a search term/string, a recognised identifying number like a stock ticker, CUSIP or ISIN
(securities) or an ISBN number (books). If your data set includes fields (columns) that can be submitted to these or other web pages (see
creating custom links below) you should consider configuring these links in your files   You can specify that the results be displayed in one or
more Omniscope Web Views [119] or the user's default browser.

 

If you would like to offer other free preconfigured links to be added to the list included in Omniscope, or otherwise communicated to our users
via our web site, please contact us [178].

Creating custom web links

Any resource available on the open web can be linked to an Omniscope IOK file using the Add web link dialog:
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The Add web link wizard process is similar to building local links. Use the drop-down to specify the web protocol for the resource (usually
http://) then type in the part of the URL/web address that is not contained in one of the fields in you data set.  Next, select one or more fields
from your data set, typing in any necessary separators like /, %20, etc. between the inserted fields. To delete, just backspace and try again.

Once you have configured a valid URL/web address, test the link by cycling through various record field values, and clicking on the displayed
link. Once you are sure that it is working as you expect, give the link a name. The link will now be added to the list of links available in your file.
In the same way as local links, you can associate web links with any field (column) and they can appear as action buttons/links in Details pop-
ups and views. Web links can also be associated with Web Views by selecting the links from the list in the Web View > View Toolbar > Links
drop-down. For more information, see Using the Web View. [119]

 

Next section: Add Images [174]
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Adding Web Services

Adding Web Services in Omniscope
Omniscope allows you to define Web Services in your IOK file, which allow you to select some records and "post" them to a server, then view
the resulting web page.  You can either use preconfigured example web services, or enter the details of a server yourself.  

Behind the scenes, Omniscope submits an POST to an HTTP server listing the record identifiers from a field of your choosing.  Omniscope then
displays the resulting web page, either in a separate browser or using the Web View [179].

Omniscope as a universal web service 'hybrid' desktop/web client

Omniscope integrates with web services to offer a hybrid 'best of both worlds' combination of powerful desktop client/user interface with the
ability to send user-selected or modified subsets of data (including user input data) back to remote servers for further processing. Corrections
and updates can be sent back the the central data repository for refresh back into Omniscope, or remote server results can be immediately
displayed using one or more Web Views [179] or the default browser on the users' machines.

Currently, Omniscope supports exporting to remote servers of any number of values (references) from a single field (column). You can define
a formula field that collapses multiple user-changed fields into a single delimiter-separated column for posting back to the central data source.
You can also write formulae files that return values read from remote web services. If you envisage a solution that requires posting a table of
selected or modified values (more than one column) please contact us. [86]

Defining Web Services within a file

Web services that will be available from within each file are defined using the Main Toolbar Settings > Web Services dialog:
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From the Main Toolbar, the Settings > Web Services menu offers the following options:

Modify Web Service- allows modification of all the parameters associated with any web service already configured in the file or remove the
web service from the file. The parameters are the same as those shown below in the Add Web Service wizard: HTTP POST URL; Web Service
name; ID field (the field (column) from which selected values should be exported) and the Record count limit, which sets the maximum on the
number of values posted at a time.

Add Web Service- selecting the Add web service option opens the Web Service configuration wizard:

 

 

Add your own Web Service configuration to the file by supplying your own values for:

HTTP POST URL: the full URL of the server file/page responding to POSTS

Web Service name: Name you give that appears on the Omniscope Web Services menu. In the example above there are 3 names for 3
different services available from the file.

ID Field: the field (column) name in the Omniscope that contains the values to be exported to the Web service being configured. Can be
different for each service

Record count limit: Can be any number of values, set to 100 by default

Omniscope includes a test web service that 'echos' whatever field (column) of values you choose to send. Try configuring this service using the
URL given, with a name like Echo Test, and selecting a field in your data set. In one of the views in Omniscope, select less than 100 records,
and in the Main Tool Bar, click on the 'Echo Test' web service. If you have not configured a Web View in Omniscope to display the results, the
default browser will open and display the echo results. If you have configured a Web View to display the web service results, they will appear in
that open Web View.

 

 

Set Web Service button text- Sets the display/hover value for the Web Services menu button...'Partner Services' in the example shown
above.

For more discussion of options for building web-integrated data publishing solutions using Omniscope, consult our KnowledgeBase sections on
Web Integration [180] and communicating with Web Services. [181]
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Adding Images

Adding Images
Thousands of pictures are worth
millions of words...

Omniscope can be used to align a set of images in a folder with records (rows) relating to each image, such that the images associated with
each record (row) can be displayed in various views:

Table View (View Tools > Column Options > Show images in cells-select column),
Tile View (Tile View > Tile Contents > Show Images-select image set), and the
Details View/windows (Details View > View Tools > Show > Images).

Before you can display images, however, you must associate one or more folders of images with the .IOK file as named image sets. Preparation
for this involves saving a set of images in a single folder with a consistent naming convention that matches the text values in one of the
columns of your .IOK file (it may be a column included just to hold the names of the images).

To save you having to find a lot of pictures in order to try this, the example below will use an Omniscope embedded demo file 'Works of Van
Gogh', and its associated high-resolution image set. To take this tutorial, first click on the link below to download a zipped folder containing the
images for the "Works of Van Gogh" demo.

Van Gogh Demo Image Set [182]105.3 MB (about 4-5 minutes on broadband)

Note: this folder contains many high-resolution images, making the download quite large. In order to bundle the entire folder of images
together, this is a .ZIP file; do not click 'Open', click 'Save'. Download and unzip the folder, and save the unzipped folder on your desktop. Once
you have saved the unzipped folder of images, open Omniscope and click  Files > Demo files and select 'Works of Van Gogh'.

Using the Add Images Wizard

The embedded version of the demo file does not have the associated image embedded in it. Go to Settings > Images and you will see there
are two options for retrieving the images, an automated, online service, and the manual approach. For this tutorial, to gain experience using
the Add Images wizard we will try adding the downloaded image set manually. Select Add more images.

The Add Images Wizard will launch:

1. Select Folder of images-Browse
to the folder on your desktop
containing the images and click select
folder.

2. Choose field/column containing
image references (the names of the
image files)...in the Van Gogh demo
this column is called 'Final Ref'. Select
'Final Ref' and you will see a sample
image name displayed...in this case, a
picture in the folder named J_30.jpg.

3. Choose format of references-
Omniscope detects this automatically
for demo files.

4. Select file extension to use...-this
will show '.jpg' since all the images in
the file already have this extension.

5. Give a unique name to this
image set...change the suggestion
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from 'Images Set 2' to 'My
Downloaded Images'.

Check the example image at bottom
right corner of the wizard and ensure
that the correct image is displayed.
Click OK to associate the named image
set.

Viewing Images

To see your image set displayed, go to  Add View on the Main Toolbar and add a Tile View. On the Tile View toolbar, click on the [ ? ] field
(column) selector drop-down and select My Downloaded Images. You will see the images start to appear, but coloured. Go to the Colour
selector to the right on the Tile View Toolbar and select 'none' to see the works coloured as van Gogh intended.

Saving reduced-size image sets reduce file size

If you have an activated Edition of Omniscope (Professional or Enterprise) you can experiment with saving the file with your downloaded
images embedded. At the same time, you can see the trade-offs between file size and image clarity/resolution that results when you reduce the
image size to reduce the size of the .IOK file. To save a version of your file click File > Save as. The Export File dialog will appear:

 

Note the commands available
along the right hand side:

Data: used to select subsets of
data to save in new file
Embed Images: If the image set
must be available inside the .IOK
file, you must embed the image
set when you save the file. Select
the image set you wish to embed.
Recall, however, that these image
files are hi-res images totalling over
100 MB. If you embed these
images without reducing their size,
the resulting .IOK file will also be
about 100 MB in size, far too big
to e-mail to friends!

Tick the box 'Reduce Image size' . Give the new version of the file you are saving with embedded images a name, such as Works of Van Gogh
200x150.iok. Click Save and you will see an image reduction dialog that enables you to reduce the size of the images to reduce file size, but at
some cost in terms of image clarity.

 

 

Accepting the existing image sizes will result in a file
of over 100 MB, so let's try reducing the
dimensions of the pictures by 50%, to 200x150
(hence the name of the file we are saving). Change
the maximum values to 200 wide and 150 high
and click OK. Omniscope will save the file with
reduced embedded images. The resulting file is
about 14 MB, still large, but not bad for an entire
art exhibition in a portable, searchable file!

 

Open the new version of file and close all the open Views except the Tile View, which should be configured to display the now embedded image
set My Downloaded Images. On the Tile View Toolbar, select the movie camera Slide show icon to the left of the Add to basket icon far right.
Click 'Start slide show' and choose full screen sub-option. Look at the image quality on your screen. If it is acceptable for the audience/screen
resolutions you intend, consider reducing the images more to reduce the .IOK file size further. If the image quality full screen is not acceptable,
you may have to reduce the maximum size of the images less (increasing the file size), or configure the views such that images are never
displayed so large. To do this, repeat the steps above, and set larger maximums in the 'Reduce image size' box.

Next section: Using Maps [183]

User Guide Top [68]
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Using Maps

Using Maps
Location, location & location

 

Omniscope allows you to use embedded vector maps that work offline, or online mapping services, such as Google Maps. Users can change
from one zooming map background to the other within the Map View. Omniscope includes a wide selection of freely dowloadable vector maps
(world, county or city level) which can be downloaded automatically and added into any file. Coordinate data in your data set is automatically
plotted on maps or scanned images, such as floor plans. Markers can also be placed manually and Omniscope will automatically capture the
coordinates to your data set. For more information on freely downloadable maps and how to use them, please visit our Maps Library [184].

Map Views

Omniscope permits you to have multiple map views, using either vector maps (work offline) or Google Maps backdrops (work online only). The
example below shows both vector and Google Maps being used to display the same coordinate data, visible in the Table View at the bottom
(click image to see larger version in a separate window).

 

 [185]

 

Map Views allow easy zooming, selection and filtering of records (rows) based on location. You can use mouse mode controls and zoom
options to manage the display, and then select groups of records on which to perform Move or Keep power queries.

To learn more about navigating, selecting and filtering, see the User Guide section Using the Map View [48], and the KnowledgeBase sections on
Maps & Coordinates [186].

Adding Maps

You can add embeddable vector maps to your local library and files from the File > Open map command, which is also accessible from the
opening desktop Tasks menu. Downloading a map from our Maps Library [184] adds it to your local collection. If you use the map in a file
shared with others, and they do not have the map, it will be automatically downloaded for use in the file. It is also possible to embed maps in
files if necessary.
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You can use any type of scanned image as map- floor plans, sports fields, logistics and supply chain charts, etc. To learn how to calibrate
coordinates for display on scanned images rather than map projections, see Changing Projections [187] in the Knowledge Base.

Adding geographic coordinates to your data

Every map defined in Omniscope requires you to specify two columns to contain the Longitude (X) and Latitude (Y) coordinate values used to
plot the records (rows) on the map. There are currently three ways to add geographic decimal coordinate (longitude and latitude) column
values to your data for map displays;

1.) Locate your records in Omniscope using the free Visokio world, country and city vector maps- just select each record in the table view and
place the markers manually to generate the coordinates in new fields (columns) automatically (see the tutorial on Using Maps [188]);

2.) Look up missing coordinates using online sources for finding coordinates such as Google Earth (and often Wikipedia). In Google Earth, look
up the missing places, set a placemark, then read off the placemark coordinate values, then type or cut-and-paste the two Longitude and
Latitude values into Omniscope columns (see Using Google Earth [189]);

3.) Merge the columns into your Omniscope data automatically using a merge file [190]. To merge in coordinate columns for capital cities or
geographic centres of countries, we supply free 'By Countries' [190]merge file containing these columns. We also supply a free 'By Cities'
[191]merge file containing coordinates for about 60,000 of the world's largest cities. Free merge files 'By post code' [192]are also available for the
UK and the U.S., and a growing number of other countries as well. Other free and licensed reference merge files may be available from data
vendors in future.

To learn more, see the User Guide section Using the Map View [48], and the Knowledge Base sections on Maps & Coordinates [186].

 

Next section: Creating Flash DataPlayers [23]
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Creating DataPlayers

Creating Exportable Flash DataPlayers
The DataPlayer View is a combined viewer and workspace that enables anyone to create exportable, interactive files we call DataPlayers. Using
the DataPlayer View, some or all of the data* in an .IOK/.IOM project file can be encapsulated in one or more Flash .SWF  files combining the
data, dynamic visualisations and query devices. DataPlayers can be embedded into offline documents (PowerPoint, Excel, Adobe Acrobat) and
web pages with full interactivity. Flash is universally-accessible and does not require users to have the the Omniscope free Viewer installed
to interact with and filter the data in real time. For more information and examples of live DataPlayers, consult the DataPlayers [193] section of
the website.

*Due to limitations in Flash, DataPlayers can not yet be scaled up to include millions of rows as Omniscope .IOK/.IOM files can. Although the
upper limit is increasing over time, it currently can be difficult to get good performance in DataPlayers with over about 15,000
rows. DataPlayer scalability and performance will be increased dramatically in future releases. For more information, see KnowledgeBase article
on DataPlayer scaling and performance [194].

Adding a DataPlayer View

The DataPlayer View is opened like any other, using the Add View menu on the Main Toolbar, or by switching from another view. Ticking the
option Open in new window at the bottom of the Add View menu will allow you to manage the DataPlayer window independently. It is good
practise to create a separate reporting tab for the DataPlayer View, which aids in creating DataPlayers and refreshing them later on. Note that
under the Appearance menu, you can choose either Tabbed (one view type per tab in the single DataPlayer file, or Simultaneous,
multiple ('dashboard') views for a given DataPlayer.

 

 

Upon opening a DataPlayer View, Omniscope will attempt to generate a Bar View DataPlayer using the Filtered data (IN) data set.   
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WARNING: If you have more than 10-15,000 records in the filtered IN data set, current limitations in Flash may interfere with full rendering
of the initial DataPlayer. It is best to first define either an Aggregation or a Named Query (or both) such that the number of records to be
encapsulated in the DataPlayers is reduced to under about 15,000 depending on row count and data complexity.

The Side Bar filter devices and ordering settings showing when the DataPlayer View is opened are replicated in the DataPlayer filter panel which
by default is on the right side of the DataPlayer. Once the initial Bar View DataPlayer is generated, you will notice the various interactive
elements of the DataPlayer. Clicking on the filters in the side panel reduces the record count, as displayed in the barometer at the
bottom. Clicking the Reset button restores all the records in the defined data set. Clicking on the details button displays (potentially
aggregated) record level details (in an expandable table) which opens at record level to display all fields as configured.

Using the menu items available on the DataPlayer View Toolbar (see below), you can refine this opening DataPlayer, add other DataPlayer view
types, and change the Omniscope Side Bar filter settings to influence the filter panel generated in the DataPlayer(s) you are creating.

CAUTION: The DataPlayers displayed in the DataPlayer View are fully interactive, and thus it is possible to set filters, change selection drop-
downs etc. just as end-users of the DataPlayer will. However, these changes are NOT PERSISTENT. The next time the DataPlayer View is
opened and the DataPlayer re-generated, all settings will revert to the settings established in the View Toolbar settings menus, described briefly
below and in detail in the in the DataPlayer View [54] reference section.

Refreshing the data in the Omniscope file, then updating the DataPlayer View will create an updated Flash 'dashboard' file containing the latest
data, which can be posted to the web or exported into existing documents, over-writing the previous versions.

DataPlayer View Toolbar overview

Like other View Toolbars, the DataPlayer View Toolbar displays many of the standard menus, such as the window View picker, Data Subset,
Aggregate and View tools menus, but also various specialised drop-down menus containing options for adding and configuring DataPlayers.
Given the scaling limitations of DataPlayers, it is sometimes necessary to define Named Queries and/or aggregations in the DataPlayer view to
reduce the record count sufficiently to allow one or more DataPlayers to be generated.

 

 

In addition to the standard View Toolbar menu items, the specialised menus on the DataPlayer View Toolbar include:

Views - used to add new view types (first default is Bar View) and specify the settings for generating, re-generating and refreshing the
DataPlayer. Current DataPlayer view type options include:

1. Bar View [195]- vertical or horizontal, with splits and stacking
2. Pie View [196]- rotating or static
3. Graph View [197] - scatter plots or time-series connected
4. Table View [198] - sortable and expandable with defined columns and orders
5. Tile View [199] - dynamic, for re-sizable 'heat-maps' that do not use fixed images in tiles
6. Tile View [200] - static, for image mosaics using fixed-size thumbnail tile images (can be linked to full-sized Details images via web)
7. Map View [201] - use embedded, downloadable vector (offline or online Google maps)
8. Details View [202] - show record level details

Details - settings relating to the Details displays in the DataPlayer, both single record and multi-record details
Appearance - options to change the size and configuration of the DataPlayers
Save/export - options for exporting DataPlayers created in Omniscope to documents and/or web pages

This section is just a brief introduction to the process of creating and exporting interactive DataPlayers from defined data-subsets and filter
settings in your Omniscope files. More detail on all the myriad configuration options for all view types is available in the Views Reference
DataPlayer View section [54].

 

Next section: Connecting to remote data [30]
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Printing

Printing Options
Omniscope offers options to print from individual views, or at the level of the entire file.  In addition to printing only one view, or the
current page, it is also possible to print some or all of the Report Pages as PowerPoint or Adobe Acrobat files, with many options to show or
hide various aspects of the Omniscope display in the printed versions. 
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Printing individual views

Sometimes, you may wish to print a single view on a single piece of paper. All views offer this option from View Tools > Capture Views >
Print.  Right clicking on views with backgrounds, like the Pie and Graph views, also presents a view  Print option.

If you are running Windows, the individual view print option available from Capture Views > Print will launch the Windows Page Setup
dialog enabling you to confirm the paper size, orientation and margins for the page you wish to print.

 

Note: When printing individual views, the view title does not print.

 

Printing one or more pages

Sometimes, you would like to print a paper copy of the entire page display, or multiple Report Pages, from Omniscope. On the Main
Toolbar, File > Print opens a printing options dialog:

 

 

Choose reports:

Current display/report  only- prints only the current page displayed in Omniscope (which may or may not be a Report Page)

Include all reports- prints only the Report Pages configured in the file.

Print some reports- allows you to choose which Report Pages you wish to print from a drop-down pick list

Display options:

Show report tabs- unless ticked, Report Page tabs are not printed

Show side bars- when ticked, Side Bars are printed on each page.

Show titles- when ticked, the page titles are printed (view titles are always printed when printing pages)

Show annotations- when ticked, prints the annotations below the views on each page

Show unused options- unless ticked, does not print aspects of the display relating to unused options, e.g. Pane-by menus are not
displayed in views with no active paning.

80/305



Show Main Toolbar- unless ticked, the Main Toolbar does not print

Show view toolbars- unless ticked, the View Toolbars do not print

Change background colour to white- when ticked, substitutes a white background when printing

Print as PowerPoint file

File > Print as PowerPoint launches the Print Options dialog described above. You can  choose to print the current display, or some or all
the Report Pages configured in your file. Click on OK and Omniscope processes the pages you have selected. When it finishes, Omniscope
displays the Print as PowerPoint wizard:

 

If you want to create a new PowerPoint file, choose New presentation. If you already have your PowerPoint file open, choose it from the list
of open presentations. Otherwise, browse to and open the PowerPoint file you wish to add pages to. If you are adding pages to an existing
PowerPoint file, you are asked where to insert them:

Warning:  If you specify Replace existing slide, make sure that the slide number choosen is a blank 'placeholder' slide or otherwise
uneeded; it will be overwritten and all addtional pages inserted behind it. Subsequent slides will not be overwritten.

Click on finish and Omniscope will open the PowerPoint file. If you wish to save or print this file, you can now do so from PowerPoint itself:

 

 

Print as .PDF (Adobe Acrobat file)

File > Print as PDF  launches the Print Options dialog described above. You can  choose to print the current display, or some or all the
Report Pages configured in your file. Click on OK and Omniscope precesses the pages you have selected. When it finishes, Omniscope displays
the Print as PDF wizard:
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Specify the new file name and location you want to save this file. Open the file to access the full range of options for managing .PDF files,
including printing.

 

 

Back to File Menu commands [100]
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File Security Options

File Security Options
Setting file security options

Omniscope files are not only more compact and visually communicative than other report data files (e.g. spreadsheet files and web tables),
they also have many more layers of security options to prevent unauthorised access to, and potential re-use of, the data within the files or
web tables.

Most of these options are accessed from the Save/Export dialog, under the IOK tab, on the right in the Security section (with the
exception of text scrambling under the Data > menu, and 'walled gardens' which are implemented via special groups of activation keys). 
Open the Save/Export dialog by choosing File > Save as or alternatively File > Export > Export file(s).  Some options are also available
under File > File security.

Password protect files

Tick 'password protect' and enter a password to protect the file. If you have already set a password, the Change option will let you change it.
Note that if you do not add additional layers of security, anyone with the password can open the file and save a copy with a new password, or
none at all.

Prevent data save/export ("Owner-locked" in version 2.5)

This copy-protection feature prevents even cut-and-paste copying from Omniscope, as well as saving or exporting the data in any way. This is
an all-or-nothing setting, designed primarily to prevent recipients of your file from extracting, modifying or plagiarising your data and
Omniscope configuration. Only the Owner (i.e. the Omniscope installation that created the file) can be used to disable this setting. The Owner
can also edit and save the file even with this setting enabled. Effectively, a file opened on a different PC with this setting enabled will operate in
"view & explore" mode only; extracting data and/or saving changes will not be permitted, just as if you were opening the file in the free Viewer.
This setting is only available in licensed installations, and not the free trial. This setting does not protect file B from being overwritten when
opening file A, choosing Save as and saving over file B. In order to prevent overwrites , you should use operating system-level options such
as setting the file as Read only in the Windows Explorer file properties.

Note: this setting was known as "Protect data from editing or copying" in earlier versions.

Write-protected ("Warning on save" in version 2.5)

This option is a safeguard against accidentally saving changes to an important file. It is a little like the "lock" slider on a removable disk. While
the option is turned on, you will be warned if you try to save the file.

As with Prevent data save/export, this option does not protect file B from being overwritten when opening file A, choosing Save as and saving
over file B. To prevent this, you should use operating system-level options such as Read only in the Windows Explorer file
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over file B. To prevent this, you should use operating system-level options such as Read only in the Windows Explorer file
properties. Omniscope's Write-protect option merely warns you if you inadvertently press Ctrl+S while an important file is open.

Time-limited files (Enterprise Edition only)

This option can be used to ensure that stale, un-refreshed copies of files are not used. Ticking this option displays a settings dialog which
enables you to specify the exact date/time the file will expire, whether or not an external Internet time-check will be required (if so, the file will
not work offline), an option to specify an "out-of-date please refresh" notice yet still allow access, and the message to display if recipients try to
open an expired file. 

 

 

For time limiting to be enforceable, you must also tick "Prevent data save/export" (see above).

Domain Locking (Enterprise Edition only)

Domain locking is a powerful and effective access-restriction and revenue protection feature. Omniscope .IOK/.IOM files are normally free-
standing and easily transferred (by e-mail, posting/downloading from blogs and websites, etc.). Adding domain-locking to an .IOK/.IOM file
imposes the restriction that the file must be opened directly from the originating (generally password-protected and secure) website. This
option enables organisations to restrict access to current employees with valid web credentials, and enables commercial data publishers to
ensure that only current subscribers have access to their data, and ensures that potentially stale, unrefreshed copies of files saved locally will
not open. More information on Using domain locking [203].

For domain locking to be enforceable, you must also tick "Prevent data save/export" (see above).

'Walled gardens' (Enterprise Edition only)

The option to designate a group of specific Omniscope installations able to create and share files only within the group is referred to as a 'walled
garden'. Those Omniscope installations with are members of the group are defined by specifically-created activation keys. Files created
by installations within in 'walled gardens' can be set to open only in other Omniscope installations activated by keys from the same 'walled
garden' list. Privileges for each installation can be set individually to Read-only or Read/Write/Create capabilities for 'walled garden' and non-
'walled-garden' .IOK files. Installations can belong to more than one 'walled garden', with different privileges in each 'walled garden'. For more
information on implementing Omniscope in high-security settings, please contact us [86].

Text Scrambling (new in version 2.5)

Introduced in version 2.5 in Data > Scramble, this feature permits text column values to be 'scrambled' such that the text values cannot be
read. This security feature is initially intended to permit us to assist you with files containing confidential information, but will be further
developed to support selective scrambling for out-sourcing some aspects of workflow and data quality while maintaining some columns of
data, e.g. names on the payroll, credit card numbers, etc. in scrambled format.

 

User Guide Top [68]

Domain Locking

Domain-locking to control access
Domain-locking is a powerful and effective fiel security and revenue protection feature. Whereas Omniscope files are normally free-standing
and easily transferred (by e-mail, posting/downloading from blocs and websites, etc.), domain-locked .IOK/.IOM files have the restriction that
they must be opened directly from the originating website, meaning that the user opening the file must have a current, valid User ID and
Password for the site.

The domain-locking option enables commercial publishers to require that anyone trying to open their files must be logged in to their website,
and ensures that stale copies of files cannot be saved locally. Sensitive corporate data can be protected such that once the users web
credentials are revoked, they can no longer open or refresh Omniscope files locked to secure domains. If a user attempts to open a
downloaded, forwarded or locally-saved copy of a domain-locked file, Omniscope will not permit this and displays this notice:
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Applying Domain Locking

In order to domain-lock a particular file please follow the steps listed below.

Using Omniscope 2.4:

1. Open the file you want to domain-lock
2. Go to Tools > Advanced tools > Edit publishing settings
3. In the Publisher details tab enter all the relevant information
4. Click the File protection tab, click on Tie to website and enter domain restriction (see below).
5. Save the file and post it to the server

Using Omniscope 2.5:

1. Open the file you want to domain-lock.
2. Click on File > Save as 
3. Click the Domain-locked check box
4. Define/enter the domain restriction (see below).
5. Save the file and post it to the server

Defining the domain restriction

The domain restriction is a text string that specifies the top-level domain of the website you want to lock the file to. Do not enter the full web
address; anything beyond just the domain will not work. For example, if you were to enter the domain "visokio.com", this would restrict the
IOK file so it would only open from URLs such as:

"http://visokio.com/any/aaa/bbb/ccc/file.iok"

"http://www.visokio.com/any/path/to/file.iok"

"http://www2.visokio.com/file.iok"

 

If you were to enter "subdomain.visokio.com", this would restrict the .IOK/.IOM file so it would only open from URLs such as:

"http://subdomain.visokio.com/any/aaa/bbb/ccc/file.iok"

"http://www.subdomain.visokio.com/any/path/to/file.iok"

"http://www2.subdomain.visokio.com/file.iok"

Linking to domain-locked files

If you create a link directly to the domain-locked .IOK/.IOM file, this will not work, because the user's web browser downloads the file to a
temporary location before starting Omniscope and opening the local copy.

You can test that domain locking is working by starting Omniscope and choosing Open from the web from the Open file dialog, then pasting
the full URL to the .IOK/.IOM file such as "http://visokio.com/any/aaa/bbb/ccc/file.iok".

To create a smoother experience for the user, it is best to create a Visokio .ILF file on the server which references the domain-locked IOK/IOM
file as follows:

In Notepad, paste the full URL of the IOK/IOM file on the server into a blank text file
Save as "filename.ILF", and upload to the server.
Create a link to this .ILF file in the page content, instead of linking directly to the .IOK/.IOM file.
Test by clicking this .ILF link in the browser...it should download the .ILF file to a temporary file and start Omniscope, which opens the ILF
file and then the domain-locked IOK/IOM file directly from the server.

Example:

Here is a working example of domain-locking a file, testing the lock, than using an .ILF file link to provide access from HTML pages. 

Note: this demo visokio.com domain hasn't been password protected. Your domain generally will be password-protected.

 

 Bond Prices Demo file  [204]

This file is not domain-locked, therefore a locally-saved copy will open.
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 Bond Prices Demo file - domain-locked [205]

This file is domain-locked to the visokio.com domain. If a locally-saved copy is opened, user will see the error message above.

Testing the domain-locked locked-status:

To open a domain-locked file from a location other than the page it is locked to, start Omniscope and choose File > Open File > Open
from the web, then paste the full URL of the file:

http://www.visokio.com/files/Resources/OUGuide/453_FileSecurity/Bond_prices_domain_locked.iok [205]

 

Best practice is to link the user to the file via an .ILF file constructed as described above:

 

Click here [206] to download the .ILF file pointing to the domain-locked file.

 

 

Back to File Security [24]
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Views Reference

Views Reference
Making the most of all the views

 

Omniscope version 2.5 offers 16 different views. More views are always under development. You can preview/test experimental views at any
time by enabling experimental features on your installation. To enable experimental features:

Version 2.4: Tools > Advanced Tools > Application wide settings > Show experimental features

Version 2.5: Settings > Advanced > Show experimental features

 (then re-start your Omniscope).

 

  View Toolbar [207] - View Toolbar commands and options common to all views

[38]

[38]

 

 

Table View [38] - see all of your data in rows and columns, with aggregation options, grouping for sub-
totals, formulae and variables for modelling, and a wide range of powerful data editing tools. [208]

  
[39]

Chart View [39] - horizontal visualisations of data values in your columns, a powerful view for querying
ranges and spotting errors your data.

[40]

Pie View [40] - show splits/proportions of values in category, number and date fields, with paning for
multiple pies per view.

[41]

Bar View [41] - display relative levels in multiple category, numeric or data fields using horizontal, vertical,
stacked, cascaded and proportional bars.
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[42]

Graph View [42] - identify relationships between columns with scatter plots or t ime series [151], using
statistical analysis to identify trends, outliers and exceptions.

[43]

Tile View [43] - Show each record as a re-sizable tile or image,useful for 'heat maps', image catalogues and
much more.

[44]

Pivot View [44] - displays summary values (sums, means, counts, etc.) at intersections of selected category
columns.

[45]

Tree View [45] - show pure (one record per node) and comparative hierarchies as dynamic, filterable, multi-
level 'trees' (replaced by Network View in 2.5+)

[46]

Network View [46] - depict both grouped hierarchies and relational networks either dual field or specified
multi-field relatonships. Grouped networks can be used to visualise almost any type of data set, while a
relational network can be used whenever there is a common relationship between the rows. (new in 2.5)

[47]

Portal View [47] - text search plus dynamic filtering of categories, numbers and dates and statistical
summaries of the target universe.

[48]

Map View [48] - geo-spatial positioning of records, with embedded or web-based maps enabling selection,
filtering, and connected markers. [209]

[49]

Venn View [49] - See the overlaps between up to 5 pre-defined subsets of the data ('named queries')
corresponding to the filter settings or selections in place at the time you save or add to the named query.

[50]

Web View [50] - use multiple web views to display multiple web pages, and exchange data with remote
web services. [176]

Content View [51] - place formatted text annotations with embedded images and formulas in this view
window located anywhere on the page. (new in 2.5)

Dial View [52] - adds dial and meter type visualisations with defined alerts and zones for high-impact
dashboards. (new in 2.5)

[53]

Details View [53] - see some or all the displayed attributes of each record, with associated image(s) and
links.

[54]

DataPlayer View [54] - provides the tools required to format some or all of the data for export as
interactive Flash DataPlayers [193].
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Back to Using Views [8]
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View Toolbars

View Toolbar Commands
This section covers the View Toolbar commands which are common to all views. Documentation for view-specific commands on the View
Toolbar > View Tools menus of each view are discussed view-by-view in the Views Reference [25] section.

View Toolbars common features/options

 

Every View has a View Toolbar at the top. The View chooser, Data Subset query selector, Aggregation options, View Tools, Fields
chooser, show Details and [X] Close View button at the far right end are present on most View Toolbars. Exceptions: Details View only
shows the details for a single record, the Web and Content Views.

 

View Chooser - the selected view name and icon always appear at the far left of the View Toolbar. Click on the drop-down
View Chooser to change the view displayed in the window.

 

Data Subset - the data set or filtered/defined subset to be displayed is selected here. By default, the Filtered data (IN)
subset is selected. If no filters are set, this will be the same as All Data. If you have defined Named Queries [10], they will be

added to the bottom of this menu in each view.

 

Aggregation - most views enable you to select various options for defining and visualising aggregated data sets, and
specifying the functions to be applied to each field (column) in the aggregated displays. For more detail, see the section on

Aggregation & Grouping.

 

View Tools - drop-down menu present on all View Toolbars, but most of the commands on this menu differ by view. The
commands which are common to almost all views are discussed below. View-specific commands are discussed in the section on

using each view.

 

Fields - you can choose the fields (columns) displayed or hidden, and the order in which the columns are displayed on a view
window-basis. Use the 'All' or 'None' buttons to show or hide all columns, and change the order by dragging the 'hands' up or

down to order the columns.

 

Details - This button, next to right-most in all View Toolbars, displays a pop-up table (with the same settings as the Table
View) showing all records currently visible in the view. If you have made an active selection before clicking on Details, you will be

asked if you want to display only the selected records. The first column in the pop-up table will have underlined values, which are links to the
individual records. Click on the underlined record to display that single record in a Details window. Alternatively, double-click the row number
("row header") to see the details for a record. For more detail, see Viewing Details. [9]

 

Close View - clicking on this icon will close each individual  view. You can re-open/return to a given view at any time using the Add View
chooser drop-down from the Main Toolbar:

View Toolbar > View Tools - commands common to all views

This discussion of the View Toolbar > View tools drop-down menu covers only those commands common to all or most views.  Most of
the commands under View Tools are specific to each view.  These commands are discussed in the sections on each view, accessible for the links
on the Views Reference [25] page.
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The bottom-most section of commands in the View Tools drop-down menu is the same for all views:

 

 

Background image - see discussion below

Export view data - takes you to the Export Data wizard (also accessible from the Main Toolbar File > Export > Export files   menu).
Opening the Export Data wizard using the View Toolbar > View Tools > Export view data command pre-selects the data set of the
current view as the set/subset of data to be exported. The Export Data wizard allows you to add or remove fields from the file to be
exported, set the column order to match the view and to decide which export file format to use, either .IOK or .CSV or Excel .XLS for
spreadsheets, or .XML for other applications). For more information, see the Export Files dialog. [125]

Capture view - provides 4 options for capturing the visible aspects of each individual view:

As new tab - this option creates a new report tab in the Omniscope file containing the view as it currently appears
Save as image - places all visible aspects of the view into a .JPG image file you can save, (or save to your clipboard) ready for pasting
into any image-capable application such as PowerPoint, Excel, Word, Photoshop, etc. To paste into PowerPoint, for example, click Save
as image then switch to PowerPoint and right-click in the location you want to put the snapshot image. Select Paste from the
PowerPoint context menu and an image of the Omniscope view will appear on top of the PowerPoint slide.
Copy image to clipboard - places all visible aspects of the view in a .JPG image in your clipboard, ready for pasting into any image-
capable application.
Print - launches the Print Options menu for managing printing the visible aspects of the view. For more information see Print Options
[210].

Show view toolbar - this option determines whether the View Toolbar is revealed or hidden. When creating report tabs, for example, it is
often desirable to hide the View Toolbar if users do not need to alter the view settings. If you have saved the tab in default format the View
Toolbar will be hidden...to reveal it for just one one view, say a Web View, tick this option.

Show view header - this option reveals an editable text title space above the View Toolbar each view

Reset view settings - allows you to reinstate the default settings for the view if you have changed the row heights, field order, etc.

Apply these settings to all {view name} views- extends the settings you have configured for the view to all other views of the same
kind. For example, if you have set a particular column order for a Table View, this command copies the settings to all other Table Views you
have configured thus far. If you have configured Table Views in saved report tabs, you will be asked if you want to change those settings as
well.

Add Background Image

The Pie, Bar, Graph, Portal and Details View Toolbar menus also contain the option to specify an image to be shown as a background to the
view.

 

 

Image files such as logos, etc. of any size in .JPG or GIF format can be added as background, sized to fit using the Crop, Letterbox or Stretch
options, then faded to create an unobtrusive backdrop for selected views. For more on working with background images, see the section on
the Layout Menu [58].

 

Next section: Table View [38] or back to Views Reference [25]

User Guide Top [68]
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Table View

Using the Table View
The Table View displays your tabular data as it was imported into Omniscope from a spreadsheet tab or a database view/table. The Table View
shows the underlying data values by row and column cells for selection, sorting and editing. Double or right-clicking on a cell allows you to edit
the contents, and you can import large tables of data from other sources by cutting and pasting the data into the Table View. The Table View
displays colour-coded values with instant aggregation and sorting, plus displays of zooming views of images associated with the data set.

Like spreadsheets, you can specify formula fields (columns) calculated according to formulae you specify using values in other fields (columns).
Each record (row) also has a links menu on the row footer (far right end of the row) enabling you to insert dynamically-generated local and
web links, or select from a menu of pre-configured links to free web services. Use the View Tools menu commands to check for duplicates,
expand and collapse text values into more or fewer columns, and many other data management and correction tasks.

 

 

The Table View is highly-configurable, enabling you to drag columns to re-order. To hide (not delete) a field (column), right-click on the column
header, select the Tools sub-menu, and select Hide from this view. The Reset all settings for this Table View command at the bottom
of the View Tools menu restores all columns to the view, resets the column order to the original import order, and clears all record sorts,
aggregations and colouring options. It does not affect Formula field or variable declarations.

View Controls- Column, Row Header and Cell menus

The Table View control menus are available via left and right-clicks on the column and row headers, and right clicking on individual cells. These
menus are discussed below.

Column Header left-click

Left clicking on column headers places a primary sort on the data set using the values in that column, and clicking again reverses the sort
direction. Small orange triangles pointing up or down indicate that an ascending or descending sort has been set using the values in a column.
The primary sort column triangle is solid orange, the other secondary sorts are unfilled. To see or clear sorts that have been set, use the
Sorted Fields by Priority drop-down on the View Toolbar (see below).

Column Header right-click: Sorting sub-menu

Sorting-sets the primary sort for the display ascending/descending on values in the field (column). You can remove a sort on this menu, or
change the order or direction of sorts. To see and manage all sorts, use the Sorted Fields by Priority drop-down on the View Toolbar
(see below).

 

 

Column Header right-click: Aggregation function sub-menu

Aggregation function- When you have Aggregation set, the function to be applied to the record (row) values taken collectively  for each
filed (column) can be different field by field. The aggregation functions available on each column header sub-menu will depend on the data type
of the field (column). For example, text columns minimum and maximum values are based on character counts. Note: Range gives the
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difference between the minimum and maximum values in the field. (See Table View > View Toolbar > Aggregation below for more on
configuring aggregation.)

 

 

Column Header right-click: Options sub-menu

Options- You can choose to display related image sets in any column, or to display configured links, either to the details display of the record,
or another link you have configured using the Settings > Links wizard on the Main Toolbar.

 

 

Show image in cell- allows you to insert an image into each cell of a column, regardless of the value in that cell. Choose from the list of image
sets which you have previously configured using Settings > Images wizard on the Main Toolbar. Multiple image sets can be displayed this
way since several columns can show different or the same images.

Show link in cell- this option will display a sub-menu of links to display when the value in the column cell is clicked. You can link the values in
any column to either the Details display, or other links which have been configured for the file using Settings > Links wizard on the Main
Toolbar. You can link the values in more than one cell to the same link, or the Details display.

Column Header right-click: Tools sub-menu

Tools- these column header sub-menu options mirror those available in the bottom section of the View Tools drop-down menu
(documented in the View Tools section below). Some of these options (Hide, Rename, Convert field data type, Field options, etc.)
mirror those available in Data > Manage Fields on the Main Toolbar documented here [101].

 

 

Warning: When using the Expand values commands, you need to create new, blank columns adjacent to the column being expanded to
receive the separated values. If you do not, you will be warned about values in the adjacent columns being overwritten. Create new blank
target columns and drag them into position to the right of the column to be expanded using Data > Manage Fields > Add new field (at
the bottom). See more discussion of using the expand and collapse commands under View Tools commands below.

Warning: Be careful when converting the field data type, as this will delete all non-compatible cell values in the field (e.g. text values will be
deleted from a field converted to number field). see more discussion of changing field data types in Data > Manage Fields [101] menu section.90/305



deleted from a field converted to number field). see more discussion of changing field data types in Data > Manage Fields [101] menu section.

Change to formula field- changes a non-formula field to a formula field. Any values in the column will be replaced by calculated results.

Convert to static values- changes a formula field with calculated values to an input colmun with static values, which you can overwrite. All
formula logic will be lost.

Row Header right-click

The rectangular space at the far left of each row is called the row header. Left clicking on the row header selects the row, such that you can
apply power query filtering operations like Move or Keep to exclude or focus on that record (row). Double-clicking on the row header brings up
the Details display. Right-clicking on the row header displays a menu of options for managing the rows in the data set:

 

 

Note: If you have sorting or aggregations set, you may not see new blank rows where you expect them. Often it is best to clear all sorts and
aggregations when adding or deleting rows.

Row Footer left/right click

The rectangular space at the far right of each row is called the row footer. Left or right-clicking on the row footer displays a Links menu which
allows you to follow or define additional links using the Add web or local links wizards also accessible from Settings > Links on the Main
Toolbar.

 

 

Cell Right-click

Right-clicking on an individual cell displays a selection and viewing options sub-menu:

 

 

Edit this cell- is the same as double clicking on the cell to place the cursor inside the cell.

Deselect- removes this record from the selection set. This is not the same as the global Deselect on the the Main Toolbar which removes all
records from the selection set.

View details for this record- displays the individual record Details for the selected record.
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View details for records with this value- launches the pop-up table view containing all records which share the same value in the cell. The
pop-up table view will be configured the same as the Table View you clicked on in terms of column order, columns displayed etc.

Select specific record- Use carefully!...when ticked, this changes the selection behaviour to select records one at a time, rather than based
on common values. If this option is ticked IT APPLIES TO ALL fields (columns). When ticked, the Main Toolbar barometer will only show 1
record selected at a time, unless you drag the mouse to select contiguous records. Resetting the the Table View returns this setting to the
default Select by value.

Select by value- the default behavior...if you select a cell, all records that share the same value in that cell are selected, as shown in the Main
Toolbar barometer in blue. You can then execute power queries such as Moves and Keeps on the selected records.

View Toolbar Menu

The Table View Toolbar contains 5 view specific drop down menus; View Tools, Aggregation, Sort, Formulas, Colour-by: and Colour
Options in addition to the View Chooser and the Show Details, Add to Basket and [X] Close window icons common to all views:

 

 

Each of these sections is documented below:

View Tools Menu

The Table View tools menu has six sub-menus; Links, Column Option, Row Options, General Options, Aggregation and Tools. The sections
below document the commands and options available under each of these sub-menus.

Links sub-menu

The Links sub-menu enables you to select which, if any, links will be associated with clicking on the values in the cells of each field (column) in
the Table View.

 

 

Fields already associated with links will show on the drop down list in bold, and their values underlined in the cells of the Table View to indicate a
live link.
No links (None) is the default for all fields except the first column on first opening, which is set to Details (which you can change). Any number
of different fields can be linked to the Details display. All other links which you have configured for the file (using the Settings > Links menu on
the Main Toolbar) will show on the pick list, available for association with any of the fields in the data set.

Column options sub-menu

The Column options sub-menu enables you to choose which fields (columns) will be shown or hidden (not deleted), and the order in which
they will be displayed for that particular Table View (global column order for the file is set at import, but can be changed using Data > Manage
fields on the Main Toolbar).
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Columns to show- reveals a list of all fields which are ticked (showing) or unticked (hidden) in this Table View. Tick or untick the check boxes
to show or hide columns and/or drag the hands up or down to change the order of columns. You can also click and drag the column headers
sideways to reorder the columns, and you can hide columns by right-clicking the column header, then selecting Tools > Hide from this
view. Suggestion: use the ALL or NONE buttons at the top right of the Columns pick list to reset the columns displayed quickly.

Column header height- allows you to add more lines to column headers to accommodate longer names on narrower columns.

Squeeze columns (prevent scrolling)- turns the column header text vertical (if necessary) and narrows all the columns/cells to display in
the window available with a minimum of horizontal scrolling. Cell values are concatenated by default, but full cell contents will show as the
mouse hovers over the cell.

Reset column widths- (not shown when Squeeze columns is ticked)- resets the display of the columns on display based on the space
available and number of columns being displayed. Columns can be widened or narrowed by dragging the edges of the column headers. This
command provides a reset to defaults.

Note: The settings that you make for a given Table View will not be applied to the Show details pop-up table unless you also choose Apply
these settings to all Table Views.

Row options sub-menu

The Row options sub-menu is used to manage the display of records (rows)

 

 

Row title- can be used to select a value to display in the row header. The default is the record number assigned by Omniscope, but if there is
a more meaningful identifier in the data set, you can choose to display it instead. Alternatively, you can choose (None) and the row header will
be narrow and blank.

Row height- used to increase the number of lines in a row. The default is one, but if you wish to display images in cells, you may want to
increase the number of lines using the slider. Display an image in one column, then increase the row height and width of the column. The
images will expand to fill the space and the text will wrap.

Show link shortcuts- by default, shortcuts to the various configured links are accessible from an icon on the row footer at the far right of
each row. Unticking this option hides the row footer, which may not be needed by file users and frees up a small amount of horizontal space.

General options sub-menu

The General options sub-menu contains options related to cell display.

 

 

Horizontal/Vertical gridline strength- removes or emboldens the lines defining the rows, columns and cells.

Cell margin- increases the white space around the edges of the cells from the default of none, to as much as 10 pixels. Can improve legibility,
especially if used in conjunction with increased text size (see below)
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Text Size- increases the size of the font used in the headers and cells of this Table View.

Abbreviate text- allows you to turn on and off cell text abbreviation. Abbreviation is useful when cells contain long text.. making columns too
wide. With abbreviation turned on, you will still see what the cell contains in a much smaller space. Abbreviation is turned on by default.

Show images inside cells- allows you to chose an associated image set to display as a zooming image in a particular field (column). Note: the
images will obscure the underlying values, so it is best to use a column containing the image references, which are often cryptic image file
names, or else a blank column added specifically for the purpose of displaying the images.

Tools sub-menu

The Tools sub-menu provides some powerful functions to manage the format and layout and otherwise improve the quality of your data
sets.

 

Select specific record- turns off the default common value-based selection i.e. clicking on any cell selects only the record that contains that
cell rather than all the records sharing that value in the field (column). This makes the table behave a bit more like a spreadsheet and enables
you to select rows to Move, Keep or Add to the Basket individually.

Select duplicate records- displays the Select Duplicate Values wizard that for selected fields, isolates all records that have more than one
identical value elsewhere in that field (also works for multiple fields). This is useful for eliminating duplicate records in large datasets. The Select
Duplicate Values wizard allows you to select which fields to check for duplicates, or triplicates etc. If you select more than one field (column)
then records duplicated in either column (but necessarily both) will be selected.

Minimum group size: use the value of 2 to detect duplicates (or triplicates); use the value 3 to detect triplicates but not duplicates

Only select redundant records- once processing is completed, the default is to leave all rows containing duplicates (or higher)
selected. If you tick this option, the first duplicated record will not be selected, so that you can you can perform Moves to
eliminate only the redundant records, and Add to Baskets to create correction files.

Case sensitive- requires duplicated values to match case in order to be considered duplicates.

Invert selection- If you have selected a complex pattern of records, and wish to quickly select all other records not currently selected, use
this command.

Collapse values- used to combine some of all of the values currently in more than one column into a single column, with a space or some
other separator you specify in between the values. You must have selected a range of columns and rows to collapse before clicking on this
command. Used to reduce column count and to create tokenized fields, which contain more than one value per cell and are used to to
capture many-to-one relationships in tabular data. For more information, see Tokenized Data [123].

Note: You cannot select a group of columns using the column headers. To select all or part of a range of columns, select the first cell in the first
column, then drag the mouse across to the right to select more columns and downward to select more rows. If you need to select many
more rows than are visible, hold the Shift key and use the vertical scroll bar to bring the bottom right hand cell of your range into view. Click
on that cell with the Shift key still depressed and the entire rectangle of columns and rows will be selected.

Expand values (by separator text)- used to replace a single column of data containing compound elements (e.g. First and Last Name with
a space between) with multiple columns each containing a single element, such as First Name Column and Last Name Column. Before using this
command, you must select the compound (separated value) column you wish to expand and create new blank column(s) adjacent to the
right of that column. Be sure to select the entire column to be expanded using the Shift + scroll down method to ensure you have selected all
the way to the bottom of the column- assuming the expansion should include all the cells in the column. Click on the command and you will be
asked to specify the text separator defining the elements to be expanded, such as a blank space, which must be entered.

Note: create the new, blank columns using the Data > Manage Fields > Add new field button (at the bottom) then drag the new column
into place below (right of) the column to be expanded, making sure to tick the new column in the Columns to show list of you are in
Reports Mode. The existing column will be used for the first element, so to split two elements you need only add one new column.

Expand values (by fixed width)- used to break a single column of data into more than one column based on defined break points you set
using the Expand Values wizard:
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Before using this command, you must select the column of values you wish to expand and create sufficient new blank column(s) adjacent to
the right of that column. Be sure to select the entire column to be expanded using the Shift + scroll down method to ensure you have
selected the column all the way to the bottom - assuming the expansion should include all the cells in the column.

Append/prepend to cells- used to add specified characters before or after the existing values in the cells.

Note: sometimes when exporting numeric identifiers with leading zeros to Excel, such as Bloomberg Excel spreadsheets using SEDOLs, Excel
does not recognise the incoming values as text and drops the leading zero, rendering the identifier incomplete. To stop this, use the Prepend
function to add a text character such as an apostrophe ' in front of the numeric identifiers to force Excel to treat the values as text.

View Tools: Aggregation settings

The Aggregation sub-menu controls the display when aggregation is set for a given Table View. Aggregation groups rows together based on
common values. You specify the fields (columns) on which aggregation is based in sequence. For example, if you have a data set in which each
record (row) is a person, you might choose a Table View display which aggregates the rows first by Location, and then by the values in other
fields, like Race or Sex (grouping the males and females in each location). You set the aggregation sequence using the Aggregation pick list
on the View Toolbar.  If you have more than one aggregation set, use the hands to drag aggregated fields into the order in which you want
the aggregations presented top to bottom = from left to right.

Note: Many different aggregation functions are availabe, and they can be different for each column. Right-click on the column header to see
which aggregation function is specified for each column in the Table View.

 

 

Expandable tree- when ticked, displays a navigational 'tree' in the far left row header. Clicking on the black triangular arrows either expands
or collapses the view of the rows at a particular level of aggregation.

Show summary rows for each level- when ticked, displays a summary row for each aggregated set of rows. The summary row calculates a
value based on the function you select in each column by right-clicking on the column header and selecting the aggregation function to be
used for that column.

...at the top- when ticked, displays the summary row for each set of aggregated rows at the top of the grouping rather than at the bottom

Show overall summary row- when ticked, shows a summary row for all rows, using the function specified for each column by right-clicking
on the column header and selecting the aggregation function to be used for that column.

...as frozen summary row- when ticked, keeps the overall summary row visible at the bottom of the Table View window.

Export aggregated data... creates a new .IOK file where the rows reflect the values selected for aggregated rows in the source file.

View Tools: Sort Selection

Sorting for each Table View is set using the Sort drop-down menu. Tick the check box of any field to sort the table by this field. Click the
orange arrow next to each field name to reverse the direction of the sort. Drag the hands next to each field to change the order of primary,
secondary and subsequent sorts.
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Use the Clear all sorts button to remove all sorts from this Table View. Note: It is common to set sorts accidently by clicking on column
headers. Always keep an eye on the Sort: field to ensure you have not inadvertently added a primary sort at the top of the list. If you have,
simply untick the unwanted sort on this list and it will be removed...no need to use Clear all sorts.

View Tools: Add Formulae/Variables

Omniscope can calculate values based on values in other columns, using a standard menu of functions (plus some additional Visokio DATASET
functions) and the same syntax as Excel.

 

 

Add formula field- creates a new field (column) of values calculated as a function of the values found in other columns, together with any
variables whose ranges have been defined (see discussion of variables below). Use the Add formula field wizard to define the calculation you
want Omniscope to perform when populating the new column. For more detail on using the Add formula wizard, see the section on
Formulas and Variables [93].

 

 

Convert existing field to use formula- use this command to substitute any values that may be in an existing column with calculated values
based on a formula you specify using the Add formula field wizard.

Edit formula- allows you to select the already-defined formula you want to edit, and displays the current formula definition in the Add/Edit
formula field wizard for editing. Formulae are specified by selecting columns and typing in arithmetic operators and selecting functions from
the the functions library. The functions library contains all the standard spreadsheet functions, plus special Visokio DATASET functions
documented in the Functions Guide [211]. For more detail on using the Edit formula wizard, see the section on Formulas and Variables [93].

Formula calculations and aggregation options (see below) can interact. The precedence settings determine (for each Table View) whether the
fields with formulae defined are calculated at individual record level, then aggregated, or aggregated first:

Calculate aggregated values over formula field results- the default behaviour (aggregation of row values happens after formulae are
calculated)
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calculated)

Calculate formula field results for aggregated values- this option changes the precedence of the calculations, such that a formula such
as =[USD Volume] / [Deal Count] in an aggregated table using aggregation function Sum, is evaluated as Sum (USD Volume) / Sum (Deal
Count) for the aggregate rows. Notice that with this option set, two "sum" concepts at play: inside a formula, SUM(Column A, Column B,
Column C...) calculates the SUM of multiple fields within the same row. In the aggregated table, the aggregation function Sum calculates the
vertical sum of all record values within the same field (column) in the aggregated row.

Add/Edit variables: Variables are input assumptions (not fields in the data set) you define by setting a default value and specified upper and
lower ranges. Variables are used as flexible input assumption values so that dynamic sensitivity analyses and real-time modelling options will be
available to users of the file. If you define Variables, the input values can be set by devices which appear on the Side Bar. These sliders must be
visible (ticked in the Devices drop-down menu on the Side Bar) in order for you and your users to 'flex' the assumptions by adjusting the
current value of the Variable(s). Any Variable(s) whose current value is different from the default will show an orange device panel, the same as
for set filter device panels. For more detail on defining and using variables, see the section on Formulas & Variables [93].

 

 

View Tools: Colour-by selection

Colour-by: {Field Name} or (None): This drop down menu allows you to select the field (column) by which to colour the rows in the Table
View. If you select a field, it overrides the default colouring based on field data type (white for text fields, ranges from red (low) to green (high)
for numeric fields, etc.) to colouring that defines records by the value and assigned colours of any any field (column) you select. You can set
the colour associated with each category in the field (column) using Data > Manage Fields > Configure > Field Options > Change value
order, colours and shapes. You can also access the Field Options command from the Column Header right-click Tools sub-menu shown
above.

View Tools: Colour Options menu

The Colour Options sub-menu is used to change the colouring behaviour of each Table View.

Aggregation group cells- colours the aggregation
headers at the left of tables with aggregations set based
on the colours assigned to the categories being
aggregated.
Aggregated value cells- colours the calculated rows
containing aggregate values based on the specified
functions by column differently from the colouring of
the underlying unaggregated records, the values of
which are displayed whenever the expandable tree
arrows at left are used to expand an aggregated row.

Granular record cells - if you find even the unaggregated cell colouring distracting, and want to return to black and white, untick this option
to turn colouring off altogether.

Alternate row colour variation- to increase legibility, Omniscope alternates the intensity of colouring in alternating rows. You can strengthen
or weaken this effect using the slider displayed by this command.

Text contrast- you can modify the intensity of the text display to suit your display and lighting/presentation conditions

 

Back to Using Views [212] or Views Reference [109]

 

User Guide Top [108]
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Formulas & Variables

Table View: Defining Formulae and Variables
Omniscope enables you to specify Formula fields (columns) with calculated values derived from the values found in other columns. Using the
Add/Edit Formula wizard, you specify the formula used to calculate the values in Formula fields. Omniscope does not currently allow you to
specify individual cell formulae, or use formulae that reference individual cells in a data set. Omniscope uses Variables for input assumptions
(rather than values contained in individual cells in the data set) with specified default values and upper and lower ranges. Variables are used for
making dynamic sensitivity analyses and real-time modelling options available to any user of the file (see below).

Note: Formula fields (columns) can be defined from the Formulas menu on the Table View Toolbar:

 

 

(You can also use Data > Manage Fields to add a new field, name it, set the data type etc., then click Configure > Change to formula
field to launch the Add/Edit Formula wizard and specify the formula you want applied to define the values).

Add formula field- creates a new field (column) of values calculated as a function of the values found in other columns, together with any
Variables whose ranges have been defined. Use the Add formula field wizard to define the logical tests and calculations you want Omniscope
to perform when populating the new column (see Defining Formulae and Variables below)

Convert existing field to use formula- use this command to substitute any values that may be in an existing column with calculated values
based on a formula you specify using the Add formula field wizard. Note you will be warned about losing any values in the column when
they are substituted with calculated values.

Edit formula- allows you to select the already-defined formula you want to edit, and displays the current formula definition in the Edit
formula field wizard for editing.

 

 

Add/Edit Formula wizard- (see section below) allows you to specify and edit formulae by selecting existing columns and defined variables,
then typing in arithmetic operators and/or selecting standard functions from a library. The functions library contains all the standard
spreadsheet functions, plus special Visokio DATASET functions documented in the Functions Guide [211].

Precedence Settings- Formula calculations and aggregation options (see below) can interact. The precedence settings below determine (for
each Table View) whether fields with formulae defined are calculated at individual record level, or at an aggregated record level:

Calculate aggregated values over formula field results- the default behaviour (aggregation of row values happens after formulae are
calculated)

Calculate formula field results for aggregated values- this option changes the precedence of the calculations, such that a formula such
as =[USD Volume] / [Deal Count] in an aggregated table using aggregation function Sum, is evaluated as Sum(USD Volume) / Sum(Deal
Count) for the aggregate rows. Notice that with this option set, there are two "sum" concepts at play: inside a formula, SUM (Column A,
Column B, Column C...) calculates the SUM of multiple fields within the same row. In the aggregated table, the aggregation function Sum
calculates the vertical sum of all record values within the same field (column) in the aggregated row. Note: some of the Visokio DATASET
functions will not work with aggregated table rows in this mode. If you use this option, and you have aggregated table rows and are using
certain DATASET functions, you will see "error" in the aggregated cells of any formulae using the unsupported functions. For more information
on using the Visokio DATASET functions, see the Functions Guide [211]in our Knowledge Base.
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Add/Edit variables: Variables are input assumptions (not fields in the data set) you define by setting a default value and specified upper and
lower ranges. Variables are used as flexible assumption values (as opposed to factual/historic values in the data set) for making dynamic
sensitivity analyses and real-time modelling options available to users of the file. The current value used in formulae containing variables are
modified from the initial default using the Side Bar sliders corresponding to each variable. These sliders must be visible (ticked in the Devices
drop-down menu on the Side Bar) in order for you and your users to 'flex' the assumptions by adjusting the current value of the variable. Any
variable whose current value is different from the default will show an orange Side Bar slider device, the same as a set filter device..

Using Add/Edit Formulae

The Add/Edit Formula wizard provides a visual workspace for defining the values in Formula fields (columns). You define the formulae in
terms of the values in other fields, any Variables you have defined and extensive library of standard and specialised functions. The example
below shows a formula for calculating staff salary increases based on performance scores using a conditional IF statement to test a field text
value and apply the corresponding Variables:

 

 

The example above is taken from the embedded demo file Human Resources, Report Tab: Salary cost analysis. The data set includes a column
called 'Performance score' with 4 values; '"Acceptable", "Good", "Outstanding" and "Poor". The formula above uses nested IF functions (in
green) and compares the value in the field 'Performance score' (in blue), with typed in test values (enclosed in double quotes) reflecting the
names of the Variables already defined, such as "Good" (in red). If the values match, i.e. an employee's value in the 'Performance score'
column is "Good", then they will receive the pay rise defined by the Variable 'Good Pay rise' (since all the other IF comparisons will fail and
the other parts of the expression will be zero). The Variable 'Good pay rise' has a default value (10) and a range. Each Variable defined also
has an associated Side Bar device. If you reveal the Variables on the Side Bar, users of the file can perform real-time modelling and sensitivity
analysis just by changing the assumed values using the sliders (see above right).

Defining variables

Omniscope permits extremely powerful modelling with multiple sensitivity analyses in real-time. Let's look at another example of a formula that
uses a different type of Variable. In the example below (taken from the embedded demo presentation 'Cajun Sugar report', where each record
is a sugar refinery), the IF function is used to test the 'Energy source' column value. Only if the value equals "Fuel", is the assumption
Variable 'Oil Price' used to adjust the energy costs.

 

 

You must define Variables before they can be used in expressions defining the values in Formula fields. Click on Add/Edit variables and you
will be asked to specify one of 5 types of Variable, each of which has a Side Bar device and other rules associated with it:

Integer slider- used when the values must be whole numbers, for example, 'head count'
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Decimal slider- used when values can be any number, such as 'oil price'
Numeric choice- used when testing for a number, such as 'customer priority no' (1, 2 or 3)
Text choice- used to change values, like "High" "Medium" and "Low" especially for conditional testing: = IF(Variable= "High", then do
this...)
True/False choice- used to change assumptions from one scenario "True" to another "False"

 

 

Depending on the type of Variable you are specifying, you will be asked to define one or more allowable values, or a range of values with a
minimum, maximum and default. If you display the Side Bar devices associated with key input/assumption Variables, users can easily change
any or all assumptions and see the calculated quantities and graphic visualisations updated in real time.

 

 

To specify different values for Variables, you can use the sliders, or you can type one or more combinations of values directly into the Side Bar.
In the example above, notice that the 'Energy source' assumption for one refinery can be changed, and other cost assumptions changed
simultaneously. The lack of orange shading on the Side Bar device tells us that the 'Energy source' = "Fuel" assumption is the default.
However, the oil price assumption slider is not set to the default value and is therefore shaded orange. If you save this non-default scenario as a
Report Page, that Report Page will always open with this mix of default and non-default values- unless you untick the Variable states option
under This page will capture: in the Create Page dialog. If you do untick this option, the Report Page will always open with the default values
set for all Variables. The user can of course change them at any time.

Note: notice above that all the calculated Formula columns display blue headers in the Table View.

Functions List

Omniscope contains an extensive list of standard and specialised functions you can use to define Formula fields. In addition to the standard
functions (with the same syntax) found in spreadsheets like Excel, Omniscope also contains a library of powerful DATASET functions that
operate on one or more columns and can define the subset of data for which calculations should be be done based on values in other
columns.

 

Each function is documented briefly in the functions list. For more detailed documentation of the specialised Visokio DATASET functions, consult
our Functions Guide [211]. 100/305



our Functions Guide [211].

 

 

If you have questions about how to define formulae for specific tasks, consult the Knowledge Base Useful Formulae [213] section. If you would
like to propose additional functions you would find helpful, please post your ideas in the Forums [214] page.

 

Back to Using the Table View [110]

User Guide Top [108]

Chart View

Using the Chart View
The Chart View gives the most comprehensive overview of the contents and structure of your data sets. In one display, the entire
composition of the file is revealed, enabling you to see relative proportions, ranges, gaps in the data, etc.

The Chart View shows all the fields (columns) in the data set as horizontal visualisation bar devices, with continuous values like numbers and
dates/times plotted smallest to largest, and category values divided into different coloured segments. Text values are shown in devices
coloured in ‘alphabet soup’ where the vertical height indicates the number of characters in each text string. Null/blank values are shown as
grey segments. Remember that nulls/blanks are not the same as zero values. Zero values will display as a single coloured line at the bottom of
a numeric bar device with a white, rather than grey background. In the example below, the field Coupon is numeric and contains both null and
zero values. All of the zero values are selected and one is highlighted:

 

There are three types of Chart View field (column) visualisation bar devices, each shown in the example below:

Text devices for text entries with many different values, such as names, comments etc. the Text visualisation bar devices show a 'staircase'
curve based on the number of characters in each value in ascending order left to right. Selection inside Text devices is done in one of two
ways; either by text input (keywords- the default) or by clicking and dragging. Right-clicking inside a Text visualisation device will display a
menu with the option to set Selection to clicking and dragging. Using this setting, you can select suspicious  text records based on blank
values, or character counts longer or shorter than you would expect for your identification codes, etc. In the example below, the field 'Name'
 below displays as a Text device. If we select based on keywords, we can enter 'John' at upper left. Notice at the far right of the device that we
found 3 'hits' on the name 'John' when entered in the search/filter box at left. Alternatively, if we set selection to clicking and dragging, we
could select all the names with less than, say 11 characters using the mouse.

Category devices fields with a limited number (by default, less than 100) of unique values contain text, but Omniscope will also type them as
Category fields. Category visualisation bar devices show the proportions of each category in the segmented (or banded) horizontal bar. Each
Category value is automatically assigned a different colour, which is the also default for other views. Selection inside Category devices is done
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Category value is automatically assigned a different colour, which is the also default for other views. Selection inside Category devices is done
by clicking on the bar segment(s) or on the segment labels as required. Clicking on a selection a second time de-selects that segment. The
Main Toolbar ‘Deselect’ button will clear all segments. The field (column) Location displays below as a Category device, with 'Hong Kong'
selected.

Number devices for numbers, currencies and dates. Numeric visualisation bar devices display the range of values as curves in ascending
order from left to right. Selection inside Number devices is done by clicking and dragging to the desired range of values. Multiple ranges can be
selected. Right-clicking in the device will display a menu with the command to ‘Enter Selection Range’ which will allow you to specify exactly the
range you wish to select. The field (column) Age displays as a Number device below, with the range of ages 25 to 45 selected.

Note: it is currently not possible to change the font used for labelling in the Chart View.

If you click on a collapsed Chart View field (column) device, such as the Sex field device above, it will expand to reveal labels for that field and
collapse any other open devices. The second and subsequent clicks within that visualisation device will select groups of records. Clicking on
another visualisation device will collapse the previous one, but any selection(s) made will remain and be visible in navy blue with moving dotted
lines. The barometer on the Main Toolbar will show how many records have been selected across any number of devices.

Right-click Device menu

If you right-click on a device, the device menu will appear, as shown below:

Field "current field"- 4 options for displaying the
field device:
Collapsed- device displays in collapsed state
Expanded- device displays in expanded state
Statistics- device displays in expanded
Statistics/Analysis mode
Histogram- device displays in expanded
Histogram/Bar Chart mode
Numeric Scaling- Linear / Log scale sets the
scaling of continuous plots of number/date fields. If
extreme values in the field 'flatten' the lower values in
the display, switch the scaling to Logarithmic to
minimise the effect of the extreme values.
Selection-right-clicking on a numeric field will reveal
three options:
Select by clicking and dragging- Switch to this
selection mode to select records in text fields
(columns) based on blanks or character counts
which are within a specific range. Very useful for
looking at suspiciously short or long text fields.
Select by searching for keywords- Searches for
matching text records like a search engine. Type the
characters sought into the box at the top of any
Text device. A preview barometer will appear in the
device showing the hit rate as each character is
entered. A misspelling will be instantly apparent as the
number of hits will drop to zero. 
Enter selection range- Selects numeric values
between a lower and upper limit you can enter
directly as numbers.

Note: The preview barometer count in the Text device may differ from the count in the Main Toolbar Barometer because the Text device102/305



Note: The preview barometer count in the Text device may differ from the count in the Main Toolbar Barometer because the Text device
barometer shows only the hits IN THAT FIELD, while the Main Toolbar Barometer shows the combined result of all selections across all devices.

Options, Display and Print- these commands are common to all views and documented in the sections on Data > Manage Fields [75] and
View Tools [121].

Chart View Toolbar Options

All charts- displays a list of all fields (columns) visible in the Chart View, with the same menu as the
device right-click menu (see above) 
Change bar width- controls the width of the bars shown in Histogram mode
Hierarchies- Use to create hierarchies by merging two or more devices into one; each field
appears only when a configurable number of categories are visible in the parent field (eg.
combining a Region and Country field so that only Regions are visible until you are down to two
regions, at which point the Countries show instead). See more on creating hierarchies below.
Show inline labels- turns on or off category labels in the collapsed devices. With this turned off,
labels will still appear when a device is clicked to open it.
Show numerics as categories- changes the way number fields look by replacing the curves
with category bands.

 

The rest of the commands shown above are common to all View Tools menus and are documented here [121]

Fields- used to choose which devices will be visible (ticked) or hidden (unticked). Also used to set the display order from top to bottom. Untick
any fields you want to hide (you can bring them back later). Using the hands at the right of the menu, drag the fields in the menu upwards
and downwards until you have them in the desired display order.

Collapse All- The Collapse All button on the Chart View Toolbar returns all expanded devices to their collapsed state. Clicking the small drop-
down arrow next to Collapse all accesses a menu from which you can choose Expand All, Bar Charts or Analysis display modes.

 

 

These menu items expand all the Chart View devices to one of their four possible display modes. For Number fields, Bar Chart mode creates a
histogram for numerical fields with bands of values displayed both horizontally and vertically. Analysis mode shows a larger version of the
plotted curve as well as key statistics on the numerical distribution. These statistics naturally update every time a query is executed. For
Category fields, Bar Chart mode shows just that, while Analysis mode shows all the Category fields as pie charts. Selections of records can be
made from all display modes directly with the mouse. Text fields do not display differently in Bar or Analysis display modes.

Creating Hierarchies

Categories which naturally 'nest' inside others, like Regions, Countries and Cities, can be combined in a hierarchy called, for example "Location".
If records from more than one Region are in the IN Universe, the Chart View will display the Regionals in a new device called Location. Once
only a single Region is selected, the Location Bar will 'drill down' and show the Countries in that region. If only one country is selected, Location
will show only the cities in that country.

Creating a new hierarchy is easy...just give it a name, "Site Map Hierarchy" in the example below...then drag the fields (columns) comprising
the hierarchy underneath in the order they belong.
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Back to Using Views [212] or Views Reference [109]

User Guide Top [108]

Pie View

Using the Pie View
The Pie View shows a proportional breakdown of your data, either categories, or numeric. The default on opening for the first time is to show
the breakdown by number of records. You can select the field to display and the field to use to split the pie into segments by using the view
controls. If your data set has both positive and negative values, you can specify which to plot. You cannot plot both positive and negative
values on the same pie, but you can use two Pie Views side-by-side for this purpose. If you must show both positive and negative values in
relation to each other, use the Bar View [113].

You can select subsets of the data set on the pies, then execute  Moves and  Keeps. You can also pane the Pie View vertically, horizontally,
or both to obtain multi-pie views, as shown at right in the example below.
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Pie View Controls

Field selector- shows all the fields whose values can be divided into segments. The default is to display the number of records divided by the
field chosen in the adjacent Split-by drop down. You can choose a text field (column) to display, but if you do, the breakdown will be by
number of characters in the text string values.

Split by- click on the ‘Split by’ drop down to choose a field to use to create segments within the pie(s).

Pane by- paning means displaying more than one pie chart within the display, horizontally, vertically, or both as shown in the example above
right. Pane by field (column) selectors in the upper left and lower right of the Pie View display enable you to select criteria for generating
multiple pies within the same Pie View. This is not the same as using two different Pie View windows.

When paning, you can use the 100% panes option in the View tools menu (see below) so that each of the multiple pies shows a
breakdown totalling 100%. Use paning sparingly...if there is not enough space around each pie, Omniscope will not be able to display the
labels, as shown in the example above.

Pie View Tools

The View tools drop-down menu offers a number of options

Show statistics- when ticked, displays a
translucent statistics panel, the content of which
can be configured using a side menu accessed
from the top of the panel. (see below) 
Overlay pane-by values- only shows when
paning is active. When ticked, displays a label on
top of each pie in the paning arrangement
Change number of bands- only shows when a
splitting by a continuous value. Slider increases
the number of intervals/segments in the pie.
Show percentages (as decimals)- when
ticked, replaces the values in the segments with
percentages of the total. In paning
arrangements, these percentages will not sum to
100% unless the 100% panes option is also
ticked (see below).
100% panes- only shows when paning is
active. When ticked, calculates percentages for
each individual pie to sum to 100%. Has no
effect if Show percentages (as decimals) is
not also ticked.

 

Add background image- provides the option to provide a faded image as a backdrop. See Page Menu [104] for details.

The rest of the commands on the View tools menu are common to all views and are documented in the section on View Tools [121]

Pie View statistics panel

The statistics panel display can be configured using the drop-down menu accessed from the upper right corner of the panel.
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If the field (column) displayed is numeric, there will be more types of statistics available. If the field is a category field, summations, means, etc.
will not be available.

Pie View right-click menu

Right-clicking anywhere on the Pie View window displays a menu of options to modify or export the display:

Selection options:
Clear selection- clears the current selection in
the Pie View

Ordering options:
By size (frequency)- when ticked, orders the
segments of each pie in descending order of
record count
By value- when ticked, orders the segments
of each pie in descending order of selected
value.

Display options:
Animate-starts the pie spinning slowly, such
that the labels display more legibly. In paning
arrangements, right click on each pane to start
spinning for each pie. 
Rotate- turns each pie up to 360 degrees to
re-orient it, usually to display labels or
important segments more legibly. Does not
spin the pie as does Animate

Copy and Print options:

Save as image or Copy image to clipboard- saves or pastes an image of the Pie View display (.JPG, .GIF, .PNG or .BMP depending on Java
version) into another document.

Print- launches the Print wizard common to all views and documented in View Tools [121]

 

Back to Using Views [212] or Views Reference [109]

User Guide Top [108]

Bar View

Using the Bar View
The Bar View is one of the most flexible views. It can be used to display either Category, Date and Time or Numeric data and calculated values
like sums and averages. Both positive and negative numeric data can be compared in the same view. Bars can be displayed vertically or
horizontally, and you can configure one or more splits (breakdowns) of selected values, with sub-breakdowns within the bars (stacked bars)
and paning to create multiple displays in a single window.
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All segments displayed in the Bar View are selectable, and can be used for power queries using the  Move and  Keep commands located
on the Main Tool Bar.

Bar View Toolbar

In addition to the View Chooser and the View Tools drop-down menu, the View Toolbar contains a series of options for modifying how
the bars display; Order bars, Flip, Cascade, 100% bars, Normalise panes, and Swap panes, plus the Show details, Slide show and
Add to Basket commands common to all views and documented under View Toolbar commands [121].

 

 

View Tools- in the Bar View, all the view-specific commands are located on an Options pull-out menu accessible from this menu, and also
accessible from the < arrow on the View Toolbar just left of the [X] close view command. All View Tools commands in the Bar View other
than the link to Options (see below) are common to all other views and documented here. [121]

Order bars- sorts the bars in order of the values displayed, clicking again reverses the sort order, and again removes the sort.

Flip- changes the layout between horizontal and vertical bars

Cascade- displays the bars on a rising, progressive 'stair-step' base, rather than a single level.

100% Bars- normalises the height of each bar so that proportional differences in the stacked sub-segments inside each bar can be compared
across the bars.

Normalise panes- normalises the height of the tallest bars in each pane, so that big differences in the absolute numbers do not minimise the
height of the bars in some panes.

Swap panes- changes between horizontal and vertical paning.

See the Options sections below for more detail on the configuration options available.

 

Bar View Controls

Controls within the Bar View are located around the edges of the view. The Value and Split by menus are at the top, with Stack by and
vertical Pane-by commands along the left side, and horizontal Pane-by menu at the bottom. Bar View configuration options are so numerous
they have been put on a series of 6 drop-down menus accessed from a pull-out Options tab that appears whenever you hover your mouse
along the right side of the display window.
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Value/+ Add field Selector- left-most above the display, this drop-down menu allows you to select the quantity to be represented in bars.
The default is the number of records, but you can change or add to the value field(s) being shown from this drop-down menu. You can toggle
the field pick list to show all fields, numeric fields only or date fields only. Clicking on the '+' after the selector allows you to add another field as a
quantity to display as an additional, separate bar next to the bar representing the first quantity. If you want to show the composition of each
bar using the Stack-by option menu at left, you may want to select the 100% option to normalise the height of all the bars such that the
stacked segments show comparable proportions. You can also specify the fields/values to represent on the Options > Measures menu (see
below), which also offers additional sub-menus to specify the function being applied (sum, mean, standard deviation, etc.).

Split by/+Field Selector- drop-down menu allows you to specify one or more category, numeric, date or text fields to define how to break
down the fields being plotted. You can also specify one or more fields to break down the values displayed using the Options > Breakdown
menu (see below). Note:Split by selections are applied before Pane by selections.

Stack by Field Selector- (left side)- specifies the field to be displayed inside of each bar to create a 'stacked' bar chart. You can also access
this command using the Options > Breakdown menu (see below).

Pane by/+ Add another Selectors- (left side & bottom)- paning creates separate sub-windows within a single display, which can be used to
further break down the bars being displayed. You can also access these commands from the Options > Paning menu (see below). Note:
Pane by selections are applied after Split by selections.

Options Tab Menu

The Options tab menu contains 6 sub-menus; Measures, Breakdown, Paning, Ordering & alignment, Layout and Style.

Options > Measures

The Measures sub-menu is used to specify the values to represent as bars. In the example below, the Age and Seniority of employees is being
plotted. Both of these are Numeric fields measured in the same units, years, so we use the Function sub-menu to specify that we want to plot
the Mean (average) of the Ages and the median (most common value) for Seniority.
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Value+ Add further fields- same as the field selector at the top left of the view, the Options dialog offers more options to specify functions,
etc.

Function- only visible if you select numeric value fields (other than the Record count default). In the example above, the functions sub-menu
is used to select average for the Ages (the sum would not be meaningful). The mean (average) age of the workers will not be weighted by the
values in another field, so the Weighted option is not ticked. For the Seniority field, the median value, rather than the mean, will be displayed.
There are no negative numbers in the Age or Seniority fields, so we will not need the Absolute value function either.

Measures on the same scale- since both values being plotted are in comparable units (years), we tick this option.

Options > Breakdown

The Breakdown sub-menu allows you to plot additional bars by splitting the display according to other fields (columns) in the data set. In the
example below, we split the display of average age and median seniority of employees by location.

 

Split by: same as the field selector at the top of the display, the Options dialog offers additional options to control how the increased number
of bars is displayed. If you choose a Split-by field with numerous values, you are also given a choice of displaying a bar for each value,
grouping the splits into ranges (histogram), or grouping the bars by sign (positive or negative).

+Add further splits... allows you to specify further fields to sub-divide the bars by

Fit to screen- tick this option if you want all bars to display in the view window, no matter how compressed the width of the bars.

Max values- use this slider to manage the number of bars displayed individually. If the total number of bars is more than the viewable
maximum, the remainder of the bars will be shown aggregated into an 'Others' grouping. The 'Others' grouping will be disaggregated only if
filtering reduces the number of bars to be displayed to less than the maximum.

Stacked by: same as the field selector on the left, you can select only one field to display inside the bars, and you cannot mix positive and
negative values.
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Max values- use this slider to manage the number of stacked segments displayed individually. If the total number of stacked segments is
more than the viewable maximum, the remainder of the segments will be shown aggregated into an 'Others' grouping. The 'Others' grouping
will be disaggregated only if filtering reduces the number of stacked segments to be displayed to less than the maximum.

Bar colours- use these options to control the colouring of the bars and bar segments.

Auto- uses the default colours assigned to each category, including for stacked sub-segments. Using this option, if you decide to
display a stacked chart using Stack by: 'Sex', the sub-segments of each bar labelled 'Male' and 'Female' would display as blue and pink,
(not the colour assigned to the field represented by the entire bar) and all bars would be displayed as a combination of blue and pink.
Fixed- assigns a uniform, fixed colour to all bars, which you can select using the colour chooser that appears when you select this
option.
By field- colours each bar (including the stacked sub-segments) a single colour corresponding the the field being plotted. Using this
option, if you decide to display a stacked chart using Stack by: 'Sex', the sub-segments labelled 'Male' and 'Female' would not be
coloured blue and pink as with Auto. Instead, each bar would be a different, but uniform colour corresponding to the field being
plotted.

Options > Paning

The Paning sub-menu is used to further sub-divide the display vertically, horizontally, or both. Paning sub-divisions are applied after Split-by
selections. In the example below, the view display has been paned vertically based on the values in the Union membership field (column), which
contains the values 'Yes' or 'No' for each employee. The resulting bar chart display indicates that Union members in this organisation are on
average younger and most commonly less senior than non-union members, in both locations, London and Madrid.

 

 

Vertical paning- same as the selector on left of display window, however the Options dialog offers more controls over how many panes to
display unaggregated y if the number of values to panes by is large relative to the space available. To see all panes unaggregated, tick Fit to
screen.

Horizontal paning- same as the selector on the bottom of display window, however the Options dialog offers more controls over how
many panes to display unaggregated. Notice in the example above that the Split-by: 'Location' choice has been replaced by a horizontal
Pane-by: 'Location' setting (faintly visible under the Options dialog panel at lower right). To see all panes unaggregated, tick Fit to screen.
Note: Pane-by selections are applied after Split-by selections.

Tiling- adds multiple plots within each pane, showing the values further sub-divided. In the example below, we have left the display paned
horizontally by 'Location' (values= Frankfurt, Madrid, etc.) and vertically by 'Union Membership' (values= 'Yes' and 'No'), and added Tiling by
Sex (values: 'Male' in light and dark blue and 'Female' in light and dark pink):
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Note: Split-by and Pane-by choices are applied before Tiling. To see the values represented by the bars in each sub-plot (cluster) within the
panes, hover on the bar with your mouse and the values are displayed in the Tooltip.

Pane background- use this command to set the background colour of the panes, which can be all the same or different.

None- sets the pane backgrounds to the default colour, usually white
Fixed- when ticked, displays a colour chooser allowing you to select a different background colour for the panes. In the example above,
the background colour has been set to grey.
By field- when ticked, allows you to pick the colours associated with the values in any field, including the Tile-by field, such that
different panes have different background colours.

Normalise panes- typically used in conjunction with stacking, sets the height of the (first) bars in all panes to be the same, regardless of their
relative magnitudes, so that the proportions of the sub-segments representing the Stack-by values will be comparable across panes.

Options > Ordering & Alignment

The Ordering & alignment sub-menu allows you to control the relative positioning of bars both within and across panes. The example below
has the same settings as the one above, except that Order bar and Order vertical panes options are ticked, and the ordering is now set to
'Ascending'. Notice that in example below, the bars representing median seniority and average age have now changed positions, and that the
Union='Yes' panes are now on top of the Union='No' panes:

 

 

Order bars- sorts the bars within panes/tiles in either Ascending or Descending order. In the example above, the bars are in comparable Years
units and the lower value, median Seniority, is displayed before the higher value, average Age. Changing the sort order to Descending will
reverse the order of the bars within the panes/tiles. Behaviour of this option can be influenced by the Alignment settings (see Alignment below).

Order stacks- whenever a Stack-by field is specified ('None' is specified in the example above), ticking this option will sort the sub-segments
within each bar in either ascending or descending order.
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within each bar in either ascending or descending order.

Order horizontal panes- when ticked, this option will order the panes horizontally, Ascending or Descending, based on the ranking of the
values. In the example above, this option is not ticked. Behaviour of this option can be influenced by the Alignment settings (see Alignment
below).

Order vertical panes- when ticked, this option will order the panes vertically, Ascending or Descending, based on the ranking of the values.
In the example above, this option is ticked, and the Union='Yes' vertical panes are displayed above the Union='No' vertical panes. Behaviour of
this option can be influenced by the Alignment settings (see Alignment below).

Alignment: comparison of bars across panes is facilitated by keeping the bars in a consistent order, especially looking vertically for a vertical
bar orientation and looking horizontally for a horizontal bar orientation (see Options > Layout > Bar orientation below).

None- when selected, the alignment setting does not have any influence and bar order within and across panes is determined strictly
by the data and the Order bars Ascending/Descending option (see above).
By visual Axis- when selected, bars are kept aligned in the same order as the bars above and below them
Always- when selected, bar order is also maintained across panes to the left and right

Options > Layout

The Layout sub-menu is used to manage the appearance of each Bar View display. Most of the visual aspects , such as orientation, width and
spacing of the bars, etc. can be managed from this dialog. In the example below, we have changed the bar orientation to horizontal, increased
the minimum bar width and reduced the bar spacing to slightly overlap the bars:

 

 

Bar orientation- changes the bars between vertical and horizontal directionality. Note that in vertical orientation, the Stack-by field selector
moves from the left side to the bottom of the display

Minimum bar width- changes the minimum width of each bar in order to display more or fewer bars

Minimum pane size- changes the minimum width/height of panes in order to display more or less panes

Pane spacing- changes pane margin/spacing allocating more or less space in the pane to the bars.

Cluster spacing- {being revised}

Bar spacing/overlap- changes the space between the bars, which can overlap (see above), touch or be spaced apart

Bar chart margin- changes the margin space around the outer edges of the display

Label size cap- sets the maximum length of the labels, which can cause them to wrap or display vertically to save space. Warning: Setting
Label size cap to 'None' (meaning no label) will suppress labels display completely. Start with the Label size cap set to 'Large' and
reduce...working in conjunction with Style/Font Size (see below).

Cascading bars (waterfall)- same as the option on the Toolbar, displays the bars on a rising, progressive 'stair-step' base, rather than a
single level.

100% Bars- same as the option on the Toolbar, normalises the height of each bar so that proportional differences in the stacked sub-
segments inside each bar are comparable across the bars.

Expand bars to fill space- sets the bar widths so as to use all available space after allowing for settings governing margins, spacings,
maximum bars and panes to show disaggregated, etc.
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Options > Style

The Style sub-menu allows you control the visual effects applied to the individual bars. In general, we suggest that you use the default effects
for best visualisation. Turning off the defaults will display the bars with no visual effects:

 

 

Shadows- adds a shadow effect to the side of each bar

Gradient fills- varies the colouring of each bar to give the impression of a more solid, reflective surface

Outlines- draws a solid border around each bar

Transparency effects- {being revised}

Gridlines- unticking this option will remove the border lines between panes

Font size- allows you to increase or decrease the label font size for best legibility

 

Back to Using Views [212] or Views Reference [109]
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Pivot View

Using the Pivot View
The Pivot View is used to display aggregated or summarised values at the intersections of fields (columns) in your datasets. Only Category
fields are available on the drop-down menus, so if you want to create a pivot on a Text field, you should first convert it to a Category field,
assuming there are not too many discrete values. See Data > Manage Fields [95]for more detail on changing data typing and limits on the
number of Category values. Note: Pivot Views using Dates and Times and Numeric columns may be supported in future. 

When you open a Pivot View and define two Category columns, Omniscope creates a pivot ( intersection grid of summary values) using the
Sum of the number of records in two Category fields by default. You can easily change the Category fields to be displayed on the horizontal
(X:) and vertical (Y:) axes using the View Toolbar options. At any time, you can exchange the( X:) and (Y:) axes by clicking on the curved
arrow at the corner to the left of the horizontal titles.  
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Value: The default value for the cells in the Pivot View is the sum of the records, so each cell will display the number of data points. You can
change the value displayed to another field using the Value: drop-down menu. Depending on the type of field you select, a Function: menu
will appear, allowing you to chose whether to display the sum, the mean, or some other transformation of the data points in each cell. Note:
the Range function displays the difference between the maximum and minimum values in the cell. The example above shows the average age
of military casualties by service branch and rank. If you choose a function such as mean, a Weight: menu will appear, allowing you to specify
another field to calculate weighted averages of the values in each cell.

You can select one or more cells to perform  Moves and  Keeps, but only on selections of all cells in one row or column at a time. You
can sort the rows and the columns simultaneously; click the row or column header once to sort descending and again to sort ascending. The
sorted column and/or row headers will turn orange to indicate sort(s) have been set. Clear your sorts using the [X] button that appears to the
left of the switch axes curved arrow when sorts are set.

View Toolbar Commands

The Pivot View tools drop-down menu provides some options to change the display.

 

 

Colour relative to- 

None- removes all coloring from cells
According to value field- applies the colouring range specified for the Value field (column) to display in the cells. The colouring range settings
(start, middle, end, etc). are those defined for the Value: field in Data > Manage Fields > Configure > Field Options > Change Value
colouring. This option will apply the absolute colors for the entire range of values, so applying it to calculated means and medians will not
result in enough colour dispersion across the cells.
Relative to all cells- this option applies the colour range specified for the Value: field relative to the range of values appearing in the cells. Use
this option to maximise dispersion of colours across reduced value ranges in all cells, typical of means and medians for example.
Relative to row- this option applies the Value: field colour range relative to the values in each row
Relative to column- this option applies the Value: field colour range relative to the values in each column

Colour totals separately- unticking this option changes the colouring scheme to include Overall totals columns values.

Value decimal places- use slider to set the number of decimal places to display fro absolute values
Percentage decimal places- use slider to set number of decimal places displayed for percentage values

Show difference columns- when ticked, displays the differences between adjacent columns in a separate column (see below)
Show difference rows- when ticked, displays the differences between adjacent rows in a separate row

 

 

 

Show difference as- ( Percentage; Value; or Both)- allows you to select how the values in difference columns and rows are displayed

Show totals row & column- the Overall or Total columns at the bottom and far right of the view can be hidden by unticking this option

Show tooltips- temporary displays of record counts and other underlying cell information on mouse hover can be hidden by unticking this
option. Note: Pivot Table tooltips are summaries of the values underlying each cell, not the record-level tooltips configured under Main
Toolbar > Settings > Tooltips.

Show hover plot- ( None;  Bar; or Pie)- a temporary graphical breakdown of the contents of a cell can be configured, either a Pie or a Bar
chart display.
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Hover plot of- (field list-Category & Numeric data types)- if a graphical cell hover display is selected, an additional option to specify the
value to be plotted appears. In the example below, a Bar chart plotting the field Country has been configured. Hovering on the intersection cell
Service:Army & Rank:Corporal, displays a Bar Chart of Countries losing one or more Army Corporals (average age: 24.13 years) plotted as
vertical bars in descending order:

 

 

Squeeze columns (prevent scrolling)- keeps the column widths set to a distance that permits all columns to be seen/selected without
horizontal scrolling of the view. Combined with row and column colouring options, this can convert the Pivot Table into a type of 'heat map'
encompassing a large number of cells at a glance.

Headers influence automatic column widths- when ticked, re-sizing one column header re-sizes all of the other column headers to match.

The remaining commands on the View tools drop-down are common to all views and are documented here [121].

 

Back to Using Views [212] or Views Reference [109]
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Graph View

Using the Graph View
The Graph View (or scatter plot) is ideal for finding and illustrating relationships in the data. In addition to plotting two selected fields (columns)
on the familiar orthogonal Cartesian axes, X (horizontal) and Y (vertical), you can colour, size and shape the markers to represent multiple
dimensions in the data set. Markers can be aggregated to group data points for large data sets, or displaced slightly to make coincident points
distinct and selectable. Powerful statistical analysis is available, and various selection and display modes can be chosen to suit any combination
of fields plotted.

Graph View Controls

Axis Selectors (X and Y)- use these pick list menus on the left side and bottom of the window to choose appropriate fields (columns) to plot
on the X and Y axes. Only numeric, date and category fields will be present in the pick list. Text fields cannot be plotted unless the values are
converted to categories and ideally given a meaningful sort order using Data > Manage Fields. Use the Sort option to sort the available
fields alphabetically and the Find/Clear tool to select from long field lists. Note: hiding fields (columns) from the axis selector lists is not
currently supported.

Switch Axes- the double arrow at the lower left of the plot exchanges the X and Y fields

Graph View Toolbar

The Graph View Toolbar features a View Tools drop-down menu, plus Trends, Mode, Zoom, Colour, Size and Shape options:
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Each of these Graph View Toolbar elements is discussed below

Graph View > View Tools

The Graph View > View Tools drop-down menu includes various options for changing the display:

Marker options- see discussion of sub-
menu below
Connect markers- see discussion of
sub-menu below
Show gridlines- turns grid lines in
background on or off
Show statistics- displays the statistics
relating to the X and Y axis fields, as
selected from the drop-down pick list.

Add background image-click to
browse to an image to set as a faded
background for the graph. Does not
obscure gridlines. Useful for putting
logos and branding into the display. The
same option is available in the Pie, Bar
and Details View and is fully documented
here. [104]

The other Graph View > View Tools commands are common to all views and fully documented here. [121]

Marker options sub-menu

Marker Options- click to launch the Marker options sub-menu, which has both Simple and Advanced display modes:

Marker Options: Heat Map; Aggregated or Displaced- tick one to select from 3 different ways of displaying plotted points in each Graph
View:

Heat Map- shows density plot of records on
the grid. Useful for plotting very large numbers
of records that overlap a great deal.
Aggregated- (default for data sets over 100
records) combines overlapping markers into
larger markers showing the number of records
aggregated. Useful when you have overlapping
records and need to see the density, similar to
the Heat Map. Note: Display on the markers of
sums and other functions calculated from fields
in the records aggregated is not currently
supported.
Displaced- used if you have many exactly
overlapping markers and want to convey a
visual representation of the density of
underlying records. When ticked, the markers
will be slightly offset to show a dense cloud,
rather than overlapping exactly despite
identical values.

Displacement- changes the amount of displacement vertically and horizontally to improve access to data points for selection and linking.

Size slider- changes the absolute scale for marker sizing to increase or decrease all marker sizes

Range slider- (greyed-out unless the Size option is set to a field) changes the magnitude of relative sizing (see Size below)

Shape by: selects the field (column) whose values will determine the shapes plotted (same as Shape: toolbar pick list below) with additional
options to specify the display of markers of records which are null (blank, not zero) in the selected Shape by field. In Simple mode, the Default
shape to use when no Shape-by field has been chosen can be set.

Default colour- selects the default colour of markers when no other colouring options are set.

Outline colour by: adds an outline of another colour, based on another filed. For example, if Sex is used, this command would put a blue
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outline on the dots representing males and a pink outline on the dots representing females- assuming that you have assigned the those
colours to the values 'Male' and Female'.

Hover plot- sets a pop-up display of either a pie or a bar chart whenever the user hovers on a marker, aggregated or not. When set, you
can select the field (column) to be charted using the pick list at right, which is otherwise greyed-out.

Marker link- selects a link to display when markers are clicked (one record only). Pick either (None), Details, or one of the links already
configured in the file using the Settings > Links wizard accessed from the Main Toolbar.

Connect markers sub-menu

Connect Markers (time series)- clicking this option expands the View Tools menu to display additional options used to configure
connected series, usually time series. In order to display one or more time series curves, the data set should contain at least one field (column)
for a date, and one or more columns for values that make up the time series. To display multiple curves in one graph, there should also be a
category field (with relatively few unique values) containing the names of each curve to be drawn.

Note: if your time series data is not in 'vertical' Omniscope layout (with the repeated observations vertical in a column) but instead in a pivoted
'horizontal' table (dates as columns and one row for each curve's values), you can use the Data > De-pivot the data option on the Main
Toolbar to change the layout. For more on how to lay out your data for display as time series, see Data Layout-Time Series [137].

Once your data layout is correct, to display the curves, switch the X axis to the date field, and the Y axis to the value you want to graph, then
select Connect markers (time series)'. Warning: to see multiple lines, you must use the Show line for each... option and select a
Category field that distinguishes the lines you want to separate. The additional time series sub-menu options allow you to show the markers
along the curves, change the curve thickness, display the curve names, smooth the curves, etc. For more detail, see Displaying Time Series
[215].

[121]

Trends

The Trends option menu enables you to access powerful statistical analysis of your data set, and to display the most significant relationships.

 

 

Clicking on this menu reveals two options:

Show line of best fit-plots a blue line of regression 'best fit' through the data points with the R-squared (measure of correlation) and gradient
values displayed in the top left corner.

Find trends-analyses and sorts all correlations and other advanced statistics across all columns in the data set. Click to calculate the first 100
best fits between all possible axes. These will show in a pop-up window with R-squared for each axis pairing. Clicking on a pairing in the window
will load the corresponding graph into the view. Too see all standard calculations for all potential X/Y axis pairs. tick the Show all columns
(advanced) option.

Mode

The Mode options menu enables you to choose how to navigate and select points and groups of points on the display. You can define one or
more selection areas/shapes in order to exclude or isolate records using Move and Keep power query commands on the Main Toolbar. You
can also use the mouse in navigational mode to define and explore specific zones in the display in maximum detail.
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Square select mode- the mouse defines one or more rectangular selection area(s)

Lasso select mode- the mouse defines one or more free-form shaped selection area(s)

Best fit select mode- the mouse defines selection areas along the line of best fit. Useful for selecting data points inside/outside of confidence
intervals in distributions.

Zoom mode- a navigational mode, the mouse defines a rectangular zone and the display zooms to show only that area. Holding the right
mouse button down in zoom mode and moving the mouse up and down will zoom in and out continuously

Pan mode- (only visible when zoomed in manually) a navigational mode, the mouse 'hand' cursor is used to 'grab' the screen and move it to
frame the desired area.

Zoom

The Zoom options menu provides fine-grained control over the magnification of the display, and they way the display adapts to power queries
and Side Bar filtering which change the distribution of the data points being displayed. Unless disabled (see below) when zooming, zoom bars
will appear along the vertical and horizontal axes, which can be moved or stretched to display desired area on-screen.

 

 

X zoom slider;Y zoom slider; Zoom out/in- used to expand the view along the right/left 'X' or up/down 'Y' axis, or to magnify (zoom in)
or de-magnify (zoom out) the display.

The zooming options below are used to define how the display updates, with no manual zooming active

Zoom to fit visible data- display sizes to show only the points still in the target universe

Zoom to fit original data- display sizes to show the range of all the data in the data set

Zoom to fixed region- allows you to define a region of interest with the mouse, to which the display will revert, regardless of the data points
in the target universe.

Note: the target universe for a given view is indicated by the colour of the view icon, green means IN universe, gold means BASKET, etc. For
more detail, see Data Universes [162].

Show zoom scrollbars- when ticked, zoom scrollbars are visible even if the display is not zoomed, When unticked, the zoom scrollbars only
show when zooming is active.
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WARNING: any manual navigation will take the display out of the default Zoom to fit visible data mode in favour of the Zoom to fixed
region. You must manually change the setting in the Zoom menu to restore a default view of all the data in the target universe.

Extend axes to show origin- when ticked, the display is altered to make the 0,0 point where the axes cross visible in the display, regardless
of the range of values in the fields (columns)

Enter axis ranges- used to define the range to be displayed numerically, based on the maxima and minima reported for the selected fields

 

 

Depending on the size settings for the markers, you may need to 'pad' these ranges up or down somewhat to accommodate the marker
sizing and achieve the optimal display.

Colour (& Key)

The Colour pick-list menu allows you to select the field to be used to colour the markers. If no colour is specified, a single uniform default
colour is used (which can be changed (see above). If you set a fill colour field, the Key display automatically appears showing the values and
associated colours for that field (column).

 

 

Note: At any time you can change the colours assigned to the values in a given field (column) using Data > Manage Fields > Configure >
Field Options > Change value order, colours and shapes.

Size

The Size options pick list menu allows you to select the field used to calculate relative sizing of the markers in the display, regardless of the
shape or the default size setting. The extent of the sizing effect is controlled by the Size and Range sliders available on the advanced Marker
Options sub-menu.

 

Shape (& Key)

The Shape options pick list allows you to specify which field (if any) you would like to use to determine the shape of the marker to use on the
plot. If you pick a field to shape by, the Key display automatically appears to the right. You can also set the Shape-by field in the Marker
options sub-menu, as well as specify the treatment of null values in the plots.

Note: At any time you can change the colours assigned to the values in a given field (column) using Data > Manage Fields > Configure >
Field Options > Change value order, colours and shapes.

The remaining Graph View Toolbar commands are common to all views and are documented here [212]

 

Back to Using Views [212] or Views Reference [109]
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Time Series

Graph View: Displaying Time Series
This section guides you through using the Connect markers (time series) options available in an expandable section of the View Tools
menu of the Graph View (download the sample file used to illustrate this section here [216]).

Data Orientation for Time Series

Omniscope manages repeated observations of values over time in vertical columns, rather than horizontal rows often used for time series in
spreadsheets. To create a multi-line time series as shown below, first put your data in the following 'vertical' orientation:

 

 

In the above example of a time series data layout for Omniscope, we have various bonds, each with an ISIN identifier, and each issued by one
of various countries (GR, FR etc.). We also have repeated observations of Price and Yield over time entered vertically down the columns. Each
record (row) in the data file is therefore a separate observation of price and yield which are repeated over time 'vertically' in separate rows

Time series data layout in Omniscope requires at least one field (column) with a natural order, such as Date, and one or more values columns
'Price', 'Yield', etc. for repeated observations of values that make up the time series. In addition, to display multiple curves on one graph, there
should be a Category field (with less than about 200-250 unique values) referencing each curve to be drawn. In this example, we have many
observations, but only 9 unique ISINs (individual bonds) so the curves can be plotted by the Category 'ISIN' reference field as shown in the
example below. Don't worry about the apparent repetition in the data values, outside of the Table View, Omniscope will render the duplication
invisible to you and the users of your files.

If your data is arranged differently from the example above, (e.g. 'horizontally' with the dates as columns and each cell in the row representing
an observation over time) you may want to use the the tools available under Data > De-/Re-Pivot on the Main Toolbar to transform your
data set to the correct 'vertical' orientation in Omniscope. More on Using De/Re-pivot [138].

Checking your data types: After importing and correcting the layout of your data, go to Data > Manage Fields [95] and make sure the
Time (here Date) and Observation (here Price, Yield etc.) fields (columns) have the correct data typing. They must be typed Numeric (decimal
or integer), or Dates & Times. Also make sure that any fields you want to use to distinguish lines (here the ISIN Bond Identifier number) are
declared of type Category. You can convert data types using the Data > Manage Fields dialog or by by right-clicking the column header in
the Table View and choosing Tools > Convert field data type.

Prepare the Graph View

Once you are sure that your data layout and field (column) data typing is correct, add a Graph View and configure the axes:

1. Add a Graph View using the  Add view button on the Main Toolbar
2. In the Graph View, select a Value (here 'Yield') field for the Y axis
3. In the Graph View, select the Time (here 'Date') field for the X axis

You will see an un-connected scatter plot of markers representing your time series data points. In the View Tools drop-down menu, tick
Connect markers (time series). A number of new options should appear on an expandable sub-menu below this command on the View
Tools menu.

WARNING: This option will be unavailable if the Graph View has been configured with Displaced (randomly offset) markers. Open the Marker
options dialog above on the View Tools menu and confirm that the Displaced option is not ticked.

Connecting markers (time series)

At this point, the display will change from unconnected scatter to connected plot, but with many heavy black lines in a jumble. The expanded
sub-menu includes a number of commands used to manage the display of connected markers:
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Time series (connect markers by X axis)- when ticked, automatically uses the field (column) selected for the X horizontal axis( here Date)
to provide the traversal order, the order in which the dots are connected. This is the most common setting for time series. When this option is
ticked, the Traversal order option below is greyed-out.

Show a line for each- used to define how many discrete lines will be plotted. Choose the Category field (here ISIN Bond Reference) that
defines each set of observations to plot. The black lines will then be replaced by a number of coloured lines corresponding to each of the
category values. If your data set does not include observations for multiple categories, leave Show a line for each with "(None)" selected to
display a single black line.

Traversal Order (showing an omni-directional path) By unticking Time series (connect markers by X axis), you can choose to draw the
lines in a different order than dictated by the X axis. If you are plotting data based on criteria other than time, configure the Traversal order
field appropriately.

Show moving average: None; Simple & Exponential- If you have many data points in each time series, you may wish to try showing a
moving average, by choosing Simple, Exponential or other data smoothing options on the sub-menu.

Line/curve smoothing- By default, lines are turned into curves while preserving data points. In other words, curves are drawn between the
data points. Depending on your data, this may be inappropriate. You can disable this using the Line/curve smoothing sub-menu. Alternatively,
a second form of curve smoothing is provided, which does not pass through the data points. Untick Curves pass through vertex points
to use this option. Both forms of smoothing can be adjusted for amount of smoothing using the Smoothing amount option.

Line width-By default, lines are shown 2 pixels thick. Use the slider to change this any value between 1 and 25 pixels.

Arrows: Show forward arrow; backward arrow; arrows for each segment; middle of each segment-adds different kinds of
directional arrow heads to the line segments displayed

Coloured- By default, if you have multiple lines displayed, these are coloured according to the values in the Category field. You can disable this
and show only black lines by deselecting this option.

Show markers- Hides or reveals the markers within the plotted lines (to resize markers, see Marker Options on the View Tools menu

Anti-aliased- Smooths the way the line is displayed

Show labels- By default, text labels will be shown beside each line if you have multiple lines. By de-selecting Show labels, these will only be
shown as you move the mouse pointer over a line.

Making line selections

When Connect markers (time series) is enabled and lines are showing, the Line select mode becomes available from the Modes drop-
down. Select this mode, and the mouse pointer will change to show that you are in Line select mode. Move the mouse pointer over a line, and
it will become highlighted.
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There are two ways to select records in Line select mode:

1. Select by clicking- Click to select the entire line, all points of which will become highlighted. All underlying records will be selected, which
you can confirm by consulting the selection preview blue bar inside the Barometer on the Main Toolbar. Click on another line to select
that as well, and watch your selection grow in the Barometer. Click on any selected line again to de-select that line.

2. Select by dragging- Click and drag the mouse pointer across a region of the graph. As you drag, a dashed rectangular region will be
shown. When the region contains part of a line, that line becomes highlighted. Release the mouse, and all lines intersected by your
mouse-drawn rectangle will be selected.

Stuck? Reset the Graph View

If you have made too many configuration changes and can't figure out how to get back, you can reset all settings for the current Graph View,
returning to a plain default view with no marker connection settings enabled. From the bottom of the View Tools menu, choose Reset all
settings for this Graph view.

 

Back to Using the Graph View [114]

User Guide Top [108]

Tile View

Using the Tile View
The Tile View represents each record in the data set as a rectangular tile, which can be grouped, sized, sorted and coloured to display
relationships, anomalies and outliers in the data. Tiles can be either image tiles displaying images associated with each record, or solid tiles
displaying text and coloured and sized to represent various attributes of each record. The Tile View can be used as an image browser (see
Open Image Set [217]), but it is also a powerful 'heatmap' (treemap) for representing data visually along multiple dimensions. Moving the mouse
over the tiles reveals the title for the record. By default, clicking on the tile selects the corresponding record. Double-clicking on the tile brings
up the details display.

The example below shows two Tile Views displaying the same collection of shoes. The Tile View on top is set to display an associated image set
(the shoe pictures) as tile contents. Note the vertical scroll bar on the right, as the pictures have been up-sized from the default so that not all
will display in the open view. The second Tile View below is showing the same collection of shoes using solid tiles coloured to match the colour of
of each pair of shoes and sized in relation to price:
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Tile View controls

The Tile View is controlled using six configuration options located across the View Toolbar:

Tile Contents: this drop-down menu provides the option to display either data values as solid, text containing tiles, or associated image sets
as picture tiles. If you select a data field, the value of that field will display inside the tile representing each record. If you select an image set, it
will display the name of the image file on tile select/hover unless you change the ungrouped tile title to the contents of another field (see
below).

Group: arranges the tiles into groups by any field. In the example above, the shoes are grouped first by Type: Ladies, Mens and Children's.

2nd Group: within the first grouping, arranges the tiles into sub-groups by the value in the specified field. In the example above, shoes are
grouped secondarily by Brand/Designer.

Size: varies the size of each tile in proportion to the value in the specified field. Can be used with both image and solid tiles. In the example
above, the solid colour tiles are sized in proportion to Price.

Sort: Sorts the tiles vertically by another field, such as Price.

Colour: determines which field value is used to colour the tile, and can be used with image tiles as a semi-transparent overlay. In the example
above, Omniscope recognised and automatically applied the colours to match the all the values in the Shoe Colour field, except for cream,
which was set manually. For more on assigning colours to specific values in a given field, see Data > Manage Fields [95].

Tile View > View Tools options

The Tile View Tools drop-down menu contains several options to change the display and selection behaviour in the view.

 

Ungrouped tile title- use this option to specify the value to be displayed on hover/selection instead of the value associated with the tile
contents display value. In the example above, the Description text is showing, rather than the file name of the associated image file, which is
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contents display value. In the example above, the Description text is showing, rather than the file name of the associated image file, which is
sometimes not informative.

Clicking applies to grouped tiles- when ticked, this option enables you to select entire groupings, rather than individual tiles.

Top-level group shown with title bar- when ticked, this option displays the field by which the top-level grouping is defined as a nested title
as shown in the examples above. When unticked, the title of the primary grouping field is displayed as a large orange text overlay on top of
the primary grouped tiles, as shown in the lower Tile View example above.

Click to get details- when ticked, a single left click displays the details window for that record

Click to select tile- when ticked, a single left click selects that record

Size Options

Sizing strength- this option is used to tune the sizing on a scale of -100% through 0 to +100%. The default is 100%, which means that the
sizing calculation uses the default. Lowering the value to 0 eliminates all sizing, and further reducing it to -100% inverts the sizing, so that lower
values get larger sizing.

Use absolute sizing- this option calculates the sizing of all tiles based on the entire dataset, and keeps them sized this way regardless of the
sub-set of records in the open view.

Use relative sizing- this option re-calculates the sizing of the tiles based only on the records in the open view. Use this setting to accentuate
small differences and counter the tendency of increasingly similar records to be sized similarly as the range of interest narrows.

Show for records with positive/negative values- the Tile View can be used either with all positive values being displayed, or all negative
values being displayed, but not both. Use two open Tile Views like the example above to show both positive and negative values, or use the
Bar View.

Advanced menu:

Individual records- ticked by default, if the chosen tile contents field is a number or date, unticking this option will aggregate values into
ranges and show the tiles for ranges, rather than the individual values per record.

Show image for first token only- if your file has a tokenised image set (multiple images per record), by defaul the Tile View will show only
the first image associated with the record. Untick this option to show all the images associated with the record.

Colour around images in tiles- the relationship between the height and width (aspect ratio) of pictures inside image sets is often not
uniform, or does not match the shape of the Tile View display. Omniscope creates blank spaces between the pictures to fill the gaps. This
option controls the colour of the background fill; none, extrapolate from image (estimated from the colours on the edge of the pictures), black
or white.

Set mosaic image- used to create an effect in which a large high-contrast picture is re-created using many smaller images related to records
in the data set. Cannot be used with grouping, sizing or sorting enabled.

Colourise images- when ticked, allows semi-transparent colour overlays to cover the entire image tile. When unticked, only the border fill
space is colourised according to the values of the files selected in Colour: on the View Toolbar

Tile size- used to over-ride the default tile sizing which tried to ensure that all tiles display in the open Tile View without scrolling. If you increase
the tile size, scroll bars will be added to the view as required. Relative or absolute sizing options are not affected.

Use grid layout- only shows when sizing is not active. Changes the allocation of space within groupings to make tile size uniform within each
group.

Tile margin- used to increase the amount of background space displayed around the edges of the tiles. Colour around images settings are
not affected

Fix aspect ratio at 4:3- used to make image collections appear more uniform and minimise distortion of images with 4:3 aspect ratio.

Tile View right-click menu options

Right-clicking on a tile brings up a detailed selection menu where you can specify exactly the records you seek, and change the settings for
the view.
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The commands available on the right-click menu under Options are the same as those available in the View Tools menu

Back to Using Views [212] or Views Reference [109]

User Guide Top [108]

Tree View

Using the Tree View
 

The Tree View is used to present and navigate structured, tabular data hierarchically. Two kinds of 'tree' hierarchies can be created and
managed in Omniscope: Pure and Comparative. Pure hierarchies have one unique record at each node (point on the tree) and the child
nodes are also unique. Examples of Pure hierarchies are organisation charts and genealogical 'family trees', where each record is a person, or
web site 'maps', where each record is a page on the site (to see an example, download the .IOK file version of our site map with Google
Analytics data included (coming soon). Comparative hierarchies have clusters of records at each node, and each record is reproduced in its
parent. Almost any data set can be represented as a Comparative hierarchy, including also Pure hierarchies.

 

 

Configuring Comparative hierarchies- By default, Omniscope will display data sets as Comparative hierarchies, like the right-hand view in
the example above. In the right-hand view, each box (node) represents a groups of employees sharing specified Category values. To create a
Comparative hierarchy display like this, it suffices to have some Category fields in the data such as Age, Sex, Location, etc. Select the Category
fields you want to display using the Fields drop-down menu on the View Toolbar. Click on a node (box) to isolate its children, then click on
the underlined node name to show the Details pop-up for the record(s) at that node. Notice that you are selecting, rather than filtering, so the
Reset command may not be available. To display all nodes (boxes) again, click on the very top level node (box) in the tree, or else use the 
Deselect command on the Main Toolbar.

Configuring Pure hierarchies: The left hand view in the example above is a Pure hierarchy, where each box (node) represents a level in the
tree relative to all the other employees. To display and navigate a pure hierarchy, like the left-hand view in the example above, requires that
your data include a number of cascaded levels, as illustrated in the combined Table and Tree view image below showing the data organised by
levels; Level 1, Level 2... to Level 5.
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This is a data 'cascade' or 'waterfall', where the first node record (the CEO) is identified by placing the record in the first level 'Level 1' with
blanks in all the other levels. The value 'CEO' also appears in Level 1 for all other records too, since they are all children of this node. In Level 2,
the Sales Director (Michael Wood) appears once with blanks downstream for himself. All the Sales staff reporting to him also have 'Sales' in Level
2. This 'waterfall' of levels and blanks defines the structure of the Pure hierarchy.

The full data set is in two parts; the input 'Level' fields that determine the structure of the tree (who works for who, who is a parent and who is
a child, etc.), and the comparative fields (age, salary, hair colour, birthday etc.) that capture attributes of each person. For data sets that have
this dual content, the Tree View can be navigated as a Pure hierarchy, while still permitting querying on comparative attributes. In Pure
hierarchy mode, the Tree View can be used most effectively in parallel with other views that can be used to query the comparative attributes,
while the Tree View updates to show which individuals share the queried attributes and their position in the structure.

To display a Pure hierarchy in the Tree view, first show only the Level fields in the desired order, then click Pure Hierarchy in the View Tools
drop-down menu on the View Toolbar. Omniscope will switch the tree to Pure mode, and there will be only one record in each node. A slider
dialog will appear, allowing you to specify how many columns from left to right have been used to define the tree:

 

 

At any time, you can change a Pure hierarchy display back to a Comparative hierarchy. To switch back to Pure hierarchy again you must
again indicate the extent of the columns that define the structure of the tree using the dialog above. More help configuring data layout for
both Pure and Comparative hierarchies is available in this tutorial file [218].

Tree View controls

Selection is done by clicking on a node (box). When a node is selected, its branch is selected and the box expands to show links to Show
details pop-ups. All nodes on non-selected branches are faded (unless AutoHide is 'On', in which case they are hidden). In Pure mode,
selected nodes will exhibit details about one individual, rather than the downstream records, although the selection is still of the branch
including all downstream nodes. For example, you can select the whole Finance department branch, but drill down from the top departmental
node (box) directly to details about the Finance Director, without displaying the records for the whole department, as would occur in a
Comparative hierarchy display.

In Comparative hierarchy, you can click and drag the headers above each node to change the order of the fields, but the order of the levels in
Pure hierarchies are fixed in the data and cannot be changed this way. Clicking on the header above a node will colour the tree downstream
from that point. When there are too many branches to display, the boxes will group into ‘Other’ nodes that will expand again whenever there
is space to display the individual branches.

Selected nodes/branches can be 'pruned' and restored using power queries with the  Move,  Keep and  Reset commands on the Main
Toolbar. Note: When AutoHide is on, branches which are not selected are hidden, rather than faded. If you have not yet executed a Move
or a Keep command, all the records are still in the target universe. To display all the nodes/branches in the tree again, you must use the 
Deselect, not the  Reset command (which may be be greyed out) on the Main Toolbar, or click on the very top node of the tree.

Tree View Toolbar

The Tree View Toolbar contains the View Tools drop-down menu, the Fields drop-down pick list, Colour field chooser and the AutoHide
On/Off option. Other commands available on the View Toolbar are common to all views and documented here. [121]

Fields- hide or show additional fields in the tree. In a Comparative hierarchy, you can also use this menu to arrange the display order by
dragging fields up or down using the drag handles.
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Colour- overrides any header-selected colouring and colours the nodes/branches by any other field chosen from a drop down menu

AutoHide- when 'On', fully hides (rather than fades) non-selected branches when one branch is selected in the tree

 

 

Show end children- {deprecated}

Pure/Comparative hierarchy- used to switch between Pure and Comparative hierarchy displays (see above).

Unselected fading level- sets the degree of fading for unselected branches/nodes whenever AutoHide is Off.

Show cell barometers- shows/hides an optional display of bar-type indicators within the boxes showing the proportion of records contained
on the branches below.

 

 

Show cell pie charts- shows/hides an optional display of pie chart indicators within the boxes showing the proportion of records contained
on the branches below.

Text size- increases/decreases the size of the text within the nodes (dense trees will benefit from a smaller text size).

Limit box size- only displayed for Comparative hierarchies, allows you to choose between setting all box heights the same, or having
upstream boxes taller than downstream. Box width is not affected.

 

Back to Using Views [212] or Views Reference [109]
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Network View

Using the Network View
Note: this is a new view in version 2.5; this page is still under development

The Network View creates a virtual network of interconnecting nodes in your machines' memory to help visualise relationships in your dataset.
Each node within a network represents a data subset and lines connecting the nodes indicate the relationships between these subsets. You can
use one of many inbuilt layout algorithms to position the nodes within the view, or use your mouse to move the node arrangement around to
create a custom layout best suited to your data.
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Setting the network type
When you first open a new Network View you will be asked to select a network type. The network type determines how the network will be
built based on the relationships in your data set. There can be more than one network type used for a given data set using multiple Network
Views.

For any given Network View, there are two broad options for specifying the type of network you wish to visualise, Grouped Hierarchies and
Relational Networks:

Grouped Hierarchies

A grouped hierarchy can be used tovisualise almost any type of
data. In a grouped network each node represents a group of
records. Once you have selected a grouped hierarchy use the field
selector on the Network View toolbar to definethe columns in your
data set to be included within the network. Each field (column)
chosen will define another 'level' within the hierarchy. At eachlevel,
the records will be split by the associated field values.

Relational Network

Arelational network can be used to represent any dataset where a
commonrelationship exists between the rows. Each row should
define a 'key' field and one or more 'linked fields'. The 'key' field
should provide a unique identifier for the row entity. For example,
for a data set comprised of people, the 'key' field might be the
person's name, insurance number or other identifier unique to
thatparticular person. The 'linked' fields create the linkage(s) to
another entity, defining the key value for the linked entity, thereby
allowing the network to determine which entities are connected.

 

 

More detail and examples of configuring netwrok types are given under choosing your network type. [219]

Network View Toolbar 
Like the View Toolbar displayed in other views, the Network View Toolbar contains a View Selector, Data Subset Selector and the Aggregate
options drop-down menu that function in the same way as they do in other views. The View Tools drop-down contains first the commands
specific to the Network View, and then the commands common to all views.

 

To the right of View Tools drop-down are the options menus specific to the Network View; Appearance options, Node options, Selection Mode
options, Zoom options, Fields selector, Layout options, Navigator pop-up and Node Labelling, Colouring, Outlining and Sizing options. These
menus are discussed in the sections below.

Appearance Options Dialog

The Appearance options dialog [220] is immediately to the right of the View Tools drop-down. This is a large, multi-tabbed dialog that allows you
to configure the colour, size and shape of the nodes, lines and labels within the network. There are three tabs; Nodes, Lines and Labels, with
many options on each tab.

Nodes [221] - options relating to the shape, size, colour and images used to represent the Nodes in your data
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Lines [222] - options relating to the display, thickness, colour, arrows and arrow positioning of the Lines between the Nodes

Labels [223] - options relating to the display of labels, field (column) names, empty values, and the spacing, alignment, fonts and background
used

All of the Appearance dialog options on all three tabs are documented here [220]

Network View Toolbar - Node type options

The Node Type options allows you to choose how nodes in the network will be portrayed. The Network View currently provides two node
shape options: markers for which a range of shapes can be selected, and square/rectangular boxes.

 

Marker - a marker consists of an arbitrary shape and a label shown adjacent to the marker. The
marker option is particularly useful when visualising networks with a large number of nodes. 
Box - a box is a rectangular shape for each node. The box label is shown inside the box and is
always visible. Box nodes usually require more space than marker nodes and, as such, are more
useful when visualising networks with a small number of nodes. 
Node Options - use the Appearance options > Node options [221] tab to select the shape to be
used for markers and to set the size and shape of boxes.

Network View Toolbar - mouse Mode options

This menu provides users the option to control the behavior of the mouse when navigating and filtering the network. The mouse mode
options in the Network View are the same as those used in other views, such as the Graph and Map Views.

 

Square selection - allows you to select and move node. To select one or more nodes hold
down the left mouse button and drag the mouse across the view panel. A rectangular
shape is created as a result of dragging the mouse. All of the nodes that are enclosed within
the rectangular shape are included in the selection. To move a node simply move the
mouse over the top of the node, hold down the left mouse button and drag the node to
the desired location. You can move several nodes at once by selecting the nodes then
moving any node from the selection.  
Lasso selection - lasso selection is used in the same way as the square selection; the
difference is that a flexible lasso shape is used to manage the selection instead of a
rectangle. With a lasso you can move the mouse to create a free-form shape, thereby
allowing for more complex selections of one or more free-form areas.
Pan - The pan mode allows you to navigate the network by moving the screen to frame
the desired area. Once you select the pan mode a 'hand' icon will appear. Hold down the
left mouse button and drag the mouse to move the window in the corresponding
direction. Whilst using the pan mode you can use the mouse wheel to zoom in and out of
the network.  
Zoom - The zoom mode allows you to zoom in or zoom out of the current network. To
zoom to a specific area hold down the left mouse button and drag the mouse to create a
rectangle highlighting the area to zoom to. To zoom in or out of the map hold down the
right mouse button and drag the mouse up (to zoom in) or down (to zoom out).
 

Network View Toolbar - Zoom options

Zoom options in the Network View are very similar to those provided in the Graph and Map Views. The slider and the zoom buttons allow you
to increase or decrease the magnification level. The following additional controls are provided:

 

Zoom out fully - Zooms the graph out to the full extent. This menu item is highlighted
whenever the network is zoomed out fully.
Zoom to custom region - Changes the interaction mode to the 'Zoom' mode. This
menu item is highlighted whenever the network is zoomed to a custom magnification.
Reload and zoom out fully - Reloads the entire graph, applies the current layout
algorithm and zooms out to the full extent. 
Show zoom scrollbars - Indicates whether the zoom scrollbars are displayed. The
zoom scrollbars are shown to the right and at the bottom of the view. They allow you to
both zoom and pan the view window.

Network View Toolbar Fields Picker

The Fields chooser allows you to define which fileds (columns) are displayed or hidden, and functions just as it does in most other Omniscope
Views
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Network View Toolbar - Layout selection

Specifying Layout Options allows you to apply a pre-defined layout algorithm to the current network. The position of the Nodes within the
network is determined according to the parameters of the chosen layout algorithm. The Network View currently provides seven layout
algorithms:

 

For examples of each, see Layout Examples
Circle - In the circle layout all of the nodes are evenly spaced across the edge of a circle. 
Grid - In the grid layout the nodes are placed across the view with an even horizontal and
vertical spacing. This gives the impression that the nodes are the corners of a grid. 
Balloon - In the balloon layout the child nodes are placed around the outside of the parent.
This pattern is repeated for the entire graph. 
Radial - The radial layout consists of several 'layers' of nodes. Each layer is represented as a
circle; the innermost circle contains the root nodes, and each subsequent circle contains
nodes from the next level of the hierarchy.
Tree - The tree layout determines the positions of the nodes based on a classic network
tree; nodes at the root of the hierarchy appear at the top of the tree and their descendents
are placed further down. There are four orientation options.
Best fit - (animated) The best fit layout uses a similar algorithm to the spring layout;
however it is designed to run for an arbitrary period of time and then stop. The Best fit layout
algorithm is generally better suited to larger volumes of data than the Spring layout.
Spring - (animated) The spring layout attempts to find theoptimal position of the nodes
based on their connection to other nodes.It may be best to describe the spring layout by
asking you to imaginethat all of the links between nodes are actually springs. If nodes
areconnected they will be pulled together, with the 'pull' between thenodes being greater the
further apart they are. The spring algorithm isbetter suited to smaller volumes of data.
Layout options - accesses the Layout options dialog (see below)

 

Network View Toolbar - Layout options dialog

Under the Layout selection drop-down is a link to the Layout options dialog, which allows you to modify the behaviour of the various layout
algorithms. 

 

General: Stretch layout to fit screen - If this optionis checked all
of the nodes in the layout will be stretched out so thatthe maximum
amount of screen space is used. Stretching is done bydefault in
some layouts (Tree, Grid), and this preference will have noeffect if
one of these layouts is in use. A good example of the
effectchanging this preference can have is to create a network and
select the'Circle' layout. Now select 'Stretch layout to fit screen'. You
shouldsee the circle of nodes stretch out to form an ellipse. 
Radial layout: Node positioning - defines how the node position
is determined when the radial layout is in use:

Parent/Child - children are grouped together underneath
the parent node. Thismakes the network hierarchy much
clearer, but may mean a large number ofnodes are
overlapping.
Evenly spaced - nodes in each level of the hierarchy are
evenly spaced out.

Tree layout: Node positioning. Same as above.
Cluster markers to fit screen - when checked, nodes too close
together are 'clustered' tocreate a single node. Clustering can only
be applied if the network ishierarchical, i.e. it has a root node, and
the root has zero or more childnodes that in turn have zero or
more child nodes...with each node having asingle parent node. 
Node density - determines how close nodes have to be to each
other before they areclustered. If the density is set to 'High' then
the space between eachnode is reduced, therefore allowing for a
high number of nodes. If thedensity is set to 'Low' then the space
between each node is increased,equating to a small number of
nodes.
Show unselected nodes - determines whether nodes which have
not been selected are shown.
Animating layouts: Frame rate -The Network View currently
provides two animated layouts:Spring and Best fit. Use this slider to
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determine how fast thelayouts run. If your network is large and
complex, setting a fast speedcould have a detrimental effect on 
performance.

Network View Toolbar - Navigator

Click on the 'Navigator' button to open a small network navigation window. The navigator window will be docked on the right hand side of the
view however it can be dragged and placed anywhere on screen. 

 

Zoom slider - Moving the zoom slider or clicking on the Zoom In or Zoom out buttons allows
you to increase or decrease the magnification. 

Navigation arrows - Clicking on the red navigation buttons allow you to shift the view in the
corresponding direction

Zoom magnifiers -  

Network View Toolbar - Node label

The Node Label drop-down allows you to determine how the label attached to each node is constructed.

 

The dropdown provides three types of measure:

Number of records - displays the number of records associated with the node.
Summary - displays summary details associated with the node.
Field name - constructs the label based on the value of all the records for the selected field. If the field is numeric
and there is more than one value the label value will be determined by applying the function specified in the
'Number field function' sub-menu. If the field is textual and there is more than one value the field value will not be
shown.

You can select as many of these measures as you want. So you could choose to show 'Number of records' and 3
fields. The order these are shown is determind by the order they are shown in the drop-down. You can change the
order by clicking and dragging the measure to the preferred position in the list.

Network View Toolbar - Node colour

The Node Colour drop-down menu allows you to specify the measure used to determine how Node colouring is calculated.

 

There are currently three types of measure:

None - the default option, no measure is used, instead node colour is the base colour setting as specified in the
Appearance Options dialog.
Number of records - the node colour is determined by the number of records represented by the node. If a node
represents a large number of records then the colour of the node will be close to the colour specified at the higher
end of the graded colour scheme.
Field name - you can choose to colour nodes by a particular field inside the dataset. If the field is numeric and there
is more than one value the colour of the node is determined by applying a function to all of the values. You can
choose which function to use by using the 'Function' sub-menu in the drop-down. The 'Function' sub-menu is only
visible when a numeric field is selected. If the field is textual and there is more than one value either multi-colour
lines or a pie-chart are used to show the values for the selected field. You can choose the fill type by using the 'Fill
type' sub-menu in the drop-down. The 'Fill type' sub-menu is only visible when a numeric field is selected.

Network View Toolbar - Node outline

The node outline drop-down menu allows you to specify the measure used to determine how the node outline is calculated. The Node outline
option can be used in exactly the same way as the Node colour menu. You might find it easier to identify the node colour outline by increasing
the outline thickness. You can modify the outline thickness using the Node options dialog.

Network View Toolbar - Node size

The node size drop-down menu allows you to specify the measure used to determine the size of a node in relation to the other nodes on
screen. 

There are currently three types of measure:

Node - the default option. No measure is used, instead the node size is the base size setting as specified in the Appearance options
dialog.
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 Number of records - the node size is determined by the number of records represented by the node. If a node representsa large
number of records then the node will appear larger.
Field name - you can choose to size nodes based on a particular numeric field in the dataset. The larger the value for the selected
field, the larger the node. If the node represents more than one value then the value used to determine the size is calculated by
applying the function selected in the 'Function' sub-menu. 

 

Back to Using Views [212] or Views Reference [109]
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Network Types

Selecting Network Type
What sort of network(s) are in my data? 

 

The Network View can depict many types of relationships within any given data set. You can have as many Network Views in a file as you like,
and multiple Network Views per tab. But how to decide which types of Network View best suits your data set?

Choosing and configuring network types...
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Layout Examples

Network View Layout Examples
Choosing the best layout for your data and users
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Appearance Options

Network View - Appearance Options
Configuring Nodes, Lines and Labeling 

 

The Network View Appearance options dialog has three tabs; Nodes, Lines and Labels

Nodes

The Nodes tab contains options to configure almost all aspects of how Nodes are displayed, including display of images to represent Nodes.

133/305



 

Node Visibility: untick box to hide empty nodes in the display

Enlarge: set the enlargement scales for both Root Nodes and
Highlighted Nodes

Defaults:

Node type - choose either round 'Marker' or square 'Box'

Marker options: (only shown when Node Type is set to 'Marker)

Marker size - allows you to control the size of the Markers
representing Nodes in a given Network View. Smaller sizes
increase the number of nodes displayed on screen. Larger
sizes are useful when applying measures to the Markers
(colour, label, outline and size) as it makes it easier to identify
the grading on each measure value.
Shape - select from various different Marker shapes.

Box options: (only shown when Node Type is set to 'Box')

Box size - Allows you to specify the sizing policy applied to
boxes within the network. Choose either

'Specified' - size of the box is determined by the
box width and box height sliders below.
'Fit label' - size of the box is determined by the
size of the label inside the box.

Colour - select the node background colour. 
Outline colour - defines the node outline colour. You may find it
useful to adjust the outline thickness when setting this value in
order to make your colour selection more prominent. 
Outline thickness - defines the thickness, in pixels, of the node
outline.

Selection: Unselected opacity When you make a Selection within
the Network View all of the selected Nodes appear blue whilst the
unselected Nodes appear slightly faded. The unselected opacity
slider allows you to define the fading level for unselected Node. A
value of '0' means the nodes don't fade at all whilst a value of '100'
means the Node disappears when de-selected. 
Images:

Image set - Allows you to define an image set and display images
from that set in the corresponding nodes on the network.  
Show images in leaf nodes only - Defines whether the images
are displayed only in the end nodes within a hierarchy
Image position - 
Image margin - Allows you to define the gap between the edge of
the node and the image inside.

Extrapolate from image. Uses the colour of the image edge.
Node colour. Uses the colour of the node.

Surrounding colour -  Allows you to define the colour
surrounding the image. The dropdown provides you with two
options:

 

 

Lines Options

Show lines - 

Show lines. Determines whether lines will be displayed.
Line defaults : Line width. The thickness of the line.
Line defaults : Colour. The colour of the line.
Show arrows. Determines whether the line arrow will be
displayed.
Arrow options : Arrow style. Allows you to define the arrow
head style. 
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Arrow options : Arrow size. The size of the arrow head.
Arrow options : Arrow position. The position of the arrow
head in relation to the parent and child nodes. 

 

Label Options

 

Show labels - 

Show labels. Determines whether labels will be displayed.
Content : Show field names. You can show field values by
clicking on the node and line label measure dropdown in the
toolbar. Once you have selected the fields you wish to view this
option determines whether the field name will be shown
alongside the field value.
Content : Hide empty values. After using the node and line
measure dropdowns in the view toolbar to configure the label
fields this option determines whether fields with empty values
are still shown.
Position : Label proximity. This option is only available when
the 'marker' node type is selected. In a network of markers the
label positioning is determined by the space available next to
the marker. If no space is available the label is not shown. The
label proximity slider determines how close labels can be placed
to adjacent markers. If the slider is set to a low value more
labels can be shown, however it may be difficult to determine
which labels belong to which markers. If the slider is set to a
high value then fewer labels will be shown thereby making it
easier to identify the node associated with any visible label.
Position : Alignment. This option is only available when the
'box' node type is selected. Determines the location of the label
inside of the box.
Font : Name. The label font face name.
Font : Size. The font size.
Font : Effects. Enables or disables the bold and italic font
effects.
Font : Text colour. The label foreground colour.
Font : Text opacity. The text transparency value. Selecting a
low value by moving the slider to the left makes the text more
transparent, selecting a high value by moving the slider to the
right increases the opacity and therefore makes the text clearer.
Background : Colour. The label background colour.
Background : Opacity.  The label background transparency
value.
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Portal View

Using the Portal View
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Using the Portal View
The Portal View summarises most aspects of the data set (it can search but does not display text fields) as either field (column) value
breakdowns (left example below), or statistics (right example below), or a mix of both. The optional search box works like a search engine
across the entire data set, and the dynamically generated range breakdowns can be selected for use in power queries using the Move, Keep
and Reset commands.

 

 

Portal View Controls

The Portal View features a global Search Box used to select text string values from anywhere in the data set. This is equivalent to the 'Search
all' filter device available on the Side Bars. Selection is done by typing into the keyword box (hits are shown in the preview counter on the far
right as each character is typed. Multiple words can be entered and the 'and/or' relationship set using the 'ALL' and 'ANY' buttons to the right of
the text search box ('ALL' is the default). Note: there is not currently an 'EXACT' option for use with numbers, etc.

The Search Box can be used in conjunction with the individual fields in the Portal View by entering text in the Search Box and selecting one
or more value ranges within the view. The keyword 'hits' will be displayed in the Search Box while the overall number of hits (text and other
values) will be shown by the blue preview bar inside the green barometer on the Main Toolbar. Note: the blue preview bar is only visible when
selections are made. Any combination of text string input and multiple field range criteria can be selected and used to execute power queries
using the Move and Keep commands on the Main Toolbar. The Search Box can also be used very effectively in conjunction with other views,
such as the Table or Details Views set to display the SELECTION universe.

Field Settings menu- each numeric, date or category field displayed has a small black downward pointing arrow that reveals a Portal View
filed display configuration menu with 3 options:

Show value breakdown- displays selectable dynamic ranges of the values in the field. Each field displays up to five categories, ranges, or
intervals as a default. Additional categories are grouped into a category named ‘Other’. Numerical fields are broken into intervals necessary to
make five groups of records. The fields containing collapsed categories are underlined. Click on any underlined field title to expand that field and
see all categories or smaller numerical intervals. Click again to collapse it again.

Expand- expands the number of ranges displayed. If Show value breakdown is not selected, this option is greyed-out.

Show statistics- displays a pick list of statistics available for each field (column). Tick those you want to display, with or without the value
ranges:

 

 

Portal View Toolbar

The Portal View tools drop-down menu features a number of options to configure the display. The Fields menu adjacent displays a pick and
ordering list used to hide or show fields. Click and drag on the hands to change the order of the fields in the view.

Colour values- when ticked (the default),
colours the values in line with other view
colouring. Untick to remove colouring.
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Number of columns- changes the number of
columns in which the field ranges are displayed.
The default is two columns. 
Change number of values- changes how
many categories or numerical ranges or
intervals are shown under each field title when
collapsed. The default is five categories/ranges
(intervals) as shown above. 
Show search- shows or hides the global
Search Box
Show record counts- shows or hides the
number of records per category or interval in
each field. The default is to show the counts. 
Font- allows you to select font name, face and
size (not colour).

 

Add background image- enables you to add a faded image to the backdrop of the view. Same as the option provided in other views and
documented in the Page Menu [91]commands.

The other options on the Portal View Toolbar, Show Details, Slide show and Add to Basket are common to all views and documented in
the section on View Toolbar. [121]

 

Back to Using Views [212] or Views Reference [109]

User Guide Top [108]

Map View

Using the Map View
The Map View is a powerful and flexible option for displaying spatial data at any level; world, country, city or even exhibition or office floor plans
or sports playing fields. Omniscope embeds its own multi-layer vector maps that let you choose to display various geographic map layers
(roads, mountains, sea depths, etc.). Omniscope comes with the world map shown below, but you can also download hundreds of other free
country, regional and city maps from the Maps Library [141] for embedding in your Omniscope .IOM/.IOK files.

 

 

Using any activated edition of Omniscope, use the File > Open map > Download maps option to install and display new maps with blank
data sets, which you can either ignore or start populating with your data. To load a scanned image or photograph for use as a backdrop, use
the File > Open map > Browse for image or map file command.

Note: Omniscope currently imports Image (.JPG, .BMP, .GIF, .PNG depending on your Java version) plus Visokio's own .VEC, .MAP and .ILF file
formats for use as coordinate backdrops in the Map View. If you save an .IOK file containing embedded image map(s), Omniscope will bundle
them into the .IOK file so that anyone with the free Viewer will see the file with the correct map(s).

Each record (row) in your data sets can be associated with a marker displayed on the map, as long as the two designated map coordinate
columns contain non-null, valid decimal coordinates. Using Place marker mode, you can add coordinates to your data set by opening a map
view (or Google Maps), zooming in to show enough detail, then pointing at the location of each record with your mouse. More on Placing
Markers [143]...

Details for each record are available by clicking on the marker representing the record or aggregated group of records. Note: if the Details view
is not open, groups of four records or less will be displayed as a cascade of individual details windows, one per record, while markers
aggregating five or more records will display the pop-up Show details table window showing the selected records with links to display
individual details.
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Map View Toolbar

The Map View Toolbar includes the View Tools drop-down menu, an option to switch back and forth between vector and Google maps, a
Map (Map Type for Google) selector, a Layer pick list, choice of mouse Mode and Zoom navigational controls, plus field (column) pick lists
to set Colour, Sizing, Shape and Label options.

The Map View also features a pop-up Navigator overview mini-window, plus the Show Details, Slide Show, Add to Basket and [X] Close
View options common to all views and documented here. [121]

Switch to Google/Vector Maps- to the right of the View Tools drop-down menu this option allows you to switch from the default vector
map to a Google Map view which uses the same coordinate columns. When you are using Google Maps, this option label changes to Switch
to Vector Map.

Suggestion: Placing, moving and correcting coordinates using the mouse in Place Marker Mode using Google Maps works well. However, if
you are manually editing, deleting or cutting and pasting coordinate data with an open Google Maps display, make sure that the Zoom setting
is NOT Zoom to fit visible data. If you are scrubbing and filtering data and find your Google Map display updating slowly or not displaying
properly, switching to the corresponding vector map, then switching back will usually restore the display in Google Maps.

A tutorial on navigating in the Map View is available here. [147]

Map View Toolbar- Map selector for vector maps

The Map selector is used to change the map in the view, or add a new vector map to the file. The drop-down menu shows the list of maps
already configured in the file, with the currently displaying map ticked. Below that is the option to add another map from those already
downloaded onto your machine, or by downloading additional maps from the Maps Library [141]. If you select to add a new, unconfigured map
to the file, the Configure Map wizard will appear (see above) so that you can define a title and specify the coordinate fields (columns) to be
used with the new map.

 

 

There is also an option to import your own map as an image in formats supported by your version of Java, plus Visokio Map formats
(.VEC,.MAP,.ILF). Click on Browse for image file to use as a map, then browse to and select any image you choose. It will appear in the
Map selector drop-down map listing menu as part of your growing collection. You can use any kind of photograph or scanned image as a Map
View backdrop for placing data points. Typical examples include sporting fields, exhibition hall, office or factory floor plan layouts, banquet
seating arrangements etc.

Map View Toolbar- Map Type selector for Google Maps

When displaying a Google Maps as a backdrop, the Map selector becomes Map Type, and allows you to chose from 3 options for the Google
Map display: Map, Satellite and Hybrid:

 

 

Choose one or more Google Map types that best suits the purpose of each display.

Map View Toolbar- Layers

The default map is a Mercator projection world map with physical and political information in a series of configurable layers. With the default
world map open, click ‘Layers’ to choose what to display. Click 'Physical' to hide or show physical altitudes and reveal the 'Political' layer. Tick or
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untick layers until you have the map you want.

 

 

Note: some layers, such as capital, major and minor cities, will not be visible when zoomed out. Omniscope shows map detail progressively,
only when the view is close enough to make sense of it. As you zoom in, more and more detail will appear, revealing the layers you have
chosen.

If you would like to develop your own layers for distribution in .IOK files for display on vector or Google Maps, please contact us.. [178]

Map View Toolbar- Mode selector

Map View selection Mode options are very similar to those used in the Graph View [114], including mouse-defined Square select and Lasso
free-form selection as well as Zooming, and Panning navigational modes.

The Mode options menu enables you to choose how to navigate and select points and groups of points on the display. You can define one or
more selection areas/shapes in order to exclude or isolate records using  Move and  Keep power query commands on the Main Toolbar.
You can also use the mouse in navigational mode to define and explore specific zones in the display in maximum detail.

Square select mode- the mouse defines one or more
rectangular selection area(s)
Lasso select mode- (not available in Google Maps) the mouse
defines one or more free-form shaped selection area(s)
Zoom mode- a navigational mode, the mouse defines a
rectangular zone and the display zooms to show only that area.
Holding the right mouse button down in zoom mode and moving
the mouse up and down will zoom in and out continuously
Pan mode- (only visible when zoomed in manually) a navigational
mode, the mouse 'hand' cursor is used to 'grab' the screen and
move it to frame the desired area.

 

Place Marker mode- used to place markers for selected records, thereby generating values for the coordinate fields in the data. To do this,
open a Table View and select a record with no coordinates/map marker by clicking the row header (or multiple records using the Shift or CTRL
keys). Once selected. go to the open Map View, and with Mode set to Place marker mode, click on the point you want to locate the selected
records on the map. In the case of the Visokio and Google world maps, the correct decimal longitude and latitude values will be placed in the
coordinates columns. In the case of other maps, the coordinates will be relative to the specific map. For more detail, see Placing Markers [143].

Map View Toolbar- Zoom selector

The Map View Toolbar Zoom selector is also very similar to that used in the Graph View. The slider and Zoom out or Zoom in controls increase
or reduce the magnification, changing the area and amount of detail/layers displayed.
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Zoom to fit:
Visible data- map automatically zooms to the level
required to just show all data points in the target
universe.
Original data- map zooms to the level required to show
the full range of data points in the data set.
Map- displays adjust to show the full extent of the map,
regardless of the data selected or remaining in the target
universe
Zoom to fixed region- allows you to define a region of
interest with the mouse, to which the map display will
revert, regardless of the data points selected or
remaining in the target universe.

 

 

Show zoom scroll bars- when ticked, displays the zoom scroll bars bottom and sides at all times, even when zooming is not active.

Map View Toolbar- Colour, Size and Shape menus (& Key)

Marker Colour, Size and Shape options are all defined with field pick lists available under each of these Toolbar options. If any of these options
(or the Marker outline colour by option available in Marker options-see above) are set, the Key display also appears to help the reader relate
the appearance of each marker to the underlying data.

 

 

NOTE: You set the colour and shape associated with each different field (column) values using Data > Manage Fields available from the Main
Toolbar. The intensity of the relative sizing effect is controlled with the Size and Range sliders in the Marker options Advanced menu (see
above).

Map View Toolbar- Labelling (vector maps only)

The Label drop-down selector enables you to choose the field to display next to all unaggregated markers. Aggregated markers show the
label (mixed) until zooming or selection results in disaggregation to a single record.
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Labelling is displayed for all unaggregated records. Selecting a record can also trigger the display of Tooltips, which cam include associated
images. Tooltips are configured for all views using Settings > Tooltips > Fields from the Main Toolbar.

Map View Toolbar- Navigator mini-view window

Click the ‘Navigator’ button to show a small map navigation and view control window that can be placed anywhere on screen. Moving the
zooming slider, or clicking the (+) Zoom in, or (-) Zoom out icons increases or decreases the magnification, which reduces or increases the
coverage area shown in the thumbnail map framing window. Clicking the red vertical and horizontal arrows in the Navigator moves the small
framing window around the thumbnail map. The thumbnail map in the Navigator shows a heat map of record density, and selected areas in
blue. Click and drag the red thumbnail map framing window in to move around the main map.

 

 

Map View Tools

The Map View Tools drop-down menu provides options to define maps and control the display of markers.

 

 

Map coordinates and title- displays the Configure Map dialog used to specify the title and coordinate fields (columns) to be used to place
records on this particular map. With the correct map displayed in the view, select the fields to use as coordinates.
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Use existing fields- if your data sets already
have columns of decimal coordinates, fully-
populated or not. Most Visokio maps, including
the default World map, support decimal
numeric values available free from Google
Earth.

Add new X/Y field pair- use this option to
add two new blank fields (columns) that will
specify the coordinates for the map displayed.
If you use manual placement (see below),
Omniscope will write the values for each record
in these fields, which you name in the dialog.

 

For more detail on map coordinate systems, and creating/transforming coordinate systems, see the Knowledge Base section on Maps &
Coordinates. [144]

Change map projection- (not shown with Google Maps) used to create or refine coordinate systems for maps/backdrops that do not
conform to the default Mercator projection decimal latitude and longitude system. This is most commonly the case with scanned images like
floor plans, sports fields, some city and road maps, etc.

Override, by setting two reference points-
ticking this option launches the Change Map
Projection wizard to define or refine the
coordinate mapping. The wizard displays the
map, with three advanced options to define or
re-calibrate the mapping by 1) positioning
corner reference points of known location, or
2) distributing the range across the entire map,
or 3) using one-to-one mapping of pixels to
coordinates (the default).

For more detail on using these 3 options to determine the display of your data on a given map or image, see the Knowledge Base section on
Changing Projections [224].

Extract map image- (not available with Google Maps) allows you to export a copy of the embedded vector map as an image file

Show map title- (not available with Google Maps) when ticked, displays the map title(s) in the upper left the map, in orange font as shown in
the examples at the top of the page.

Marker options- clicking launches the Marker options dialog, very similar to that used in the Graph View [114]. This dialog enables you to
configure how markers on displayed on the maps/scanned images you are using as backdrops for your data.

 

Heat Map- (not available with Google Maps)
shows density plot of records on a grid. Useful
for plotting very large numbers of records that
overlap a great deal.
Aggregated- (default for data sets over 100
records) combines overlapping markers into
larger markers showing the number of records
aggregated. Useful when you have overlapping
records and need to see the density, similar to
the Heat Map. Note: Display on the markers of
sums and other functions calculated from fields
in the records aggregated is not currently
supported.
Displaced- (not available with Google Maps)
used if you have many exactly overlapping
markers and want to convey a visual
representation of the density of underlying
records. When ticked, the markers will be
slightly offset to show a dense cloud, rather
than overlapping exactly despite identical
values.

Displacement- (not available with Google Maps) changes the amount of displacement vertically and horizontally to improve access to data
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points for selection and linking.

Size slider- changes the absolute scale for marker sizing to increase or decrease all marker sizes

Range slider- (greyed-out unless the Size option is set to a field) changes the magnitude of relative sizing (see Size below)

Shape by: (not available with Google Maps) selects the field (column) whose values will determine the shapes plotted (same as Shape: toolbar
pick list below) with additional options to specify the display of markers of records which are null (blank, not zero) in the selected Shape by
field. In Simple mode, the Default shape to use when no Shape-by field has been chosen can be set.

Default shape/colour- selects the default colour of markers when no other colouring options are set.

Outline colour by: (not available with Google Maps) adds an outline of another colour, based on another field. For example, if 'Sex' is used,
this command would put a blue outline on the dots representing Males and a pink outline on the dots representing Females- assuming that you
have assigned the those colours to the values 'Male' and Female'. 

Hover plot- (not available with Google Maps) sets a pop-up display of either a pie or a bar chart whenever the user hovers on a marker,
aggregated or not. When set, you can select the field (column) to be charted using the pick list at right, which is otherwise greyed-out.

Marker link- (not available with Google Maps) selects a link to display when markers are clicked (one record only). Pick (None), Details, or one
of the links already configured in the file using the Settings > Links wizard accessed from the Main Toolbar.

Connect markers- (not available with Google Maps) similar to the option available in the Graph View [114], opens and expandable sub-menu.
Use of these options with the Map View is documented here. [225]

Colour Effects- (not available with Google Maps) launches an extensive menu of options to modify the display of the map/backdrop:

Bleaching- reduces the intensity of the map
image, making the markers more distinct.
Hue shift- shifts the map colours to achieve a
different palette
Brightness- reduces or enhances brightness
of map
Contrast- reduces or enhances map contrast
Colour strength- shifts the map colouring
from shades of grey to saturated colouring
Halo size- defines the radius of a surrounding
'halo' for each marker
Halo strength- defines the intensity of the
halo colouring
Surrounding colour- used to specify a
background colour that displays around the
edge of the map. It is only visible when zoomed
out beyond the edges of the map
Base colour- specifies a colour only visible
when all map layers are removed

 

 

Back to Using Views [212] or Views Reference [109]

User Guide Top [108]

Connect Markers

Connect Markers-Map View
This section demonstrates how to use the Connect Markers option in the Map View to draw a path around the map. You can download this
example file showing a holiday around the world here. [226] The various display commands on the expanded sub-menu are documented below.
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1. Create a new Map View file

Start Omniscope and select File > Open map, then choose World. A new empty file will be created and opened, showing the Map View and
the installed World Map, ready for adding markers.

2. Enable Connect markers

From the Map View View Tools menu choose Connect Markers. Since you don't have any markers yet, you won't see any change.

3. Place markers

From the Mode drop-down in the Map view, choose Place marker mode. The mouse pointer will change to a cross-hair when over the map.
Move to the first location in the trip (for example, London in the UK), and click the left mouse button. The Add record dialog will appear. Type in
a summary of this location, and press Enter or click OK. For example, 'Depart London, UK'. Move the mouse pointer to 'hover' over this
marker. You'll see a Tooltip appear with the text you have entered.

4. Zoom in for more accuracy

Now click the Map View Navigator button to show the Map Navigator, and use the controls to zoom in and pan around until you can see the
next location accurately. Click to add another marker, and enter the description. For example, zoom into Hong Kong and add a marker with
the text 'A few days in Hong Kong'.

You'll see a black line joining the marker from the previous point. Carry on zooming into cities and adding markers and text until you've finished
the path around the map. You can add more information by adding fields (columns) using Data > Manage Fields [95] to add fields (columns),
and then entering data into your new fields from the Table View [110], which you can open using  Add View.

5. Viewing the result

Click the Map View Mode drop-down again and change to Zoom mode to avoid accidentally placing markers. Open the Mode drop-down
again and click Zoom to fit map. You'll see the entire trip with a black line joining the markers. Hover the mouse pointer over a marker and
you'll see the text for that point. If you don't like the "line/curve smoothing", you can adjust or turn this off from within the View Tools
menu.

Connect Markers sub-menu command reference

Show a line for each- used to define how many discrete lines will be plotted. Choose the Category field (here ISIN Bond Reference) that
defines each set of observations to plot. The black lines will then be replaced by a number of coloured lines corresponding to each of the
category values. If your data set does not include observations for multiple categories, leave Show a line for each with "(None)" selected to
display a single black line.

Traversal Order (showing an omni-directional path) By unticking Time series (connect markers by X axis), you can choose to draw the
lines in a different order than dictated by the X axis. If you are plotting data based on criteria other than time, configure the Traversal order
field appropriately.

Show moving average: None; Simple & Exponential- If you have many data points in each time series, you may wish to try showing a
moving average, by choosing Simple, Exponential or other data smoothing options on the sub-menu.

Line/curve smoothing- By default, lines are turned into curves while preserving data points. In other words, curves are drawn between the
data points. Depending on your data, this may be inappropriate. You can disable this using the Line/curve smoothing sub-menu. Alternatively,
a second form of curve smoothing is provided, which does not pass through the data points. Untick Curves pass through vertex points
to use this option. Both forms of smoothing can be adjusted for amount of smoothing using the Smoothing amount option.

Line width-By default, lines are shown 2 pixels thick. Use the slider to change this any value between 1 and 25 pixels.

Arrows: Show forward arrow; backward arrow; arrows for each segment; middle of each segment-adds different kinds of
directional arrow heads to the line segments displayed

Coloured- By default, if you have multiple lines displayed, these are coloured according to the values in the Category field. You can disable this
and show only black lines by deselecting this option. 144/305



and show only black lines by deselecting this option.

Show markers- Hides or reveals the markers within the plotted lines (to resize markers, see Marker Options on the View Tools menu

Anti-aliased- Smooths the way the line is displayed

Show labels- By default, text labels will be shown beside each line if you have multiple lines. By de-selecting Show labels, these will only be
shown as you move the mouse pointer over a line.

The section on Time Series [215] also covers advanced options for the Time Series > Connect Markers functions, most of which are the
same in the Map View.

 

Back to Using the Map View [118]

User Guide Top [108]

Venn View

Venn View
Visualise intersections & overlaps among define data queries/subsets

 

The Venn View is based on the familiar Venn diagram. This view enables visualisation and filtering on overlaps between up to 5 different named
query data sets or subsets, which must first be pre-defined as Named Queries [10]. Notice that the number of records (or other measure
specified in Value/Function) not included in any selected set/subset is displayed upper left after the heading 'Outside'. In the HR example below
right, the median age of all the staff not included in one of the selected subsets is 42.

 

 

Venn View Toolbar

 

Venn View Toolbar View picker, Data Subset selector, Aggregate options drop-down and the show Details all function the same as they do
in all the views. View Toolbar options unique to the Venn View include the upper-pane View tools options, the Value: menu to specify the
values to be used, and the Sets: menu to specify the existing Named Query data subsets (maximum 5) for which Venn shapes will be
displayed.

Venn View Tools

Venn View > View tools

Preserve aspect - (default) locks the shape of each circle to remain a
circle. Unticking this option allows the Venn shapes to distort to reflect the
intersections.

Paint outside space - colours the background outside the Venn shapes,
which can improve visual impact especially if there are unselected records
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being displayed upper left under the heading 'Outside'

Play sounds - try it, you might like it

Show zero counts - displays set names and intersection counts even if
zero.

 

The rest of the options in the lower panes are common to the View tools
menus for all views and are documented here [207].

 

Venn View Value/Function:

 

Venn View > Value: {Function}

Use this menu to select the values for which the counts are displayed
inside the Venn shape representing each data set/subset. Notice that
text columns are not shown. 

Counts only are available for category values. If you select numeric
value, an additional Function menu appears allowing you to specify
the calculation applied. (see example of average age above right)

 

Find: shows subsets of field (column) names to shorten the list

Sort: orders the field (column) names to speed selection

Venn View Sets:

Venn View > Sets: (number of sets selected)

All of the Named Queries which define subsets are available
here for selection and display as Venn shapes, up to a limit of
5. Drag the hands at right upwards or downwards to re-order
the list.

 

 

Back to Views Reference [25]

User Guide Top [68]

Details View

Using the Details View
The Details View can display all of the information about a record in Omniscope, with very flexible branding, text formatting and image display
options. Can also be used as an editing form, allowing data entry and corrections by anyone with basic keyboard skills. Whenever a Details
View is open, the Details display for individual records will show in the open view, rather than the pop-up or Side Bar panel details displays.
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Details View Toolbar

The Details View toolbar contains a View Tools drop-down, a Highlight button (used to turn record highlighting in other views off and on)
and the Slideshow, Add to Basket and [X] Close view commands common to other views. For more detail on highlighting and configuring
slide shows, see Viewing Details and Highlighting [122].

Warning: If you have global record cycling enabled, and you turn off the Highlighting option, the record cycling will stop. To re-start record
cycling, hover your mouse on the barometer to expose the global automatic record cycling menu, and click on the green forward arrow to re-
start.

View Tools

The View Tools drop-down menu contains many flexible options for configuring the Details View display:

Show- defines what to display; images only, text only or both. When there is more than one image set configured, you can select which
images to show (they appear horizontally).

Show navigation controls- when ticked, displays a manual record-cycling slider only for the Details View. This is different from the automatic
record cycling which affects all views. Drag the slider forwards and back, enter a record number or use the green forward/back arrows. When
ticked, the Sync(hronisation) option keeps the record cycling in the that Details View on the same record as the global record-cycling.

Show as an editable form- when ticked, for each record, all fields are displayed in a single column with the values in individual text editing
boxes, as shown in the example above right. This mode is used to facilitate data entry and correction using a single, easy-to-understand
interface that anyone can use.

Number of text columns- drag the slider to the number of columns you want to use to display the text/field values you wish to show. The
default is two columns with coloured values following field names as shown in the example below:

 

 

Links- similar to the command used in other views, this displays a pick list is used to assign which values will be underlined and launch
associated links from the Details View. In the example directly above, the 'Issuer', 'S&P', 'Moody's' and 'Fitch' field values have been assigned
links, and therefore show underlined. In the Details View, at the top the top of the links menu is a Configure links buttons option:

As shown in the example above, for each link where the
'Button' option is ticked, and action button is displayed
in the Details View.

Ticking on the 'Link' option adds an underlined link
bearing the link name to the bottom of the display, as
an alternative to the button.
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Use the 'hand' drag handles to move Buttons/Links up
or down, re-ordering them in the display from left to
right as shown above.

 

Title Field- selects a field (column) value to display in the upper left-hand corner of the view window. If you display a field as a Title, remember
to untick the Title field in the fields pick list (see below) to avoid displaying the values twice.

Title Style- enables you to apply text styling (fonts, font face, colour and alignment) to the Title field display.

Fields- a pick list appears allowing you to tick/untick fields you wish to show/hide; drag the hands up or down to change the order (Note: you
will only see these when ‘Text’ or ‘Images and text’ is chosen in the ‘Show’ menu).

Show field names- when ticked (default) displays the field (column) names prior to the values. Untick to suppress the filed names.

Description field- selects a field (column) value to display at the bottom of all other fields. Used to display longer text entries that do not wrap
well if displayed in the columns with other, shorter field values. If you display a field as a Description, remember to un-tick the Description field in
the fields pick list (see above) to avoid displaying the values twice.

Description style- enables you to apply text styling (fonts, font face, colour and alignment) to the Description field

Colour by values- when ticked, colours category values according to the colours assigned to each value, and numbers/dates by the scale
reflecting the range of values (default : low=red to high = green). Text fields are always displayed in black.

Add Header/Background Image- used to include logos and other faded backgrounds in the display. These commands appear in several
views with otherwise blank backgrounds and are documented under the Page Menu [104].

The other commands on the Details View Tools menu are common to all views and documented under View Tools. [121]

View Controls- configuring the display layout

The layout and sizing of the image and text spaces in the Details View is controlled using a divider line which you can find by hovering the
mouse over the divider between image and text. When you do this, the frame divider will appear. Click and drag the divider to get the
proportion of image to text area you want. Click the frame divider switch button on the right when the divider appears and the orientation will
switch between horizontal and vertical.

Suggestion: Omniscope has powerful image re-sizing and management features. Be sure to experiment with allocating more space to the
images to optimise the display in the Details View

 

Back to Using Views [212] or Views Reference [109]

User Guide Top [108]

Web View

Using the Web View

Opening Static Web Views

The Web View is one of the 12 standard views available in Omniscope. It differs for the other views in that it is not intended to depict all of the
data in the data set. Instead, it is intended to broaden the reach of the .IOK/.IOM file to other related content and services available on the
web.

As with other views, you can add a Web View to the display by switching one or more existing views to be Web Views (by clicking the view
name and choosing Web View in the View Chooser) or by adding a new Web View to the display using Add view on the Main Toolbar

You can have any number of Web Views open, with each pointing to a different address (URL) on the web:
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The first time you open the Web View, it will show the Omniscope default static page (the Google homepage). "Static" means this view won't
update when you filter or navigate in Omniscope. Omniscope Web Views work just like web browsers. You can enter a different address in the
address bar, or follow the links on the page displayed to change the current page. You can resize the windows to be quite small. Omniscope
can switch the screen display of the web page to a style intended for small screen devices.

If you save the .IOK file and later re-open it, any static Web Views will re-open showing the same page that was showing when you saved the
file. There is no such thing as a "home page" with the Omniscope Web View. Instead, Google is the default page if you've never opened a Web
View before, and each Web View will re-open as it was saved.

Configuring Dynamic Link-based Web Views

A dynamic Web View is one that is automatically synchronised with the rest of Omniscope. When you select specific data in another
Omniscope view, the Web View will reload to show a relevant page as defined by the selected link. You can't enter a different web address into
a dynamic Web View. To change a dynamic Web View back to a static one, change Link or Web service to "(none)" in the View Toolbar.

There are two types of dynamic web view: link-based and web service-based. Both are used for showing web pages containing information
about a single record (link-based) or groups of records (web-service based). When you highlight a record in Omniscope, an open link-based
Web View will update to show the linked page for the highlighted record. If there is no record selected/highlighted in any Omniscope view, link-
based dynamic Web Views will remain blank.

In Omniscope, a highlight is set whenever you select a single record, such as a single row in the Table View. In the example below, selecting the
record of a specific casualty in Iraq displays a personal memorial page for that soldier in the link-based Web View:

 

 

To create a link like this in an Omniscope file, choose Web View> View Toolbar > Link > (Tools)/Add web link. This allows you to define
the link and associate that link with that Web View. You can administer all the links in your file from the top-level Settings > Links [227] menu. 

It is possible to define much more complex data-driven links. For example, you can use two or more field values as parameters in a link like this
one:

http://myIntranetServer/addressBook?firstName=[First Name]&lastName=[Last Name] 
where 'First Name, and 'Last Name' are fields in the data set.

Omniscope has a number of preconfigured links built in, which saves you having to figure out the link syntax for common websites offering
free web services. See Using Web Services in the Web View [228]

 

Back to Using Views [212] or Views Reference [109]
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Using Web Services in the Web View

Dynamic Web Views - Web Services

Web views are also used to display the results of dynamic requests for web services. Some free web services, such as YouTube and Google
Maps, are already configured. If your file includes a collection of video clip identifiers recognised by YouTube, selecting a clip from your
Omniscope 'video jukebox' will play the corresponding clip in a Web View as streamed from YouTube:

 

 

You can also add any custom Web Service to your file. As with Links, you must pre-define custom Web Services configurations using the Main
Toolbar Settings > Web Services menu, then use the Web View selector drop down to the right of the View Tools drop-down to link that
Web View with the selected web service.

Multi-input web services

Connections to web services that accept a series of inputs (or a table), rather than a single value/text string, are less easy to implement, since
they require a specific web server page implementation. Examples of multi-record Web Services already defined in Omniscope include popular
mapping services, such as Google Maps.

Multi-record web services links to Omniscope work by submitting an HTTP POST to the web service page containing a series of record IDs. This
is equivalent to submitting a form listing all the record IDs. This functionality allows you to program server pages that accept a list of record IDs
in an HTTP POST request and provides any further information associated with those records in HTML, in the HTTP response. You can also
configure the maximum number of records in a web service post (the default is 100). This allows you to restrict access to the server page to
only moderate requests, especially useful if allowing users to retrieve 50,000 price graphs at a time might be undesirable. At present, you can
only configure a single-parameter web service post. If you envision a solution that requires a tabular, multi-field post, please contact us.

We provide a simple example 'echo' page which can be used to test your configuration and to understand the results. This is the default page
when adding a Web Service. To see the test echo service, go to Settings > Web Services > Add web service and click OK without making
any changes to the defaults.

After adding a web service, depending on how it was configured, you may need to select it in the Web View using the Link > Web Service
selector to the right of the View Tools drop-down.
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Web Views pointing at Web Services rather than links will show all records currently included by your filters. If you then make a data selection in
another view (such as the Pie View), the Web View will show only the selected records. When you clear your selection, the Web View will return
to showing all the records included by your filters.

To use the Echo test, first filter down to, or select, no more than 100 records using Side Bar filters and/or using Select, Move & Keep power
query sequences in other views. Once the selected number of records falls below the threshold, Omniscope creates a form submission with
form keys "RECORD0", "RECORD1", "RECORD2" (etc.) and posts the form values to the configured server for the selected Web Service. You
will normally see the results of the POST returned in the Web View.

The Web View, like other views, is configurable using Report Pages. You can, for example, create a Report Page with 3 Web Views, and another
Report Page with just a Table View and one Web View, then switch between the two. Omniscope supports opening any number of views and
managing the positioning of these views through flipping individual panes using the 'flip' icon command on the view divider.

 

Back to Web View [119]
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Content View

Using the Content View
Add and display free HTML text, dynamic formulae and links to related web content

 

Note: This is a new view in version 2.5; this page is still under development
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View Toolbar

 

Like other View Toolbars, the left-most part of the Content View Toolbar contains the View and data Subset selectors, and the Aggregate
options. The View Tools drop-down begins with commands unique to this view, followed by commands common to all views.

To the right of the View Tools menu are the Format and Edit options drop-downs. Use of these is discussed in the sections below.

View Tools

 

Format options

 

Edit options
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Insert - Click to enter Edit mode, which reveals the Insert
drop-down containing options to insert a wide variety of
content inside the view display using the wizards to assist you

Commit - Once you have completed inserting content, click
to make your changes persistent in the file.  You can still
change the formatting of the content you have inserted.

Cancel - Reverts the content to the last committed state.

 

 

 

Functions

Record count

Web link

Web-based image

Link to file

Link to tab

Command link

Image
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Dial View

Using the Dial View
Adding typical 'dashboard' gauge-type displays and alerts

 

Note: This is a new view in version 2.5; this page is still under development
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View Toolbar

 

 

 

 

View Tools

 

Style Options

 

Range settings
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Alerts settings

 

 

 

 

Zones Settings

 

 

 

 

 

Value Options
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DataPlayer View

DataPlayer View
DataPlayers are standard .SWF Flash files which contain the data, multiple visualisations and intuitive query devices used to filter the interactive
display(s). For a general introduction to Visokio DataPlayers and how they are created and refreshed using Omniscope, please see the sections
on DataPlayers [193], Creating DataPlayers [23], and DataPlayer FAQs [229].

DataPlayers can be created in any size, using either tabbed or simultaneous 'dashboard' layouts and any of many different view
types. Interactive DataPlayers are exportable, universally-accessible Flash .SWF files for documents (PowerPoint, Excel and Adobe .PDF)
and/or web pages. DataPlayers can be exported from Omniscope files using Professional or Enterprise Editions either directly into documents
(with full interactivity), or as an HTML scripted target page, plus related Javascript, images and .SWF files within a single, uploadable folder, or
or as standalone .SWF files for refreshing exported DataPlayer data sets by overwriting already posted .SWFs.

The Omniscope DataPlayer View enables DataPlayers to be created and displayed on tabs within Omniscope files. Omniscope .IOK files should
be configured with dedicated tabs for one or more exportable DataPlayers. Whenever the data in the .IOK file is refreshed from its linked
source or edited from any tab, the DataPlayer(s) will be updated within their Omniscope tab(s) using the newly-refreshed data and the
persistent settings in the Views sub-menus.

The example below shows a tabbed configuration using each of the current views, one per tab. The Human Resources data set in the example
below is the same as that included in the embedded 'How to use Omniscope.iok' tutorial file's DataPlayer tab. The data describes 111
employees of a fictional company with more than 4 years seniority.
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Principal elements of all DataPlayers include:

View chooser buttons (tabbed display only) - each DataPlayer can contain multiple view types. Clicking on these tabs changes the view
type displayed, the order of which you can determine by changing the order of the view types in the Views drop-down menu. Simultaneous
'dashboard' display is another Appearance option.

Query devices - the Omniscope Side Bar filter devices and value colouring/ordering settings displayed when the DataPlayer View is opened are
replicated in the DataPlayer side filter panel. Like in Omniscope, clicking or sliding the filters in the side panel reduces the displayed record count,
as displayed in the barometer at the bottom.

Slider - often, there are more query devices on the side filter panel than can be displayed vertically. DataPlayers where this occurs display a
vertical slider to allow the user to access the query devices below the opening set.

Barometer - like Omniscope files, each DataPlayer displays a 'barometer' that indicates the number of records inside the DataPlayer, and the
subset of those which are displaying given the current filter settings

Details button - this button can be used at any time to display record (row) level values according to the settings for single and multiple
Details display.

Refresh button - like Omniscope files, clicking Refresh returns any filtered records to the visible data set, as confirmed by the barometer.

Within each view, drop-down menus can be configured to give users choices of fields (columns) to display, or no options at all. 

Using the menu items available on the DataPlayer View Toolbar (see below), you can extend and refine the opening DataPlayer by adding
other DataPlayer view types, and changing the Omniscope Side Bar filter settings to change the query devices available the filter panel
generated in the DataPlayer(s) you are creating.

WARNING: If you have more than 10-15,000 records in the 'Filtered data (IN)' data set when you first open a DataPlayer View, current
limitations in Flash may interfere with full rendering of the initial DataPlayer. It is best to first define either an Aggregation or a Named Query (or
both) such that the number of records to be encapsulated in the initial default DataPlayer is reduced to under about 10,000 (depending on
row count and data complexity).

CAUTION: The DataPlayers displayed in the DataPlayer View are fully interactive, and thus it is possible to set filters, change selection drop-
downs etc. just as end-users of the DataPlayer will. However, these changes are not persistent. The next time the DataPlayer View is opened
and the DataPlayer re-generated, all settings will revert to the settings established in the View Toolbar Views settings menus, as described
below.

DataPlayer View Toolbar Menus

The DataPlayer View Toolbar includes options to create exportable DataPlayers like the example above, using defined subsets, or even all
of your data [194].

 

 

The DataPlayer View Toolbar View chooser, Data Subset selector and Aggregation drop-down menus work as they do in all Views. The
functions of the other View Toolbar drop-down menus are documented below.

 > View Tools

The bottom five commands on the View Tools drop-down are common to all Views and are documented here. Unlike most other views, View
Tools > Capture View offers only the option of saving the DataPlayer on a new tab. Options to export DataPlayers to documents and web
pages (with full interactivity) are located on the Save/export sub-menu.
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Create skin element > Add skin -  DataPlayers are highly customisable. All of the principal elements of DataPlayers use skin elements that
can be replaced with skin elements of your own creation. If you wish to add skin elements of your own to a file, select the type of skin element
that you have created, give it the name you want to appear in the menus, select the source file containing your version, and set the Inner and
Outer Frame limits. For more information on creating and using your own skin elements, see the KnowledgeBase article on modifying and
creating skins [230].

 

 > Views

All of the settings governing adding additional view types and the view-specific configurations of DataPlayers are on the Views drop-down
menu.

 

Opening View:

 

 

One of each View Type added with names:

 

Add, change, re-order (drag the 'hands' up or down) or remove DataPlayer view types from your DataPlayer using the commands on the
Views drop-down menu.

CAUTION: It is good time-saving practise to re-order the DataPlayer view you are working on from last to first in the list. This is because each
time you click 'Apply' or 'OK', the DataPlayer will be updated/re-generated with new settings, and the result will open to the first view/tab. Once
all the views have been fully configured, you can re-order the views to suit your readers.

The Edit sub-menu commands (including re-naming each view) specific to each view type are documented on pages accessed from the links
below (or from the User Guide DataPlayer View sub-menu links at the upper left of this page).

> Views > Edit command sub-menus

 

Bar View [195]

Pie View [196]

Graph View [197]

Table View [198]

Tile View -
dynamic [199]

Tile View- static
[200]

Map View [201]

Details View [202]

 

 

More view types are in development and will be added to future versions of Omniscope. Over time, the view types available in exportable Flash
DataPlayer format will approach those available in the Omniscope project files. If you have urgent particular needs for evolution or addition of
view types, please contact us [86].

 > Details

Regardless of the number of view types in a DataPlayer (either in tabbed or simultaneous layout), options to display user-selected subsets of
the records, either singly or in groups, for all of the views in a given DataPlayer are set using the Details drop-down menu.
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Individual record (row) display options:

(None) - no details display for individual records
Pop-up details - (the default) pressing the Details button with a single
record showing, or clicking on markers or rows corresponding to a single
record will bring up a configurable secondary details display on top of the
DataPlayer 
External link - a pre-defined or possibly parametric (data-driven) link to a
separate web page will be used to display details or supplementary (usually
hi-res) images

Edit individual details options - if 'Pop-up details' has been chosen, a
three-tabbed options dialog will appear, documented here [231].

Multiple record (row) display options:
Show multiple in table - use expandable table view secondary details
display for multiple record selections.

Show multiple with forward/back - show 'card-deck' style secondary
display enabling users to page through the pop-up details display for all the
records selected.

Edit multiple details options - depending on which option for multiple
record display is chosen, a tabbed options dialog will appear, documented
here. [231]

 

 > Appearance

The options governing the overall look and feel of the DataPlayer outside the individual view types are accessed from the Appearance drop-
down menu.

 

Tabbed Views - display all one view at a time with buttons to switch views.
Simultaneous Views -  a 'dashboard' display of all views simultaneously.
Layout views vertically - modifies the default layout for simultaneous
'dashboard' DataPlayers (use the Size setting to increase the size of the
DataPlayer for 'dashboard' views).

Filter position - sets the position of the filter panel and query devices
within the DataPlayer.

Size - use sliders to set the width, height and filter panel width in pixels.
Styles - allows you to modify and save a set of skin colouring settings that
match your organisations standards, or experiment with pre-configured
options.
Colours - allows you to individually specify colouring of all skins. You can
save your own set of selections as your own Style and add it to the Style
menu.
Skin elements - allows you to select different, non-default skin elements
(Frames, Filters, and Buttons) from drop-down lists.
Components - options to change the functional  look and feel, text strings
fonts and font colours, etc. associated with various components.

 

Configuration sub-menus for Size, Styles, Colours, Skin elements and Components options are further documented here [232].

 

Record cycling - DataPlayers can be animated to 'step through' the highlighting of individual records, displaying Tooltips in some views

Load links in new page - if you have selected Individual details display option External link, tick this option to display the results of the link
in a new tab of your readers' default external browser.

 

 > Save/export

DataPlayers are separate Flash .SWF files which can be exported from Omniscope and inserted in documents and web pages with full
interactivity. To use the document export options, your machine must have the relevant document-creation applications installed; MS
PowerPoint and Excel, and either Adobe Acrobat Reader (free) or a .PDF Publisher. 159/305



PowerPoint and Excel, and either Adobe Acrobat Reader (free) or a .PDF Publisher.

 

Save standalone .SWF - exports just the main .SWF file, which can be uploaded with
the same name to replace an older online version with a new version containing new
data or modified configuration.
Save for web - exports an model .HTML file containing <script> tags referencing a
collection of files, image folders and scripts and the related, uploadable folder. All you
need to do is paste in the <script> text and insert the <object> tags positioning the
main .SWF file in the folder on the display page.
Insert into PowerPoint - inserts the DataPlayer into a new or existing PowerPoint
slide (only displays when presentation is opened in Slide Show mode).
Insert into Excel - inserts the DataPlayer into a new or existing Excel workbook tab.
Insert into .PDF - inserts the interactive DataPlayer into an Adobe .PDF document.

 

Publish on my.visokio.com - you can post a DataPlayer on a blank page hosted by Visokio, then reference this page from your blog or send
a link tot he page to your readers by e-mail.

 

More information on posting DataPlayers online [233]

 

More information on inserting DataPlayers in common documents [234]

 

Back to Views Reference [25]
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DP Bar View

DataPlayer Bar View
Editing persistent/default settings for Bar View DataPlayers

 

 

DataPlayer View: View Toolbar > Views > Edit menus

 

 

General tab
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Fields tab
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Colours/Fonts tab
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DP Pie View

DataPlayer Pie View
Editing persistent/default settings fro Pie View DataPlayers

 

DataPlayer View: View Toolbar > Views > Edit menu
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General tab

 

 

Fields tab
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Fonts tab
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DP Graph View
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DataPlayer Graph View
Editing persistent/default settings for Graph View DataPlayers

 

DataPlayer View: View Toolbar > Views > Edit menu

 

 

General tab

 

 

Axis/Gridlines tab
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Markers tab
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Fonts tab
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Time Series/Lines tab
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DP Table View
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DataPlayer Table View
Editing persistent/default settings for Table View DataPlayers

 

DataPlayer View: View Toolbar > Views > Edit menu

 

 

 

General tab

 

 

Columns tab
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Fonts tab
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Expansion tab
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Expansion images tab
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Expansion fonts tab
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DP Tile View-dynamic

DataPlayer Dynamic Tile View - Re-sizable solid tiles
Editing persistent/default settings for Tile View (re-sizable) DataPlayers

 

DataPlayer View: View Toolbar > Views > Edit menu
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General tab

 

 

 

Fonts tab
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DP Tile View-static

DataPlayer Static Tile View - non-resizable image tiles
Editing persistent/default settings for Tile View (static) DataPlayers

 

DataPlayer View: View Toolbar > Views > Edit menu
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The non-resizing (with images) Tile View has only one options tab:

Name - the name you give will appear on the tab of the
DataPlayer corresponding to this view.

Tile Contents - specify either images from defined image
 sets or values from the data set to appear inside the tiles.
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DP Map View

DataPlayer Map View
Editing persistent/default settings for Map View DataPlayers
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Editing persistent/default settings for Map View DataPlayers

 

DataPlayer View: View Toolbar > Views > Edit menu

 

 

General tab
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Markers tab

 

 

Fonts tab
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DP Details View

DataPlayer Details View
Editing persistent/default settings for Details View DataPlayers
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DataPlayer View: View Toolbar > Views > Edit menu

 

 

General tab

 

 

 

184/305



 

 

Images tab
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Fonts tab
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Back to DataPlayer View [54]

User Guide Top [68]

DP Detail Displays

Editing DataPlayer Details Windows
Setting single and multiple details window display options
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There are several options for configuring the display of the Details display windows that underlie each DataPlayer. Details display windows
are not the same as Details View DataPlayers. Every DataPlayer view type includes a subsidiary Details window that responds to user clicks on
the Details button.

Individual - refers to details for one record (row) only

None - no details display window for individual records

Popup details - details window will open on top of DataPlayer,
configurable to be slightly smaller...display cannot be larger than DataPlayer

External link - allows you to use an external web page to display details
(and hi-res images, etc.) for each record. Link must already be
defined using Main Toolbar: Settings > Links > Add web link

Edit individual details options [235] - all settings controlling the display
of details for individual records (rows)

Multiple - refers to details for selected subsets of records (rows)

Show multiple records in a table [236]-multiple record details in an
expandable table. (similar to DataPlayer Table View)

Show multiple records with forward/back options [237] - multiple
record details in a single window with forward/back paging through records

Edit multiple details table options - all settings controlling the display of
multiple records according to the choice of either single window or
expandable table display.

 

 

If you specify External link, then click on Edit individual details options, you will see a list of the links already configured in the file:

 

DataPlayer View Toolbar: Details > Edit individual (record) detail options   

If you choose Popup details as the single record details display type, then click Edit individual details display options, you will see a three-
tabbed dialog containing all the settings

 

General tab

 

 

Images tab

 

 

Fonts tab
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General tab

The General tab includes

 

 

Template settings determine the layout of space in the
details display window

 

Standard -

Letterbox -

Image only -

No image -

Vertical -

Video -

 

 

Fields to show:
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Images tab
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Individual fonts tab

 

 

 

(back to top) [238]

DataPlayer View Toolbar: Details > Show multiple records with forward/back options 
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General tab

 

 

 

Templates are the same as those for individual record displays

 

Fields to show drop-down selector works the same as for individual record details display (see above)

 

Images tab
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Fonts tab

 

 

 

(back to top) [238]

DataPlayer View Toolbar: Details > Show multiple records in a table > Edit multiple table options 
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General tab

 

 

Columns tab
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Fonts tab

 

 

Expansion tab
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Expansion images
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Expansion fonts

 

 

(back to top) [238]
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DP Appearance Display
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DataPlayer View Toolbar > Appearance > sub-menu options
Configuring Size, Styles, Colours, Skin elements and Component options

 

 > Size

 

 

 

 

 

 > Styles

 

 

 

 > Colours
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Skin Elements

 

 

 

 > Components

 

 

 > Barometer
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 > Buttons

 

 

 > Filters

 

By default, the numbers or dates appear above the sliders. If you have short integer numbers, and mor horizontal space, you can un-tick the
Text always above sliders option and the values will appear at the ends of the sliders. (not recommended for dates)

Relatively large data sets may not be able to synchronise the display with movement of the slider in real time. Use the Sliders filter on
release option to de-couple movement of the slider from the up-date of the visualisation, improving the user experience.
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 > Global colour options

Sets colour options across all view types in the DataPlayer

 

 

 > Scroll bars

 

 

 > Tooltips
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The column(s) to show as tooltips are currently a global Omniscope setting available from Settings > Tooltips (2.5)

 

 

 > View Tabs

 

 

 

 

Back to DataPlayer View [54]
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DP Document Display

Displaying DataPlayers inside Documents
Inserting DataPlayers in common document format files - with full interactivity
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DP Web Display

Displaying DataPlayers on the Web
Posting and refreshing DataPlayers to your own or Visokio-hosted web pages

 

There are currently three options for exporting DataPlayers for display on the web:

Publish on my.visokio.com - If you do not have your own website, or you cannot edit the HTML on the page you wish to display the
DataPlayer on, you can use a hosted Visokio.com page, and link to your DataPlayer page from your blog, or send the link to your users
via e-mail.
Save for web - If you have your own web site pages and administrative rights to add or modify pages, choose the Save for web
option the first time you publish your DataPlayer. You will be given a page of HTML and a related folder to upload (see below).
Save standalone .SWF - If you just want to test a DataPlayer, or are updating a main .SWF (same name and size) that you have
already published using fresh data and/or modifications to the views or settings, you can export just the main .SWF and upload it to
replace its predecessor. 

Save/export > Publish on My Visokio.com

If you choose this option, you will be asked to assign a password to the page/file and once your DataPlayer has been successfully uploaded,
you will see the link to the page displaying your DataPlayer.

 

You can use the resulting link in blogs and e-mails to display a blank
web page with just your DataPlayer on it:

 

http://my.visokio.com/my/How_to_use_Omniscope/ [239]

 

You can update this online DataPlayer at any time by saving a new
file to the same location with the exact same name (you will be
asked for the password).

 

You cannot delete the page or the file, but you can upload a blank
or re-directing version if you wish to display elsewhere and cannot
recall the links you distributed.

 

Save/export > Save for web

Choosing the Save for web option exports a blank .HTML file and an associated folder containing some 'helper' files and image folders.
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Choose the name of the DataPlayer save for web file carefully,
avoiding spaces and illegal characters, and using caution with upper
and lower case naming. Omniscope will check for spaces and illegal
characters, but preserve case in the names.

Once you approve any changes to the name, Omniscope will save
an .HTML page and an associated folder of files and images with the
same name to the location you indicate.

The blank HTML page can be used as a starting point for creating
the page on which the DataPlayer will display, or the code between
the <script> tags pasted into an existing display page. The folder of
files should be uploaded to the web server preserving the name and
the same relative position to the display page (immediate sub-
directory).

 

The exported Save for web folder contains any image folders (containing all the image files) used/referenced in the DataPlayer, the main .SWF
DataPlayer file (with the extension _main.swf) and some helper files used to smooth the loading and display of the DataPlayer in site
visitors' browsers.

 

 

The easiest way of publishing the main.swf DataPlayer file on your intended display page is to use use your CMS to position the Flash file and
generate the object tags. Alternatively, you can add hand-coded <object> tags following the model code below. Be sure to note the size of
the DataPlayer and provide an appropriate space in the page.

 

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0"
 width="750" height="290"><param name="movie" 
value="/files/How_to_use_Omniscope_files/How_to_use_Omniscope_main.swf"
 /><param name="quality" value="high" /><param name="menu" value="false" /><param name="wmode" value="" /><embed
src="/files/How_to_use_Omniscope_files/How_to_use_Omniscope_main.swf"
 wmode="" quality="high" menu="false" pluginspage="http://www.macromedia.com/go/getflashplayer [240]" 
type="application/x-shockwave-flash" width="750" height="290"></embed></object>

 

ADVANCED: For advanced users, the blank HTML page exported together with the folder for upload contains the following code, reflecting
the names you assigned when you saved the DataPlayer and when you created any associated image folders. If you wish to use scripts, you
can paste this code into the various sections of your page.

<HTML>
<HEAD>
<script src="How_to_use_Omniscope_files/How_to_use_Omniscope_AC_RunActiveContent.js"
 type="text/javascript"></script>
<meta http-equiv=Content-Type content="text/html";  charset=ISO-8859-1">
<TITLE>Visokio Omniscope - How_to_use_Omniscope</TITLE>
</HEAD> 204/305



</HEAD>
<BODY align=center topmargin=0 leftmargin=0 marginheight=0 marginwidth=0>
<center>
<div style='margin: 10 10 10 10'>
<!-- using adobe javascript to pre-activate control -
 needs the How_to_use_Omniscope_files/How_to_use_Omniscope_AC_RunActiveContent.js script file -->
<script type="text/javascript">
    AC_FL_RunContent(
        'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,47,0',
        'width','750',
        'height','290',
        'id', 'preview',
        'quality', 'high',
        'bgcolor', '#FFFFFF',
        'FlashVars', 'movieToLoad=How_to_use_Omniscope_files/How_to_use_Omniscope_main.swf',
        'movie','How_to_use_Omniscope_files/How_to_use_Omniscope_preloader'
    );
</script>
</div>
</center>
<!-- Javascript to get round IE "Click to activate and use control" -->
<script type="text/javascript" src="ieupdate.js">
    theObjects = document.getElementsByTagName("object");
    for (var i = 0; i < theObjects.length; i++) {
    theObjects[i].outerHTML = theObjects[i].outerHTML;
}
</script>
</BODY>
</HTML>

Save/export > Save standalone .SWF

If you have already published a DataPlayer and you wish to replace it with a more current .SWF containing refreshed data, or you wish to test
the performance or other features, you can choose to export just the main .SWF file. Choose the name carefully, avoiding spaces and illegal
characters, and using caution with upper and lower case naming. Omniscope will check for spaces and illegal characters, but preserve case in
the names. If you are replacing an existing .SWF on the site, be sure to use the exact same name with the suffix 'main'. In the example above,
the relative location and name of the file to be overwritten on your web server is shown following the code 'movieToLoad=

How_to_use_Omniscope_files/How_to_use_Omniscope_main.swf

 

Note: to display a standalone .SWF locally, you may need to associate the .SWF file extension with your browser.

 

 

Back to DataPlayer View [54]

User Guide Top [68]

Commands Reference

Main Toolbar Commands Reference - Version 2.5+ 
What does this command/option do?

Below is an index to the version Main Toolbar command menus starting from version 2.5. Click on the anchor links below to jump down to the
sub-section containing the command(s) you are seeking. If you are still using version 2.4 or earlier, the 2.4 Commands Reference is here [241].
For information on commands and options related to specific Views and View Toolbars, please consult the Views Reference. [25]

Accustomed to the version 2.4 menus?

If you're using 2.4, please see the command reference for 2.4 [241].  If you're used to Omniscope 2.4, and can't find a command in 2.5, see
this guide to changes [242].
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Version 2.5 and later

 

 

 

 

|File [55]|Data [56] |Tab [57] |Layout [58] |Toolbars [59] |Settings [60] |Help [61]|

File menu [55] 

New File [55]

Open file [77]

Connect to database [78]

Open image collection 
Open folder of files
Open online source
Open map
Open demo

-----------------------
Save
Save as...
File security
About this file
Help with this file
-----------------------
Export
Save screen image
Print
Print as PowerPoint
Print as PDF

------------------------
Close
------------------------
Exit

Data menu [56] 

Manage fields
Add field (column)
Add records (rows)
Delete selected records
Formulas
---------------------
Reload from file
Refresh from source
Automatic refresh
Edit source
----------------------
Merge
Repeat last merge
Import from Bloomberg
----------------------
Replace within values
De-pivot
Re-pivot
Scramble
-----------------------
Undo edit
Redo edit
Undo/redo history

Tab menu [57] 

New [57]

------------------------
Commit changes 206/305



Commit changes
Commit changes for all
------------------------
Revert changes
Revert changes for all
-------------------------
Rename
Duplicate
--------------------------
Delete
Delete others
Go to
--------------------------
Tab settings

Layout menu [58] 

Mode selection: [58]

Working mode
Presenting mode
Reporting mode
Dashboard mode

--------------------------
Edit modes
--------------------------
View spacing
Title
Title style
--------------------------
Annotation
Annotation style
--------------------------
Background image
Header image
Center image
--------------------------
Import PowerPoint slide
Clear layout
--------------------------
Styles
Configure styles 

Toolbars menu [59] 

Toolbar visibility:
[59]

Main toolbar
View toolbars
View headers
View data toolbars
Sidebar toolbar
Details toolbar
-------------------

Left sidebar
Right sidebar
Freeze sidebar width
Auto-hide scrollbars
---------------------------
Cycling toolbar
Tab bar
Floating tab navigator
Next/previous buttons
----------------------------
Toolbar settings 

Settings menu [60] 

This tab: [60] 
Brushing enabled
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Brushing enabled
Details
Tooltips
Value colours
Colour ranges
Advanced tab settings
-----------------------------
This file:
Images
Links
Web Services
Branding
Advanced file settings
----------------------------
Application-wide:
Language
Window size
Enterprise (Enterprise only)
Advanced

Help menu [61] 

Create Help Page [61] (screen)
Open user guide file
Video tutorial
Online help
-----------------------------
Visit Visokio website
Contact us
Error reporting
-------------------------------
Automatically check for updates
Check for software updates now
-------------------------------
About
License agreement
Licensing and activation

 

 

Back to Main Toolbar [13]

User Guide Top [68]

File Menu

File > Menu Commands
Version 2.5+

 

File > Menu: groups commands related to importing data from a file, table(s)
of a relational database, online 'cloud', a folder of files/documents, our online
map library or a folder of images.

New file - opens a dialog where you can specify how many rows and
columns you need to start with. Generally, you should start small, except if
you are planning to cut-and-paste data into the new Omniscope file, in which
case you must  specify enough rows and columns to receive the paste.

Open file - launches the Open file dialog [77], which looks like a W indows file

browse w indow, but has some addit ional features and opt ions on the right side.

Navigate your directory structure and find the file you w ish to load, be it  an exist ing

Omniscope .IOK file, or a supported delimited data file; Excel .XLS, .CSV (comma

separated value) or other common data file formats such as .TSV, .TXT etc.
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Connect to database - launches the Database Connection Wizard [78]

 

 

 

 

 

 

 

Back to Commands Reference [27]

User Guide Top [68]

Open file

File > Open file...Using the Open Data File Dialog
Opening and importing data from files

 

Clicking on File > Open file brings up the File open dialog, which looks similar to a Windows file browse dialog:

 

File > Open dialog: Most source data files in Excel .XLS, .CSV,

.TSV and other common delimited text data file formats w ill open

direct ly in Omniscope. The   Help icon in the upper right

displays a format guide [243] for import ing spreadsheet files. Always

confirm that your spreadsheets conform to this simple layout

before trying to open them in Omniscope. If you have problems,

such as all the values appearing in one column, you may need to

change the delimiter or rename a tab-delimited file extension from

.TXT to .TSV. If only some of the data filelds (columns) have not

separated cleanly, you can use the Expand or Collapse Values 

funct ions in the Table View Tools [38] menu to separate data into

more columns or combine data from mult iple columns into fewer

columns.

 

If you encounter problems import ing data from one or more files,

see also the KnowledgeBase sect ion on import ing and export ing

data to and from Data Files. [79]

Opening remote data files

Opening remote data files over the web -
If the source data file you want to open is not on your machine 209/305



 

If the source data file you want to open is not on your machine

or local network, you can use the Open from Web button to

specify the exact locat ion (URL) of the data file you w ish to

import.

 

 

Customise data import

 

Adapting to regional and non-standard data
formatting -

If you are repeatedly using/import ing other peoples'

spreadsheets, you can depart from the recommended standard

spreadsheet layout somewhat by t icking the Customise data

import behaviour opt ion and providing Omniscope w ith

addit ional information about the layout of the data you are

import ing. For example, sometimes you may have a .CSV, .TSV or

Excel .XLS file which does not have the column headers on the

first row. W ithout customisat ion, Omniscope w ill assume the first

row contains headers, and include the actual column headers as

the first row of data. To skip any number of redundant upper 

rows on file import, use the Skip first ?? rows box to enter the

number of redundant (usually formatt ing) rows in your data file to

be skipped before trying to read in the headers.

International data issues
Data File delimiters - the .CSV file extension stands for "Comma Separated Values", which means the cells in each row of the data table are separated by
the comma character. However, if you are in a region that also uses the comma for the decimal point (e.g. several European countries, such as France) some
versions of Excel create .CSV files that use a semicolon as the separator character. Sometimes these files are saved w ith a .TXT rather than .CSV extension,
even though they are mult i-column tables. Omniscope is unable to detect these situat ions automatically. If you open such a file in Omniscope, your data w ill
very clearly be wrong, w ith most columns appearing as text w ith semicolons. To import this kind of file, use the Customise data import option dialog to
change the Separator character  to a semicolon " ; ". Pipe "|" delimited files can also be imported, but first you must re-save the file w ith a .CSV extent ion,
then use the opt ion that appears to change the delimiter to "|".

Dates & Numbers -  If you are running on W indows, when import ing data that is in a delimited  text format which includes Excel, CSV and TSV (tab-
separated values), Omniscope w ill use your W indows Regional Sett ings to try to automatically recognise data. For example, for a PC w ith United States
Regional Sett ings, Omniscope w ill recognise "5/13/2005" as a date and "1,500.5" as a number. For some internat ional users, however, this may not work as
expected and the result  w ill be an import of all columns as type Text (shown either as mult i-coloured Category columns or white Text columns in Omniscope).
If this occurs, you can usually manually convert numbers and dates & t imes fields using the Data > Manage fields dialog. for more information on formatt ing
dates & t imes, and dealing w ith t ime zone issues, see the sect ion on Dates & T imes.

If you know your data has been formatted for a different region, change the Locale drop-down accordingly. For example, if you live in Germany but have
received a .CSV from an American customer, you should choose 'English (US)'. If you find Omniscope gets things wrong and your data is incorrect ly
recognised, you can disable auto-detect ion of dates and numbers by deselect ing the two Recognise...checkboxes. All fields w ill open as Category or Text
data and their text values w ill be preserved. See the KnowledgeBase sect ion for more on information on dealing w ith Internat ional data issues. [244]

Importing XML files
Import ing .XML files which have already been transformed to Visokio .XML Schema [245] is the same as opening a .CSV. 
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Transforming XML into Omniscope Schema -

If your .XML file conforms to another schema, then you must

prepare an .XSL Transform  [246]file, t ick Customise data

import  and specify that file to transform the non-Visokio XML file

to Visokio XML Schema for import. Your .XSL Transform stylesheet

can be accessed from any locat ion, including the web, using the

Enter web address (URL) opt ion to specify the online locat ion of

the .XSL file.

 

Note: if your XML data set is not already in a tabular structure,

you must array it  into a tabular structure using your XSL file.

 

 

 

Back to File > Menu [55] or Commands Reference [27]
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Connect to database

File > Connect to Database...Using the Database Connection
wizard
Connecting to relational databases using SQL and ODBC or JDBC

Omniscope can connect to and import data from any relational database that supports common protocols like ODBC and JDBC. The Database
Connection wizard guides you through the process of connecting and importing your data, and saving it as a new Omniscope file. Your file will
remember its source(s), and on refresh re-execute the embedded SQL statement to re-generate the reporting view/table and repeat any
subsequent merges with other files either on opening, or on demand. 

The Omniscope Database Connection wizard lets you define a connection and pass any standard SQL expression that results in a single 'flat'
table. If you do not have authorisation to execute SQL statements, or don't know the SQL required to generate the table you want, your
Database Administrator may have to create the connection in the wizard and/or create the appropriate reporting view(s).

Some organisations also have additional high-performance analytical and reporting databases that pre-prepare data for reports by performing
joins, aggregations, sorts and scans on data assembled from multiple transactional databases. In general, Omniscope interacts with 'business
intelligence' analytical databases in exactly the same way as transactional database views/tables. For more technical information, see the
Database Connections [80] section of the KnowledgeBase.

Using the Database Connection Wizard

Clicking on File > Connect to database launches the Database Connection wizard. The wizard guides you through a six-step process for
defining a linked data source from a relational database view/table. You will need to know the type of database and its connection details. Using
the Database Connection wizard, you enter the connection details for your database and choose which database table or reporting view you
wish to retrieve data from. By default, this will create a persistent linked data source relationship between this database table/view and
the Omniscope file.

 

Connection type: Select the type of connection you are
creating from the options currently available. 

 

ODBC - use this option to connect to defined data
sources, like MS Access.  Can also be used to connect to
spreadsheets for testing.
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JDBC - use with databases other than MS SQL Server &
Oracle if you have the JDBC driver installed.

 

MS SQL Server - use this option with MS SQL Server
2000. If you have 2005 or 2008 use the generic JDBC
option.

 

Oracle - use this option with all versions of Oracle
databases

 

Detailed examples of each type of connection are available
in our KnowledgeBase. [247]

 

 

Database server:

 

 

Authentication:
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Choose table:

 

 

Customise SQL:
Omniscope can import the results of any SQL statement
that returns a table. The default SQL statement imports
everything from the selected data table or reporting view.

If you know SQL and your database, you can modify the
default statement and your statement will be saved and re-
evaluated each time the file is refreshed.

 

If you have several related queries, you may want to save
them in a text file and paste them in with minor variations.

 

Note: To modify the SQL statement programatically using
Enterprise XML actions for automated refresh and
distribution using the Scheduler watch folder [248], please
contact us.

 

 

Specify a title:

 

Back to File > Menu [55] or Commands Reference [27]

User Guide Top [68]
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Data Menu

Data > Menu Commands
Version 2.5+

 

Data > Menu: groups commands for managing the underlying tabular
data set in the open file, including adding fields (columns) and records
(rows), creating formula fields, refreshing the data from source(s),
merging in data from other sources, etc.

Manage fields -

 

 

 

 

 

 

 

 

 

 

 

Back to Commands Reference [27]
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Tab Menu

Tab > Menu Commands
Version 2.5+
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Tab > Menu: groups commands providing options for creating new tabs, for managing
the options to commit or revert changes you have made to the configuration of tabs,
deleting tabs and managing tab settings.

New - provides options for creating a new tab. There are many options and settings.
This same dialog is also available under the drop down to the left of the "+"at the
rightmost end of the Tab Bar where all the tabs are displayed. More detail on options for
creating new tabs.

 

 

 

 

 

 

 

 

 

 

 

 

Back to Commands Reference [27]
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Layout Menu

Layout > Menu Commands
Version 2.5+
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Layout > Menu: groups commands governing the formatting and annotation of
each tab.

Display mode options selector: use these to quickly change the formatting of
each tab for diffferent purposes. (the first two options also appear on the far right
of the Main Toolbar for quicker access.
Working mode -
Presenting mode -
Reporting mode -
Dashboard mode -

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Back to Commands Reference [27]
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Toolbars Menu

Toolbars > Menu Commands
Version 2.5+
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Toolbars > Menu: Groups commands governing the visibility of various toolbars and
other on-screen aids
Main Toolbar - untick to hide the main toolbar on a given tab, this is done automatically
in some display mode layout options, like reporting Mode.

 

 

 

 

 

 

 

 

 

 

Back to Commands Reference [27]
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Settings Menu

Settings > Menu Commands
From version 2.5

217/305



 

Settings > Menu: groups commands setting options at Tab level, File level, and
Application-wide level.

This Tab:
Brushing enabled - 'brushing' or fading is an option that greys-out unselected records in
Views on a given tab. Click to toggle this setting on or off for a given tab.

Details - 

 

 

 

 

 

 

 

 

 

 

 

 

Back to Commands Reference [27]
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Help Menu

Help > Menu Commands
Version 2.5+
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Help > Menu: groups commands and links to online resources that
can help you make the most of your Omniscope installation.
Create help page - opens the dialog used to prepare and edit the
file-specific help screen for users/recipients of the file. More detail on
creating help screens for your files is here.

 

 

 

 

 

 

 

 

 

Back to Commands Reference [27]
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Change List: 2.4 to 2.5

Mapping 2.4 to 2.5 commands & dialogs
Where did that command go?

 

This page lists Main Toolbar Command menu items in Omniscope 2.4 which have been moved as of version 2.5.

The old 2.4 command menu name/location is shown like this.  The new 2.5 command/location is shown like this.

Commands whose names/locations have not changed are not listed here. 

For the full list of commands, see the Commands Reference sections for version 2.5 [27]+ or 2.4 and previous [241].

 

|File [249]|Edit [250] [250]|Tools [251] [251]|Reports [252] [252]|Page [253] [253]|Appearance [254]|Help
[255]|

Omniscope 2.4 File menu

Demo files   File > Open demo

Import into current file:

Reload data from file   Data > Reload from file
Refresh data from source   Data > Refresh from source
Edit data source   Data > Edit source
Update for new data source   Data > Edit source 219/305



Update for new data source   Data > Edit source
Import query from XML file   Queries > Import/export XML query file
Import references into basket   Replaced with linked text search devices
Merge data from another file   Data > Merge
Repeat last merge   Data > Repeat last merge
Import fields from Bloomberg   Data > Import from Bloomberg

Save IOK   File > Save

Omniscope 2.4 Edit menu   Data menu

Manage fields (columns)   Data > Manage fields
Add field (column)   Data > Add field (column)
Add records (rows)   Data > Add records (rows)
Delete selected rows   Data > Delete selected records
Replace within values   Data > Replace within values
De-pivot data   Data > De-pivot
Re-pivot data   Data > Re-pivot
Undo edit   Data > Undo edit
Redo edit   Data > Redo edit
Undo/redo history   Data > Undo/redo history

Omniscope 2.4 Tools menu   Settings menu

Automatic refresh   Data > Automatic refresh
Language   Settings > Language
Enable brushing   Settings > Brushing enabled
Record cycling   Toolbars > Cycling toolbar
Show details using   Settings > Details
Tooltips   Settings > Tooltips
Links   Settings > Links
Web services   Settings > Web services
Images   Settings > Images

Advanced Tools:

Edit publishing settings   Settings > Advanced file settings > Publishing settings
Start Scheduler   Settings > Enterprise > Scheduler
Edit Enterprise action descriptor   Settings > Enterprise > Edit Enterprise action descriptor
Application-wide settings   Settings > Advanced
Show virtual keyboard alongside text fields   Settings > Advanced > Miscellaneous > Virtual
keyboards
HTTP proxy settings   Settings > Advanced > HTTP proxy settings 
Auto-convert large category fields to text  Settings > Advanced file settings > Auto-convert
text fields

Omniscope 2.4 Reports menu   Tab menu

Page: Rename   Tab > Rename
Page: Delete   Tab > Delete
Page: Delete others   Tab > Delete others
Export XML query file   Queries > Import/export XML query file
Administer all: Delete all pages   No longer available
Create page: From current Omniscope configuration   Tab > New > From current layout (or click the +
button next to the tabs)
Create page:Text only   Tab > New > Text-only
Create page: From image or PowerPoint slide   Tab > New > From image
Navigation: Start   No longer available
Navigation: Next Page   No longer available
Navigation: Previous Page   No longer available
Navigation: Go to page   Tab > Go to 
Navigation: Exit Report   No longer available
Show report tabs   Toolbars > Tab bar

Omniscpe 2.4 Page menu  Layout menu

Reset layout   Layout > Clear layout
Remove all views   Layout > Clear layout
Page margin   Layout > View spacing
Add/Change background image   Layout > Background image
Add/Change header image   Layout > Header image
Add/Change centre image   Layout > Centre image
Add/Style/Remove title   Layout > Title 220/305



Add/Style/Remove title   Layout > Title
Add/Style/Remove annotation   Layout > Annotation
Show main toolbar   Toolbars > Main toolbar
Show view toolbars   Toolbars > View toolbars

Omniscope 2.4 Appearance menu 

Resize window to   Settings > Window size

Branding:   Settings > Branding

Add web services logo   Settings > Web services > Button image
Set publisher link  Settings > Branding > Corner logo > Link

Value colouring:

Value colour schemes   Settings > Value colours
Graded colour range settings   Settings > Colour ranges

Universes-allow/hide universes   Settings > Advanced tab settings > Data subsets
Views-allow/hide views   Settings > Advanced tab settings > View restrictions

Misc:

Show view toolbars   Toolbars > View toolbars
Show main toolbars   Toolbars > Main toolbar
Freeze width of Side Bars    Toolbars > Freeze sidebar width
Show unused options   No longer available
Show report tabs   Toolbars > Tab bar
Report tab text lines   Layout > Configure styles > Tabs > Text lines

Look and feel   Layout > Configure styles > ...

Apply to all report pages   Layout > Configure styles > Apply to all tabs

Themes   Layout > Configure styles > Presets   (or use layout modes)

Omniscope 2.4 Help menu

How to use Omniscope    Help > Open user guide file
User guide   Help > Online help > User guide
Quick Start guide   Not available
Knowledge base   Help > Online help > Knowledge base
Movie tutorials   Help > Video tutorial
Report a bug   Help > Error reporting > Report a problem
View saved bug reports   Help > Error reporting > View saved reports
Submit a sales enquiry   Help > Contact us
Submit a support query   Help > Contact us
Compare Omniscope Editions   Not available
Online demonstration files   Help > Online help > Online demonstration files

 

 

Back to Main Toolbar [13]
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2.4 Commands Reference

Main Toolbar Commands Reference - Version 2.4 and earlier 
What does this command/option do?

Below is an index to the version 2.4 and earlier Main Toolbar command menus. Click on the links below to jump down to the sub-section
containing the command(s) you are interested in. This section is for users of version 2.4 and earlier.  For information on commands and
options related to specific Views and View toolbars, please consult the Views Reference. [25]

Moving to Omniscope 2.5+?
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Many commands have changed in 2.5 to make them clearer and more logically structured.  If you're used to Omniscope 2.4, and can't find a
command in 2.5, see this guide [242].  Also see the full command reference for 2.5 [27].

 Version 2.4 and previous

 

 

 

 

|File [249]|Edit [250] [250]|Tools [251] [251]|Reports [252] [252]|Page [253] [253]|Appearance [254]|Help
[255]|

File menu [100]

New File [55]

Open file [100]

Connect to database [132]

Open image collection [217]

Open folder of files [256]

Demo files [100]

Open map [100]

Import into current file [145]

Reload data from file [145]

Refresh data from source [145]

Edit data source [145]

Update for new data source [145]

Import query from XML file [145]

Import references into basket [145]

Merge data from another file [128]

Repeat last merge [145]

Import fields from Bloomberg [145]

Save IOK [100]

Save as... [100]

About this file [100]

Help with this file [100]

Export [257]

Export files [163]

Export references [163]

Export images [163]

Export XML query file [163]

Export back to source [257]

Create Excel spreadsheet [257]

Create Bloomberg spreadsheet [257]

Save screen image [100]

Print [258]

Print as PowerPoint [258]

Print as .PDF [258]

Close [100]

More [100]

Exit [100]

(back to top) [259]

Edit menu [101]     

Manage fields (columns) [95]

Add field (column) [101]

Add record (rows) [101]

Delete selected rows [101]

Replace within values [101]

De-pivot data [138]

Re-pivot data [138]
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Undo/Redo Edit [101]

Undo/Redo history [101]

(back to top) [259]

Tools menu [102]

Automatic refresh
Language [102]

Use system language setting [102]

Edit translations [102]

Use local translations file [102]

Submit edited translations [102]

Enable brushing [102]

Record cycling [102]

Show details using [102]

Tooltips [102]

Links [227]

Add/modify web link [227]

Add/modify local link [227]

Preconfigured links [227]

Web services [173]

Images
Advanced Tools [260]

Edit publishing settings (Enterprise only)
Start Scheduler (Enterprise only)
Edit Enterprise action descriptor (Enterprise only) [175]

Application-wide settings [175]

Show virtual keyboard alongside text fields [175]

HTTP proxy settings [175]

Auto-convert large category fields to text [175]

(back to top) [259]

Reports menu [103]

Page: Rename [103]

Page: Delete [103]

Page: Delete others [103]

Export XML query file [103]

Administer all: Delete all pages
Create page: From current Omniscope configuration [103]

Create page:Text only [103]

Create page: From image or PowerPoint slide [103]

Navigation: Start [103]

Navigation: Next Page [103]

Navigation: Previous Page [103]

Navigation: Go to page [103]

Navigation: Exit Report [103]

Show report tabs [103]

(back to top) [259]

Page menu [104]

Reset layout [104]

Remove all views [104]

Page margin [104]

Add/Change background image [104]

Add/Change header image [104]

Add/Change centre image [104]

Add/Style/Remove title [104]

Add/Style/Remove annotation [104]

Show main toolbar [104]

Show view toolbars [104]
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(back to top) [259]

Appearance menu [105]

Resize window to [105]

Branding [105]

Set cover page [105]

Set back page
Add corner logo [105]

Add web services logo [105]

Set publisher link [105]

Banner advert [105]

Value colouring [105]

Value colour schemes [105]

Graded colour range settings [105]

Universes-allow/hide universes [105]

Views-allow/hide views [105]

Misc- [105]

Show view toolbars [105]

Show main toolbars [105]

Freeze width of Side Bars [105]

Show unused options [105]

Show report tabs [105]

Report tab text lines [105]

Look and feel: [105]

Canvas: Canvas background colour [105]

View/Device panels: [105]

Panel has background gradient [105]

Panel background colour [105]

Panels have shadows [105]

Panels transparent 
Show border around views [105]

Panel border size [105]

Panel border colour [105]

Panel header has gradient [105]

Panel header colour [105]

Panel header text colour
Inside view text colour [105]

Query Devices [105]

Active query device colour [105]

Title Size, Style
Font Colour, Size, Style [105]

Report (pages) [105]

Report tab text colour [105]

Report tab font size [105]

Apply to all report pages [105]

Revert to defaults
Themes [105]

(back to top) [259]

Help menu [106]

Help with this file [106]

Edit help page [106]

How to use Omniscope [106]

User guide [106]

Quick Start guide [106]

Knowledge base [106] 224/305



Knowledge base [106]

Movie tutorials [106]

Report a bug [106]

View saved bug reports [106]

Visit Visokio website [106]

Contact us [106]

Submit a sales enquiry [106]

Submit a support query [106]

Compare Omniscope Editions [106]

Online demonstration files [106]

Automatically check for updates [106]

Check for software updates now
About [106]

License agreement [106]

Product licensing and activation [106]
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2.4 File Menu

File > Menu Commands
The File > menu on the Main Toolbar contains commands used to import data into Omniscope, manage .IOK files, and export data from
Omniscope in various file formats  and as images for printing/pasting into documents. Commands accessible from the File > drop down on the
Main Omniscope Toolbar include:

 

 

New- Choosing New creates a new blank table with an initial number of fields (columns) and rows (records) you can specify. The default is
500 rows and 6 columns. If you have an activated Edition, you can set the number of rows and columns to be larger. Once you specify a size,
a new blank table will open showing the 3 empty default views; Table View, Pie View and Chart View. In the Table View, right click on column
header 'A' and select Tools > Rename field to begin assigning your own names to the fields, then begin entering data as you would for a
spreadsheet.  Note: You can also administer the naming and data typing of each column from the Edit > Manage Fields menu.
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Open File- Choosing Open file launches the Open Dataset wizard [129], which looks like a Windows file browse window, but has some additional
features and options on the right side. Navigate your directory structure and find the file you wish to load, be it an existing Omniscope .IOK file,
or a data in a supported data file format; Excel .XLS, .CSV (comma separated value) or other delimited text data file formats such as .TSV, .TXT
etc.

 The Open Data Set wizard looks like a Windows file browse dialog: 

 

 

The   Help icon in the upper right of the Open Dataset Wizard [129] displays a format guide [243] for importing spreadsheet files. Always confirm
that your spreadsheets conform to this simple layout before trying to open them in Omniscope.  For more detail, see Using the Open Dataset
wizard [129]. If you encounter problems, see also the Knowledge Base section on importing and exporting data to and from Data Files. [131]

Connect to database- The Connect to database command launches the Database Connection wizard [132] which guides you through the
steps required to import data directly from a relational database table/view instead of an exported data file.

 

 

Omniscope uses ODBC or JDBC [261]protocols to access database files. For more detail, see Connecting to Databases [132] and, for more
technical detail, consult the Knowledge Base Database Connections [262] section.

Open image collection- Omniscope can be used to inspect and  manage collections (folders) of images, for use as embedded image sets in
Omniscope, as image folders associated with DataPlayers, or for any purpose where well-organised and documented (large) folders of images
must be assembled, inspected, managed and shared with others at any size/resolution. More on using Open Images [217].

Open folder of files- Omniscope can also be used to visualise and navigate collections (folders) of computer files, whether the files are a .PDF
document archive on a file server, a collection of podcasts or videos, or the entire contents of your hard disk drive. Omniscope permits you to
visualise the relative size and age of the files, sort them based on data modified, etc. If you point Omniscope at a folder containing documents
in .PDF format, the documents will display in the Omniscope Web View when selected. More on using Open Folder of files [256].

Demo files- Omniscope installs with a selection of embedded demo files you can use to familiarise yourself with the possibilities inherent in
Omniscope. Some of the embedded demo files have associated image sets that can be downloaded when the application is launched. In some
cases, you can download the image sets separately and associate and re-size the image set yourself. See Image Sets [263] under the Resources
section of our web site.

Open Map- This option is used to add more maps to your installation or import and embed a specific image file for use as a  Map View
backdrop with a custom co-ordinate system. Freely-downloadable, embedded vector maps from the Visokio Maps Library [141] can be
accessed and downloaded at anytime. The Open Maps command displays all the maps which are already stored on your machine (the files
are usually located in C:\Program Files\Visokio Common\maps) for use in both Omniscope and Flash DataPlayer .SWF files. 

 

226/305



 

The Open Map command reveals available maps already downloaded, the default world map, the option to download additional standard
Visokio maps, and the option to browse for and import/embed an image or customised map file for use as a backdrop with a derived
coordinate grid.  Recognised map file types for import and embedding include Image (.JPG, .PNG, .GIF, etc. depending on your version of
Java), files, plus (Visokio) .MAP, .VEC, and .ILF files.  Whether you download a standard map or import a customised map, the next display will
be in the Map View [118]. For more information on using geographic coordinate systems with Visokio maps and customising co-ordinate systems
for use with imported images such as floor plans or sports fields, consult the Knowledge Base section on Maps & Coordinates [144].

Import sub-menu

Import into current file-  This command reveals a sub-menu containing options for refreshing data from linked sources, administering the
data sources linked to a specific file, importing XML query files to recreate record selections sent by others, importing single column lists of
references sent by others as .TXT files for matching, merging in (or repeating the merge of) additional columns or rows of data from other .IOK
or .XLS/.CSV data files (see using the Merge Data wizard [128]), and importing/refreshing fields from Bloomberg (Professional & Enterprise
Editions only, assuming you are running on a Bloomberg-connected PC).

 

 

 

For more detail on the sub-menu commands, see the section on the Import into current file [145] sub-menu.

Save/Save As .IOK-  This creates a new Omniscope file based on the existing one you have open. This command uses the same Data
Export wizard screens discussed here [163], with the export data file type already set to .IOK, and the same data sub-set and field
(column) selection options used when exporting subsets of your data to .XLS or .CSV files. When creating a new version of an .IOK file,  you
can also choose to save the new .IOK file with additional options:

Write-protected- which prevents accidental saves of experimental variants overwriting the master copy;
Password-protected- to prevent unauthorised access;
Prevent data edit/export- data cannot be edited, exported or cut-and-pasted to another application;
Time-limited- an option to set the time period the file will be valid for and open without prompting the user to refresh the file with a
more current one.  If you choose to time-limit the new file you are saving, you will see a screen like this:
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The Save as copy option makes it possible to save the file to another location, without changing the location of the current directory, so you
can save an later update to the same base location, for example.

File security - depending on your edition (Professional or Enterprise) allows you to set some of the security options available for the file.  For
more detail on security options for Omniscope files, see section on file security options [24].

Informational screens

About this file- displays an informational screen giving administrative and licensing details about the open file. For details about your
installation of Omniscope, press Ctrl+F1

 

 

Help with this file- displays the file-specific Help page you can configure for file recipients using the Help > Edit help page wizard. See Help
Menu commands [106] for more information and an example. 

Note: Publisher-authored Help pages are not currently Report Page-specific.

Export sub-menu

Export- this command reveals a sub-menu of options for exporting some or all of the data from the current .IOK/.IOM file. 

Selecting Export launches the Export files dialog [163] with the export file type already set by default to Excel .XLS workbook files. You can
change this to .CSV or other supported data file types.
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Export references- launches the Export files dialog [163] with the export file type already set to the single column .TXT file format.  The wizard
allows you to specify the field and records (by universe) from which to generate an exported a list of references.

Export the images- launches the Export files dialog [163] with the export file type already set to a folder of images. The wizard allows you to
choose which associated image set you wish to export and to set re-sizing limits on individual picture size to limit the maximum size of the
images exported to the folder. Note: Omniscope files make excellent image catalogues. You can view and filter  a collection of images, put
selected images in the Basket, then export them as a new collection to a folder for re-use.

Export XML query- launches the Export files dialog [163] with the export file type already set to XML Query. This allows you to export your
current filter settings (query) or any other named query as a small, portable text file that others (such as database administrators, customers,
etc) who have the same Omniscope file can load the query file and instantly focus their display on the exact sub-set of records corresponding
to your exported query.

Export back to source- will overwrite the linked data source file (but not a relational database table/view) with corrected/edited data from
the Omniscope file.  Warning: if your source data file is a spreadsheet file with formulae, formatting or comments fields, they will be
overwritten and lost.

Create Excel spreadsheet- creates a new Excel spreadsheet containing the fields (cxolumns) and data subset you specify. Note that if you
want to paste data from Omniscope into an existing Excel spreadsheet, you can also use copy/paste. You must have Excel installed to use
these features.

Create Bloomberg spreadsheet- creates a new Excel spreadsheet including imported, automatically refreshing Bloomberg fields i.e. source
files that can update in real-time. Professional and Enterprise Editions only. You must have Bloomberg access and Excel installed on your PC to
use this feature. For more information, see Working with Bloomberg [26].

Printing

Save screen image- Exports the current screen display in a range of image file formats (.JPG, .BMP, .GIF, .PNG, .WBMP) suitable for pasting
into other applications. Also provides an option to copy the image directly to the clipboard for re-use.

Print screen- Sends the current screen display to your printer as an image.

Print page- for more detail on Printing, see Printing options [258]

Print as PowerPoint- for more detail on Printing, see Printing options [258]

Print as .PDF- for more detail on Printing, see Printing options [258]

Close & Exit

Close- closes the current Omniscope file. Opening a new Omniscope file will automatically close the Omniscope file currently open.  You will
asked if you want to save your changes first.

Exit- Exits the Omniscope application (but not the Enterprise Edition Scheduler or Generator, which are autonomous applications intended to
be run on always-on servers). You will be asked if you want to save if you have made changes to data or view configurations, but neither
closing nor exiting will commit changes to Report Pages. The file will next open with the Report Page tabs in red, indicating that you have to
either commit the changes or revert to the original configuration of the Report Page.

 

Back to Main Toolbar [13] or Commands Reference [241]  [160]

User Guide Top [68]

Open Files

File > Open File...Using the Open Dataset Wizard
Clicking on File > Open file brings up then Open Dataset wizard, which looks much like a Windows file browse dialog:
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Note: Until you decide to un-link the files, Omniscope will remember the location of the source file(s) you are importing from, and will check to
see if the data in these file(s) has changed, usually every time the Omniscope file is opened. The source data file(s) are is known as a linked
source. You can break and re-establish the links between Omniscope and its source data file(s) at any time. If you have multiple tabular files as
linked sources, they must share a common column such that Omniscope can re-perform the merges each time the data in the source file(s)
changes.

Most source files in Excel .XLS, .CSV, .TSV and other common delimited text data file formats will open directly in Omniscope. If you have
problems, such as all the values appearing in one column, you may need to change the delimiter or rename a tab-delimited file extension from
.TXT to .TSV (see below). If only some of the columns have not separated cleanly, you can use the Expand or Collapse Values functions in
the Table View Tools [110] menu to separate data into more columns or combine data into fewer columns. For more information, see the section
on Data Layout [130].

If the source data file you want to open is not on your machine, or local network, you can use the Open from Web button to specify the
exact location (URL) of the data file you wish to import:

 

 

Customise Data Import

If you are repeatedly using/importing other peoples' spreadsheets, you can depart from the recommended simple spreadsheet layout
somewhat by ticking the Customise data import behaviour option and providing Omniscope with additional information about the layout
of the data you are importing. For example, sometimes you may have a CSV, TSV or Excel file which does not have the column headers on
the first row. Without customisation, Omniscope will assume the first row contains headers, and include the actual column headers as the first
row of data. To skip any number of redundant rows on file import, use the Skip first ?? rows box to enter the number of redundant rows in
your data file before the header.
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International data issues

Data File delimiters-.CSV stands for "Comma Separated Values", which means the cells in each row of the data table are separated by the
comma character. However, if you are in a region that also uses comma for the decimal point (e.g. several European countries, such as
France), some versions of Excel create .CSV files that use a semicolon as the separator character. Sometimes these files are saved with a .TXT
extension, even though they are multi-column tables.

Omniscope is unable to detect this situation automatically. If you open such a file in Omniscope, your data will very clearly be wrong, with most
columns appearing as text with semicolons. To iport this kind of file, use the Customise data import option dialog to change the Separator
character  to a semicolon " ; ".

Dates & Numbers-  If you are running on Windows, when importing data that is in a delimited  text format which includes Excel, CSV and
TSV (tab-separated values), Omniscope will use your Windows Regional Settings to try to automatically recognise data. For example, for a PC
with United States Regional Settings, Omniscope will recognise "5/13/2005" as a date and "1,500.5" as a number. For some international users,
however, this may not work as expected and the result will be an import of all columns as type Text (shown either as multi-coloured Category
columns or white Text columns in Omniscope). If this occurs, you can usually manually convert numbers and dates & times fields using the
Edit > Manage fields dialog. for more information on formatting dates & times, and dealing with time zone issues, see the section on Dates &
Times.

If you know your data has been formatted for a different region, change the Locale drop-down accordingly. For example, if you live in
Germany but have received a .CSV from an American customer, you should choose "English (US)". If you find Omniscope gets things wrong
and your data is incorrectly recognised, you can disable auto-detection of dates and numbers by deselecting the two Recognise checkboxes.
All fields will open as Category or Text data and their text values will be preserved. More on dealing with International data issues [136]

Importing XML files

Importing .XML files which have already been transformed to Visokio XML Schema [245] is the same as opening a .CSV. If your .XML file conforms
to another schema, then you must prepare an .XSL Transform [246]file, tick Customise data import and specify that file to transform the
non-Visokio XML file to Visokio XML Schema for import. Your .XSL Transform stylesheet can be accessed from any location, including the web.
Note: if your XML data set is not already in a tabular structure, you can array it into a tabular structure using your XSL file.
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Back to File Commands [264]

User Guide Top [68]

Connect to Database

File > Connect to database
Using the Database Connection wizard

 

The Omniscope Database Connection Wizard lets you define a connection and pass any standard SQL expression that results in a flat table
output.  If you do not have authorisation to execute SQL statements, or don't know the SQL required to generate the table you want, your
Database Administrator may have to create the appropriate comprehensive reporting view(s). This means using database reporting tools
to draw data from multiple transactional tables to create a single, 'flattened' tabular view of your data for human consumption via Omniscope,
i.e. scrubbing, analysis, reporting and presentational purposes.

Some organisations have additional high-performance analytical and reporting databases, sometimes which perform joins, aggregations, sorts
and scans on data assembled from multiple transactional databases. In general, Omniscope interacts with these additional 'business intelligence'
analytical databases in exactly the same way as it interacts with transactional database views/tables. For more technical information, see the
Database Connections [80] section of the KnowledgeBase.

Using the Database Connection Wizard

Clicking on File > Connect to database launches the Database Connection wizard. The wizard guides you through a six-step process for
defining a linked data source from a relational database view/table. You will need to know the type of database and its connection details. Using
the Database Connection wizard, you enter the connection details for your database and choose which database table or reporting view you
wish to retrieve data from. By default, this will create a persistent linked data source relationship between this database table/view and
the Omniscope file.
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1. Connection type: In this step you define what type of connection you are creating from the options currently available.  Detailed
examples of each type of connection are available in our KnowledgeBase. [4]

 

 

2. ODBC configuration: Assuming you chose the most common ODBC connection type , you will be asked for a name, or if you are rolling
out auto-refresh from the database to a large number of desktops, a DNS-less connection string may be preferable.  For more details on
using easy-administration connection strings, see the KnowledgeBase. [265]

 

233/305



 

3. Authentication: if access to the database view/table is authenticated, tick the box and supply the Username and Password combination to
be used whenever the file is refreshed.

 

 

4. Choose Table: assuming the comprehensive database reporting view has already been defined as an ODBC-required single table, enter the
name here:
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5. Customise SQL: If there is a need to exclude some records in the linked database view/table from the Omniscope file, queries can be
added  to the connection. These can be refined/edited at any time using File > Import to current file > Edit data source

6. Specify a title: Choose a name for this connection/linked relational database source that communicates something about the underlying
queries (if any) being used.

 

Back to File Menu [100]

User Guide Top [108]

Image Collection

File > Open Image Collection (Folder)
Omniscope can be used as a photo browser, allowing you to explore and manage large folders of images, and to send selected, annotated
collections to others in compact, searchable .IOK files with supplementary information on the photos, their locations etc. 

Open and link to folder

File > Open Image Collection opens a new Omniscope file in folder browser mode that allows you to point at any folder (with or without
sub-folders) containing image files in .JPG, .GIF. .BMP, or .PNG format. Browse to the folder, select it and click Select.

 

 

Browse Photos & Save File

Wait a few moments for Omniscope to import the pictures.  The Tile View and left Side Bar will appear, with the images scaled down to display in
the Tile View. The Side Bar filter/query devices allow you to Search All for a keyword, to filter the size of the files (and hence the quality/size of
the picture), and to filter the date of the pictures. The Tile View initially shows all the pictures found in the folder chosen. As you filter, some
pictures will disappear, and the remaining pictures will get bigger.
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At this point, you might want to save a new .IOK file linked to this image folder. This will capture any settings you configure to the file.  You do
not have to embed the pictures in the file at this time.  In future, you can use File > import into current file > Refresh from source to
update the file to include any new photos added to the folder. 

Selecting collections

You can Select and Move pictures you want to exclude from further consideration, thereby enlarging the remaining pictures. When you see a
picture you would like to add to a collection file (such as  your 'holiday highlights'), click the picture to get the Details pop-window showing a
larger view, then click Add to basket to save that picture in the BASKET universe. Carry on filtering and exploring your photos, adding more
pictures selected for the collection file to the Basket.

 

 

Viewing the basket

When you've finished selecting photos for the collection file, view the Basket by clicking the  Basket  button to the right of the
Barometer on the Main Toolbar. A Table View of the BASKET universe will appear. Click Table View  to display the View Chooser, and select
a Tile View of the BASKET universe. For more detail, see Data Universes [162]
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If you're happy with your BASKET of images, you might want to view a Slide show. See Viewing Details [122].

Saving the new image collection file

When you've finished reviewing the images you wish to save as a collection, choose File > Save as IOK/IOM. In the Save as dialog that
appears, you will see a number of configuration options on the right-hand side. 

 

 

Click Records (rows) and choose Records in the Basket (XXX records). This will create a new file with only the images you added to the
Basket. When you make this change, the dialog will transform from a Save as dialog to an Export the images [163]dialog with the Images tab
pre-selected.

Under Embed images, click Image sets and tick Image. This means the image set called 'Image' will be embedded inside the IOK file. In other
words, the IOK file will be like a ZIP or archive, containing images. If your images are quite large, you may want to down-size them when
embedding in the IOK file. If so, tick Reduce image sizes. A dialog for down-sizing the images will appear after you click Export.  In Linked
data source, un-tick Keep link to remove the reference to the original folder of images on your PC.  Enter the name you want to save the
file as, say 'My holiday snaps', and click Export.

 

 

If you chose to reduce image sizes, enter the maximum dimensions you want for any image (in pixels), and all images exceeding these
dimentsions will be down-sized, preserving their aspect ratio, until they fit within these dimensions. You may have to wait a while down-sizing
the images, but once done, you should have a simple and small (depending on the size and number of images) .IOK/.IOM file for sending to
friends. 

237/305



If you send an .IOK file, they only need the Omniscope free Viewer to open and view it, even export their own selected images if you have not
locked the file. If you are using Omniscope Standard and send an .IOM file, they will need at least a Standard in order to open and act upon the
file.

Back to File Menu [100]

User Guide Top [108]

 

Open Folder

File > Open Folder of Files
Like opening a folder of images, Omniscope can also be used to explore folders of files on part or even all of your PC or connected
servers' hard disks. Choose File > Open folder of files. Browse to the top-level folder you want to explore (for example your entire C:/
drive) and click Select.  After a few moments, depending on the number of files scanned, you will see the Tile View on the left and the right-
hand Side Bar with filter/query devices showing on the right.

Opening View

By default, in this configuration of the Tile View, each tile represents a file, sized according to the size of the file. Initially, tiles (files) are
grouped by types of files. For example, System files, Video files, Music files, etc. Colour is used to show the date of each file. A green tile
represents a recently modified file; red represents older files. This view allows you to see at a glance where the space on your hard disk is
allocated (by the size of the tiles) what sort they are (by the grouping) and how old the files are (by the colour). 

 

 

Filter and Group by Folder

The smallest tiles/files might not be clearly visible if they are much smaller than the biggest files. Use the Side Bar query devices on the right to
filter and search for relatively smaller files. For example, on a Windows machine, certain very large system files have very old dates.  Filter them
out by excluding System files in the Side Bar. You may want to do the same for Video files.  Now set the 2nd Group option to Enclosing Folder,
enabling you to see the exact locations of your larger, older (non-system) files:
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Grouping by Levels and Extensions

You can change the primary grouping (using the Group drop-down in the Tile view) to show Level 1, which groups the files according to the
first level of folders in your directory structure. You can also change the 2nd Group option to Extension to gain an overview of your files by file
type. After you have analysed your Images, for example, exclude them using the Side Bar filter to focus on other types of files which tend to
be smaller.  Instantly you will see the relative size of each top-level folder, excluding System, Video and Images.

 

 

Browsing Documents (.PDF)

By filtering out all files that are not documents, you can use Omniscope as a document browser. For example, the Web View can display any
Acrobat .PDF document. Saving this configuration as a Report Page with the filter set to Documents only permits any recipient of the file to
browse the documents in a defined location (any network-accessible file server, not just their local machine as in this example).
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Back to File Menu  [100]

User Guide Top [108]

Import & Refresh

File > Import to Current File...
The File > Import to current file sub-menu contains commands for refreshing, up-dating and adding to the data in the open Omniscope
file, as well as importing queries and lists of references prepared by others to focus attention on particular records in the data set.

 

 

 

Reload data from file- reloads the data currently held in memory, which may have been updated from another Source .IOK file while you
were working on the display. If there is no refresh available, the command is greyed-out.

Refresh data from source- this command overwrites the current data set with the latest data available from the linked source, whether it is
a time-stamped data file or a direct connection to a continuously-refreshing relational database view/table. If there is no linked data source
defined for the open file, the command is greyed-out.

Edit data source- this command applies to currently linked data sources and is typically used when the linked data source is a direct database
connection with a query defined. This command can be used to access the connection settings and refine the query definition or other
settings. If no data source is currently defined for the file, the command will be greyed-out.
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Update for new data source...allows you to to re-establish a link to a data source for an .IOK file that does not currently have one, most
likely because it has been unlinked. If either the Omniscope .IOK file or the linked data source file have changed name or position, you can use
this command to edit the link to keep the linked data source operational. You will be warned about potential loss of any edits you made to the
Omniscope file while unlinked, and connected to either the Data File Import or Database Connection wizards depending on whether the new or
re-established linked source is a file or a database view/table.

Import query from XML file...if someone else has prepared and exported a query relating to your file, you can reproduce the effect of the
query on your own file by importing their XML query file, which will execute the imported query and update the records in your IN and OUT
universe accordingly.

Import references into basket- if someone has exported a list of references as a .TXT file, this command imports that list, and places all the
matching records into the BASKET universe. Omniscope will warn you if any incoming references cannot be matched and placed in the
Basket. For more information, see Using the Basket [107].

Merge data from another file...Omniscope supports merging rows and columns of data from other unlinked files, such as other .IOK, .CSV
or .XLS files, either as Joins (adding more columns) or Concatenations (adding more rows).

Joins: Data can be brought in as additional fields (columns) assuming there is a common column of values that Omniscope can use to
match up the rows in both files. More than one column can be used to specify joins.
Concatenations: .IOK files with largely common fields (columns) but different records (rows) can be "stacked" on top of each other to
assemble combined files containing all the records (rows). For example, several 'regional' files could be concatenated to create a single
'global' file.

Omniscope provides a Merge Files wizard to help you execute Joins and Concatenations. For more detail, see Using the Merge Files wizard.
[128]

Repeat last Merge- this option is used whenever the merge files used to create an Omniscope file are also changing and being updated, such
that a full refresh of the Omniscope file also requires re-executing the merges to update all data to the most recent values. This option requires
that the merge files remain in the same relative location with the same name(s).

Import fields from Bloomberg...(Professional & Enterprise Editions only) used to add fields (columns) available from Bloomberg into the
current .IOK file. The columns will only be populated when running on machines with access to Bloomberg. When first importing fields
(columns) from Bloomberg, the option to Refresh Bloomberg data is added to the menu. Depending on the number of records (rows), you
may have to press this a few times to fully populate a multi-field import for the first time. For more information, see Working with Bloomberg
[266].

 

Back to File Menu [100]

User Guide Top [108]

 

Merge Data

Using the Merge Data Wizard
To merge data from another file into your own IOK file, you must have at least one column in your data matching one of the columns in the
external merge file. For example, to use our By Countries merge files, you must have a column in your data that has the names of countries,
or their ISO codes, or other standard identifiers. Sample merge IOK files containing geographic co-ordinates for countries and major cities, plus
examples of other useful reference data are available here [190].

To open the Merge Data wizard, click File > Import into Current File > Merge Data from another file:

 
1. Choose external data file- point to the external
merge file containing the fields (columns) you wish to join into
your data.

2. Choose type of merge- You have a choice of types of
merge, Join or Concatenate. To add new fields/columns to
your data from a Merge File, choose Join. To add similar files
together, for example combining regional report files together
to form a global report, choose Concatenate.

3. Select fields to merge from external data- the drop-
down list will show all the columns in the external merge file. 
Untick the box next to any columns that you do not wish to
import into your new, merged file.

4. Join by matching records where- If you choose Join,
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specify one or more fields (columns) present in your file and
the merge file you wish to import, combining its columns with
your own. Choose the field (column) in your data set, and
select the corresponding field (column) in the external merge
file. If you chose Concatenate, all the Join options will be
greyed out. Scroll to the bottom and...

5. Execute Merge.  For Joins, the wizard provides feedback
on the matching process, reporting records in your file that
do not match any merge file records, records that do match
(and how many duplicate matches there are). It also reports
the number of records in the merge file that do not match
any records in your file.

6. Which record sets do you want to retain? for Joins,
depending on your needs you can keep your non-matching
records, the matching records, and/or the external merge file
records that do not match as well. For Concatenates, if the
file being added contains fields (columns) that are not in your
original file, Omniscope will inform you you that new
column(s) have been added and colour their headers blue. 

 

Note: If you use Date and Time fields as Join criteria, the names of the fields (columns) can be different but be sure that the format of the
data in both fields (columns) is exactly the same.

SUGGESTION: Before using a field (column) as a matching field, it is good practise to check whether the values in the matching fields in both
your own (target) file and the incoming merge file are unique ( using Table View > View Tools > Tools > Select duplicate records). If
both are unique, the number of merged records will be the same as the number of matching records, plus any non-matching records if you
choose to keep them.  If your (target) file's matching field has repeated records (such as multiple addresses with the same post
code), Omniscope will warn you that permutations (additional records) will be created in the incoming post code merge file so that all address
records receive their map coordinates. If you attempt to merge two files, both of which have repeated values in the matching fields, try to
specify as many additional join criteria as you can so as to minimise the number of permutations created. 

7. If there are conflicting field names...before accepting the merge, protect yourself in the event of duplicate column names (both files
may contain columns called City and Country). If you tick this option, Omniscope will modify the names of duplicated columns to, for example,
City(2) and Country(2) to avoid mixing/overwriting dissimilar data. Click OK, Apply Merge to modify your file by adding in the corresponding
columns from the Merge File.  

 

 

Warning: If you click File > Save (or Ctrl+S) after merging, your original file will be overwritten with the merged file. If you do this
inadvertently, you can always recover the original file by deleting all the merged columns (highlighted in blue). If you want to preserve your
original file (recommended) be sure to use File/Save As to save the merged file as a new file with a different name.

 

Back to File Commands [100]
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Export Files

Using File > Export > Export files dialog
The File > Export > Export file(s) sub-menu provides many options for exporting some or all of the data, images and queries from the
open Omniscope file for use by other applications, such as spreadsheets, or in the case of References and XML query files,  by other
Omniscope users with access to copies of the same .IOK/.IOM file.
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Selecting File > Export > Export file(s) launches the Export Data wizard.  Choosing File > Export > Export file(s) > Export
References,  > Export the images, and  > Export XML query file also open the Export file wizard to the relevant tab.

[266]

Export files wizard

The Export files wizard is a tabbed dialog that enables you to export data as a new Omniscope .IOK file, an Excel .XLS file, a list of references
(values from one selected field/column) as a .TXT file, a folder of images you have associated with (but not necessarily embedded into) the
.IOK file, or an Omniscope query as an .XML file that can be opening by other Omniscopes to re-create the same view with the same data file.
You change the type of file you want to export by selecting the appropriate tab at the top of the Export files wizard.

Exporting to Spreadsheets- .CSV, Excel .XLS etc.

Selecting the Export Data tab will specify an Excel Workbook .XLS file by default, but you can change the format of the exported data file to
another supported format such as comma-separated value (.CSV), tab-separated value (.TSV) or an .XML text data file (in Visokio schema
[267]).

 

 

At the right side of the Export Data wizard, there are powerful options for specifying the fields (columns) and records (rows) to be exported. 
Untick any fields you do not want exported to the new file, and specify which data universe currently contains the records that you wish to
export.
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Save As...Exporting Omniscope .IOK/.IOM files

At any time, you can use the File > Save as or the Export Data wizard to create a new Omniscope .IOK  or .IOM file from an existing one
by selecting the first .IOK/.IOM tab on the Export Data wizard.  In addition to specifying the fields and records you want to export, you
also have several options to manage access and the refresh cycle for the new .IOK file.

Note: Standard Editions save only .IOM files that can be opened only with activated, licensed Omniscopes. Professional and Enterprise Editions
can save both .IOK and .IOM files, and can open an .IOM and re-save it as an .IOK file that will open in the free Viewer.

 

 

Strong compression

IOK files are already many times smaller than the equivalent spreadsheet file size.  Strong compression reduces the size of IOK files even further,
at the expense of requiring more memory and taking longer to save the file.  You might use this if you are publishing or sending files via email
or the web.

File security options 

When creating new Omniscope .IOK/.IOM files, you can choose to save the new .IOK/.IOM file using several options for managing access to
the file, to the data inside the file, and the period of time for which the file will be valid.  More information... [24]

Exporting a list of References

Sometimes you will want to export only a list of record (row) identifiers to share with others using Omniscope or other applications. Choosing
the References tab in the Data Export wizard allows you to specify which field (column) you wish to export, and which Universe contains
the records you wish to export. For example, if you have saved a number of interesting records in the Basket, you would specify BASKET,
rather than IN, SELECTION or ALL universes as the source of the records references to be exported.
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Reference files are exported as single column .TXT files, useful for importing/matching in to other applications or other Omniscopes to re-create
the same list, perhaps with up-dated data, for co-workers or customers.

Exporting a folder of Images

If you have associated an image set with a particular Omniscope file, the Export Data wizard will display an Images tab option. Selecting this
tab allows you to create a new copy of the image folder, perhaps changing the size of the images to reduce the size of the files in which they
will be embedded.  If you have downloaded all online images associated with a file (by opening a Tile View showing the images, or using record
cycling in the Details view, for example) you can export  a copy of those images to a folder for local use.

 

 

Note that the image set to be exported only needs to be associated with (but not necessarily embedded into) the current Omniscope file in
order to use the Export Folder of Images option. If you are exporting an embedded image set that you have already reduced from the original
sizes, Omniscope may warn you that it does not have access to the folder with the images at original size, and that the images in the new,
exported folder will be of reduced size.

Exporting an XML Query file

Any pattern of filter settings and history of Moves and Keeps can be saved as a named query, using an XML file only Omniscope can read.  The
query may be the current active query, or any query associated with a Report Page defined in the file.
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Exported queries can only be opened by other Omniscopes with open files that have the same fields present.  There may be new records or
changed data values in the version of the file importing the query, however. The export/import XML queries feature is used to permit others to
quickly reproduce a data quality or screening views using the IN and OUT universes, perhaps on a daily basis as the data in each successive
version of the .IOK/.IOM file changes.

Back to File Menu [100]

User Guide Top [108]

  

2.4 Edit Menu

Edit Menu Commands
The Edit menu contains commands used to alter the content and layout of your data sets.

 

 

Manage fields (columns)- launches the powerful and useful Manage Fields dialog, from which you can configure nearly every aspect of
each field (column) in your data set. This dialog is used to add, remove, hide and globally re-order fields. It is also used to manage/change the
data typing for each column (integer number, decimal number, dates and times, text and categories) and to configure and format the way the
values are displayed.  For more information, see Using Manage Fields .

Add field (column)- adds a new, blank field (column) to the dataset. Unless you are in Reports Mode, you will see the new column appear at
the far right in the Table View. If you are in Reports Mode, the new column will not be visible until you go to View Tools > Column Options
> Columns to show, find the new field at the bottom of the pick list, tick it to reveal the new column and drag it into place in that Table
View. This command is also available at the bottom of the Manage Fields dialog. The difference is that if you drag the new column into place
using the Manage Fields dialog re-order, it will position the new column globally for all views, not just the Table View (and pop-up Show details
table) or a Table View in a Report Page.

Add records (rows)- adds a specified number of new records (rows) to the bottom of the data set.  This can also be done (with more
precision as tgo where the rows are added) from the Table View row header right-click menu.

Delete selected records (rows)- deletes selected rows (can be un-done using Undo edit ...see below)
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Replace within values- used to perform global search and replace operations. Choose which fields (columns) you are going to search and
replace, then type in exactly the text string to be found, and the string you wish to replace it with.

 

 

De-pivot/Re-pivot data- Sometimes source data is laid out 'horizontally' when Omniscope would manage it better 'vertically' (e.g. time
series), and vice-versa. Sometimes data needs to be exported from Omniscope in an orientation different from that used in Omniscope
reports. To avoid the time consuming process of changing the orientation of data from horizontal to vertical (row becomes column) or vertical
to horizontal (column becomes row), Omniscope has both a De-pivot and Re-pivot function. Use of these functions is discussed in more
detail here [138].

Note: transposing a data set (exchanging all  rows and columns) with or without headers currently takes two steps, this will likely change...

Undo/Redo edit- allows you to reverse data editing operations

Undo/Redo history- keeps a history of reversible operations. Operations which can no longer be reversed/re-done are greyed out.

 

Back to Main Toolbar [268] or Command Reference [160]
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Manage Fields

Edit > Manage Fields
The Manage fields dialog is the central menu for accessing almost all commands that relate to adding, naming, showing or hiding, and
removing fields (columns) from your data set. All of the fields (columns) in your data set will be visible here, even if you have hidden them in
some or all views. Data typing, which tells Omniscope how to treat the values it finds in each field (column), can be centrally managed from this
dialog.

 

 

Note: Rename, Change Field type and Field options commands are also available from the Side Bar (right-click on filter device) and the
Table View (right-click on column header).

Changing field data type

For each field, the Field Type drop-down allows you to change the data type from the default assumptions made by Omniscope when the
data was imported. Depending on your data source, Omniscope cannot always automatically determine the most suitable data type. The Field
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type drop-down shows the current data type, which may or may not be optimal for your analysis and reports. Omniscope classifies all data
columns as either Integer numbers, Decimal numbers, Dates and Times, or Text. In addition, if the number of unique values in a column is less
than about 250, Omniscope can treat each of the unique values in that column as a Category. It is important to use the most suitable data
type for each column to get the best results.

Valid data types for values in each field (column) include:

Integer numbers: (examples: 1,253 or -256 ) Integer number field options include a thousands separator. Integer number cells will
not accept decimal input, and will truncate (not round) any non-integer values found. Often, identification numbers which are not used
as numbers, such as '02345678', are typed by Omniscope as Integer numbers. In general, the data type for these fields should be
changed to Text (remove the thousands separator first). If there are less than about 200-250 unique values, and you want to graph
related values for each ID number, then change the data typing to Category. (see below)
Decimal numbers: (examples: 1,253.761 or -.023, or 12%) Decimal number field options include a thousands separator, the option to
display cell values as percentages (0.12 displays as 12%) and you can set the number of decimal places displayed. Decimal number
fields only accept numbers (and the minus sign) as inputs, no letters or date separators, etc. If you want to specify a calculation, you
must change the field to a Formula field and specify the expression. See Formulas and Variables [93]

Dates and Times (examples: 5 Jan 2005 15:37 or 12/25/2007) There are a wide range of formats which can be interpreted as dates.
Common formats are recognised by Omniscope and imported automatically. If Omniscope does not recognise your date format, it may
ask you to specify the format your data is in. Date fields can use specified custom date formats, and you can also change the date
display format for an existing date field using the field options. If you encounter problems with recognising and formatting dates and
times, see Working with Dates & Times. [135]

Text (examples: names and addresses) Text fields accept any type of input. Omniscope supports putting more than one text value in a
cell, with a specified delimiter between each value. See the discussion of Tokenized data. [123]

Categories are a useful data type whenever a field (column) contains only a limited number (say 200-250) unique values, although the total
number of records (rows) can be any number. Typical examples are a 'Sex' column, which usually contains only two unique values; 'Male' or
'Female', or list of distinct colours, such as 'red', 'orange' and 'green'. On data import, Omniscope will count the number of unique values, and
for text columns will usually set the data type to be Category by default. Category fields also have the following options: Graded (the values
are ordered and colour options shown with a continuous green to red scale, and Tokenized, meaning each cell can contain a delimited list of
multiple values. See the discussion of Tokenized data [123].

Note: if you import data with a field containing a mixture of numbers and values such as "?", Omniscope will treat this as a Text or Category
field. If you then convert the data type type to numbers, Omniscope will warn you before blanking out the "?" values.

Re-ordering, Adding, Removing and Hiding fields

Ordering and Resetting field orders- use the drag handles far right to re-order your columns from the default import order to the order
you find most useful in the majority of the views. You can change this order view-by-view and in Reports Pages, but clicking on Reset field
orders will return all views to this order, although hidden columns will remain hidden.

Add new field- creates a new, blank field in your file after the end of the list of existing fields. Enter the name, which must be unique, and click
OK. Initially, the field will be a Category field, and all values will be blank (empty, also called null and shown in grey). Use the Field type drop-
down to change the data typing to the desired field type (described above). Use the drag handles to move it into position between other
fields, then click Reset field orders. This will display the new field in the Table View in the correct location. Note: New fields will remain hidden in
Report Pages already configured. You must visit each Report Page and use the Columns/Fields to show option in each view to reveal the
new field, then Commit the changes to make them persistent.

 

 

Configure fields menu

Click the Configure drop-down for each field to get other actions and configurations related to a field.

Rename field- often data sets imported from database tables rather than human-friendly views will have obscure field names which are not
easy for those receiving your file to understand. Use this command to change the field (column) names in Omniscope...the data refresh
process will not be affected. If you want to preserve the display of upper case acronyms, 'ISIN' rather than 'Isin'...be sure to tick the Preserve
upper/lower case of field name option.

Change to formula field- converts a column from input values to calculated values according to a formula you specify. See Formulas &
Variables.
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Field Options sub-menu

Add field notes allows you to annotate a field; any text you enter here will appear in a tooltip whenever the mouse hovers over a Table View
column header, or a Side Bar filter device. Use this to attribute the source of your data, clarify definitions, etc.

 

 

Hide throughout file- same as Hide Field, you will be asked explicitly if this applies to Report Pages already configured. If you do not want to
hide the field in Report Pages where it is currently displayed, choose Skip Report Pages. Note: you can still reveal hidden fields in Side Bar filters
using the Devices drop down.

Replace within values- same as the command available on the Edit menu [101]

Change Value order, colours and shapes

Changing values and value order-

Edit value- Sometimes minor variations in spellings cause Omniscope to manage more distinct categories than actually exist. The Edit value
command allows you to standardise spellings of potentially thousands of values in the data set in order to achieve the correct category listings.

Value order- this option applies to Category fields, for which you usually need to define a sorting order. By default, category values are sorted
alphabetically. For many categories, alphabetical order is not meaningful. In the example below, a sequence of tasks in creating a web site have
been dragged into a new order using the drag handles at far right. The Task values will now display and sort in this new, non-alphabetical order
in all views. If we now choose to convert this field to a Graded Category, the new top and bottom values will define the colouring range (see
below). Note: If you set a category sort order from top to bottom, and find that some views display the values in a sequence opposite to your
preference, try reversing the sort order by dragging the Category values from bottom to top.

 

 

Import/Export- If you have a notepad file (.TXT) listing the values in correct business order, you can import the list and Omniscope will
automatically arrange the sort order accordingly. You can also export a list showing the current sort order.

Sort alphabetically- returns the sort order to the default

Setting and changing colours
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For Category fields, if you don't like the colours chosen automatically for your Category values, or have specific colours you would like to use,
click the square colour box next to the value you would like to change to display a Colour Chooser. This dialog enables you to select the
colour associated with each Category value with great precision.

 

 

If your Category field is Graded (see above), you can't change Category values individually. Instead, you can choose start and end colours,
and the values in between have a graded colour.

 

 

Date and Time, Integer and Decimal fields also allow you to change the gradation colours, with various options to achieve the best use of
colour given any distribution of values within the field. You can specify the start and ending colours for the continuous range, and skew the
colour spectrum by specifying the middle colour also.

 

 

Numeric fields often have very skewed distributions due to extreme values, etc. and the resulting colour spectrum will be too uniform for most
of the values. If you choose Fit to data behaviour, you can adjust for skewed data by selecting mean or skewed mean as a way of finding the
'middle' value for colouration purposes. If you have a more uniform distribution of values in your field, you may choose Fixed Range 250/305



'middle' value for colouration purposes. If you have a more uniform distribution of values in your field, you may choose Fixed Range
behaviour and specify Start, Middle and End values to achieve very precise colouring effects.

Setting and changing shapes

You can assign marker shapes to category values, such that different shapes are plotted on the Graph or Map view, depending on the value
for the specified Shape field in each record.

 

 

Back to Edit Menu Commands [101]
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De/Re-Pivot

Edit > De & Re-Pivot
Sometimes source data is laid out 'horizontally' in rows when Omniscope would manage it better 'vertically' in columns. Sometimes data needs
to be exported from Omniscope in a layout/orientation different from that used in Omniscope. To avoid the time-consuming process of
changing the orientation of data from horizontal to vertical (row becomes column) or vertical to horizontal (column becomes row), the
Omniscope Edit menu has both a De-pivot data and Re-pivot data function.

 

 

Edit > De-Pivot data...

Data tables containing repeated observations of values sometimes place each set of observations in a column, such as the example of daily
bond yields by ISIN identifier below. This 'horizontal' layout with the dates of each observation in a separate column is not useful for time series
analysis in Omniscope, so we use the Edit > De-pivot data wizard to change the layout/orientation of the data set:
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In this case, the ISIN identifier is already in a single column, so we do not need to create another column. We therefore untick this column from
the list of columns to be De-pivoted as shown above.

In the new data layout, we want all the dates of reported yields/prices to be in one column, which we can re-name 'Date' or similar.  Next to
the new 'Date' column (the pivot series values), for each ISIN we want the observed Yield/Price for that day (the pivot cell values), which we
can rename accordingly:

 

 

Given the information above, Omniscope will automatically change the data layout/orientation accordingly, with the ISIN reference duplicated
for each date, and the column names changed to those you specified.  Note: do not worry about the 'vertical' duplication of the ISIN
values. This duplication is only visible in the Table View and does not appear in the reports and charts
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With the data now in 'vertical' Omniscope layout, we can use the Graph and other views to display the time series:

 

 

Edit > Re-Pivot data...

Sometimes you may need to do the reverse of De-pivoting, i.e. converting a single column into many different columns by unique values.  For
example, you may need to export a data set in spreadsheet format with a layout/ data orientation different from that used in your Omniscope
reporting file. The Edit menu also contains a Re-pivot data function which performs these changes in data layout or orientation
automatically.  In the example below, we are going to convert this data set from the 'vertical' layout with the dates all in one column, to a
'horizontal' layout with a column for each date and the observations under each date.

 

 

We want to keep the ISIN column as a column, so we select Dates as the pivot series as shown above, then we select Yields as the value fields
to be arranged under the new date columns as shown below:
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 The result of the Re-pivot is a typical 'horizontal' data layout/orientation:

 

 

Back to Edit Menu commands [101]
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2.4 Tools Menu

Tools Menu commands
The Main Toolbar Tools menu and sub-menus group together commands and options for managing data refresh, language settings,
'brushing' or fading of unselected records, display of individual record-level details, links to related content and services outside the file,
associating image sets with the file and many advanced configuration options.

Automatic refresh- when ticked, displays the Automatic
refresh drop-down management menu and Hold button
on the right side of the Main Toolbar. See Using
Automatic Refresh [269] for more detail.
Language- enables you to change the language of all the
menus in Omniscope. See detailed section below.
Enable brushing- greys-out (fades) non-selected records
in all views simultaneously. To read unselected Table View
records when greyed-out, disable brushing by unticking
this option. Note: brushing option not Report Page
specific. If Table View records become too sparse, change
the Table View universe to the SELECTION universe to
concentrate all the selected records.
Record cycling- record cycling automatically shifts
selection from one record to another, with a configurable
time delay. Tick/untick to turn global record cycling on and
off (including inside Details Views if the synchronise option is
ticked). For more on using record cycling, see Viewing
Details [122].

Tools > Show details using

In addition to using the Details View, there are various options for showing record-level details.
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The default (whenever the Details View is not open) is to display details using the pop-up window. If Side Bars are visible, there are options to
display details panels at the bottom of either one (but not both) of the Side Bars. For more information, see Viewing Details [122]

Tools > Tooltips

Tooltips are temporary text displays that appear whenever you hover your mouse over a marker or other representation of one (or a group
of) record(s) in the data set. Using the drop -down pick list, you can select which field values will be displayed whenever Tooltip displays are
visible.

 

 

Tooltip displays are Report Page specific.  If you are in Reports Mode, the selections you make will be remembered and the selected values will
appear in all Tooltip displays on that Reports Page. If you Exit Reports, the Tooltip displays will revert to the defaults you set for the file.  Note:
Use Tooltips sparingly...selecting too many field values to display will can create large blocks of text values that obscure too much of the open
views.

You can also choose to display associated image sets as tooltips:

 

 

To learn how to associate image sets with your .IOM/.IOK files, see Tools > Images below.

Tools > Links

Links extend your file users' experience to include content not contained within the Omniscope .IOM/.IOK file itself. By adding links, anyone can
integrate related external content (documents, files and web pages) into their .IOM/.IOK files, with one-click access via their local network, and
the open web.
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You specify links and make them available for use within your .IOM/.IOK file using the Add web link, Add local link and Preconfigured
links dialogs.  For more information, see Tools > Links [227].

Tools > Web Services

Web Services are data processing services that use Internet standards to post data to a remote server, which usually delivers a response in
web page format.  Popular examples of Web Services in action include submitting text to a search engine and receiving the results page,
or submitting stock tickers to view price charts. More detail on Web Services [270].

 

 

Omniscope is a 'hybrid' web/desktop application that is easy to integrate with Web Services.  In addition to the preconfigured free web services
(that accept a single value text string input) available on the Links menu, there is also a useful multi-record submit Web Service via HTTP POST
available in Omniscope. The Tools > Web Services dialogs permit you to configure and edit Web Services that expect multi-record  input to
work seamlessly with your Omniscope files. Accepting the defaults under Add web service will configure an 'echo test' service (hosted by
Visokio) in which our server repeats back a list of references you have selected in your local Omniscope file. More information on configuring
and using web services with Omniscope is available in Tools > Web Services [173]and the Web View [119] subsection on using Web Services
[228].

Tools > Images

Before you can display images, you must associate one or more folders of images with the .IOK file as a named image set. Preparation for this
involves saving a set of images in a single folder with a consistent naming convention, such that the same text values are present in one of the
columns of your .IOK file (it may be a column included just to hold the names of the images). It is also possible for Omniscope to display
multiple images per record, provided you have entered multiple 'tokenized' values in the image reference cell.

There are 3 ways to display image sets in Omniscope:

For high speed and performance, images can be displayed from a separate local folder, assuming the Omniscope .IOM/.IOK file is always
kept in the same position relative to the image folder. 
For more portability and publishing, entire image sets can be embedded into Omniscope files at selected sizes/resolutions to minimise the
impact on .IOM/.IOK file size. 
It is also possible for Omniscope to display images obtained 'on-demand' from a remote server.
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Once you have associated one or more image sets (each with single or multiple images per record) with your file, you can display these
images in various views:

Table View (View Tools > Column Options > Show images in cells- select column),
Tile View (Tile View > Tile Contents > Show Images-select image set),
Details View & pop-up windows (Details View > View Tools > Show > Images)
Slide show pop-up windows (launched from most View Toolbars)

For more detail, see Adding Image Sets [260]

Tools > Language

Omniscope can be used with any language. You can use existing translations, modify existing translations, or create your own translations files
based on those that already exist.

 

Language selector- choose from the list of available translations

Use system language setting- tick this option to start Omniscope with the language setting specified in the operating system.  If a user
selects a different language, it will override and untick this setting. That user's installation will open using the preferred language until reset using
this command.

Edit translations- opens the embedded EditedLanguages.iok  translation file. You can make changes to the translations text in this file, being
careful to follow the Guidelines in the Translations Guide [172]. When you have finished editing, choose File > Save (not Save As) to save the
edited file in its original location.  In Tools > Languages, ensure your edited language is selected, then close and re-start Omniscope to see
the changes you made via the edited file.

Use local translations file- if you open the embedded EditedLanguages.iok file to make and save changes, this option will be ticked.  To
revert to showing the default translated text, untick this option and restart Omniscope.

Submit edited translations- if you would like your translations/edits to be included in the default for a given language, or added to
the menu as a new language or variant, submit your EditedLanguages.iok file to us using this command.

We supply free extended  trial keys to people helping us with translations. For more information, see the Translations Guide [172] in our
Knowledge Base.

Tools > Advanced tools

Additional Tools sub-menus are available from the Advanced Tools menus. Note: Some of these commands are only available in the
Enterprise Edition.
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For more detail on these and other Tools > Advanced tools sub-menu commands, see Advanced Tools  [175]

Back to Main Toolbar [268] or Commands Reference [160]

User Guide Top [108]

Auto Refresh

Using Automatic (Live) Refresh
Automatic refresh is a new Professional/Enterprise edition feature available from version 2.3 that automates the process of refreshing data
whenever it changes from within an open Omniscope file. To activate Automatic Refresh, choose Data > Automatic refresh.  A notice will tell
you that a new Auto refresh drop-down menu and a red Hold button have been added to the right-hand side of the Main Toolbar:

 

The menu will display the timing of the last update. If a fresher version of the data has been retrieved from source and is available, but not yet
delivered, the Display latest update option will be available. Pressing the red Hold button pauses refreshing, which may be useful if you are
selecting records in preparation for adding them the the Basket or executing power queries using Move and Keep.

If any failures to refresh fully are detected, they are recorded in a log file you can access. Otherwise you will see a greyed-out notice No
failures.

Unticking Polling enabled will stop the automatic refresh process. Unticking Show live refresh button will hide the button until the next
time you select Data > Automatic refresh on the Main Toolbar. You can also choose whether or not to play a sound on refresh and report
errors on this User's installation.  You can also disable all automatic refresh behaviour by deselecting Data > Automatic refresh.

There are two options for implementing automatic refresh depending on the source of the data. The default is for the User File to refresh from
the Source .IOK file from which it was created. This is the Refresh by reloading IOK file option.  The other option, Refresh from linked
data source is used when the source data file is not an .IOK Source file, but is instead a data file such as a spreadsheet, an exported copy of a
database view/table, or a direct connection to a database via ODBC or JDBC. [261]

If the linked data source is a file, Omniscope will automatically check the source file time stamp at the intervals specified in the Timings section. If
the time stamp has changed between polling intervals, Omniscope imports the latest version of the data and displays it.
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If the linked data source is a direct ODBC or JDBC connection to a database view, Omniscope will pull a copy of the data from the database
view(s)/table(s) at every interval specified, but will not display it if there has been no change in the data.  More sophisticated, higher-
performance and less resource-intensive update and refresh options can be developed for direct connections to databases using bespoke
Connectors. For more information on developing bespoke Connectors, contact us. [178]

Timings options controlling polling behavior are useful when many User machines are being auto-refreshed. They are configured from this
dialog:

 

 

These settings enable automatic refresh solutions to be tuned to the update cycle of the data, and to avoid large numbers of User Omniscopes
hitting the same resources at exactly the same time.

For more background on this and other data refresh options, see the Knowledge Base sections on Integration [169] and configuring Auto-
Refresh [170]solutions on both the client and server side.

Back to Tools Menu [102]

User Guide Top [108]

Links

Tools > Links
Links extend your file users' experience to include content not contained in the Omniscope .IOK file itself. By adding links, anyone can integrate
other related content (documents, images, web pages, audio-video clips, etc.) into their .IOK files via their local network, and the open web.
You can include full links in a column in your data, or specify data-driven (parametric) links that Omniscope composes on the fly, combining
pre-defined strings with user-selected values in cells to create valid URLs.

Omniscope comes with a number of preconfigured links to free web services, such as a Google search, Wikipedia reference or Yahoo stock
price charts. Once created, links can be attached to any field using the Links command available in many View Tools menus.  Any number of
Web Views [119] can be configured to display the results of selected links, or the users' default browser is used.

From the Main Toolbar, the Tools > Links menu enables you specify links and make them available for use within your .IOK file using the Add
web link, Add local link and Preconfigured links dialogs:
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The Add local link, Add web link and Preconfigured links dialogs are simple to use and allow anyone to create dynamic local and web links
combining text strings typed in just once (like a network file server/folder locations or web site domain names) with the values of fields
contained in the .IOK file. The result is user-selected, dynamic, data-driven links that extend users' access to related information dramatically.

Adding/Editing Local links

File folders located on your machine (or on other machines accessible to you over your local networks) can contain documents, images, audio
and video clips, practically any kind of digital content related to your data. For example, you may store a folder of documents on a remote file
server that users of your .IOK file may wish to consult. If you have a reference name/number for each document (or the enclosing folder for
groups of documents), including the references as a column in your .IOK file will permit users of your file to link to the folder or specific
documents, audio or video clips, etc. inside.

 

[173]

 

Using the Add local link wizard, you build up the link by:

1.) Browsing to the network location containing the files you are linking to,
2.) Building the file name by adding in any text that does not change (e.g. 'fileserver' in the example above) and specifying each of the fields in
your .IOK file containing values that will add specificity to the location/document/file the user will be linking to. To delete, backspace and try
again. Once have have fully specified the link to an existing file/document, 
3.) Try the link across a number of different records ( in the example above, there was no document found)
4.) Name the link once you are sure that the link is correctly specified and working across the full range of records

Once the link is fully configured, it will appear with the name you have given it on all menus relating to links in the file. If you then assign the link
to a field (column) in the data set, you can create an underlined link from all the values in that field that launches the link whenever the user
clicks on a value in that field (column). You can assign a link to a field in several ways, the simplest being to open the Table View, then click View
tools > Links and select the field from the list that appears. In the Table View, the values for that field (column) should become underlined
once you assign the link. You can also display local links as action buttons/links in Details Views and pop-up windows.

Note: You can assign a link to any field (column), not just the fields whose values comprise part of the definition of the link. For example, you
could define a link made up of the reference numbers of documents and some other text, but assign this link to the column containing the title
of the document. Clicking on the title would launch the document, using the reference number from that record, (not the title) as an
argument to complete the definition of the link.

Adding/Editing Web links

Any resource available on the open web can be linked to an Omniscope .IOK file using the Add web link wizard. 
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The Add web link wizard process is similar to building local links. Use the drop-down to specify the web protocol for the resource (usually
http://) then type in the part of the URL/web address that is not contained in one of the fields in you data set.  Next, select one or more fields
from your data set, typing in any necessary separators like /, %20, etc. between the inserted fields. To delete mistakes, backspace and try
again.

Once you have configured a valid URL/web address, test the link by cycling through various record field values, and clicking on the displayed
link. Once you are sure that it is working as you expect, give the link a name. The link will now be added to the list of links available in your file. 
In the same way as local links, you can associate web links with any field (column) and they can appear as action buttons/links in Details View
and pop-up windows. Web links can also be associated with Web Views by selecting the links from the list in the Web View Toolbar drop-down.
For more information, see Using the Web View. [119]

Pre-configured links

Omniscope contains a menu of preconfigured links to many free, popular web services you can add to your files for the convenience of file
users.

 

 

Free web services tend to expect a single cell value, such as a search term/string of text, a recognised identifying number like a stock ticker,
CUSIP or ISIN (securities) or an ISBN number (books). If your data set includes fields (columns) that can be submitted to these or other web
services (see Adding Web Services [173]), you should consider configuring these links in your files. You can set the results to display in one or
more Omniscope Web Views [119], or the user's default browser.

Back to Tools Menu commands [102]

User Guide Top [108]

Add Images
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Tools > Image Sets
Before you can display images related to your data set, you must first associate one or more image folders with your .IOK/.IOM file as named
image sets. Preparation for this involves saving a set of images in a single folder with a consistent naming convention, such that one of the
columns of your .IOK/.IOM file (it may be a column included just to hold the names of the images)  contains the same text values as the file
names of the images in the folder, i.e. 'picture1', 'picture2' etc. Any image naming convention can be used, so long as the same exact text
strings are present in one of the columns of your data set. You can omit the file extension from the data column if all the images have the
same extension, e.g .JPG or .GIF. If the images are mixed format, the names in the data column must include the file extension for at least one
of the formats.

There are 3 ways to display images in Omniscope:

For high performance, images can be displayed from a separate local folder, assuming the Omniscope .IOK/.IOM file is always kept in
the same position relative to the image folder. 
For more portability and publishing, entire image sets can be embedded into Omniscope files at selected sizes and resolutions to minimise
the impact on .IOK/.IOM file size. 
It is also possible for Omniscope to display images obtained from a remote server.

It is also possible for Omniscope to display multiple images per record, provided you have entered multiple values in the image reference cell by
declaring the field (column) to be Tokenized (for more detail, see Tokenized data). [123]  If you enter multiple image references per cell, the Tile
View will show the first image by default, but you can change this in the Tile View View Tools > Advanced sub-menu. The Details View, pop-
up windows and Slide shows will all display the tokenized images for each record.

The Tools > Images menu contains two options:

Add Image Set- launches the Add Image Set wizard documented below.

Modify Image Set (only visible if an image set is already associated with the file)- launches the Edit Image Set wizard, which is effectively the
same as the Add image set wizard. The modify image set option is usually used to re-import or re-embed an image set using the Refresh
embedded images button at the bottom.  Warning: Only use this command if you are sure you know the location of a complete new
image set, ideally containing images at the original resolution, so that you can remove the old one and replace it with a new one.

Using the Add/Edit Images wizard

1. Select Folder of images- Browse
to the folder containing the images. If
the file is located on a remote machine
accessible via the web, click Web and
enter the web address of the folder.

2. Choose field/column containing
image references- specify which field
in your data file contains the names of
the image files, and confirm by cycling
through a range of example values.

3. Choose format of references-
specify which format the image names
are in 

4. Select file extension to use- for
image sets with mixed formats (e.g.
.JPG and .GIF), you must include the
file extensions for the non-default
format as part of the image names in
the reference field, but you do not
need to add the extension to the
default format references.

5. Give a unique name to this
image set- give each image set you
create a descriptive name.

Check the example image at bottom
right corner of the wizard and ensure
that the correct image is displayed.
Click OK to associate the named image
set with the open .IOK/.IOM file.

Viewing Images
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To see your image set displayed, go to  Add View on the Main Toolbar and add a Tile View. On the Tile View Toolbar, click on the [ ? ] field
(column) selector drop-down and select 'My Image Set' or whatever unique name you have used.  The Tile View should display all the images
in the image set.  Missing images will be substituted with a red tile, but you can create a special image to substitute the missing ones, give it a
name, add it to the images folder, and add its name to the empty cells in the image reference column.

Saving/reducing image sets to manage file size

Once you have associated and image set, you can save the .IOK/.IOM file with your images embedded. You can also experiment with the
trade-offs between file size and image clarity/resolution when you reduce the image sizes to reduce the size of the .IOK/.IOM file. To save a
version of your file click File > Save as .IOK/.IOM.  The File Save wizard will appear:

 

Note the commands available along
the right hand side:

Data: used to select subsets of data
to save in new file

Embed Images: If you wish your
image set to be available inside the
.IOK/.IOM file, you must embed the
image set when you save the file.
Select the image set you wish to
embed. .

 

If you embed large numbers of large images without reducing their size, the resulting .IOK file can become far too big.  In general, images can
be substantially reduced from their original size without affecting the quality of the display on computer monitors. To test the effects of
reducing the image file sizes, tick Reduce Image size. Give the new version of the file you are saving with reduced embedded images a name,
such as 'My File with max picture size 200x150.iok'.

 

Click Save and you will see an image reduction dialog
that enables you to reduce the maximum
dimensions of the images, thereby reducing the size
of the .IOK/.IOM file, but sometimes at some cost in
terms of image clarity. If you set maximum values
for width and height, Omniscope will scale down any
images with dimensions exceeding the maximum
until the relevant dimension is within the maximum.

 

The size of the images displayed is not affected as much as the resolution, since Omniscope manages the sizing of the images dynamically
within each display.  

Testing Image Quality

Open the new version of the file and close all the open views except the Tile View, which should be configured to display the now embedded
image set My Downloaded Images. On the Tile View Toolbar, select the movie camera Slide show icon to the left of the Add to basket icon
far right. Click Start slide show and choose full screen sub-option. Look at the image quality on your screen. If it is acceptable for the
audience/screen resolutions you intend, consider reducing the images more to reduce the .IOK file size further. If the image quality full screen is
not acceptable, you may have to reduce the maximum size of the images less (increasing the file size), or configure the views such that images
are never displayed so large. To do this, repeat the steps above, and set larger maximums in the Reduce image size dialog.

Back to Tools Menu Commands [102]

User Guide Top [108]

Advanced

Tools > Advanced Tools
The Main Toolbar Tools > Advanced Tools menu and sub-menus include a number of important options, some of which (Edit publishing
settings, Start Scheduler, and Edit Enterprise Action Descriptor) are only available in the Enterprise Edition (see below).
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settings, Start Scheduler, and Edit Enterprise Action Descriptor) are only available in the Enterprise Edition (see below).

 

 

{Note: Some of the menu items shown above are only available in the Enterprise Edition...these functions are discussed in the
section Enterprise Edition-Advanced Tools below}

Show virtual keyboard alongside text fields- tick to enable users to enter text without keyboards

HTTP Proxy Settings- useful for activation, updates and automatic bug reporting. For more information, see Proxy Settings [85] in our
Knowledge Base.

Autoconvert large Category fields to Text-  by default, Omniscope will not treat a Text field (column) containing more than about 200
unique values as a Category field, for performance and other reasons. Sometimes there is some leeway around this depending on the size and
composition of your data set, and some views will only display breakdowns by Categories. Unticking this option will allow you to experiment
with treating some text fields as very large Categories.

Warning: There is still a safe upper limit for unique values treated as Categories rather than Text. Trying to convert a field (column) with more
than 500 unique values will definitely trigger a warning:

 

 

For more information on data typing and converting text fields to categories, see Edit > Manage Fields [95].

Application-wide settings sub-menu

The application-wide settings sub-menu is used to configure various aspects of your Omniscope installation that apply to all files you open.

 

264/305



 

Embedded web browser- allows you to change the installed browser underlying the Web View and Outside browser (see below). Current
options include Internet Explorer and Firefox/Mozilla. 

Number of recent files to show in file menu- allows you to specify the number of recently-opened files to show at the bottom of the File
menu.

Number of recent files to show on welcome screen- allows you to specify the number of recently-opened files to show under Recent
files heading on the Welcome screen (version 2.3+).

Screen resolution- Used to tell Omniscope the type of display screen the file will be used on (Handheld, Projector, Desktop or  Kiosk/TV), so
that layout, font size etc. can be optimised.  This is the same as the display setting on upper right of the the Welcome screen (version 2.3 +).
This is not the same as the option to change only the resolution displayed, which does not affect Omniscope's choice of layout, font size,
etc. See also the command  Appearance > Resize window to [105]: which changes only the resolution displayed.

Show diagnosis tools-  this option reveals some additional error reporting options, for example a menu item to report errors on loading
images from image sets. We may ask you to enable this to help with troubleshooting.

Show experimental features-  every version of Omniscope contains some experimental features which are still under development.  Tick
this option if you want to see/ test these features.

Show outside browser if configured... the outside browser is an Omniscope web browser which opens before any specific .IOM/.IOK file is
opened. It is different from Web Views, which are configured within each .IOM/.IOK file to open as required. The outside browser feature is used
to provide a group of users the ability to browse and select from a library of .IOM/.IOK and other data files displayed on a web page.  For more
information, see Using the Outside Browser [271].

Revert to defaults- resets all Application-wide settings menu options to the default settings.

Debugging- used to create log files that record each event in various processes.  We may ask you to tick some or all of these in order to
generate a log file we can review to help us troubleshoot problems.

Performance sub-menu:

Disable initial views on opening a file- this setting enables you to explicitly control, one-by-one, the views that open with your data.  It is
used to recover files whose initial opening configuration becomes unusable for some reason, or where opening very large files on machines with
limited RAM that require the utmost conservation of memory.  Warning: If you leave this setting ticked, all files will open with no views
showing....use only when dealing with specific circumstances.

Map outline simplification- reveals a sub-menu which allows you to adjust the resource demands associated with drawing and zooming/up-
dating maps.

Marker shadows in Map and Graph Views- unticking this will improve performance in some files with very large numbers of markers visible
in the Map or Graph Views.

Use anti-aliasing for smoother maps- unticking this will improve performance in some files with extensive use of maps

Reset to defaults- resets performance options to the default settings

Enterprise Edition Advanced Tools

The Enterprise Edition contains advanced automation, data and revenue protection features used in commercial data publishing:

Edit publishing settings- {Enterprise Edition only} this dialog is used to set the publisher identification text and links that will appear
whenever a file recipient clicks on File > About on a file produced with this installation. 265/305



whenever a file recipient clicks on File > About on a file produced with this installation.

 

 

Edit publishing settings: file protection options- {Enterprise Edition only}

Protected- used to prevent data editing, export and copying (including copy-and-paste copying). Other options to time-limit or password-
protect files are available from the File > Export or Save as [163] dialog.

 

 

Tie to website- {Enterprise Edition only} enables domain locking, a powerful and effective revenue protection feature. Omniscope .IOK files
are free-standing and easily transferred by e-mail, posting/downloading from blogs and websites, etc. Commercial publishers can use this
domain-locking feature to require that anyone trying to open their files must be logged in to a specific web site. If the file recipient is not logged
in, the .IOK file containing the data will not open, and will display a notice to that effect:

 

 

Start Scheduler- {Enterprise only} the Scheduler is Visokio application separate from Omniscope used to automate the refresh, import,
merge and publishing/distribution of data files by defining a set of actions performed repeatedly on a specified time cycle. For more information,
see Using the Scheduler [272].

Edit Enterprise Action Descriptor- {Enterprise only} the Scheduler uses Enterprise Actions Descriptors XML files, which you can configure
using an Enterprise Edition user interface, or manually, based on a documented specification. [273]  Examples of actions which can be
automated include:   
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For more detail, see Creating and Editing  XML Actions [274]

 

Back to Tools Menu [102]

User Guide Top [108]

2.4 Reports Menu

Reports Menu Commands
The Main Toolbar Reports menu provides access to all the commands used to create and administer Reports Pages configured in the file. If no
Reports Pages are yet configured, you will see only the Create Page heading on the menu. If Omniscope is currently displaying a combination
of views, queries, variable settings, etc. that you would like to make persistent, you should choose to create a Reports Page. Note: Standard
Edition can create only one Report Page, which is the same as the opening display. Professional and Enterprise Editions can create any number
of persistent, tabbed Report Pages, with grouping and other advanced options.

Create page from current Omniscope
configuration. You will enter Reports
Mode and all your current settings will be
copied to create a new Reports Page. In
Reports Mode, any further changes you
make will apply only to the open Report
Page, and all subsequent changes must be
Committed to become persistent (see
below).

If you choose Text only, you will
presented with a dialog to create a typical
formatted text presentation page, with up
to 3 different images embedded.

If you choose From image or
PowerPoint, a file browse dialog will open
to select either a large image file (for
example a .JPG screenshot file exported
from another Omniscope file) or an existing
PowerPoint file, from which you can select
slides to import as Report Pages.

The commands below are also accessible from the Reports Navigator, which appears in the lower right-hand part of the screen when the file is
in Reports Mode. These commands are more fully documented below in the Reports Navigator section.

Administer all pages- if you already have Reports Pages configured in your file, you can manage modifications to all pages, or delete them all
using these commands.

Navigation: Start ; ...Go to Page- if you already have Reports Pages configured in the file, these commands allow you the access any
Page, from the start or from a drop-down menu that appears on the right of the Go to Page command.

Show report tabs- this option displays a tab for each Report Page across the top of the Main Toolbar, even if you are also displaying buttons
in the Side Bar Reports Panel.

Creating Report Pages
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To create a Report Page from the current display in Omniscope, or as a text or image slide/imported PowerPoint slide, use Reports > Create
Page from the Main Toolbar Reports menu. If you have revealed the Side Bar Reports Panel, you can also click New to access the Create
New Page wizard:

Page name: this name appears on a
report tab at the top of the display, or
a button on the Side Bar Reports panel
if you provide access to Report Pages
there. You can change this name at
any time on the tab or in the Reports
panel. It is best to keep the page name
relatively short, as you can use Title
and Annotation fields below to convey
more detail.
Query State- preserves all filter
settings and exclusions as persistent
settings for the page
View and layout configuration-
preserves the open views and layout
Variable states- if you have defined
one or more assumption variables as
part of formulae, this preserves the
current value(s) of those variables as
the opening value(s) for the page.
Title: the title text that will appear at
the top of the page. You can edit this
at any time by right-clicking on the title
field with no text selected.

Annotation: explanatory text to focus the readers' attention on specific aspects or actions. You can edit this at any time by double-clicking
on the annotation text field.

Header/Background Image- adds images to each Report Page; Header images display at the top of the page, Background images can be
faded and display in views that otherwise display blank backgrounds. For more information on fading background images, see Page menu
commands. [104]

Apply default report layout: If you leave this box ticked, Omniscope will hide the View Toolbars and increase the margins around the views
for a cleaner display. If you wish to preserve the existing settings, untick this box.

Once configured and named, each pre-defined, persistent Report Page appears anytime the user clicks on the top report tab, or the button
next to the Report Page name in the Side Bar Reports panel, or uses the Report Navigator menu, which appears faintly in the bottom left
corner of the display in Reports Mode.

Reports Navigator

Start; Next; Previous; Go to
page...used to cycle through the
Reports Pages already configured in
the file.
Administer all pages sub-menu:
Commit all modified pages-
makes all changes which you have
made to your Report Pages
persistent
Revert all modified pages- returns
all Reports Pages to their last
persistent configuration
Delete all pages- deletes all Report
Pages currently configured

Reports Navigator > Tools sub-menu: Tick or untick to Show or Hide various toolbars. Note that these changes apply to the current
Report Page only, and only if the modifications are Committed to make them persistent.

268/305



Show/Hide main toolbar- when
unticked, the Main Toolbar is not visible
unless the user hovers the mouse near
the top of the display.
Show/Hide view toolbars-when
unticked, the View Toolbars associated
with each view are not shown
Show/Hide unused options- when
unticked, simplifies the display of certain
view menus
Show/Hide right/left side
bars-when unticked, hides one or both
Side Bars

Reset layout- returns the page layout to the defaults, such as the Main Toolbar displayed, Report Tabs displayed, etc.

Save file as...saves the open file with a new name and/or settings and options, using the Export file as .IOK/.IOM [163]dialog

 

Report Sections

From the Side Bar Reports panel, you can group your Reports into sections, as shown in this example file [275]. To create a section name,
choose Create New > Section at the bottom of the Side Bar Reports panel. Rename or delete sections using the black triangle drop down.
Drag and drop to reorder reports in sections.

 

 

Reports with independent queries and views

You can also mix query-only and view-only reports. To create such query-only or view-only report items, choose Create new Omniscope
page from the New... button in the Reports panel, and select either Query state or Views and layout configuration.

This example file [276] illustrates navigating a set of query-only reports, grouped under a section name in the Side Bar Reports panel, and a set
of view-only reports configurations, also grouped independently. This allows you to configure a set of different view configurations (by task, or
form of analysis, such as 3 Web Views, or a Graph and a Web View, or 2 Pie Views) and an independent set of queries (such as last week's, or
last month's trades, or erroneous trades) enabling users to navigate any combination independently. For example, a user might open Query A
then Views X. They can then choose to either change to a Query B while keeping Views X displayed, or Views Y while keeping Query A
displayed.

Note:the buttons in the Side Bar Reports Panel only highlight the last report item opened. If you open Query A then Views X, you will see only
Views X selected in the Reports Panel. The view configuration from Views X will be showing and the filters will continue to represent Query A
correctly. But because only Views X is actually selected, manipulating the query will not affect Query A.

Back to Main Toolbar [268]commands

User Guide Top [108]
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2.4 Page Menu

Page Menu Commands
The Main Toolbar Page menu commands provide many options useful for creating more informative displays and Reports Pages. The
commands on this menu can be used to configure many aspects of the current display. If you make changes to the current view using Page
menu commands, then close and save the file, it will next open with those changes preserved in the current display, even if the display is not
configured as a Report Page. 

Configuring Pages

Page menu commands can be used to:

Reset layout-removes any changes which have been made
to the margins and other layout settings.  If no changes
have been made, the command is greyed out.
Remove all views-closes all open views.  To add new views,
use Add View
Page margin- sets a width (in pixels) for spacing to display
around the edges of views. Remove with Reset layout
Add Background; Header; Centre image- allows you to
specify an image file (.JPG, .GIF, .PNG, .BMP depending on
your Java version) to be displayed in various parts of the
Page (see below for more detail on image display options)
Add; style; remove title- adds, styles or removes a text
title at the top of the page in a margin that varies with the
font size of the title text.  You can edit this at any time by
right-clicking on the box with no text selected. See below for
more detail on text styling options. 
Add; style; remove annotation- a free text field that
displays at the bottom of the view, unusually conveying the
main message of each page. You can edit this at any time by
right-clicking on the box with no text selected. See below for
more detail on text styling options.

 

You can also tick/untick the options to Show/Hide the Main Toolbar and the View Toolbars for all views on the page. View Toolbars can
usually be hidden if the users of the page are not expected to need access to the options available on them. Even when hidden, the Main
Toolbar comes back into view whenever the user hovers the mouse near the top of the display. 

Page menu commands apply to each Report Page individually, and any changes must be Committed to become a persistent change, or
Reverted to return the Report Page to its default configuration/layout. For options covering aspects of the look and feel of Report Pages that
apply to more then one page, see the Appearance [105] command menu.

Text styling options

Title and annotation text can be styled by choosing the font, the font size and face, as well as the horizontal alignment and text colour:

 

 

Image display options

Background images can be faded so that they interfere less with other aspects of the display. Use the Fading slider to adjust the intensity of
the image, from weak (very faded) to strong (barely faded).
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Background image options also include 3 Crop style options for fitting background images of any size/aspect ratio to the display:

Crop- preserves aspect ratio by cutting off the longest dimension
Letterbox- preserves aspect ratio by reducing the image along the longest dimension and padding out the other dimension, does not
fill the entire display
Stretch- distorts aspect ratio by stretching the image vertically and horizontally to fill the display space available.

Header images are not intended to be faded and/or resized, as they are generally logos whose aspect ratios and legibility must be preserved. If
you use a tall header image, it will increase the size of the margin at the top and reduce the display space usable for views.

 

 

Centre images can be made from PowerPoint slides or other large screenshots. They are not intended to be faded, but do have zooming
options and a control to stop the picture clarity from being reduced by up-scaling.

Back to Main Toolbar [268] or the Commands Reference [160]

User Guide Top [277]

2.4 Appearance Menu

Appearance Menu Commands
Omniscope files can be used not only to assemble, check, analyse and transform data, but also to distribute as interactive final reports and
presentations for various audiences; senior management, customers, partners, friends...anyone with an Omniscope free Viewer or better. The
Appearance menu commands enable you to change almost everything about the Omniscope display to conform with your desired look and
feel and provide the simplest file opening experience for recipients of your files.

Appearance > Resize window to:
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Allows you to resize the Omniscope display to preview how your Omniscope reports and presentations will look at various screen sizes ranging
from SXGA (1280x1024 pixels) down to QVGA (320x240 pixels).

 

 

The Resize window to option only changes the size of the display.  You can also adapt the default spacing of layouts, margins, font type and
size, etc. to various screen types (Handheld, Projector/Laptop, Desktop and Kiosk/TV) using the Resolution option on the Welcome screen, or
from the Main Toolbar Tools > Advanced Tools > Application-wide settings > Screen resolution.

Appearance > Branding

Omniscope is a data file publishing system that supports a wide range of branding and corporate identity options. This includes advertising
placement options for data publishing business models supported by advertising revenue.

 

 

Set cover page; back page- these pages are informational displays (not interactive Reports Pages)

The Cover page opens (and closes) before any views or Report Pages.
The Backpage displays when the file is closed, and is useful for reminders, acknowledgements and providing contact details relating to
the file.

Clicking on the option to configure a Cover or Back informational page launches a Set ... Page dialog that accepts 5 inputs from you. The
dialog to create the Back informational page is very similar to the Cover page example shown below:
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1. Set page title: enter text to display
at the top of the page

2. Add an image: select an image to
display (.JPG,.GIF,.BMP,.PNG depending
on Java version)

3. Add text: add the text you wish to
display, with hard returns to wrap the
text evenly and keep the box size from
becoming too wide.  Basic HTML tags
can be used to style the text

Insert link: generates the full HTML to
make a link you enter live.

4. Set button text: changes the text
displayed in the button from 'Continue'
to whatever you prefer

5. Close automatically in: sets the
time delay to display the page (not
used for the Help Page)
Preview appearance- use this
feature to see how the information
page will display. Click the button in the
preview to return from preview to edit
mode.

 

When you are happy with your information page, click Submit to save the configuration and make the page active.

Add corner logo- allows you to replace the small Visokio logo in the upper right hand corner with a logo of your own.  For best results, use a
logo image about 19 pixels high.  If you change the logo, the link associated with it will be changed to the URL you have entered under Set
publisher link (see below).

Add Web Services logo- allows you add a logo to the Web Services menu tab on the Main Toolbar. For more information, see Configuring
Web Services [173]

Set publisher link- allows you to enter the address of a web page (URL) that will be displayed as an active link in the File > About this file
notice for all files produced with your installation. If you have substituted your own logo for the Visokio corner logo, clicking on your corner
logo will also take the user to this URL.

Banner adverts- Omniscope supports the display of banner adverts with live links to the advertiser on each page.  The adverts can be
positioned at the top, right, left or bottom of the display, and do not affect placement of header images, titles, etc. In general, rectangular
images look best, such as typical full-width banner ads. Note: Server-based deployment, Flash .SWF display, embedding animated .GIF images
and Report Page specific adverts are not currently supported, but this may change in future versions. For more information and examples,
see Advertising Options [165].

Appearance > Value Colouring

Omniscope makes extensive use of colouring by values to help you and the users of your files visualise the relationships, relative
magnitudes and overall meaning in your data sets. The Appearance > Value colouring sub-menu contains options to change the
way ranges of values within fields (columns) are coloured.  It also has options to assign colours to specific values in fields automatically
and control the colour palette Omniscope uses to assign initial colours to Category values. You can override colour assignments for specific
values and range endpoints at any time using the colour selectors available in Edit > Manage Fields > Configure >Field Options >
Change value order, colours and shapes.
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Value colour schemes- clicking launches a dialog that enables you to manage various aspects of colouring values:

Presets: a number of pre-configured combinations of settings are available, including 'Corporate Blue', 'Subdued' and 'Monochrome' colouring
schemes. If you make changes to the defaults to create your own scheme, you can name it and save it for future use with specific files. To
return to the default 'Classic' Presets, click on Revert to defaults.

Category fields:

Recognise colour &
positive/negative words- when
ticked, these options automatically
assign pre-defined colours to
recognised text values, such as 'red' or
'green' or 'yes' or 'no'.
Identify all other Category values
using...multiple colours- use these
controls to eliminate colour ranges
from the palette used to assign colours
to specific values in Category
fields. You can eliminate colour ranges
by un-ticking them, and set the
brightness and saturation to further
refine the colouring scheme. To see the
effect of the settings, try choosing
various Preset schemes and comparing
the settings. For example,
'Intense' versus 'Subdued', or
'Primaries' versus 'Bleached'
Identify all other Category values
using...multiple shades of a single
base colour-used to present an even
more uniform colouring of categories
using a specified base colour and
adjusting the contrast setting to
heighten or diminish the differences in
colour tones. 'Corporate Blue' and
'Monochrome' are examples of
schemes using a single base colour.

Number, Date and Graded Category fields- fields (columns) consisting of defined ranges of values, such as Number, Date & Time and
Graded Category fields, are coloured according to a spectrum calculated based on the range between the lowest and highest values and the
start (lowest) and end (highest) colour specified here.  The default or 'Classic' scheme uses a range from red (lower values) to green (higher
values).  You can change the default here by clicking on the Start or End colours, and optionally specify a middle value to extend the colouring
more or less depending on the middle colour chosen.  At any time, you can change the colouring scheme applied to a specific field (column)
using Edit > Manage Fields > Configure >Field options > Change value order, colours and shapes.

Note: If you do override the settings made in this dialog for one or more fields (columns), you can clear all of your customised settings using
the Clear button shown above.

Graded colour ranges-  this dialog determines default behaviour in colouring ranges for Number and Date & Time fields (columns).  

Middle colour position: By default, Omniscope assigns the middle colour of a range to the middle value in the field.  This works well for
relatively uniform distributions of values.  However, when some very high or low values are present in the field, the result can 'compress'  the
colouring scheme such that there is not enough difference in colouring for most of the records.

 

 

If many of your columns contain 'skewed' distributions of values, you may want to set the default behaviour to assign the middle colour to the
mean (average value), or for even more skewed distributions, to the skewed mean. If only a few fields (columns) are skewed, you may want to
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mean (average value), or for even more skewed distributions, to the skewed mean. If only a few fields (columns) are skewed, you may want to
set the treatment of the skewed fields individually using Edit > Manage Fields > Field options > Change value colouring.

Fit to data colour range- Omniscope manages colour ranges in two modes; a filtering-neutral mode, which assigns and displays colours
based on the full range of values in the field (column), and a dynamic filtering re-colouring mode, which re-calculates the range and re-assigns
colours based on the range of values present in the universe being displayed. The default is the dynamic re-colouring mode, Fit range to
current universe, but you can change the default setting here by selecting Fit to range of all records instead.

Appearance > Universes

Omniscope selection, filtering and basket management functions assign every record  in the data set to multiple data universes. By default,
every view can be opened on any of the 5 universes, and each view indicates the target universe being displayed by the colour of the
corner 'eye-con' and the view selection menu.

 

 

Allow OUT; ALL; SELECTION; BASKET-  depending on the file and target users, you may want to simplify the menus and options by
preventing views being opened on certain universes, such as the OUT or ALL universes.  If these universes are not being used in Report
Pages and could confuse novice users, you can prevent viewing them by removing them from the View Chooser.  You can turn off access to
all universes other than the IN universe by unticking them here. Note: Users can re-enable access to universes on this menu, but not save
changed versions of the file, provided you ticked the Prevent data edit/export option when you last saved the .IOK/.IOM file

Show coloured borders- this option provides for more visual impact by displaying a coloured border around each view indicating the target
universe for the view.

Appearance > Views

Depending on the file and target users, you may want to simplify the display options by removing the   Add View option from the Main
Toolbar, or by removing certain views from the View Chooser. This could be because the view(s) are not useful, or because the
size/configuration of the file makes some views slow relative to the usefulness of the view.

 

 

For example, for large files with many unique Category values, the Tree View can be very computationally intensive, and could be turned off if
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it is not very useful in Report Pages and configured to perform well. See Using the Tree View [117]for more information. 

Note: Motivated users of the file can still access this menu and re-enable the view(s), so these are just menu simplification options rather than a
short-cut to avoid configuring all views as meaningfully for your data as possible. However, provided you ticked the Prevent data
edit/export option when you last saved the .IOK/.IOM file, any user that re-enables or otherwise changes the file settings in the Appearance
menu will not be able to save or forward a persistent version of their changed .IOK/.IOM file.

Appearance > Misc

Omniscope is designed to be used for analysis, but also for distribution as final reports, for giving live presentations and for printing as static
PowerPoint slides or Adobe Acrobat .PDF documents. Depending on the immediate use you have for the file, you may wish to modify certain
aspects of the display:

 

 

Show/hide view toolbars- untick this option to hide the View Toolbars, making the display appear more like a final report/presentation

Show/hide main toolbar- untick to hide the Main Toolbar across the top (it will always re-appear when the mouse hovers near the top of
the display)

Freeze width of Side Bar(s)- untick this option to allow users to narrow or widen the Side Bars (Report Page-specific)

Show unused options- untick to simplify menus by removing references to options not used in the file.

Show report tabs- untick to hide report tabs at the top, under the Main Toolbar.

Appearance > Look and Feel

In addition to defining colouring schemes for value ranges, you can also manage the overall aesthetics of your file using the options available
on the Appearance > Look and Feel sub-menu. The options available on this sub-menu are used to define Themes, combinations of
settings you can use to, for example, mute the colouring application-wide to achieve a more corporate look. The best way to see the
differences these settings can make is to try applying the pre-configured Themes (see below), then opening the Look and Feel dialog and
noting the settings used. Note: Look and Feel menu options are Report Page-specific. To apply the same settings to all the Report Pages in
your file, choose Apply these settings to all pages.

 

Canvas: Canvas background colour- sets the colour
of the background displayed when no view is open, in the
margins, and behind the title and annotation text.
View/Device Panels: modify the appearance of view
windows and the Side Bar device panels
Panel has background gradient- applies a solid-
looking, reflective effect for views with backgrounds
Panel background colour-sets the colour of the view
panels with backgrounds
Panels have shadows- applies a shadowing effect to
each panel
Panels transparent- allows the canvas to show through
for views with a backgrounds
Show border around views- turns view border option
off and on
Panel border size- defines the thickness of the border
around each view
Panel border colour- sets the colour of the outer
border around each view 276/305



border around each view
Panel  header has gradient- applies a solid-looking,
reflective effect to the View Toolbars
Panel header colour- sets colour of area under the View
Toolbar
Panel header text colour- sets colour of text on View
Toolbar

Query Devices settings: (see below)

 

Report Page(s) settings: (see below)

Query Devices settings: (displayed on the Side Bars)

Active query device colour- changes the colour
indicating that a filter/query device is active from the
default dark orange to any other colour (purple in the
example left)
Title- sets font face and size (not colour) for the
filter/query device titles
Underline expandable sections- removes the default
underscore from category devices that are expandable,
(such as 'Race' in the example left)
Font- sets font face, size and colour for the labels within
the devices (dark blue in the example at left)

Report Page(s) settings: Tabs

Report tab text colour- sets the colour of Report Page tab text

Report tab font size- sets the size of the Report Page tab text

 

Appearance > Themes

Themes are combinations of settings of options for Look & Feel. A list of pre-defined Themes come with the application. You can modify these
Themes, or create your own,  and save your modified settings as a new Theme with a name you assign. Your Theme(s) will be saved  in your
program folder and will be available for use in all files you prepare with your installation. There is the option to apply the Theme to all Report
Pages.

 

 

Back to Main Toolbar [268] or Command Reference [160]
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Advertising

Advertising Options
Banner adverts- Omniscope Professional and Enterprise Editions support the display of banner adverts with live links to the advertiser on
each page. The banner adverts can be positioned at the top, right, left or bottom of the display. Currently, you can specify only one banner
image per page, and one link per image (see note below).

In general, rectangular images look best, such as typical full-width banner ads, displayed either vertically at the sides:

 

 

 

... or horizontally at the top or bottom:

 

 

Note: Server-based deployment, Flash .SWF display, embedding animated .GIF images and Report Page-specific adverts are not currently
supported, but this may change in future versions

Back to Appearance Menu  [105]
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2.4 Help Menu

Help Menu Commands
The Main Toolbar Help menu contains links to a wide range of support options:

 

 

Help with this file- launches the file-specific Help page display you can create to explain the finer points of your file to users. You create this
Help page for each file using the Help > Edit help page command below.  Note: Help pages are not Report Page specific....use annotations
and field notes instead.

Edit help page- opens the Set Help Page dialog to compose your help page

 

How to use Omniscope- launches the embedded, interactive, tabbed tutorial file illustrating the major features of Omniscope.

User Guide- links to this Omniscope User Guide [108]

Quick Start guide- links to the one-page introduction [278] contained in this User Guide

Movie tutorials- links to various Flash screencasts illustrating common tasks in Omniscope.

Report a bug- if Omniscope displays an error message (throws an exception), or if you see something you think is a bug, please use this
form to tell us about it. 
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Try to give us as many details as you can regarding what you were doing at the time. This will help us try to reproduce the problem. If the file
does not respond, send us the file if you can. If your machine hangs, there is a Hang Diagnosis procedure [279].

View saved bug reports- If you are offline when filing bug reports, Omniscope will save them for review and forwarding to us via e-mail.

Visit Visokio website- this links to our main site homepage at www.visokio.com [280]

Contact us- links to our contact page [86]

Submit a sales enquiry- links to our contact page [86] for license sales

Submit a support query- links to our contact page [86]for support

Compare Omniscope Editions- links to our comparison chart [281] summarising differentiating features of the various editions of Omniscope.

Online Demonstration files- links to our main demos page [282], which features more and larger demos than those embedded in the
application. Embedded demos are accessible from the Main Toolbar under Files > Demo files and from the opening screen Demos section.

Automatically check for updates- tick this option if you want Omniscope to check for a newer version every time you start the application

Check for updates now- confirms that you have the latest version

About- very useful display of your edition/version number, whether or not you are licensed for Commercial Publishing, your license key
number (keep a copy in a safe place) and the version of Java that Omniscope is using (there may be more than one version of Java on your
machine).

License agreement- links to our licensing page [283]with full text copies of our licensing agreements.

Product licensing and activation- this menu is used to activate a free Viewer,  and to deactivate an activated installation prior to re-building
the machine or moving the key to another machine (you may do this a maximum of 3 times). It is also advisable to periodically Refresh your
activation after installing a newer version over an older one. For more detail see the Activation and Refresh [87].

 

Back to Main Toolbar [284]  or Command Reference [241]
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Using Connectors

Connecting to Remote Data
Access, visualise, refresh, edit, archive and share copies of remote-hosted or 'cloud-based' data

Connectors enable Omniscope to access data sources other than delimited data files or relational databases permitting connections to
tables/reporting views using ODBC or JDBC. [167] There are two types of connectors; direct connectors which log into services directly from
Omniscope, and web (services) connectors you add into your online services accounts that deliver your data to Omniscope on your desktop.

Omniscope's 'hybrid' desktop/web client-side capability is the perfect compliment to cloud-based platforms and services. Combined solutions
address most of the issues associated with the trend towards ever more usage of remote services. We are continuously adding new
connectors and other features to help you make the most of these 'hybrid' cloud solutions enabled by Omniscope on the desktop.

Note: Connectors for accessing and synchronising with remote-hosted data and service 'clouds' are available only from activated Omniscopes,
not the free Viewer.

Bloomberg Connector

Activated Omniscope Editions can import, save and refresh data from Bloomberg using the commands Data > Import from Bloomberg to
define the fields (columns) to be added to the file. To refresh on demand with the latest real-time data from Blomberg, use Data > Refresh
from Source or Ctrl+F5. If you send the file to others with access to Bloomberg, the file will refresh from Bloomberg on opening, assuming
refresh behavior has been set to 'Always'. More on using Omniscope with Bloomberg [26].
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Email Connector

Omniscope 2.5 and above include the ability to access email in accounts from providers that support either POP3 or IMAP  protocols.
How to use the Omniscope Email connector [32]

Google Spreadsheets

Google spreadsheets are on-line collaborative tools for gathering and maintaining structured data sets.

How to use Omniscope with Google Spreadsheets [33]

Facebook

Facebook [285] is a social networking application that allows users to create networks of relationships centred on their accounts.

How to use Omniscope with Facebook [34]

Google Analytics

The Google Analytics import function allows you to download and analyse Google Analytics data from within Omniscope.

How to use Omniscope with Google Analytics  [35]

Web Mapping

A web site map is a network of interconnecting pages within a particular website. A connection between two pages exists if the first page
contains a link to the second page. You can use the webmap functionality within Omniscope to visualise the structure of a website. 

How to use Omniscope for Web Site Mapping [36]

Salesforce/Force.com Connector

Salesforce [286] is an application that runs in the Force.com [66] online cloud-computing hosted platform, one of the largest and fastest-growing
general-purpose SaaS platforms. Salesforce is widely used for CRM (Customer Relationship Management, composed of the 'Sales Cloud' and
service/case management, aso know as the 'Service Cloud'). Almost any application can be written on the Force.com platform. If you have a
Salesforce account, it is possible to access your Reports and Data Objects/Tables stored in Salesforce using either the Omniscope direct
connector (File > Open online source > Salesforce) or the free web connector [67] your Administrator can install into your Salesforce
account from the online AppExchange [287].

Salesforce web connector: the free Omniscope Connector for Salesforce [67] web service can be installed in your Salesforce account(s) from
the AppExchange listing page [67] by your Administrator, unless you have a Group Edition. Instructions for installing in Group Editions are here.
The web connector installation will add a new tab from which you can download reports and un-joined data objects using pre-configured
templates to deliver files that will open in the free Viewer. An activated version of Omniscope is required to modify and save customised
templates, which can then be uploaded to your account, adding new download and viewing options for different classes of users within your
organisation. More on using the online Web Connector for Salesforce [288].

Salesforce direct connector: Omniscope Professional and Enterprise 2.5 (and later) enable to access your Salesforce reports and data
objects directly. More on using the Direct Connector for Salesforce [289]to access, modify, edit and synchronise changes with your Salesforce-
hosted data.

More detail and a solutions roadmap for making the most of the combination of Salesforce and Omniscope is here [28].

GoogleBase Connector

(experimental feature)

Amazon.com Connector 

(experimental feature)

 

Bespoke Connectors

If you would like to discuss developing an Omniscope Connector for your remote data ASP/SaaS platform, client-premise installed application,
or online data service, please contact us. [86]
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Bloomberg

Using the Bloomberg
Connector
Import real-time data with live updates

{Omniscope Professional and Enterprise Editions only}

Note: Omniscope will connect to Bloomberg only if Omniscope is running on a PC which has Bloomberg Terminal software installed, together
with a local copy of Excel and the Bloomberg DDE Server and Add-In for Excel installed. 

To determine if the Bloomberg Add-in for Excel is installed on your machine, follow these steps:

In Excel (pre-2007), click the Tools menu item, expand the menu fully, and select Add-In
In Excel 2007, click the Office Button > Excel Options > Add-ins > Manage > COM Add-ins > Go
In the Add-ins window, look to see if there is an item called “Bloomberg” and that it is ticked.

If the Bloomberg Add-in appears but is not ticked, then simply tick it and restart Excel. Otherwise, you will have to install the Bloomberg Add-
in. Download and install the DDE Server and the Excel Add-in from the Bloomberg Software Support [290] page, then do the test above to
determine if it has worked. If it has, then you are ready to use the Omniscope Bloomberg import and export functions via the DDE Server and
Excel Add-in.

Importing data from Bloomberg

This method of importing data from Bloomberg outlined below is for manual for simple cases only. More advanced users who are comfortable
using the Excel Add-in for Bloomberg and want more automation options should use the method outlined under Alternative Bloomberg Import
Method [291]. We are planning to upgrade the Bloomberg Connector in the near future, please contact us [86] if you have requirements not
currently addressed.

 

Using the Bloomberg Data Import Wizard

You can manually add refreshable Bloomberg fields to your Omniscope files using the Bloomberg data import wizard.

The Bloomberg data import wizard is accessed from Data > Import from Bloomberg:

Bloomberg search formula- choose from four common
formulae, or cut and paste your own formula from a working
spreadsheet. (each of the options is further explained below)

Select Ticker/ISIN/ID field- your data set must contain a field
that can be used by Bloomberg to match to their data. Securities
identifiers like ISIN or SEDOLs, or Bloomberg tickers, etc.

Bloomberg fields to import- depending on your licensing
arrangements with Bloomberg, there are many thousands of
fields of data you can import and refresh directly into Omniscope
files:

(   Bloomberg fields list [292])

If you do not see the field you want listed in the dialog, check the
Bloomberg list to make sure it is available and note its exact
name.

Add new field- type in the exact name of the Bloomberg field
you wish to import and click add new field. It will be added to
your list of import and refresh options and ticked.

Select record set- select which data universe of data you wish
to import the specified Bloomberg fields for. In the example at left, 282/305



to import the specified Bloomberg fields for. In the example at left,
we are importing Bloomberg fields for only 16 securities in the
basket, rather than the 72 in the IN universe or the 43,975 in
this reference file for this class of instrument.

When you click OK, the bloomberg data will be imported, which may take a little while.

Note: To refresh your Bloomberg fields with live Bloomberg data imported into Omniscope, you must use the Refresh command:
Data > Refresh Bloomberg data (or you can use the keyboard shortcut Ctrl+F6)

This works so long as the Omniscope file is open.  If you close the Omniscope file and open it again later, you will have to use the Bloomberg
Data Import wizard to add the Bloomberg fileds to your file again.

 

Search/import formulae options:  

Choose the form of Bloomberg search/import formulae that best suits your data and requirements.

 

 

Bloomberg Ticker Formula-  =BLP(%ROW%,%COL%)

Typical BLP string which submits the Omniscope field value selected for ID, then the Bloomberg field names being requested, i.e those ticked
below

Bloomberg ISIN Formula-  =BLP(CONCATENATE(%ROW%," Corp ISIN"),%COL%)

This formula is for submitting ISINs from Omniscope in the form 'XS0109263607 Corp ISIN', then the Bloomberg field names being requested,
i. e. those ticked below

Example (string concatenation)-  =CONCATENATE(%ROW%," ",%COL%)

This formula can be used to test/demonstrate this function on machines which are not actually running Bloomberg.

User defined- choose this option to specify your own formula, using %ROW% to represent the Omniscope column values selected under
Select Ticker/ISIN/ID field, and %COLUMN% to represent the Bloomberg fields you have ticked under Bloomberg fields to import.

Note: If you are importing fields for many records, you may have to manually refresh several times to ensure that all values have been
imported. See Refreshing data from Bloomberg below.

Refreshing Data from Bloomberg

The best method of refreshing data, both in your own desktop, and in copies of the files you send to others who also have access to
Bloomberg from their machines depends on your requirements, especially record (row) count, update/refresh speed and performance.

If you or recipients of your files want to refresh Bloomberg fields in Omniscope on a manual, as-needed 'pull' basis, using the Data > Refresh
Bloomberg data should perform well enough. Indeed, when you first import Bloomberg fields into an Omniscope file, you may have to
refresh manually a couple of times to fully populate the file. This form of refresh is best for small portfolios and for less-than real-time updates,
for example daily closing prices.

Because persistent auto-refresh from Bloomberg has not yet been fully implemented in Omniscope, if you want to refresh a very large number
of records on an automated 'push' real-time basis, use File > Export > Create Bloomberg spreadsheet to generate a stand-alone
automatic price-monitoring Excel spreadsheet that may perform better for large portfolios requiring frequent real-time updates. This situation
will change in future.

User Guide Top [108]
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Alternative Bloomberg Import Method
Advanced Bloomberg data import & refresh options

 

There is an alternative method for importing data from Bloomberg which by-passes the manual, non-persistent Importing using Bloomberg
Data Import Wizard [26] method described above. System set up and requirements are the same.

To use this method you must also be permitted to run macros within Excel. Create an Excel spreadsheet using the template available here:

 

Sample Excel Bloomberg Import & Auto-refreshTemplate [293]

 

Within this spreadsheet you set up your Bloomberg data using the Excel Add-in for Bloomberg and set it to auto-refresh. The template
contains a macro which will automatically save the file on a regular basis for as long as it is open. Once you are happy with the file, open it in
Excel (permitting macros to run if asked) and you can minimise it to the bottom of your screen. Now launch Omniscope and open up the
Excel file from the place on your hard-drive where you have it saved. When it is open you can set it to auto refresh and as the data in the
Excel spreadsheet is populated from Bloomberg, the Omniscope will pull in that data and update to reflect it.

Alternatively, you can open an existing Omniscope file containing references such as ISINs or ticker symbols which are the same as those in
your Excel spreadsheet and merge the values in. Then if you set up Live Update it will refresh the merge while retaining your own data.

 

 

 

 

 

Back to Using Bloomberg with Omniscope [26]
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Email Connector

Importing Email
Downloading, visualising and searching email

 

New in 2.5...page under development

 

Omniscope version 2.5 and beyond include a connector that can import e-mail from any online email account supporting either the IMAP or
POP-3 email management protocols. Most modern web-based email accounts support at least one of these protocols.

 

To import email data into Omniscope, select File > Open online source > Email. The Account details dialog will be displayed:

Mail server - Select your email server. If your email server
does not appear in this list you should select the 'Custom'
option. 
Account type -This option is only enabled if you select the
'Custom' mail server. Select the type of email account
(either POP-3 or IMAP).
Incoming mail server URL - This option is only enabled if
you select the 'Custom' mail server. Select the address of
the mail server.
Incoming mail server port - This option is only enabled if
you select the 'Custom' mail server. Enter the mail server
port.
Use SSL Encryption - This option is only enabled if you
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select the 'Custom' mail server. Check this box if your email
server uses Secure Sockets Layer encryption.
Username - Enter the username you use to log-in to your
email account.
Password - Enter the password you use to log-in to your
email account.
Max messages - Determines the maximum number of
email messages that will be downloaded. A value of '10'
means the 10 most recent messages will be downloaded.
Download content - Check this box if you want to
download the message content. This will enable you to read
messages within Omniscope but will also increase the size
and amount of data downloaded.
Download attachments - Check this box if you want to
download message attachments. If this option is selected,
then you must also specify a valid attachment directory.
Attachment directory - This determines the folder
attachments are moved to after they have been
downloaded.

 

Once you have entered the relevant information click the 'OK' button to start downloading the message data. A status dialog will be displayed
to show you how many messages have been downloaded and how many are still to come:

 

 

Back to Using Connectors [30]
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Link to Google Spreadsheets

Using Omniscope with Google Spreadsheets
Display of dynamic collaborative data sets with live refresh

 

New in 2.5...this page in progress

 

Google Docs and Spreadsheets [294]is a free service that enables anyone to create documents, spreadsheets and presentations online. You
can import and collaboratively edit or publish from .doc, .xls, .csv, .ppt, .txt, .html, .pdf and other formats. You can export files for use with
traditional desktop software as well.

Hosted online spreadsheets enable powerful new workflows with collaborative data compilation and editing options...no more playing 'file tag'
with offline spreadsheet files circulating as e-mail attachments. Hosted online solutions enable co-workers to share the same online copy of each
document, spreadsheet or presentation. All revisions are saved and recoverable.

Combining Google's free hosted online spreadsheets with Omniscope provides a 'best of both worlds' solution enabling many new workflow
and publishing options. Data publishers and most businesses can benefit greatly by shifting most typical spreadsheet data compilation and
maintenance workflows to an 'online spreadsheet linked to Omniscope' solution.
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Creating Shareable Google Spreadsheets

When you create a new Google Spreadsheet, there are two ways of inviting others to help compile, edit and maintain the data.  For data being
published to the public, you can define a link or key allowing anyone with the link to connect to the data using Omniscope, and optionally help
to edit the data. Once this link is embedded in the Omniscope file, this source worksheet will be remembered and data refreshable in activated
Omniscopes from the Omniscope file. For company internal data, you can  use the more Google Docs Share with others dialog to determine
who will have what type of access to the spreadsheet, who can make changes etc.

 

 

Importing Data from Google Spreadsheet Worksheets

To create an Omniscope file from a Google Spreadsheets worksheet (either private or public) as a linked data source, go to File > Open online
source > Google Spreadsheets. Enter your account details for private spreadsheets, or the link or spreadsheet key to use public
spreadsheets. Once you have logged into your account or connected to a public spreadsheet, select the worksheet that will be the linked data
source for this Omniscope file.

 

 

 

Omniscope will automatically import the data and open in the default layout. You can further configure the layout of the Omniscope file, then
save it  as an .IOK/.IOM file. The default refresh behaviour with online data sources is 'Never', since you may want to open the file while offline.
If you or your colleagues have activated Omniscopes, while online you can use Data > Refresh from source for on-demand refresh, or you
can go Data > Automatic Refresh to configure automated refresh based on frequency of polling timings you can configure. If you plan to
always open the file while online, you may choose to save it with refresh set to 'Always'.

Refreshing Data from Google Spreadsheets

You can save an Omniscope file whose linked data source is a Google spreadsheet with the refresh behaviour set to 'Always', and the file will
update itself with the latest data from the Google spreadsheet. You can also activate and configure Automatic refresh to keep the Omniscope
file updated while open.

You can view the linked data source spreadsheet from the Omniscope file using the Web View.  Files using the Google Spreadsheets connector
open by default to display the linked spreadsheet in a Web View:
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Facebook Connector

Using Omniscope with Facebook
Download and visualise a network of your Facebook friends.

 

New in 2.5...page under development

 

Omniscope 2.5 and beyond provides a connector that allows you to download data from Facebook.

 

To import data from a Facebook account, select File > Open online source > Facebook.

First, you must click on the link at the top of the dialog.
This will take you to the Visokio Facebook application log-
in screen. Enter your Facebook username and password
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in screen. Enter your Facebook username and password
and click 'OK'.

 

Tokenise friend list -

 

 

 

 

 

Show user profile images -  
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Google Analytics

Using Omniscope with Google Analytics & AdWords
Free web traffic digital marketing data compiled by Google, delivered in Omniscope

 

New in 2.5...this page is in progress

 

Omniscope 2.5 and beyond provides a connector that allows you to download Google Analytics data directly into Omniscope.

Google Analytics is a free online service provided by Google that allows you to monitor various statistics about visitors to your websites. In
order to use Google Analytics you will need to sign-up and then configure your web-pages to generate the required information. Once you
have signed up you can log-in to the Google Analytics website to view and analyse your website analytics data. To sign up for Google Analytics
or to get more information click here [295].

Omniscope allows you to download Google Analytics data straight to your desktop. This means you can use Omniscope's powerful visualisation
environment to quickly and effectively download and analyse all of the data for any Google Analytics report in one go.

To import Google Analytics data select File > Open online source > Google Analytics. A dialog will be displayed asking you to enter your
Google Analytics username and password. Enter the same username and password that you use to log-in to the Google Analytics website.
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Once you have entered your username and password click the 'OK' button. Omniscope will attempt to contact the Google Analytics server. If
the server was contacted successfully and your username and password are valid the report configuration dialog will be shown. This dialog
allows you to specify what Google Analytics data you want to download.

 

 

Account - Select your Google Analytics account. 
Profile -  Select your website profile.
Report - Select from one of 8 pre-defined Reports or
choose 'Custom' to generate a custom Report. With
Custom Reports you can specify the information you want
to download and how you want it to be organised. To
configure a Report, select a combination of dimensions and
metrics. Dimensions determine how the data is segmented,
such as browser type, visitor city or language. Metrics
provide data for the selected dimensions, such as the
number of visitors, unique page views and bounce rate.
Start date - Select the start date of your data.
End date -  Select the end date of your data.
Max records - Define the maximum number of records
you want to download at once.

 

When you are happy with the configuration click the 'OK' button to download the data from the Google Analytics server into Omniscope.

 

Back to Using Connectors [30]
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Web Site Mapping

Mapping Web Sites with Omniscope
Enter a web URL and Omniscope will crawl and map it, importing keywords and content

 

New in 2.5... this page in progress

 

In Omniscope 2.5 and beyond you have the ability to generate a website map and view the site and associated data on content and structure
in Omniscope.

To generate a website map you need to provide Omniscope with one or more 'seed' URL's. Omniscope will 'crawl' and then download the
contents of each of these URLs and extract all the links. The content of each of the linked pages is then downloaded and the content
extraction process is repeated. The resulting data set contains the details of all of the pages downloaded and the connections that exist
between these pages. This can be visualised in Omniscope using the Network View to show a 'map' of all the pages, with each node in the map
representing a page and each line representing a link between from one page to another.

A website map can prove useful in many different scenarios:

You can use the website map functionality to get a quick understanding of your site structure. For example, you can quickly determine
which pages haven't been modified in the last few months or determine the number of 'clicks' a user has to use to reach a particular
page.
You can download and save a website map and use it as an 'Offline browser' for a particular website; allowing you to view the content
for each page even when you're not connected to the internet.
By selecting the 'Include Google Analytics data' option you can import Google Analytics information for each page inside the website
map. This can be used to provide additional data such as the number of clicks on each page and the bounce rate.
Omniscope automatically extracts the top keywords in each page. You can use this to get an understanding of the themes in a
particular page without having to read the content or you can filter the data by a particular set of keywords, allowing you to retrieve
pages of interest.

To generate a web site map select File > Open online source > Website map. 
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URL(s) - Enter one or more URL's to use as a starting
point for the website map.
Link depth (same host) - determines the maximum
depth of the website map, i.e. the maximum number of
pages out from a starting URL. Generating a website map
for a very large site can take a long time. You can use this
setting in combination with the 'Max pages' setting to
reduce the number of pages processed and speed up the
overall map generation time.

Include external pages - most web sites include links to
pages on other sites.  When ticked, this option includes
pages from other sites referenced by links.
Enforce tree structure -  when checked, Omniscope will
ensure the resultant map reflects a proper tree structure. If
selected, and during the map generation process
Omniscope encounters a page that has already been
processed, it is not added to the list of links. The diagram
below shows the difference between an enforced and a
non-enforced website map.

 

 

Import Google Analytics data - when checked Omniscope will attempt to retrieve Google Analytics information for any of the pages
encountered that belong to one of the sites associated with a Google Analytics account to which you have access. If you select this option
then you will have to enter a Google Analytics username and password. More information on the Google Analytics functionality within
Omniscope can be found here [35].
Start date - only available if the 'Import Google Analytics data' option is checked. Select the start date for the Google Analytics data.
End date - only available if the 'Import Google Analytics data' option is checked. Select the end date for the Google Analytics data.

 

 

 

 

Enforce tree structure selected  Enforce tree structure unselected
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Using Omniscope with Salesforce
Adding the perfect desktop/web compliment to Salesforce

Omniscope provides a low-cost, low-risk route to business intelligence reporting and data quality initiatives involving data hosted in
Salesforce. Omniscope tabbed presentation files contain a copy of all the data, open offline, are highly-visual and easily shared with others as
presentations. Admistrators with upload access to the free Visokio Reports web tab can use or modify the default templates for each
Report. The constantly-evolving default templates are based on the general experience of various clients, but can easily be modified to create
templates suitable for different classes of users in your organisation. Creating and uploading customised templates adds them to the future
download options for each Report on the Visokio reports tab.

Install the Omniscope Connector for Salesforce tab from the AppExchange

Start by installing the free Omniscope Connector for Salesforce 2.1 [67] (a certified, AppExchange-listed application) into your Salesforce user
accounts. Salesforce Administrators can do this automatically from the AppExchange if your organisation has the Professional, Enterprise or
the Unlimited editions of Salesforce. If your organisation uses Salesforce Group Edition, any Administrator can install the Connector tab
manually by following these directions. [296]

Installing the web connector will add a new 'Visokio Reports' tab to some or all of your user accounts. From this tab, users with the free
Omniscope Viewer [297] installed can download, view, filter and query the data in their Reports. Default Omniscope file templates are provided for
each Report or Data Object/Table. Using an activated Omniscope, the default templates can be modified and uploaded for others to use when
downloading to the free Viewer. Users without the free Omniscope Viewer installed cannot open local copies of their data, but can still use the
interactive Flash DataPlayer 'dashboards' exported from Omniscope to the Visokio Reports web tab. For more details, see using the web
connector. [288]

Use Omniscope 2.5 to access Salesforce directly and synchronise changes

If you install  Omniscope 2.5 [297], and you have Professional, Enterprise or Unlimited editions of Salesforce, you can not only modify templates,
edit/merge data offline and save secured copies, you can also access Reports and Data Objects/Tables directly using the File > Open online
source > Salesforce login and download option (you will need to paste-in your security token). Using Omniscope 2.5 Professional or
Enterprise, you can add to/edit Data Objects/Tables offline and then synchronise your changes with Salesforce using the File > Export >
Synchronise with Salesforce wizard. For more details, see accessing Salesforce directly from Omniscope 2.5 [289].

Once your 30-day free trial period has expired, upgrading your Omniscope from free Viewer to the Professional Edition enables you to
continue modifying and uploading customised templates and DataPlayer 'dashboards', integrating/merging in data from non-Salesforce
sources, saving and sharing secured Omniscope files offline, and synchronising offline changes back to Salesforce. Non-activated Omniscope
installations will revert to being free Viewers able to download and filter/query default or customised files using the free web connector tab
installed in the user accounts. No need to uninstall.

Roadmap to 'the best of both worlds'

Installing the free Omniscope Viewer and the free Omniscope web tab from the AppExchange enables any organisation to embark on a simple,
low-cost, low-risk, ‘tiny-steps' progression of continuous improvements, while delivering users live, working reports with many useful
visualisations of their data beginning on Day One:

 

1. Install free Omniscope Viewers and add the free Visokio Reports web tab to user accounts

a. Download key reports/data objects from each user's account tab using the standard templates, enabling users to see, filter
and sort all their data to find alert conditions, data errors & inconsistencies.

b. Ask users to start flagging incomplete, out-dated and erroneous data records/fields online in Salesforce using the "!" character
or similar

c. Download key data objects as Omniscope files and consult the Flagged Errors tab to view all the records which have been
flagged for online correction/completion either online via Salesforce, or offline using an activated Omniscope Professional and the
direct connector for Salesforce, available in the free 30-day trial.

d. Create custom reports containing the most useful joins...users can then download and view standard template versions of
these reports using Omniscope.

e. File refresh & security - the data in Omniscope files downloaded in templates is always fresh, and cannot be exported or copied
(not even cut-and-paste). Users of free Viewers cannot save the files...they must always return to their Salesforce account Visokio
Reports tab to download fresh copies of the data or view online DataPlayers in sub-tabs.

2. Upgrade to Omniscope Professional 2.5 (requires activation)

a. If your 30-day free trial has expired, contact us [86] for a licensed activation key to upgrade from free Viewer to Omniscope
Professional.

b. Now you can save and modify files downloaded from your Salesforce account tab to fit the needs of your organisation-
adding/changing report tabs to highlight key messages, introducing corporate branding, etc. Make multiple versions of each 291/305



adding/changing report tabs to highlight key messages, introducing corporate branding, etc. Make multiple versions of each
report/data object template to suit the needs of different classes of users.

c. Save your changed .IOK file(s), then upload one or more of your modified files from the Visokio Reports tab in your Salesforce
account. Note: you can upload the file empty, with all data deleted... data in the uploaded template file(s) will not be synchronised
with the online data.

d. Modify the standard Flash DataPlayers shown in the DataPlayer View tab of each template file downloaded, then export your
new customised DataPlayer ‘dashboard' to web pages (including Salesforce tabs) and/or internal documents such as PowerPoint,
Excel or .PDF.

e. The custom templates/DataPlayer configurations uploaded will be selectable for future downloads from the Visokio Reports tabs
of authorised users, whether using the free Viewer or a Professional.

f. Data integration projects: download custom versions of your reports/data objects and then use Omniscope to merge in related
data from other sources (spreadsheets, ERP databases, etc.) to create combined reports (using any number of joins)that can be
circulated to users with the free Viewer.

g. Using Omniscope 2.5 or later, you can also login to your Salesforce account from inside Omniscope, connecting directly to
reports or data objects using File > Open Online Source > Salesforce Table/Report

h. Use the powerful data cleansing/scrubbing and editing capabilities of Omniscope to make changes to your data and save local
copies of files.

i. Using Omniscope 2.5 or later, use the File > Export > Synchronise with Salesforce command to make changes to both
your local copies and the corresponding user-editable fields within your Salesforce organisation.

j. File refresh & security- Users with Professional Editions will be able to refresh directly from source on opening. Offline files sent to
users with the free Viewer show configurable opening screen ensuring they do not use stale files.

k. Continue to optimise the configuration of templates for all your reports and data objects based on user feedback and the
evolving needs of your business...enjoy the total flexibility of the hybrid solution you have created.

3. Automate refresh and distribution with Omniscope Enterprise Edition

a. Omniscope Enterprise edition is designed to automate the entire process of refreshing and distributing Omniscope reports and
Flash DataPlayer inserts from a central 'always-on' server with access to all the required data sources, including Salesforce.

b. A single Enterprise Edition allows automated refreshes of files with data from Salesforce and other sources, plus distribution (via
e-mail or FTP) of refreshed .IOK files and DataPlayer dashboards either according to a defined schedule or on-demand using the
Scheduler or the Generator, two automation tools included with Enterprise Editions.

c. File refresh & security - Enterprise installations offer the full range of file security options, including domain-locking of files (files will
not open if user is not logged into specified site and download page e.g. Salesforce)

Getting started: 

For the quickest start, maximum flexibility and lowest average cost-per-user in deploying your solution, use both types of connector:

Using the Salesforce web connector [288] (download and forward templated reports installed in your online Salesforce account by your
Administrator)

Using the Salesforce direct connector [289] (login to Salesforce directly for data import/editing/refresh; requires login, password and security
token to paste in)

 

User Guide Top [68]

Install in Salesforce

Using the Salesforce Visokio Reports Tab
Install this free service in any Salesforce Edition, including Group
Edition

 

The Omniscope web connector for Salesforce is a certified, AppExchange-listed free service [67] that can be installed by your Salesforce
Administrator in any Edition of Salesforce, including Group Edition. Once installed, the new web connector tab provides your users with one-
click downloads of pre-formatted, filterable, highly-visual, offline copies of Salesforce Reports and Data Objects/Tables.  The downloaded 292/305



click downloads of pre-formatted, filterable, highly-visual, offline copies of Salesforce Reports and Data Objects/Tables.  The downloaded
files can be shared as presentations with anyone using the Omniscope free Viewer. Each file download contains not only all the data [298],
configured as multi-tabbed visualisations and reports, but also an exportable interactive Flash DataPlayer 'dashboard' [193] that can be displayed
on the Salesforce tab, or exported from the downloaded file for display on other web pages and/or in documents such as PowerPoint, Excel
and .PDF, with full interactivity.

 

[299]

 

 

[67] Install from the
AppExchange

 

If you are running the Professional, Enterprise or
Unlimited Edition of Salesforce, and you are logged into
an Administrator account, you can install the free web
connector service just by clicking the [Get It Now]
[67]button.

If you are running Group Edition of Salesforce, you can
still install the web connector manually following these
instructions [300].

Once installed, the web connector tab appears at the
right-most end of your opening tabs, usually with the
label 'Visokio Reports'.

Click on the tab

At the top of the tab is a link for all users to install a free
Omniscope 2.5 [297] Viewer, with free 30-day trial of
Omniscope Professional authoring capabilities anyone
can use to modify the default templates and
DataPlayers.

[301]

 

Select Report or Data Object/Table to download

The web connector tab includes 3-4 sub-tabs:
All Reports - lists all standard and custom Reports
available to the account. The one-click Omniscope icon
next to each Report downloads the data using the
default template. At right are options to add/remove
Reports to/from the My Reports shortlist on the next
tab, and to upload a new, modified  template, added as
a new file icon and option for future downloads.
My Reports*- a user-managed shortlist of the
more important and more frequently-accessed reports.
You can add or remove Reports from this page using
the option on the page.
Data Objects/Tables - a listing of standard and
custom (un-joined) Data Objects/Tables available to the
account, which can be joined and edited and
synchronised with Salesforce using Omniscope
Professional.
DataPlayers - Clicking on an online DataPlayer icon will
display the interactive DataPlayer (default or
customised) generated on-demand with current data.

* not available when installed in Group Edition

Your data will open in your installed Omniscope
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[302]

 

 

Your data will open in your installed Omniscope

If you clicked on a default template icon, the opening
configuration of the downloaded file will be a general-
purpose default provided to all users of the web
connector. Default template file may not anticipate
custom reports or data objects or custom fields
(columns) in your data. If you send us your own
versions, (scramble, disguise or delete the data in the
file) we may modify and post additional templates as
you suggest.

There is also a template file containing the configuration
of the DataPlayer automatically displayed just by
clicking on the DataPlayer icon next to the Report. 

You can customise and export DataPlayers using
Omniscope Professional, save and upload new
templates and add icons to display one or more as
new options on your Visokio Reports tab in Salesforce.

[303]

 

 

If you like, customise templates and upload

If you customise either the default template file or the
template file for the DataPlayer automatically displayed
online, you can make your customised
download template and/or online DataPlayer template
available for future use with refreshed data. The Add
template option enables you to upload the new file,
assign a new name, and specify whether to display the
additional Omniscope .IOK template or the modified
automatically displayed .SWF DataPlayer file as
additional download/display options. 

Use Omniscope Professional to customise template files
and DataPlayers for different purposes or user
groups. All template .IOK files can be downloaded and
interacted with using the free Viewer, dramatically
reducing average cost-per-seat of your Business
Intelligence and reporting solution for Salesforce.

 

Installing in Group Editions  

WARNING: due to limitations imposed by Salesforce, when installed in Group Edition accounts, the Omniscope web connector does
not support upload of customised templates, and displays All Reports, rather than the custom "My Reports" tab by default.

 

Group Edition installs are not done using the [Get it Now] button on the AppExchange. they must be done manually following these
instructions:

To begin, go to www.salesforce.com [286] and make sure to login to an account with a System Administrator profile

Click "Setup" at top of screen
In left side panel under "App Setup" click "Create" to expand menu
In expanded section under "Create" click "Tabs"
In the middle "Web Tabs" (not "Custom Object Tabs" above or "VisualForce Tabs" below) box, inside the Web Tabs header, click the grey
"New" button centre

Step 1. Choose Tab Layout, choose "2 columns with Salesforce sidebar"
Click "Next"

Step 2. Define Content and display properties > Tab Content definition > "Tab Type" choose "URL" from drop-down list

Under Display Properties:
1. In "Tab Label" type "Visokio Reports" or whatever label you want to appear on the new tab
Leave "Tab Name" blank
2. "Tab style" click magnifier to open a list of icon/style choices
Choose any style, for example, a desk indicating desktop reports
3. Leave the Content Frame height set to '600'
leave splash page set to None 294/305



leave splash page set to None
4. Fill in the Description field with something that reminds users what the application does, like:
"Delivers Omniscope files to desktop"
Click "Next"

Step 3. Enter the URL Details
In the big white box with the title "Button or Link URL" paste:

https://salesforce.visokio.com/index2.jsp?sid=={!User.Session_ID}&apiurl={!API.Partner_Server_URL_70}

(clear the space first, and make sure to delete any duplication of the initial letters 'http')

Leave the encoding setting Unicode (UTF-8)
Click "Next"

Step 4. Add to Custom Apps make sure ALL options are ticked
Click "Save"

 

Make sure your users have Omniscope installed.  They can now click on the new Visokio Reports tab and choose a default template to
download.

 

Back to Using Omniscope with Salesforce.com [28]
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Improving Default Files

Default Configured Reports and Data Objects
Download Reports and Data Objects in the default configuration

 

Salesforce is a highly flexible platform that allows you to create custom fields, custom Reports and custom Data Objects. We are working to
improve the default templates available when you first install the web connector to better anticipate the most common data sets for each
Report, so that there is less customisation to do before you can give users access to the files on the Visokio Reports tab.

 

New in 2.5...this page in progress...

 

 

 

 

 

 

 

 

 

 

 

 

 

Back to Using Your Salesforce Visokio Reports Tab  [288]
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Upload New Templates

Modifying & Uploading Templates
Uploading customised templates and designating DataPlayers for online display

 

Using an activated Omniscope Professional, anyone can modify and save a downloaded file for use as a new template, then upload it (not
available for Group Editions of Salesforce) back to the Salesforce Visokio Reports tab to serve as an additional template option for future
downloads of that Report or Data Object/Table.

In addition, if at least one DataPlayer is configured in the file, and the file saved with a DataPlayer tab as the open tab, then the file can be
designated as the template for the DataPlayer to be displayed online whenever users click on that template. Also, to save storage space in
your Salesforce account, you can upload the template file empty of all data...the file will be populated with the latest data each time a user
downloads it.

To upload a new template file, click on +Add Template from the All Reports or My Reports pages and the upload new template dialog will
appear:

 

 

Choose file - opens a browse dialog that enables you to select the saved file that you want to upload.  

Note: If you plan to use a DataPlayer configured in the file as an online displayable DataPlayer, you must save the file with the DataPlayer tab
containing the preferred DataPlayer open.

Template name - choose a name that everyone will see on the tab...try to make clear who the template is internded for and avoid using
spaces in the file name...like this: MyNewTemplateforSales.iok

Show as .IOK file - when ticked, this refreshable template file will be shown as a downloadable Omniscope option, which can be navigated in
the free Viewer offline.

Show as DataPlayer - when ticked, this file will be displayed with the option of viewing the configured DataPlayer 'dashboard' online, just by
clicking on the template icon. If you want this option to be available, you MUST save the file with the DataPlayer tab you want to display as the
open tab.

Change default size of DataPlayer - DataPlayers can be sized in terms of pixel budgets for height and width. If you make larger
DataPlayers, make sure you set the pixel budget associated with the DataPlayer in the file being uploades big enough to display it properly on
the web tab, but not so big that user have to scroll sidebars to see and interact with it.

Upload template - your template should appear next to the Report or Data Object/Table it applies to.  You cannot delete the default
templates, but we welcome suggestions on how to improve the defaults to better serve your needs.

 

 

Back to Using Your Salesforce Account Visokio Reports Tab  [288]
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Export DataPlayers

Displaying and Exporting Flash DataPlayers
Interactive visual 'dashboards' for web tabs and offline documents

 

There are two default template files for every Salesforce Report and Data Object/Table, each containing a tab with an exportable Omniscope
DataPlayer interactive Flash 'dashboard'. The default DataPlayer template file contains the DataPlayer on the top tab. This DataPlayer
configuration is used to generate the DataPlayer displayed online on the Visokio Reports tab in your Salesforce account. You can modify the
default DataPlayer template file and upload a new version for automatic refresh and display if you have an activated Omniscope and a
Salesforce Edition higher than Group Edition. You can also use the Save/export menu options on the DataPlayer view toolbar of either
template file to export DataPlayers to non-Salesforce web pages or offline documents, with full interactivity.

 

Direct Connector

Direct Connection & Synchronisation
with Salesforce
Omniscope 2.5 or later (all Salesforce Editions except Group Editions)

If you use the Professional, Enterprise or Unlimited Editions of Salesforce, and you have installed Omniscope 2.5 [297], during the free 30-day
trial period you can access your Salesforce Reports and Data Objects/Tables directly. Using Omniscope 2.5, all standard and custom Reports
can be accessed directly and most fields (columns) in the Data Objects/Tables can be edited/completed offline and changes synchronised back
to Salesforce. Omniscope files scale to millions of records, yet are very compact, easily-shared and re-purposed interactive files with
comprehensive multi-tabbed visual overviews. Omniscope is the perfect complement to Salesforce and Force.com 'cloud-based' solutions for
improving data quality, facilitating local offline data management and providing end-users with refreshable analytic reports, highly-visual final
management presentations, and interactive Flash DataPlayer 'dashboards' [193] exportable to web pages and documents like PowerPoint,
Excel and Adobe .PDF.

Connecting to your Salesforce account data

Open Omniscope and go to File > Open online source > Salesforce. You will be presented with a log-in sequence requesting your User ID,
password and security token, which you should copy-paste. All applications that connect directly to Salesforce must present a security token
at login. You will need to set your own security token from your Salesforce account. Salesforce will send you the digital text string via e-
mail. Save your token in a Notepad file, because you will have to paste it into Omniscope each time you login.

 

 

 

 

 

Once you have successfully logged in to your Salesforce account, you can choose to import either an existing standard or custom Report
data set, or an existing standard or custom Data Object/Table. Report data sets can be configured, saved and shared with others, including
additional data merged in from other non-Salesforce sources. However, copies of the data in Reports files cannot be edited offline such that the
changes are synchronised back to Salesforce. Un-joined Data Objects/Tables contain many fields (columns) which can be filtered and
corrected offline in Omniscope, and the changes synchronised back to Salesforce. 
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Note: some fields (columns) in every Data Object/Table are Salesforce system-generated and cannot be edited offline. In addition, some
records (rows) in Data Objects/Tables which have become interconnected with other Data Objects/Tables, such as converted Leads, cannot
be edited/synced back to in their original Leads Data Object/Table, but the user-editable fields related to unconverted leads CAN be edited and
the changes synced back to the Leads Data Object/Table.

 

 

 

 

 

Improving Data Quality and Reporting

Use Omniscope to filter records (rows) for blanks, variations in spellings, inconsistencies among different records relating to the same account,
and other typical data quality problems. Make systematic corrections, even across thousands of records, very quickly and easily in Omniscope,
then synchronise the changes with Salesforce (see below). Regularly archive copies of all Reports and Data Objects/Tables. Quickly perform
data integration by merging in data from other systems and/or stand-alone or collaborative spreadsheets.

Configuring/Uploading Customised Template Files

If you open an online Report or Data Object/Table for the first time using the direct connector in Omniscope Professional 2.5, you will have to
configure the Omniscope file report tabs yourself. However, if you have installed the free Omniscope (web) Connector for Salesforce [67]in your
account(s), you can download an existing templated file for each standard Report or Data Object/Table from the 'Visokio Reports' tab, then
follow these directions to change the file data source [304] so that you can start from an already  templated reporting file. Once you have fully
customised your copy of the pre-templated file, and synchronised any changes to the data with Salesforce, you can upload the file back to
the Visokio Reports tab, adding a new, customised template download option for each Report or Data Object/Table. Colleagues  will be able to
download future fresh views of the data using the now customised template, even with the free Viewer.

Note: Uploading a populated customised file to the 'Visokio Reports' tab as a new template does not synchronise the data. Only the layout,
report tab configurations and overall look and feel of the file is remembered. Each future download is fully re-populated with the freshest data
from Salesforce.

Editing, Adding and Synchronising Data with Salesforce

Once you have downloaded and added to or edited user-editable fields (columns) in Omniscope, you must synchronise these changes with
Salesforce in order for your changes to become persistent in the online data. When you are ready to commit your changes to the online
version of the Salesforce data, go to Data > Synchronise with Salesforce to launch the synchronisation wizard.
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WARNING: If you close and open your local Omniscope file before you have successfully synchronised with Salesforce, be sure to skip or
cancel the refresh, since this will overwrite any changes you made in the local file with values from the current online data set. You can avoid
this risk by saving local copies with un-synchronised changes with the refresh option set to 'Never' until all changes have been successfully
synchronised.

Synchronisation

The Synchronisation wizard opens comparing the status of your local Omniscope version of the data with the then-current version of the Data
Object/Table downloaded in Salesforce. In the example below, no new rows were added online while the file was being edited locally in
Omniscope.  Had new records been added by someone else online, they would show on the right current Salesforce pane in green, with the
option to download the new records (rows) during synchronisation.

 

 

By default, there is a protective setting preventing online records from being deleted if they are not present in the local Omniscope copy.  To
change this, tick the option to Enable row deletion below the local changes listing.

 

More detail on synchronisation [305], best practices and common warning and error messages.

 

Back to Using Omniscope with Salesforce [28]

User Guide Top [68]

Changing Data Source

Changing the Data Source of Template Files
Save time by starting from default template files for standard Reports & Data Objects
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You can save time configuring Omniscope files for all your Reports and Data Objects/Tables if you start by downloading a copy of your data
using the default templates available on the 'Visokio Reports' tab of the Omniscope (web) Connector for Salesforce, a certified, free
AppExchange-listed application [67] your Administrator can install.

The templated files available via the web connector are downloaded without a linked source. To add/edit and synchronise data saved locally in
Omniscope 2.5+ with your online instance of Salesforce, you first need to associate each downloaded file with the corresponding Salesforce
online Report or Data Object directly.

Changing the linked data source of a file is done from Data > Change source by selecting select Salesforce importer as the type of data
source.

 

 

 

If you are working with a downloaded Report file, and are interested in live refresh of the data in the Report file, choose Salesforce report.
The data in Reports cannot be edited directly, but can be refreshed on demand into Omniscope, and the configuration of the Omniscope file
changed and saved/forwarded assuming you have an activated edittion of Omniscope (not the free Viewer).

If you are working with a downloaded Data Object/Table, and you wish to add/edit data then synchronise the changes with Salesforce, choose
Salesforce data table, which are editable. You will then be prompted to login to your Salesforce account and asked to paste-in your security
token. Note: Salesforce Group accounts do not support direct connections.

 

 

Please note:

Some fields (columns) and some records (rows) within
each Data Object/Table are not directly editable from
outside of Salesforce. They may need to be edited from
inside the web interface of Salesforce, or by reference
to another Data Object/Table.

Fields which are not editable are indicated in the
heading. Rows which are not editable are usually
screened out by filters set in the editing tab of the default
template.
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Synchronising Changes

Editing Data Locally and Synchronising Changes with
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(in progress...)
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Roadmap/Best Practices

Making the most of Omniscope and Salesforce
 

(In progress...)
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